You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     p...@freebsd.org
Last committer: l...@freebsd.org
Ident:          $FreeBSD: head/textproc/p5-Pod-Spell/Makefile 412179 2016-03-30 
17:59:15Z lth $
Log URL:        
http://package19.nyi.freebsd.org/data/103i386-default-build-as-user/412197/logs/p5-Pod-Spell-1.19.log
Build URL:      
http://package19.nyi.freebsd.org/build.html?mastername=103i386-default-build-as-user&build=412197
Log:

====>> Building textproc/p5-Pod-Spell
build started at Thu Mar 31 01:14:26 UTC 2016
port directory: /usr/ports/textproc/p5-Pod-Spell
building for: FreeBSD 103i386-default-build-as-user-job-22 10.3-RELEASE FreeBSD 
10.3-RELEASE i386
maintained by: p...@freebsd.org
Makefile ident:      $FreeBSD: head/textproc/p5-Pod-Spell/Makefile 412179 
2016-03-30 17:59:15Z lth $
Poudriere version: 3.1.12
Host OSVERSION: 1100102
Jail OSVERSION: 1003000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 10.3-RELEASE
UNAME_r=10.3-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
LINUX_OSRELEASE=2.6.32
SAVED_TERM=
MASTERMNT=/poudriere/data/.m/103i386-default-build-as-user/ref
FORCE_PACKAGE=yes
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=p5-Pod-Spell-1.19
OSREL=10.3
_OSRELEASE=10.3-RELEASE
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=32
PWD=/poudriere/data/.m/103i386-default-build-as-user/ref/.p/pool
MASTERNAME=103i386-default-build-as-user
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1003000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
INSTALLDIRS="site" CC="cc" CCFLAGS="-O2 -pipe  -fstack-protector 
-fno-strict-aliasing" PREFIX="/usr/local"  INSTALLPRIVLIB="/usr/local/lib" 
INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl 
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work  
HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh PERL_EXTUTILS_AUTOINSTALL="--skipdeps" 
PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work  
HOME=/wrkdirs/usr/ports/textproc/p5-Pod-Spell/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  
LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/Pod-Spell"
EXAMPLESDIR="share/examples/Pod-Spell"
DATADIR="share/Pod-Spell"
WWWDIR="www/Pod-Spell"
ETCDIR="etc/Pod-Spell"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/Pod-Spell
DOCSDIR=/usr/local/share/doc/Pod-Spell
EXAMPLESDIR=/usr/local/share/examples/Pod-Spell
WWWDIR=/usr/local/www/Pod-Spell
ETCDIR=/usr/local/etc/Pod-Spell
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License ART20 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Pod-Spell-1.19 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.4_1.txz
[103i386-default-build-as-user-job-22] Installing pkg-1.6.4_1...
[103i386-default-build-as-user-job-22] Extracting pkg-1.6.4_1: .......... done
===>   p5-Pod-Spell-1.19 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of p5-Pod-Spell-1.19
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ART20 accepted by the user
=> Pod-Spell-1.19.tar.gz doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch 
http://cpan.metacpan.org/modules/by-module/Pod/Pod-Spell-1.19.tar.gz
Pod-Spell-1.19.tar.gz                                    0  B    0  Bps
===> Fetching all distfiles required by p5-Pod-Spell-1.19 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ART20 accepted by the user
===> Fetching all distfiles required by p5-Pod-Spell-1.19 for building
=> SHA256 Checksum OK for Pod-Spell-1.19.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ART20 accepted by the user
===> Fetching all distfiles required by p5-Pod-Spell-1.19 for building
===>  Extracting for p5-Pod-Spell-1.19
=> SHA256 Checksum OK for Pod-Spell-1.19.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Pod-Spell-1.19
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Pod-Spell-1.19 depends on package: p5-Class-Tiny>=0 - not found
===>   Installing existing package /packages/All/p5-Class-Tiny-1.001.txz
[103i386-default-build-as-user-job-22] Installing p5-Class-Tiny-1.001...
[103i386-default-build-as-user-job-22] `-- Installing perl5-5.20.3_8...
[103i386-default-build-as-user-job-22] `-- Extracting perl5-5.20.3_8: 
.......... done
[103i386-default-build-as-user-job-22] Extracting p5-Class-Tiny-1.001: ...... 
done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   p5-Pod-Spell-1.19 depends on package: p5-Class-Tiny>=0 - found
===>   Returning to build of p5-Pod-Spell-1.19
===>   p5-Pod-Spell-1.19 depends on package: 
p5-File-ShareDir-ProjectDistDir>=1.000 - not found
===>   Installing existing package 
/packages/All/p5-File-ShareDir-ProjectDistDir-1.000008.txz
[103i386-default-build-as-user-job-22] Installing 
p5-File-ShareDir-ProjectDistDir-1.000008...
[103i386-default-build-as-user-job-22] `-- Installing p5-Path-Tiny-0.076...
[103i386-default-build-as-user-job-22] `-- Extracting p5-Path-Tiny-0.076: 
...... done
[103i386-default-build-as-user-job-22] `-- Installing p5-Sub-Exporter-0.987_1...
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Params-Util-1.07_2...
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Params-Util-1.07_2: ........ done
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Sub-Install-0.928_1...
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Sub-Install-0.928_1: ....... done
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Data-OptList-0.110...
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Data-OptList-0.110: ....... done
[103i386-default-build-as-user-job-22] `-- Extracting p5-Sub-Exporter-0.987_1: 
.......... done
[103i386-default-build-as-user-job-22] `-- Installing p5-Path-Class-0.36...
[103i386-default-build-as-user-job-22] `-- Extracting p5-Path-Class-0.36: 
.......... done
[103i386-default-build-as-user-job-22] `-- Installing 
p5-File-ShareDir-1.102_2...
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Class-Inspector-1.28_1...
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Class-Inspector-1.28_1: ......... done
[103i386-default-build-as-user-job-22] `-- Extracting p5-File-ShareDir-1.102_2: 
.......... done
[103i386-default-build-as-user-job-22] `-- Installing 
p5-Path-IsDev-1.001002_1...
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Role-Tiny-2.000001...
[103i386-default-build-as-user-job-22] |   | `-- Installing 
p5-Class-Method-Modifiers-2.12...
[103i386-default-build-as-user-job-22] |   | `-- Extracting 
p5-Class-Method-Modifiers-2.12: ....... done
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Role-Tiny-2.000001: ......... done
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-File-HomeDir-1.00_1...
[103i386-default-build-as-user-job-22] |   | `-- Installing 
p5-File-Which-1.21...
[103i386-default-build-as-user-job-22] |   | `-- Extracting p5-File-Which-1.21: 
....... done
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-File-HomeDir-1.00_1: .......... done
[103i386-default-build-as-user-job-22] |   `-- Installing 
p5-Module-Runtime-0.014_1...
[103i386-default-build-as-user-job-22] |   `-- Extracting 
p5-Module-Runtime-0.014_1: ....... done
[103i386-default-build-as-user-job-22] `-- Extracting p5-Path-IsDev-1.001002_1: 
.......... done
[103i386-default-build-as-user-job-22] `-- Installing p5-Path-FindDev-0.5.2_1...
[103i386-default-build-as-user-job-22] `-- Extracting p5-Path-FindDev-0.5.2_1: 
......... done
[103i386-default-build-as-user-job-22] Extracting 
p5-File-ShareDir-ProjectDistDir-1.000008: ....... done
===>   p5-Pod-Spell-1.19 depends on package: 
p5-File-ShareDir-ProjectDistDir>=1.000 - found
===>   Returning to build of p5-Pod-Spell-1.19
===>   p5-Pod-Spell-1.19 depends on package: p5-Lingua-EN-Inflect>=0 - not found
===>   Installing existing package 
/packages/All/p5-Lingua-EN-Inflect-1.89.3_1.txz
[103i386-default-build-as-user-job-22] Installing 
p5-Lingua-EN-Inflect-1.89.3_1...
[103i386-default-build-as-user-job-22] Extracting 
p5-Lingua-EN-Inflect-1.89.3_1: ... done
===>   p5-Pod-Spell-1.19 depends on package: p5-Lingua-EN-Inflect>=0 - found
===>   Returning to build of p5-Pod-Spell-1.19
===>   p5-Pod-Spell-1.19 depends on package: p5-Pod-Escapes>=1.01 - not found
===>   Installing existing package /packages/All/p5-Pod-Escapes-1.07.txz
[103i386-default-build-as-user-job-22] Installing p5-Pod-Escapes-1.07...
[103i386-default-build-as-user-job-22] Extracting p5-Pod-Escapes-1.07: ....... 
done
===>   p5-Pod-Spell-1.19 depends on package: p5-Pod-Escapes>=1.01 - found
===>   Returning to build of p5-Pod-Spell-1.19
===>   p5-Pod-Spell-1.19 depends on package: perl5>=5.20<5.21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Pod-Spell-1.19
Can't locate File/ShareDir/Install.pm in @INC (you may need to install the 
File::ShareDir::Install module) (@INC contains: 
/usr/local/lib/perl5/site_perl/mach/5.20 /usr/local/lib/perl5/site_perl 
/usr/local/lib/perl5/5.20/mach /usr/local/lib/perl5/5.20 
/usr/local/lib/perl5/site_perl/5.20 /usr/local/lib/perl5/site_perl/5.20/mach .) 
at ./Makefile.PL line 9.
BEGIN failed--compilation aborted at ./Makefile.PL line 9.
*** Error code 2

Stop.
make: stopped in /usr/ports/textproc/p5-Pod-Spell
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to