You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     roy...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/sysutils/xen-tools/Makefile 412349 2016-04-01 
14:25:16Z mat $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/412377/logs/xen-tools-4.5.2_3.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=412377
Log:

====>> Building sysutils/xen-tools
build started at Sat Apr  2 05:29:21 UTC 2016
port directory: /usr/ports/sysutils/xen-tools
building for: FreeBSD 93amd64-default-job-21 9.3-RELEASE-p39 FreeBSD 
9.3-RELEASE-p39 amd64
maintained by: roy...@freebsd.org
Makefile ident:      $FreeBSD: head/sysutils/xen-tools/Makefile 412349 
2016-04-01 14:25:16Z mat $
Poudriere version: 3.1.12
Host OSVERSION: 1100102
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 9.3-RELEASE-p39
UNAME_r=9.3-RELEASE-p39
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=xen-tools-4.5.2_3
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for xen-tools-4.5.2_3:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-extra-qemuu-configure-args="--disable-gtk  --disable-smartcard-nss  
--disable-sdl  --disable-vte  --disable-glx  --disable-curses  --disable-tools  
--disable-curl  --cxx=c++" --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
HOSTCC="cc" CC="cc"  ac_cv_path_BASH=true  ac_cv_path_XGETTEXT=true MAKE=gmake 
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl 
PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python2.7" 
CMAKE_PREFIX_PATH="/usr/local" 
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work  
HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work  
HOME=/wrkdirs/usr/ports/sysutils/xen-tools/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-Wno-ignored-attributes -Qunused-arguments -Wno-header-guard 
-Wno-tautological-compare -Wno-format-extra-args -w -isystem /usr/local/include 
-fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-isystem 
/usr/local/include"  LDFLAGS=" -L/usr/local/lib -fstack-protector" LIBS=""  
CXX="c++" CXXFLAGS="-Wno-ignored-attributes -Qunused-arguments 
-Wno-header-guard -Wno-tautological-compare -Wno-format-extra-args -w -isystem 
/usr/local/include -fstack-protector -fno-strict-aliasing -isystem 
/usr/local/include"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 
555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 55
 5"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd9
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/xen"
EXAMPLESDIR="share/examples/xen"
DATADIR="share/xen"
WWWDIR="www/xen"
ETCDIR="etc/xen"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/xen
DOCSDIR=/usr/local/share/doc/xen
EXAMPLESDIR=/usr/local/share/examples/xen
WWWDIR=/usr/local/www/xen
ETCDIR=/usr/local/etc/xen
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv2 LGPL3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   xen-tools-4.5.2_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.7.0.txz
[93amd64-default-job-21] Installing pkg-1.7.0...
[93amd64-default-job-21] Extracting pkg-1.7.0: .......... done
===>   xen-tools-4.5.2_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of xen-tools-4.5.2_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 LGPL3 accepted by the user
===> Fetching all distfiles required by xen-tools-4.5.2_3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 LGPL3 accepted by the user
===> Fetching all distfiles required by xen-tools-4.5.2_3 for building
=> SHA256 Checksum OK for xen-4.5.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 LGPL3 accepted by the user
===> Fetching all distfiles required by xen-tools-4.5.2_3 for building
===>  Extracting for xen-tools-4.5.2_3
=> SHA256 Checksum OK for xen-4.5.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for xen-tools-4.5.2_3
===>  Applying extra patch 
/usr/ports/sysutils/xen-tools/files/0002-libxc-fix-xc_dom_load_elf_symtab.patch
===>  Applying extra patch /usr/ports/sysutils/xen-tools/files/xsa160-4.6.patch
===>  Applying FreeBSD patches for xen-tools-4.5.2_3
====> Applying xsa162-qemuu.patch
===========================================================================
=======================<phase: build-depends  >============================
===>   xen-tools-4.5.2_3 depends on package: dev86>0 - not found
===>   Installing existing package /packages/All/dev86-0.16.20.txz
[93amd64-default-job-21] Installing dev86-0.16.20...
[93amd64-default-job-21] Extracting dev86-0.16.20: .......... done
===>   xen-tools-4.5.2_3 depends on package: dev86>0 - found
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on package: seabios>0 - not found
===>   Installing existing package /packages/All/seabios-1.9.1.txz
[93amd64-default-job-21] Installing seabios-1.9.1...
[93amd64-default-job-21] Extracting seabios-1.9.1: .... done
===>   xen-tools-4.5.2_3 depends on package: seabios>0 - found
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[93amd64-default-job-21] Installing gmake-4.1_2...
[93amd64-default-job-21] `-- Installing indexinfo-0.2.4...
[93amd64-default-job-21] `-- Extracting indexinfo-0.2.4: .... done
[93amd64-default-job-21] `-- Installing libiconv-1.14_9...
[93amd64-default-job-21] `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-21] `-- Installing gettext-runtime-0.19.7...
[93amd64-default-job-21] `-- Extracting gettext-runtime-0.19.7: .......... done
[93amd64-default-job-21] Extracting gmake-4.1_2: .......... done
===>   xen-tools-4.5.2_3 depends on executable: gmake - found
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on executable: pkgconf - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12_1.txz
[93amd64-default-job-21] Installing pkgconf-0.9.12_1...
[93amd64-default-job-21] Extracting pkgconf-0.9.12_1: ....... done
===>   xen-tools-4.5.2_3 depends on executable: pkgconf - found
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on file: /usr/local/bin/python2.7 - not found
===>   Installing existing package /packages/All/python27-2.7.11_1.txz
[93amd64-default-job-21] Installing python27-2.7.11_1...
[93amd64-default-job-21] `-- Installing libffi-3.2.1...
[93amd64-default-job-21] `-- Extracting libffi-3.2.1: .......... done
[93amd64-default-job-21] Extracting python27-2.7.11_1: .......... done
Message from python27-2.7.11_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   xen-tools-4.5.2_3 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on package: perl5>=5.20<5.21 - not found
===>   Installing existing package /packages/All/perl5-5.20.3_8.txz
[93amd64-default-job-21] Installing perl5-5.20.3_8...
[93amd64-default-job-21] Extracting perl5-5.20.3_8: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   xen-tools-4.5.2_3 depends on package: perl5>=5.20<5.21 - found
===>   Returning to build of xen-tools-4.5.2_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   xen-tools-4.5.2_3 depends on shared library: libyajl.so - not found
===>   Installing existing package /packages/All/yajl-2.1.0.txz
[93amd64-default-job-21] Installing yajl-2.1.0...
[93amd64-default-job-21] Extracting yajl-2.1.0: .......... done
===>   xen-tools-4.5.2_3 depends on shared library: libyajl.so - found 
(/usr/local/lib/libyajl.so)
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on shared library: liblzo2.so - not found
===>   Installing existing package /packages/All/lzo2-2.09.txz
[93amd64-default-job-21] Installing lzo2-2.09...
[93amd64-default-job-21] Extracting lzo2-2.09: .......... done
===>   xen-tools-4.5.2_3 depends on shared library: liblzo2.so - found 
(/usr/local/lib/liblzo2.so)
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on shared library: libpixman-1.so - not found
===>   Installing existing package /packages/All/pixman-0.34.0.txz
[93amd64-default-job-21] Installing pixman-0.34.0...
[93amd64-default-job-21] Extracting pixman-0.34.0: .......... done
===>   xen-tools-4.5.2_3 depends on shared library: libpixman-1.so - found 
(/usr/local/lib/libpixman-1.so)
===>   Returning to build of xen-tools-4.5.2_3
===>   xen-tools-4.5.2_3 depends on shared library: libglib-2.0.so - not found
===>   Installing existing package /packages/All/glib-2.46.2.txz
[93amd64-default-job-21] Installing glib-2.46.2...
[93amd64-default-job-21] `-- Installing pcre-8.38...
[93amd64-default-job-21] `-- Extracting pcre-8.38: .......... done
[93amd64-default-job-21] Extracting glib-2.46.2: .......... done
No schema files found: doing nothing.
===>   xen-tools-4.5.2_3 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   Returning to build of xen-tools-4.5.2_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for xen-tools-4.5.2_3
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd9.3
checking host system type... amd64-portbld-freebsd9.3
Will build the following subsystems:
  xen
  tools
  docs
configure: creating ./config.status
config.status: creating config/Toplevel.mk
config.status: creating config/Paths.mk
=== configuring in tools 
(/wrkdirs/usr/ports/sysutils/xen-tools/work/xen-4.5.2/tools)
configure: running /bin/sh ./configure --disable-option-checking 
'--prefix=/usr/local'  '--with-extra-qemuu-configure-args=--disable-gtk  
--disable-smartcard-nss  --disable-sdl  --disable-vte  --disable-glx  
--disable-curses  --disable-tools  --disable-curl  --cxx=c++' 
'--localstatedir=/var' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' 
'--build=amd64-portbld-freebsd9.3' 'build_alias=amd64-portbld-freebsd9.3' 
--cache-file=/dev/null --srcdir=.
configure: loading site script /usr/ports/Templates/config.site
configure: WARNING: Setting CC, CFLAGS, LDFLAGS, LIBS, CPPFLAGS or CPP is not 
recommended, use PREPEND_INCLUDES, PREPEND_LIB, APPEND_INCLUDES and APPEND_LIB 
instead when possible.
checking build system type... amd64-portbld-freebsd9.3
checking host system type... amd64-portbld-freebsd9.3
checking for gcc... cc
checking whether the C compiler works... no
configure: error: in 
`/wrkdirs/usr/ports/sysutils/xen-tools/work/xen-4.5.2/tools':
configure: error: C compiler cannot create executables
See `config.log' for more details
configure: error: ./configure failed for tools
===>  Script "configure" failed unexpectedly.
Please report the problem to roy...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/sysutils/xen-tools/work/xen-4.5.2/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/sysutils/xen-tools.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to