You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     de...@freebsd.org
Last committer: de...@freebsd.org
Ident:          $FreeBSD: branches/2016Q2/www/mod_proxy_uwsgi/Makefile 404827 
2015-12-30 10:58:08Z demon $
Log URL:        
http://beefy3.nyi.freebsd.org/data/93i386-quarterly/414715/logs/ap24-mod_proxy_uwsgi-2.0.12.log
Build URL:      
http://beefy3.nyi.freebsd.org/build.html?mastername=93i386-quarterly&build=414715
Log:

====>> Building www/mod_proxy_uwsgi
build started at Sat May  7 02:17:51 UTC 2016
port directory: /usr/ports/www/mod_proxy_uwsgi
building for: FreeBSD 93i386-quarterly-job-20 9.3-RELEASE-p41 FreeBSD 
9.3-RELEASE-p41 i386
maintained by: de...@freebsd.org
Makefile ident:      $FreeBSD: branches/2016Q2/www/mod_proxy_uwsgi/Makefile 
404827 2015-12-30 10:58:08Z demon $
Poudriere version: 3.1.12
Host OSVERSION: 1100102
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 9.3-RELEASE-p41
UNAME_r=9.3-RELEASE-p41
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-quarterly/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=ap24-mod_proxy_uwsgi-2.0.12
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-quarterly/ref/.p/pool
MASTERNAME=93i386-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work  
HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work  
HOME=/wrkdirs/usr/ports/www/mod_proxy_uwsgi/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
APACHEMODDIR="libexec/apache24"
APACHEINCLUDEDIR="include/apache24"
APACHEETCDIR="etc/apache24"
APACHE_VERSION="24"
AP_NAME="proxy_uwsgi"
AP_MODULE="mod_proxy_uwsgi.so"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
AP_MOD_EN="-A"
DOCSDIR="share/doc/mod_proxy_uwsgi"
EXAMPLESDIR="share/examples/mod_proxy_uwsgi"
DATADIR="share/mod_proxy_uwsgi"
WWWDIR="www/mod_proxy_uwsgi"
ETCDIR="etc/mod_proxy_uwsgi"
--End PLIST_SUB--

--SUB_LIST--
APACHEMODDIR="libexec/apache24"
APACHEETCDIR="etc/apache24"
APACHE_VERSION="24"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mod_proxy_uwsgi
DOCSDIR=/usr/local/share/doc/mod_proxy_uwsgi
EXAMPLESDIR=/usr/local/share/examples/mod_proxy_uwsgi
WWWDIR=/usr/local/www/mod_proxy_uwsgi
ETCDIR=/usr/local/etc/mod_proxy_uwsgi
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ap24-mod_proxy_uwsgi-2.0.12 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.7.2.txz
[93i386-quarterly-job-20] Installing pkg-1.7.2...
[93i386-quarterly-job-20] Extracting pkg-1.7.2: .......... done
===>   ap24-mod_proxy_uwsgi-2.0.12 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ap24-mod_proxy_uwsgi-2.0.12
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ap24-mod_proxy_uwsgi-2.0.12 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ap24-mod_proxy_uwsgi-2.0.12 for building
=> SHA256 Checksum OK for uwsgi-2.0.12.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ap24-mod_proxy_uwsgi-2.0.12 for building
===>  Extracting for ap24-mod_proxy_uwsgi-2.0.12
=> SHA256 Checksum OK for uwsgi-2.0.12.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ap24-mod_proxy_uwsgi-2.0.12
===========================================================================
=======================<phase: build-depends  >============================
===>   ap24-mod_proxy_uwsgi-2.0.12 depends on file: /usr/local/sbin/apxs - not 
found
===>   Installing existing package /packages/All/apache24-2.4.20_1.txz
[93i386-quarterly-job-20] Installing apache24-2.4.20_1...
[93i386-quarterly-job-20] `-- Installing expat-2.1.0_3...
[93i386-quarterly-job-20] `-- Extracting expat-2.1.0_3: .......... done
[93i386-quarterly-job-20] `-- Installing libiconv-1.14_9...
[93i386-quarterly-job-20] `-- Extracting libiconv-1.14_9: .......... done
[93i386-quarterly-job-20] `-- Installing libxml2-2.9.3...
[93i386-quarterly-job-20] `-- Extracting libxml2-2.9.3: .......... done
[93i386-quarterly-job-20] `-- Installing apr-1.5.2.1.5.4...
[93i386-quarterly-job-20] |   `-- Installing gdbm-1.11_2...
[93i386-quarterly-job-20] |   | `-- Installing indexinfo-0.2.4...
[93i386-quarterly-job-20] |   | `-- Extracting indexinfo-0.2.4: .... done
[93i386-quarterly-job-20] |   | `-- Installing gettext-runtime-0.19.7...
[93i386-quarterly-job-20] |   | `-- Extracting gettext-runtime-0.19.7: 
.......... done
[93i386-quarterly-job-20] |   `-- Extracting gdbm-1.11_2: .......... done
[93i386-quarterly-job-20] |   `-- Installing db5-5.3.28_3...
[93i386-quarterly-job-20] |   `-- Extracting db5-5.3.28_3: .......... done
[93i386-quarterly-job-20] `-- Extracting apr-1.5.2.1.5.4: .......... done
[93i386-quarterly-job-20] `-- Installing perl5-5.20.3_8...
[93i386-quarterly-job-20] `-- Extracting perl5-5.20.3_8: .......... done
[93i386-quarterly-job-20] `-- Installing pcre-8.38_1...
[93i386-quarterly-job-20] `-- Extracting pcre-8.38_1: .......... done
===> Creating users and/or groups.
Using existing group 'www'.
Using existing user 'www'.
[93i386-quarterly-job-20] Extracting apache24-2.4.20_1: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from apache24-2.4.20_1:
To run apache www server from startup, add apache24_enable="yes"
in your /etc/rc.conf. Extra options can be found in startup script.

Your hostname must be resolvable using at least 1 mechanism in
/etc/nsswitch.conf typically DNS or /etc/hosts or apache might
have issues starting depending on the modules you are using.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

- apache24 default build changed from static MPM to modular MPM
- more modules are now enabled per default in the port
- icons and error pages moved from WWWDIR to DATADIR

   If build with modular MPM and no MPM is activated in 
   httpd.conf, then mpm_prefork will be activated as default
   MPM in etc/apache24/modules.d to keep compatibility with 
   existing php/perl/python modules!

Please compare the existing httpd.conf with httpd.conf.sample
and merge missing modules/instructions into httpd.conf!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
===>   ap24-mod_proxy_uwsgi-2.0.12 depends on file: /usr/local/sbin/apxs - found
===>   Returning to build of ap24-mod_proxy_uwsgi-2.0.12
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ap24-mod_proxy_uwsgi-2.0.12
===========================================================================
=======================<phase: build          >============================
===>  Building for ap24-mod_proxy_uwsgi-2.0.12
===>  Generating apache plist
(cd /wrkdirs/usr/ports/www/mod_proxy_uwsgi/work/uwsgi-2.0.12 && 
/usr/local/sbin/apxs -c  -o mod_proxy_uwsgi.la apache2/mod_proxy_uwsgi.c)
/usr/local/share/apr/build-1/libtool --silent --mode=compile cc -std=gnu99 
-prefer-pic -O2 -pipe -I/usr/include -fno-strict-aliasing    
-I/usr/local/include/apache24  -I/usr/local/include/apr-1   
-I/usr/local/include/apr-1 -I/usr/include -I/usr/local/include 
-I/usr/local/include/db5  -c -o apache2/mod_proxy_uwsgi.lo 
apache2/mod_proxy_uwsgi.c && touch apache2/mod_proxy_uwsgi.slo
apache2/mod_proxy_uwsgi.c:264: error: static declaration of 
'ap_proxy_buckets_lifetime_transform' follows non-static declaration
/usr/local/include/apache24/mod_proxy.h:1071: error: previous declaration of 
'ap_proxy_buckets_lifetime_transform' was here
apxs:Error: Command failed with rc=65536
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to