You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     novato...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/devel/covtool/Makefile 327722 2013-09-20 
17:03:26Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s/logs/covtool-2.1.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s
Log:

====>> Building devel/covtool
build started at Fri Oct 18 09:49:22 UTC 2013
port directory: /usr/ports/devel/covtool
building for: FreeBSD head-i386-default-job-19 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 i386
maintained by: novato...@gmail.com
Makefile ident:      $FreeBSD: head/devel/covtool/Makefile 327722 2013-09-20 
17:03:26Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=42263
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=covtool-2.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES ADDR2LINE="/usr/local/bin/addr2line" 
AR="/usr/local/bin/ar" AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc46" CFLAGS="-O2 -pipe 
-Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing"  CPP="cpp46" CPPFLAGS=""  
LDFLAGS=" -Wl,-rpath=/usr/local/lib/gcc46"  CXX="g++46" CXXFLAGS="-O2 -pipe 
-Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing 
-Wl,-rpath=/usr/local/lib/gcc46"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -
 m 444"  
 BSD_INSTALL_MAN="install  -o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/covtool
DOCSDIR=/usr/local/share/doc/covtool
EXAMPLESDIR=/usr/local/share/examples/covtool
WWWDIR=/usr/local/www/covtool
ETCDIR=/usr/local/etc/covtool
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for covtool-2.1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   covtool-2.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of covtool-2.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by covtool-2.1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by covtool-2.1 for building
=> SHA256 Checksum OK for covtool-2.1.zip.
===========================================================================
=======================<phase: extract-depends>============================
===>   covtool-2.1 depends on file: /usr/local/bin/unzip - not found
===>    Verifying install for /usr/local/bin/unzip in /usr/ports/archivers/unzip
===>   Installing existing package /packages/All/unzip-6.0_1.txz
Installing unzip-6.0_1... done
===>   Returning to build of covtool-2.1
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by covtool-2.1 for building
===>  Extracting for covtool-2.1
=> SHA256 Checksum OK for covtool-2.1.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for covtool-2.1
===>  Applying FreeBSD patches for covtool-2.1
===========================================================================
=======================<phase: build-depends  >============================
===>   covtool-2.1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of covtool-2.1
===>   covtool-2.1 depends on executable: gcc46 - not found
===>    Verifying install for gcc46 in /usr/ports/lang/gcc
===>   Installing existing package /packages/All/gcc-4.6.3.txz
Installing gcc-4.6.3...Installing mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
Installing gcc-ecj-4.5... done
Installing binutils-2.23.2... done
 done
===>   Returning to build of covtool-2.1
===>   covtool-2.1 depends on file: /usr/local/bin/as - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for covtool-2.1
===========================================================================
=======================<phase: build          >============================
===>  Building for covtool-2.1
gmake[1]: Entering directory `/wrkdirs/usr/ports/devel/covtool/work'
g++ -o covtool.o  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc46 
-fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46 -Wall -pedantic -I. 
-I/usr/include/g++ -fpermissive -c covtool.c
gmake[1]: g++: Command not found
gmake[1]: *** [covtool.o] Error 127
gmake[1]: Leaving directory `/wrkdirs/usr/ports/devel/covtool/work'
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/covtool
===>  Cleaning for covtool-2.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to