You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/databases/p5-qdbm/Makefile 327717 2013-09-20 
16:13:47Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s/logs/p5-qdbm-1.8.78.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s
Log:

====>> Building databases/p5-qdbm
build started at Fri Oct 18 10:16:43 UTC 2013
port directory: /usr/ports/databases/p5-qdbm
building for: FreeBSD head-amd64-default-job-12 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/databases/p5-qdbm/Makefile 327717 
2013-09-20 16:13:47Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=29966
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=p5-qdbm-1.8.78
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/qdbm
DOCSDIR=/usr/local/share/doc/qdbm
EXAMPLESDIR=/usr/local/share/examples/qdbm
WWWDIR=/usr/local/www/qdbm
ETCDIR=/usr/local/etc/qdbm
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for p5-qdbm-1.8.78
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-qdbm-1.8.78 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of p5-qdbm-1.8.78
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by p5-qdbm-1.8.78 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by p5-qdbm-1.8.78 for building
=> SHA256 Checksum OK for qdbm-1.8.78.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by p5-qdbm-1.8.78 for building
===>  Extracting for p5-qdbm-1.8.78
=> SHA256 Checksum OK for qdbm-1.8.78.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-qdbm-1.8.78
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-qdbm-1.8.78 depends on file: /usr/local/bin/perl5.14.4 - not found
===>    Verifying install for /usr/local/bin/perl5.14.4 in 
/usr/ports/lang/perl5.14
===>   Installing existing package /packages/All/perl-5.14.4_2.txz
Installing perl-5.14.4_2...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
===>   Returning to build of p5-qdbm-1.8.78
===========================================================================
=======================<phase: lib-depends    >============================
===>   p5-qdbm-1.8.78 depends on shared library: qdbm - not found
===>    Verifying install for qdbm in /usr/ports/databases/qdbm
===>   Installing existing package /packages/All/qdbm-1.8.78.txz
Installing qdbm-1.8.78... done
===>   Returning to build of p5-qdbm-1.8.78
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-qdbm-1.8.78
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/perl/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/java/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/cgi/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/ruby/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/plus/configure
configure: loading site script /usr/ports/Templates/config.site
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for main in -lc... yes
checking for main in -pthread... yes
checking for main in -lz... yes
checking for main in -llzo2... no
checking for main in -lbz2... yes
checking for main in -liconv... no
checking for main in -lqdbm... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING:  'Makefile.in' seems to ignore the --datarootdir setting
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-qdbm-1.8.78
cd depot && [ -f Makefile ] ||  
LD_LIBRARY_PATH=.:..:../..:/usr/local/lib:/root/lib perl Makefile.PL CC="gcc" 
INC="-I. -I../.. -I/root/include -I/usr/local/include" OPTIMIZE="-O2"  LD="gcc" 
LIBS="-L../.. -I/root/lib -L/usr/local/lib -lqdbm -lbz2 -lz -pthread -lc" 
PREFIX="/usr/local" ;  LD_LIBRARY_PATH=.:..:../..:/usr/local/lib:/root/lib make
Checking if your kit is complete...
Looks good
Warning: -L../.. changed to 
-L/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/perl/depot/../..
Unrecognized argument in LIBS ignored: '-I/root/lib'
Unrecognized argument in LIBS ignored: '-pthread'
Writing Makefile for Depot
Writing MYMETA.yml
cp Depot.pm blib/lib/Depot.pm
/usr/local/bin/perl5.14.4 /usr/local/lib/perl5/5.14/ExtUtils/xsubpp  -typemap 
/usr/local/lib/perl5/5.14/ExtUtils/typemap  Depot.xs > Depot.xsc && mv 
Depot.xsc Depot.c
gcc -c  -I. -I../.. -I/root/include -I/usr/local/include  
-DAPPLLIB_EXP="/usr/local/lib/perl5/5.14/BSDPAN" -DHAS_FPSETMASK 
-DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector 
-I/usr/local/include -O2    -DVERSION=\"1.0\"  -DXS_VERSION=\"1.0\" -DPIC -fPIC 
"-I/usr/local/lib/perl5/5.14/mach/CORE"   Depot.c
gcc: not found
*** Error code 127

Stop.
make[2]: stopped in 
/wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/perl/depot
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/databases/p5-qdbm/work/qdbm-1.8.78/perl
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/p5-qdbm
===>  Cleaning for p5-qdbm-1.8.78
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to