You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     fernando.apesteg...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/lang/basic256/Makefile 327741 2013-09-20 
19:53:09Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s/logs/basic256-0.9.9.64.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s
Log:

====>> Building lang/basic256
build started at Fri Oct 18 10:34:53 UTC 2013
port directory: /usr/ports/lang/basic256
building for: FreeBSD head-i386-default-job-04 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 i386
maintained by: fernando.apesteg...@gmail.com
Makefile ident:      $FreeBSD: head/lang/basic256/Makefile 327741 2013-09-20 
19:53:09Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=65392
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=basic256-0.9.9.64
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  --with-extra-libs=/usr/local/lib  
--with-extra-includes=/usr/local/include
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MOC="/usr/local/bin/moc-qt4" UIC="/usr/local/bin/uic-qt4" LIBS="" 
 QMAKE="/usr/local/bin/qmake-qt4" 
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" QTDIR="/usr/local" 
SDL_CONFIG=/usr/local/bin/sdl-config SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" 
SDL_CONFIG=/usr/local/bin/sdl-config SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/basic256
DOCSDIR=/usr/local/share/doc/basic256
EXAMPLESDIR=/usr/local/share/examples/basic256
WWWDIR=/usr/local/www/basic256
ETCDIR=/usr/local/etc/basic256
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for basic256-0.9.9.64
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   basic256-0.9.9.64 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of basic256-0.9.9.64
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by basic256-0.9.9.64 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by basic256-0.9.9.64 for building
=> SHA256 Checksum OK for basic256_0.9.9.64.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by basic256-0.9.9.64 for building
===>  Extracting for basic256-0.9.9.64
=> SHA256 Checksum OK for basic256_0.9.9.64.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for basic256-0.9.9.64
===>   Converting DOS text files to UNIX text files
===>  Applying FreeBSD patches for basic256-0.9.9.64
===========================================================================
=======================<phase: build-depends  >============================
===>   basic256-0.9.9.64 depends on executable: espeak - not found
===>    Verifying install for espeak in /usr/ports/audio/espeak
===>   Installing existing package /packages/All/espeak-1.47.11.txz
Installing espeak-1.47.11...Installing portaudio-18.1_3... done
 done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on executable: sqlite3 - not found
===>    Verifying install for sqlite3 in /usr/ports/databases/sqlite3
===>   Installing existing package /packages/All/sqlite3-3.8.0.2.txz
Installing sqlite3-3.8.0.2... done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on executable: flex - found
===>   basic256-0.9.9.64 depends on file: /usr/local/bin/sdl-config - not found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_2,2.txz
Installing sdl-1.2.15_2,2...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing pciids-20131010... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4... done
 done
Installing aalib-1.4.r5_6... done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on executable: bison - not found
===>    Verifying install for bison in /usr/ports/devel/bison
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
Installing bison-2.7.1,1...Installing m4-1.4.17,1... done
Installing gettext-0.18.3.1... done
 done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/lib/qt4/libQtCore.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtCore.so in 
/usr/ports/devel/qt4-corelib
===>   Installing existing package /packages/All/qt4-corelib-4.8.5.txz
Installing qt4-corelib-4.8.5...Installing glib-2.36.3...Installing 
python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4_2...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
No schema files found: doing nothing.
 done
Installing icu-50.1.2... done
 done
====
Note that some of the standard modules are provided as separate
<snip>
Installing libXcursor-1.1.14... done
Installing libXfontcache-1.0.5... done
Installing libXi-1.7.2,1... done
Installing libXinerama-1.1.3,1...Installing xineramaproto-1.2.1... done
 done
Installing libXmu-1.1.2,1...Installing libXt-1.1.4,1... done
 done
Installing png-1.5.17... done
Installing xdg-utils-1.0.2.20130919_1...Installing xprop-1.2.2... done
Installing xset-1.2.3_1... done
 done
Installing xorg-fonts-truetype-7.7_1... done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/bin/moc-qt4 - not found
===>    Verifying install for /usr/local/bin/moc-qt4 in /usr/ports/devel/qt4-moc
===>   Installing existing package /packages/All/qt4-moc-4.8.5.txz
Installing qt4-moc-4.8.5... done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/lib/qt4/libQtNetwork.so - 
not found
===>    Verifying install for /usr/local/lib/qt4/libQtNetwork.so in 
/usr/ports/net/qt4-network
===>   Installing existing package /packages/All/qt4-network-4.8.5.txz
Installing qt4-network-4.8.5...Installing ca_root_nss-3.15.1_1... done
 done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/bin/qmake-qt4 - not found
===>    Verifying install for /usr/local/bin/qmake-qt4 in 
/usr/ports/devel/qmake4
===>   Installing existing package /packages/All/qt4-qmake-4.8.5.txz
Installing qt4-qmake-4.8.5... done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/bin/rcc - not found
===>    Verifying install for /usr/local/bin/rcc in /usr/ports/devel/qt4-rcc
===>   Installing existing package /packages/All/qt4-rcc-4.8.5.txz
Installing qt4-rcc-4.8.5... done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.5.txz
Installing qt4-uic-4.8.5... done
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/lib/qt4/libQtWebKit.so - 
not found
===>    Verifying install for /usr/local/lib/qt4/libQtWebKit.so in 
/usr/ports/www/qt4-webkit
===>   Installing existing package /packages/All/qt4-webkit-4.8.5.txz
Installing qt4-webkit-4.8.5...Installing binutils-2.23.2... done
Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
 done
Installing gnomehier-3.0... done
Installing gobject-introspection-1.36.0_2... done
Installing gstreamer-plugins-0.10.36_3,3...Installing videoproto-2.3.2... done
Installing libXv-1.0.10,1... done
Installing gstreamer-0.10.36... done
Installing orc-0.4.18... done
 done
Installing qt4-declarative-4.8.5...Installing qt4-opengl-4.8.5... done
Installing qt4-script-4.8.5... done
Installing qt4-sql-4.8.5... done
Installing qt4-svg-4.8.5... done
Installing qt4-xml-4.8.5... done
Installing qt4-xmlpatterns-4.8.5... done
 done
 done
*******************************************************************************

        To enable QT's database support, install the database plugin ports.
        The following plugin ports are available:

                IBase/Firebird  - databases/qt4-ibase-plugin
                MySQL           - databases/qt4-mysql-plugin
                ODBC            - databases/qt4-odbc-plugin
                PostgreSQL      - databases/qt4-pgsql-plugin
                SQLite          - databases/qt4-sqlite-plugin                   
        

*******************************************************************************
===>   Returning to build of basic256-0.9.9.64
===>   basic256-0.9.9.64 depends on file: /usr/local/lib/qt4/libQtXml.so - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   basic256-0.9.9.64 depends on shared library: SDL-1.2 - found
===>   basic256-0.9.9.64 depends on shared library: SDL_mixer-1.2 - not found
===>    Verifying install for SDL_mixer-1.2 in /usr/ports/audio/sdl_mixer
===>   Installing existing package /packages/All/sdl_mixer-1.2.12_4.txz
Installing sdl_mixer-1.2.12_4...Installing smpeg-0.4.4_10... done
Installing timidity-0.2i_1... done
Installing libvorbis-1.3.3_1,3...Installing libogg-1.3.1,4... done
 done
Installing flac-1.3.0_1... done
 done
===>   Returning to build of basic256-0.9.9.64
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for basic256-0.9.9.64
Project MESSAGE: Running make for ./LEX/Makefile
bison -d basicParse.y
basicParse.y: conflicts: 3 shift/reduce
flex basicParse.l
Project MESSAGE: Running make for ./LEX/Makefile
bison -d basicParse.y
basicParse.y: conflicts: 3 shift/reduce
flex basicParse.l
Project MESSAGE: Running make for ./LEX/Makefile
bison -d basicParse.y
basicParse.y: conflicts: 3 shift/reduce
flex basicParse.l
===========================================================================
=======================<phase: build          >============================
===>  Building for basic256-0.9.9.64
/usr/bin/make -f Makefile.Release all
clang -c -pipe -O2 -pthread -D_THREAD_SAFE -Wall -W -DLINUX -DLINUX_ESPEAK 
-DSOUND_SDL -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_CORE_LIB 
-DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4 -I. 
-I/usr/include/espeak -Itmp/moc -I/usr/local/include/qt4 -I/usr/local/include 
-o tmp/obj/lex.yy.o LEX/lex.yy.c
basicParse.l:313:6: warning: unused variable 'num' [-Wunused-variable]
        int num;
            ^
basicParse.l:614:6: warning: unused variable 'num' [-Wunused-variable]
        int num;
            ^
basicParse.l:621:6: warning: unused variable 'num' [-Wunused-variable]
        int num;
            ^
lex.yy.c:4226:17: warning: unused function 'yyunput' [-Wunused-function]
    static void yyunput (int c, char * yy_bp )
                ^
lex.yy.c:4268:16: warning: function 'input' is not needed and will not be 
emitted [-Wunneeded-internal-declaration]
    static int input  (void)
               ^
5 warnings generated.
clang -c -pipe -O2 -pthread -D_THREAD_SAFE -Wall -W -DLINUX -DLINUX_ESPEAK 
-DSOUND_SDL -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_CORE_LIB 
-DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4 -I. 
-I/usr/include/espeak -Itmp/moc -I/usr/local/include/qt4 -I/usr/local/include 
-o tmp/obj/basicParse.tab.o LEX/basicParse.tab.c
basicParse.y:190:26: warning: unused parameter 'size' [-Wunused-parameter]
newByteCode(unsigned int size) {
                         ^
basicParse.y:2418:21: warning: unused parameter 'msg' [-Wunused-parameter]
yyerror(const char *msg) {
                    ^
2 warnings generated.
clang++ -c -pipe -g -O2 -pthread -D_THREAD_SAFE -Wall -W -DLINUX -DLINUX_ESPEAK 
-DSOUND_SDL -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_CORE_LIB 
-DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4 -I. 
-I/usr/include/espeak -Itmp/moc -I/usr/local/include/qt4 -I/usr/local/include 
-o tmp/obj/BasicEdit.o BasicEdit.cpp
In file included from BasicEdit.cpp:48:
./LineNumberArea.h:51:12: warning: 'LineNumberArea::sizeHint' hides overloaded 
virtual function [-Woverloaded-virtual]
     QSize sizeHint();
           ^
/usr/local/include/qt4/QtGui/qwidget.h:537:19: note: hidden overloaded virtual 
function 'QWidget::sizeHint' declared here: different qualifiers (const vs none)
    virtual QSize sizeHint() const;
                  ^
1 warning generated.
clang++ -c -pipe -g -O2 -pthread -D_THREAD_SAFE -Wall -W -DLINUX -DLINUX_ESPEAK 
-DSOUND_SDL -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_CORE_LIB 
-DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtWebKit -I/usr/local/include/qt4 -I. 
-I/usr/include/espeak -Itmp/moc -I/usr/local/include/qt4 -I/usr/local/include 
-o tmp/obj/BasicGraph.o BasicGraph.cpp
BasicGraph.cpp:136:3: error: reference to 'mutex' is ambiguous
  mutex->lock();
  ^
BasicGraph.cpp:44:16: note: candidate found by name lookup is 'mutex'
extern QMutex *mutex;
               ^
/usr/include/c++/v1/__mutex_base:35:24: note: candidate found by name lookup is 
'std::__1::mutex'
class _LIBCPP_TYPE_VIS mutex
                       ^
BasicGraph.cpp:138:3: error: reference to 'mutex' is ambiguous
  mutex->unlock();
  ^
BasicGraph.cpp:44:16: note: candidate found by name lookup is 'mutex'
extern QMutex *mutex;
               ^
/usr/include/c++/v1/__mutex_base:35:24: note: candidate found by name lookup is 
'std::__1::mutex'
class _LIBCPP_TYPE_VIS mutex
                       ^
2 errors generated.
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/lang/basic256/work
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/lang/basic256/work
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/basic256
===>  Cleaning for basic256-0.9.9.64
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to