You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     din...@freebsd.org
Last committer: din...@freebsd.org
Ident:          $FreeBSD: head/sysutils/ua/Makefile 327804 2013-09-21 11:06:03Z 
dinoex $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s/logs/ua-1.0.1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s
Log:

====>> Building sysutils/ua
build started at Fri Oct 18 10:44:44 UTC 2013
port directory: /usr/ports/sysutils/ua
building for: FreeBSD head-amd64-default-job-16 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: din...@freebsd.org
Makefile ident:      $FreeBSD: head/sysutils/ua/Makefile 327804 2013-09-21 
11:06:03Z dinoex $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=10201
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=ua-1.0.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/ua
DOCSDIR=/usr/local/share/doc/ua
EXAMPLESDIR=/usr/local/share/examples/ua
WWWDIR=/usr/local/www/ua
ETCDIR=/usr/local/etc/ua
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for ua-1.0.1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ua-1.0.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of ua-1.0.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ua-1.0.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ua-1.0.1 for building
=> SHA256 Checksum OK for ua-1.0.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ua-1.0.1 for building
===>  Extracting for ua-1.0.1
=> SHA256 Checksum OK for ua-1.0.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ua-1.0.1
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ua-1.0.1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/sysutils/ua/work/ua-1.0.1/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/sysutils/ua/work/ua-1.0.1/configure
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of c++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking for gcc... cc
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking dependency style of cc... gcc3
checking for MD5_Init in -lcrypto... yes
checking for MD5_Update in -lcrypto... yes
checking for MD5_Final in -lcrypto... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: executing depfiles commands
===========================================================================
=======================<phase: build          >============================
===>  Building for ua-1.0.1
/usr/bin/make  all-am
c++ -DHAVE_CONFIG_H -I.      -O2 -pipe -fno-strict-aliasing -MT filei.o -MD -MP 
-MF .deps/filei.Tpo -c -o filei.o filei.cc
In file included from filei.cc:35:
In file included from ./filei.h:58:
/usr/include/c++/v1/ext/hash_set:202:2: warning: Use of the header 
<ext/hash_set> is deprecated.  Migrate to <unordered_set> [-W#warnings]
#warning Use of the header <ext/hash_set> is deprecated.  Migrate to 
<unordered_set>
 ^
In file included from filei.cc:35:
In file included from ./filei.h:59:
/usr/include/c++/v1/ext/hash_map:209:2: warning: Use of the header 
<ext/hash_map> is deprecated.  Migrate to <unordered_map> [-W#warnings]
#warning Use of the header <ext/hash_map> is deprecated.  Migrate to 
<unordered_map>
 ^
2 warnings generated.
mv -f .deps/filei.Tpo .deps/filei.Po
c++ -DHAVE_CONFIG_H -I.      -O2 -pipe -fno-strict-aliasing -MT ua.o -MD -MP 
-MF .deps/ua.Tpo -c -o ua.o ua.cc
In file included from ua.cc:56:
In file included from ./filei.h:58:
/usr/include/c++/v1/ext/hash_set:202:2: warning: Use of the header 
<ext/hash_set> is deprecated.  Migrate to <unordered_set> [-W#warnings]
#warning Use of the header <ext/hash_set> is deprecated.  Migrate to 
<unordered_set>
 ^
In file included from ua.cc:56:
In file included from ./filei.h:59:
/usr/include/c++/v1/ext/hash_map:209:2: warning: Use of the header 
<ext/hash_map> is deprecated.  Migrate to <unordered_map> [-W#warnings]
#warning Use of the header <ext/hash_map> is deprecated.  Migrate to 
<unordered_map>
 ^
ua.cc:189:19: error: no member named 'getopt' in the global namespace
   while((opt = ::getopt(argc,argv,"hb:viws:m:2pn")) != -1) {
                ~~^
ua.cc:192:27: error: no member named 'optarg' in the global namespace
            BN = ::atoi(::optarg);
                        ~~^
ua.cc:194:57: error: no member named 'optarg' in the global namespace
               std::cerr << "Invalid buffer size " << ::optarg << std::endl;
                                                      ~~^
ua.cc:199:28: error: no member named 'optarg' in the global namespace
            max = ::atoi(::optarg);
                         ~~^
ua.cc:211:33: error: no member named 'optarg' in the global namespace
            sep = std::string(::optarg);
                              ~~^
ua.cc:240:17: error: no member named 'optind' in the global namespace
   if (argc > ::optind) { 
              ~~^
ua.cc:241:21: error: no member named 'optind' in the global namespace
      if (argc >= ::optind +1 && *argv[::optind] == '-') {
                  ~~^
ua.cc:241:42: error: no member named 'optind' in the global namespace
      if (argc >= ::optind +1 && *argv[::optind] == '-') {
                                       ~~^
ua.cc:242:23: error: no member named 'optind' in the global namespace
         if (argc > ::optind + 1) {
                    ~~^
ua.cc:246:12: error: use of undeclared identifier 'optind'
         ++optind;
           ^
ua.cc:253:18: error: no member named 'optind' in the global namespace
   for(int i = ::optind;;) {
               ~~^
2 warnings and 11 errors generated.
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/sysutils/ua/work/ua-1.0.1
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/sysutils/ua/work/ua-1.0.1
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/ua
===>  Cleaning for ua-1.0.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to