You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@heily.com
Last committer: kmo...@freebsd.org
Ident:          $FreeBSD: head/sysutils/jobd/Makefile 415559 2016-05-20 
16:57:33Z kmoore $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/415751/logs/jobd-0.7.0.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=415751
Log:

====>> Building sysutils/jobd
build started at Tue May 24 16:37:27 UTC 2016
port directory: /usr/ports/sysutils/jobd
building for: FreeBSD 93amd64-default-job-24 9.3-RELEASE-p42 FreeBSD 
9.3-RELEASE-p42 amd64
maintained by: m...@heily.com
Makefile ident:      $FreeBSD: head/sysutils/jobd/Makefile 415559 2016-05-20 
16:57:33Z kmoore $
Poudriere version: 3.1.12
Host OSVERSION: 1100109
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 9.3-RELEASE-p42
UNAME_r=9.3-RELEASE-p42
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=jobd-0.7.0
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/jobd/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/jobd/work  
HOME=/wrkdirs/usr/ports/sysutils/jobd/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/jobd/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/jobd/work  
HOME=/wrkdirs/usr/ports/sysutils/jobd/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/jobd"
EXAMPLESDIR="share/examples/jobd"
DATADIR="share/jobd"
WWWDIR="www/jobd"
ETCDIR="etc/jobd"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/jobd
DOCSDIR=/usr/local/share/doc/jobd
EXAMPLESDIR=/usr/local/share/examples/jobd
WWWDIR=/usr/local/www/jobd
ETCDIR=/usr/local/etc/jobd
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License ISCL accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   jobd-0.7.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.3.txz
[93amd64-default-job-24] Installing pkg-1.8.3...
[93amd64-default-job-24] Extracting pkg-1.8.3: .......... done
===>   jobd-0.7.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of jobd-0.7.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by jobd-0.7.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by jobd-0.7.0 for building
=> SHA256 Checksum OK for mheily-jobd-v0.7.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by jobd-0.7.0 for building
===>  Extracting for jobd-0.7.0
=> SHA256 Checksum OK for mheily-jobd-v0.7.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for jobd-0.7.0
===========================================================================
=======================<phase: build-depends  >============================
===>   jobd-0.7.0 depends on executable: docbook2mdoc - not found
===>   Installing existing package /packages/All/docbook2mdoc-0.0.9.txz
[93amd64-default-job-24] Installing docbook2mdoc-0.0.9...
[93amd64-default-job-24] `-- Installing expat-2.1.1...
[93amd64-default-job-24] `-- Extracting expat-2.1.1: .......... done
[93amd64-default-job-24] Extracting docbook2mdoc-0.0.9: ..... done
===>   jobd-0.7.0 depends on executable: docbook2mdoc - found
===>   Returning to build of jobd-0.7.0
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for jobd-0.7.0
checking for the existence of <sys/limits.h>.. yes
checking for the existence of <sys/event.h>.. yes
checking for an executable docbook2mdoc.. yes
creating Makefile
creating src/Makefile
*** ERROR *** Unable to generate dependencies for ipc.cpp
Please review the contents of config.log to determine the cause: 
setting $prefix to /usr/local
setting $libdir to /usr/local/lib
setting $bindir to /usr/local/bin
setting $sbindir to /usr/local/sbin
setting $libexecdir to /usr/local/libexec
setting $mandir to /usr/local/man
setting $sysconfdir to /usr/local/etc
setting $datadir to /usr/local/share
setting $localstatedir to /var
setting $runstatedir to /var/run
[DEBUG] checking dependencies of static-ipc.o:\n + c++ -include ../../config.h 
-I../../vendor -fPIC -std=c++11 -Wall -Werror -isystem /usr/local/include  -O2 
-pipe -fstack-protector -fno-strict-aliasing -MM -MT static-ipc.o ipc.cpp
cc1plus: error: unrecognized command line option "-std=c++11"
[ERROR] Unable to generate dependencies for ipc.cpp
*** ERROR *** Unable to run configure in ./libjob/
Please review the contents of config.log to determine the cause: 
setting $prefix to /usr/local
setting $libdir to /usr/local/lib
setting $bindir to /usr/local/bin
setting $sbindir to /usr/local/sbin
setting $libexecdir to /usr/local/libexec
setting $mandir to /usr/local/man
setting $sysconfdir to /usr/local/etc
setting $datadir to /usr/local/share
setting $localstatedir to /var
setting $runstatedir to /var/run
[DEBUG] checking dependencies of static-ipc.o:\n + c++ -include ../../config.h 
-I../../vendor -fPIC -std=c++11 -Wall -Werror -isystem /usr/local/include  -O2 
-pipe -fstack-protector -fno-strict-aliasing -MM -MT static-ipc.o ipc.cpp
cc1plus: error: unrecognized command line option "-std=c++11"
[ERROR] Unable to generate dependencies for ipc.cpp
[ERROR] Unable to run configure in ./libjob/
*** ERROR *** Unable to run configure in ./src/
Please review the contents of config.log to determine the cause: 
setting $prefix to /usr/local
setting $libdir to /usr/local/lib
setting $bindir to /usr/local/bin
setting $sbindir to /usr/local/sbin
setting $libexecdir to /usr/local/libexec
setting $mandir to /usr/local/man
setting $sysconfdir to /usr/local/etc
setting $datadir to /usr/local/share
setting $localstatedir to /var
setting $runstatedir to /var/run
[ERROR] Unable to run configure in ./src/
===>  Script "configure" failed unexpectedly.
Please report the problem to m...@heily.com [maintainer] and attach the
"/wrkdirs/usr/ports/sysutils/jobd/work/jobd-0.7.0/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/sysutils/jobd.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to