You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     hask...@freebsd.org
Last committer: p...@freebsd.org
Ident:          $FreeBSD: head/security/hs-crypto-api/Makefile 394918 
2015-08-20 23:02:14Z pgj $
Log URL:        
http://beefy4.nyi.freebsd.org/data/head-amd64-default/p415869_s300703/logs/hs-crypto-api-0.13.2.log
Build URL:      
http://beefy4.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p415869_s300703
Log:

====>> Building security/hs-crypto-api
build started at Thu May 26 08:20:43 UTC 2016
port directory: /usr/ports/security/hs-crypto-api
building for: FreeBSD head-amd64-default-job-21 11.0-CURRENT FreeBSD 
11.0-CURRENT r300703 amd64
maintained by: hask...@freebsd.org
Makefile ident:      $FreeBSD: head/security/hs-crypto-api/Makefile 394918 
2015-08-20 23:02:14Z pgj $
Poudriere version: 3.1.12
Host OSVERSION: 1100109
Jail OSVERSION: 1100113




!!! Jail is newer than host. (Jail: 1100113, Host: 1100109) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-CURRENT r300703
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=hs-crypto-api-0.13.2
OSREL=11.0
_OSRELEASE=11.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES LINUX_OSRELEASE=2.6.32
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100113
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for hs-crypto-api-0.13.2:
     DOCS=on: Build and/or install documentation
     DYNAMIC=on: Add support for dynamic linking
     HSCOLOUR=off: Colorize generated documentation by HsColour
     LLVM=off: Use the LLVM backend for code generation
     PROFILE=off: Add support for profiling
====> Options available for the single C_Compiler: you have to select exactly 
one of them
     GCC=on: Build with modern GCC (from ports)
     PCLANG=off: Build with Clang from ports
     BCLANG=off: Build with Clang from base
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--libdir=/usr/local/lib/cabal/ghc-7.10.2 --libsubdir=crypto-api-0.13.2 
--with-gcc=gcc48 --with-ld=/usr/local/bin/ld --with-ar=/usr/local/bin/ar 
--haddock-options=-w --with-haddock=/usr/local/bin/haddock --enable-shared 
--enable-executable-dynamic --disable-executable-profiling 
--disable-library-profiling
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work  
HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work 
TMPDIR="/wrkdirs/usr/ports/security/hs-crypto-api/work/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 
DESTDIR=/wrkdirs/usr/ports/security/hs-crypto-api/work/stage  
TMPDIR=/wrkdirs/usr/ports/security/hs-crypto-api/work/tmp 
XDG_DATA_HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work  
HOME=/wrkdirs/usr/ports/security/hs-crypto-api/work 
TMPDIR="/wrkdirs/usr/ports/security/hs-crypto-api/work/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc48" CFLAGS="-O2 -pipe  
-I/usr/local/include -fstack-protector -Wl,-rpath=/usr/lo
 cal/lib/gcc48 -fno-strict-aliasing"  CPP="cpp48" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib -fstack-protector 
-Wl,-rpath=/usr/local/lib/gcc48 -L/usr/local/lib/gcc48" LIBS=""  CXX="g++48" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -fstack-protector 
-Wl,-rpath=/usr/local/lib/gcc48 -fno-strict-aliasing  
-Wl,-rpath=/usr/local/lib/gcc48"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GHC_VERSION=7.10.2
PORTNAME=crypto-api
PORTVERSION=0.13.2
LIBDIR_REL=lib/cabal/ghc-7.10.2/crypto-api-0.13.2
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/cabal/ghc-7.10.2/crypto-api-0.13.2"
EXAMPLESDIR="share/examples/cabal/ghc-7.10.2/crypto-api-0.13.2"
DATADIR="share/cabal/ghc-7.10.2/crypto-api-0.13.2"
WWWDIR="www/crypto-api"
ETCDIR="etc/crypto-api"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/cabal/ghc-7.10.2/crypto-api-0.13.2
DOCSDIR=/usr/local/share/doc/cabal/ghc-7.10.2/crypto-api-0.13.2
EXAMPLESDIR=/usr/local/share/examples/cabal/ghc-7.10.2/crypto-api-0.13.2
WWWDIR=/usr/local/www/crypto-api
ETCDIR=/usr/local/etc/crypto-api
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   hs-crypto-api-0.13.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.3.txz
[head-amd64-default-job-21] Installing pkg-1.8.3...
[head-amd64-default-job-21] Extracting pkg-1.8.3: .......... done
===>   hs-crypto-api-0.13.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of hs-crypto-api-0.13.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-crypto-api-0.13.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-crypto-api-0.13.2 for building
=> SHA256 Checksum OK for cabal/crypto-api-0.13.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-crypto-api-0.13.2 for building
===>  Extracting for hs-crypto-api-0.13.2
=> SHA256 Checksum OK for cabal/crypto-api-0.13.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for hs-crypto-api-0.13.2
===========================================================================
=======================<phase: build-depends  >============================
===>   hs-crypto-api-0.13.2 depends on executable: ghc - not found
===>   Installing existing package /packages/All/ghc-7.10.2.txz
[head-amd64-default-job-21] Installing ghc-7.10.2...
[head-amd64-default-job-21] `-- Installing libiconv-1.14_9...
[head-amd64-default-job-21] `-- Extracting libiconv-1.14_9: .......... done
[head-amd64-default-job-21] `-- Installing gmp-5.1.3_3...
[head-amd64-default-job-21] |   `-- Installing indexinfo-0.2.4...
[head-amd64-default-job-21] |   `-- Extracting indexinfo-0.2.4: .... done
[head-amd64-default-job-21] `-- Extracting gmp-5.1.3_3: .......... done
[head-amd64-default-job-21] `-- Installing libffi-3.2.1...
[head-amd64-default-job-21] `-- Extracting libffi-3.2.1: .......... done
[head-amd64-default-job-21] `-- Installing gcc-4.8.5_2...
[head-amd64-default-job-21] |   `-- Installing mpc-1.0.3...
[head-amd64-default-job-21] |   | `-- Installing mpfr-3.1.4...
[head-amd64-default-job-21] |   | `-- Extracting mpfr-3.1.4: .......... done
[head-amd64-default-job-21] |   `-- Extracting mpc-1.0.3: ...... done
[head-amd64-default-job-21] |   `-- Installing binutils-2.25.1_2,1...
[head-amd64-default-job-21] |   | `-- Installing gettext-runtime-0.19.7...
[head-amd64-default-job-21] |   | `-- Extracting gettext-runtime-0.19.7: 
.......... done
[head-amd64-default-job-21] |   `-- Extracting binutils-2.25.1_2,1: .......... 
done
[head-amd64-default-job-21] |   `-- Installing gcc-ecj-4.5...
[head-amd64-default-job-21] |   `-- Extracting gcc-ecj-4.5: . done
[head-amd64-default-job-21] `-- Extracting gcc-4.8.5_2: .......... done
[head-amd64-default-job-21] Extracting ghc-7.10.2: .......... done
Message from gcc-4.8.5_2:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc48

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   hs-crypto-api-0.13.2 depends on executable: ghc - found
===>   Returning to build of hs-crypto-api-0.13.2
===>   hs-crypto-api-0.13.2 depends on package: ghc>=7.10.2 - found
===>   hs-crypto-api-0.13.2 depends on package: hs-cereal>=0.2 - not found
===>   Installing existing package /packages/All/hs-cereal-0.4.1.1.txz
[head-amd64-default-job-21] Installing hs-cereal-0.4.1.1...
[head-amd64-default-job-21] Extracting hs-cereal-0.4.1.1: .......... done
===>   hs-crypto-api-0.13.2 depends on package: hs-cereal>=0.2 - found
===>   Returning to build of hs-crypto-api-0.13.2
===>   hs-crypto-api-0.13.2 depends on package: hs-entropy>=0 - not found
===>   Installing existing package /packages/All/hs-entropy-0.3.7.txz
[head-amd64-default-job-21] Installing hs-entropy-0.3.7...
[head-amd64-default-job-21] Extracting hs-entropy-0.3.7: .......... done
===>   hs-crypto-api-0.13.2 depends on package: hs-entropy>=0 - found
===>   Returning to build of hs-crypto-api-0.13.2
===>   hs-crypto-api-0.13.2 depends on package: hs-tagged>=0.1 - not found
===>   Installing existing package /packages/All/hs-tagged-0.8.1.txz
[head-amd64-default-job-21] Installing hs-tagged-0.8.1...
[head-amd64-default-job-21] Extracting hs-tagged-0.8.1: .......... done
===>   hs-crypto-api-0.13.2 depends on package: hs-tagged>=0.1 - found
===>   Returning to build of hs-crypto-api-0.13.2
===>   hs-crypto-api-0.13.2 depends on executable: gcc48 - found
===>   hs-crypto-api-0.13.2 depends on file: /usr/local/bin/as - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for hs-crypto-api-0.13.2
[1 of 1] Compiling Main             ( Setup.hs, Setup.o )
Linking ./setup ...
Configuring crypto-api-0.13.2...
===========================================================================
=======================<phase: build          >============================
===>  Building for hs-crypto-api-0.13.2
Building crypto-api-0.13.2...
Preprocessing library crypto-api-0.13.2...
[ 1 of 11] Compiling Crypto.CPoly     ( Crypto/CPoly.hs, 
dist/build/Crypto/CPoly.o )
[ 2 of 11] Compiling Crypto.Types     ( Crypto/Types.hs, 
dist/build/Crypto/Types.o )
[ 3 of 11] Compiling Crypto.Util      ( Crypto/Util.hs, 
dist/build/Crypto/Util.o )
[ 4 of 11] Compiling Crypto.Random    ( Crypto/Random.hs, 
dist/build/Crypto/Random.o )
[ 5 of 11] Compiling Crypto.Classes[boot] ( Crypto/Classes.hs-boot, 
dist/build/Crypto/Classes.o-boot )
[ 6 of 11] Compiling Crypto.Modes[boot] ( Crypto/Modes.hs-boot, 
dist/build/Crypto/Modes.o-boot )
[ 7 of 11] Compiling Crypto.Classes   ( Crypto/Classes.hs, 
dist/build/Crypto/Classes.o )
[ 8 of 11] Compiling Crypto.HMAC      ( Crypto/HMAC.hs, 
dist/build/Crypto/HMAC.o )
[ 9 of 11] Compiling Crypto.Padding   ( Crypto/Padding.hs, 
dist/build/Crypto/Padding.o )
[10 of 11] Compiling Crypto.Classes.Exceptions ( Crypto/Classes/Exceptions.hs, 
dist/build/Crypto/Classes/Exceptions.o )
[11 of 11] Compiling Crypto.Modes     ( Crypto/Modes.hs, 
dist/build/Crypto/Modes.o )
In-place registering crypto-api-0.13.2...
Creating package registration script: register.sh
*** Signal 10

Stop.
make: stopped in /usr/ports/security/hs-crypto-api
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to