You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     k...@freebsd.org
Last committer: r...@freebsd.org
Ident:          $FreeBSD: head/x11/plasma-scriptengine-ruby/Makefile 415864 
2016-05-25 20:56:06Z rene $
Log URL:        
http://package19.nyi.freebsd.org/data/103i386-default-build-as-user/415919/logs/plasma-scriptengine-ruby-4.11.14.log
Build URL:      
http://package19.nyi.freebsd.org/build.html?mastername=103i386-default-build-as-user&build=415919
Log:

====>> Building x11/plasma-scriptengine-ruby
build started at Fri May 27 18:13:38 UTC 2016
port directory: /usr/ports/x11/plasma-scriptengine-ruby
building for: FreeBSD 103i386-default-build-as-user-job-02 10.3-RELEASE-p3 
FreeBSD 10.3-RELEASE-p3 i386
maintained by: k...@freebsd.org
Makefile ident:      $FreeBSD: head/x11/plasma-scriptengine-ruby/Makefile 
415864 2016-05-25 20:56:06Z rene $
Poudriere version: 3.1.12
Host OSVERSION: 1100109
Jail OSVERSION: 1003000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 10.3-RELEASE-p3
UNAME_r=10.3-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
LINUX_OSRELEASE=2.6.32
SAVED_TERM=
MASTERMNT=/poudriere/data/.m/103i386-default-build-as-user/ref
FORCE_PACKAGE=yes
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=plasma-scriptengine-ruby-4.11.14
OSREL=10.3
_OSRELEASE=10.3-RELEASE-p3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=32
PWD=/poudriere/data/.m/103i386-default-build-as-user/ref/.p/pool
MASTERNAME=103i386-default-build-as-user
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1003000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work  
HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh QTDIR="/usr/local" 
QMAKE="/usr/local/bin/qmake-qt4"  MOC="/usr/local/bin/moc-qt4" 
RCC="/usr/local/bin/rcc" UIC="/usr/local/bin/uic-qt4"  
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-$(ccver="$(c++ --version)"; 
case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work  
HOME=/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work TMPDIR="/tmp" 
NO_PIE=yes WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 
-pipe -fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.2"
RUBY_ARCHLIBDIR="lib/ruby/2.2/i386-freebsd10"
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.2"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.2/i386-freebsd10"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.2"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.2/i386-freebsd10"
RUBY_MODDOCDIR="share/doc/ruby22/plasma-scriptengine-ruby"
RUBY_MODEXAMPLESDIR="share/examples/ruby22/plasma-scriptengine-ruby"
RUBY_DOCDIR="share/doc/ruby22"
RUBY_EXAMPLESDIR="share/examples/ruby22"
RUBY_RIDIR="share/ri/2.2/system"
RUBY_SITERIDIR="share/ri/2.2/site"
RUBY_ELISPDIR="lib/ruby/elisp"
RUBY_VERSION="2.2.5"
RUBY_VER="2.2"
RUBY_SHLIBVER="22"
RUBY_ARCH="i386-freebsd10"
RUBY_SUFFIX="22"
RUBY_NAME="ruby22"
RUBY_DEFAULT_SUFFIX="22"
RUBY20="@comment
"
RUBY21="@comment
"
RUBY22=""
RUBY23="@comment
"
RUBY_RD_HTML_FILES="@comment
"
QT_PREFIX="/usr/local"
QT_BINDIR="bin"
QT_INCDIR="include/qt4"
QT_LIBDIR="lib/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
KDE4_PREFIX="/usr/local"
KDE4_VERSION="4.14.3"
KDE4_GENERIC_LIB_VERSION=4.14.3
KDE4_NON_GENERIC_LIB_VERSION=5.14.3
PYCACHE=""
PYC_SUFFIX=pyc
PYO_SUFFIX=pyo
CMAKE_BUILD_TYPE="release"
OSREL=10.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/plasma-scriptengine-ruby"
EXAMPLESDIR="share/examples/plasma-scriptengine-ruby"
DATADIR="share/plasma-scriptengine-ruby"
WWWDIR="www/plasma-scriptengine-ruby"
ETCDIR="etc/plasma-scriptengine-ruby"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/plasma-scriptengine-ruby
DOCSDIR=/usr/local/share/doc/plasma-scriptengine-ruby
EXAMPLESDIR=/usr/local/share/examples/plasma-scriptengine-ruby
WWWDIR=/usr/local/www/plasma-scriptengine-ruby
ETCDIR=/usr/local/etc/plasma-scriptengine-ruby
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/sbin/pkg - 
not found
===>   Installing existing package /packages/All/pkg-1.8.3.txz
[103i386-default-build-as-user-job-02] Installing pkg-1.8.3...
[103i386-default-build-as-user-job-02] Extracting pkg-1.8.3: .......... done
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/sbin/pkg - 
found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by plasma-scriptengine-ruby-4.11.14 for 
building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by plasma-scriptengine-ruby-4.11.14 for 
building
=> SHA256 Checksum OK for KDE/4.11.14/kde-workspace-4.11.14.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/ruby22 
- not found
===>   Installing existing package /packages/All/ruby-2.2.5,1.txz
[103i386-default-build-as-user-job-02] Installing ruby-2.2.5,1...
[103i386-default-build-as-user-job-02] `-- Installing libffi-3.2.1...
[103i386-default-build-as-user-job-02] |   `-- Installing indexinfo-0.2.4...
[103i386-default-build-as-user-job-02] |   `-- Extracting indexinfo-0.2.4: .... 
done
[103i386-default-build-as-user-job-02] `-- Extracting libffi-3.2.1: .......... 
done
[103i386-default-build-as-user-job-02] `-- Installing libyaml-0.1.6_2...
[103i386-default-build-as-user-job-02] `-- Extracting libyaml-0.1.6_2: 
......... done
[103i386-default-build-as-user-job-02] `-- Installing libedit-3.1.20150325_2...
[103i386-default-build-as-user-job-02] `-- Extracting libedit-3.1.20150325_2: 
.......... done
[103i386-default-build-as-user-job-02] Extracting ruby-2.2.5,1: .......... done
Message from ruby-2.2.5,1:
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:
<snip>
        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/ruby22 
- found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by plasma-scriptengine-ruby-4.11.14 for 
building
===>  Extracting for plasma-scriptengine-ruby-4.11.14
=> SHA256 Checksum OK for KDE/4.11.14/kde-workspace-4.11.14.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/ruby22 
- found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for plasma-scriptengine-ruby-4.11.14
===>  Applying FreeBSD patches for plasma-scriptengine-ruby-4.11.14
===========================================================================
=======================<phase: build-depends  >============================
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/ruby22 
- found
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/cmake - 
not found
===>   Installing existing package /packages/All/cmake-3.5.2_1.txz
[103i386-default-build-as-user-job-02] Installing cmake-3.5.2_1...
[103i386-default-build-as-user-job-02] `-- Installing expat-2.1.1...
[103i386-default-build-as-user-job-02] `-- Extracting expat-2.1.1: .......... 
done
[103i386-default-build-as-user-job-02] `-- Installing cmake-modules-3.5.2...
[103i386-default-build-as-user-job-02] `-- Extracting cmake-modules-3.5.2: 
.......... done
[103i386-default-build-as-user-job-02] `-- Installing curl-7.49.0...
[103i386-default-build-as-user-job-02] |   `-- Installing ca_root_nss-3.22.2...
[103i386-default-build-as-user-job-02] |   `-- Extracting ca_root_nss-3.22.2: 
....... done
[103i386-default-build-as-user-job-02] `-- Extracting curl-7.49.0: .......... 
done
[103i386-default-build-as-user-job-02] `-- Installing libarchive-3.2.0_1,1...
[103i386-default-build-as-user-job-02] |   `-- Installing liblz4-131...
[103i386-default-build-as-user-job-02] |   `-- Extracting liblz4-131: 
.......... done
[103i386-default-build-as-user-job-02] |   `-- Installing lzo2-2.09...
[103i386-default-build-as-user-job-02] |   `-- Extracting lzo2-2.09: .......... 
done
[103i386-default-build-as-user-job-02] `-- Extracting libarchive-3.2.0_1,1: 
.......... done
[103i386-default-build-as-user-job-02] `-- Installing jsoncpp-1.7.2...
[103i386-default-build-as-user-job-02] `-- Extracting jsoncpp-1.7.2: .......... 
done
[103i386-default-build-as-user-job-02] Extracting cmake-3.5.2_1: .......... done
Message from ca_root_nss-3.22.2:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/cmake - 
found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/moc-qt4 
- not found
===>   Installing existing package /packages/All/qt4-moc-4.8.7_1.txz
[103i386-default-build-as-user-job-02] Installing qt4-moc-4.8.7_1...
[103i386-default-build-as-user-job-02] Extracting qt4-moc-4.8.7_1: .... done
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/moc-qt4 
- found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===>   plasma-scriptengine-ruby-4.11.14 depends on file: 
/usr/local/bin/qmake-qt4 - not found
===>   Installing existing package /packages/All/qt4-qmake-4.8.7.txz
[103i386-default-build-as-user-job-02] Installing qt4-qmake-4.8.7...
[103i386-default-build-as-user-job-02] Extracting qt4-qmake-4.8.7: .......... 
done
===>   plasma-scriptengine-ruby-4.11.14 depends on file: 
/usr/local/bin/qmake-qt4 - found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/rcc - 
not found
===>   Installing existing package /packages/All/qt4-rcc-4.8.7.txz
[103i386-default-build-as-user-job-02] Installing qt4-rcc-4.8.7...
[103i386-default-build-as-user-job-02] Extracting qt4-rcc-4.8.7: .... done
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/rcc - 
found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/uic-qt4 
- not found
===>   Installing existing package /packages/All/qt4-uic-4.8.7.txz
[103i386-default-build-as-user-job-02] Installing qt4-uic-4.8.7...
[103i386-default-build-as-user-job-02] Extracting qt4-uic-4.8.7: .... done
===>   plasma-scriptengine-ruby-4.11.14 depends on file: /usr/local/bin/uic-qt4 
- found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===>   plasma-scriptengine-ruby-4.11.14 depends on file: 
/usr/local/bin/automoc4 - not found
===>   Installing existing package /packages/All/automoc4-0.9.88_4.txz
[103i386-default-build-as-user-job-02] Installing automoc4-0.9.88_4...
[103i386-default-build-as-user-job-02] `-- Installing qt4-corelib-4.8.7_2...
[103i386-default-build-as-user-job-02] |   `-- Installing glib-2.46.2...
[103i386-default-build-as-user-job-02] |   | `-- Installing libiconv-1.14_9...
[103i386-default-build-as-user-job-02] |   | `-- Extracting libiconv-1.14_9: 
.......... done
[103i386-default-build-as-user-job-02] |   | `-- Installing python27-2.7.11_2...
[103i386-default-build-as-user-job-02] |   |   `-- Installing 
gettext-runtime-0.19.7...
[103i386-default-build-as-user-job-02] |   |   `-- Extracting 
gettext-runtime-0.19.7: .......... done
[103i386-default-build-as-user-job-02] |   | `-- Extracting python27-2.7.11_2: 
.......... done
[103i386-default-build-as-user-job-02] |   | `-- Installing pcre-8.38_1...
[103i386-default-build-as-user-job-02] |   | `-- Extracting pcre-8.38_1: 
.......... done
[103i386-default-build-as-user-job-02] |   | `-- Installing perl5-5.20.3_13...
[103i386-default-build-as-user-job-02] |   | `-- Extracting perl5-5.20.3_13: 
.......... done
[103i386-default-build-as-user-job-02] |   `-- Extracting glib-2.46.2: 
.......... done
No schema files found: doing nothing.
[103i386-default-build-as-user-job-02] |   `-- Installing icu-55.1...
[103i386-default-build-as-user-job-02] |   `-- Extracting icu-55.1: .......... 
done
[103i386-default-build-as-user-job-02] `-- Extracting qt4-corelib-4.8.7_2: 
.......... done
[103i386-default-build-as-user-job-02] Extracting automoc4-0.9.88_4: .... done
Message from python27-2.7.11_2:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_13:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from qt4-corelib-4.8.7_2:
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
===>   plasma-scriptengine-ruby-4.11.14 depends on file: 
/usr/local/bin/automoc4 - found
===>   Returning to build of plasma-scriptengine-ruby-4.11.14
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for plasma-scriptengine-ruby-4.11.14
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work/.build
-- The C compiler identification is Clang 3.4.1
-- The CXX compiler identification is Clang 3.4.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at /usr/local/share/cmake/Modules/FindKDE4.cmake:71 (message):
  ERROR: Could not find KDE4 kde4-config
Call Stack (most recent call first):
  CMakeLists.txt:1 (find_package)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.5)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/x11/plasma-scriptengine-ruby/work/.build/CMakeFiles/CMakeOutput.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/plasma-scriptengine-ruby
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to