You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     joh...@freebsd.org
Last committer: joh...@freebsd.org
Ident:          $FreeBSD: branches/2016Q3/security/xmlsec1/Makefile 414108 
2016-04-27 13:01:05Z johans $
Log URL:        
http://beefy4.nyi.freebsd.org/data/93amd64-quarterly/422268/logs/xmlsec1-1.2.22.log
Build URL:      
http://beefy4.nyi.freebsd.org/build.html?mastername=93amd64-quarterly&build=422268
Log:

====>> Building security/xmlsec1
build started at Sat Sep 17 01:41:26 UTC 2016
port directory: /usr/ports/security/xmlsec1
building for: FreeBSD 93amd64-quarterly-job-17 9.3-RELEASE-p45 FreeBSD 
9.3-RELEASE-p45 amd64
maintained by: joh...@freebsd.org
Makefile ident:      $FreeBSD: branches/2016Q3/security/xmlsec1/Makefile 414108 
2016-04-27 13:01:05Z johans $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 9.3-RELEASE-p45
UNAME_r=9.3-RELEASE-p45
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=xmlsec1-1.2.22
OSREL=9.3
_OSRELEASE=9.3-RELEASE-p45
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/93amd64-quarterly/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES LINUX_OSRELEASE=2.6.32
MASTERNAME=93amd64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for xmlsec1-1.2.22:
     DOCS=on: Build and/or install documentation
     GNUTLS=off: Enable GNUTLS support
     NSS=off: Enable Mozilla's NSS support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-openssl="/usr" --without-gnutls --without-nss --without-nspr 
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/security/xmlsec1/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/xmlsec1/work  
HOME=/wrkdirs/usr/ports/security/xmlsec1/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
ABS_BUILDDIR=/wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22 
TMPFOLDER=/wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22 DOCS=docs 
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include 
OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/security/xmlsec1/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/xmlsec1/work  
HOME=/wrkdirs/usr/ports/security/xmlsec1/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -I/usr/local/include -fstack-protector -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -L/usr/local/lib  -fstack-protector" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -fstack-protector 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_M
 AN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
DOCS=""
NO_DOCS="@comment
"
GNUTLS="@comment
"
NO_GNUTLS=""
NSS="@comment
"
NO_NSS=""
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/xmlsec1"
EXAMPLESDIR="share/examples/xmlsec1"
DATADIR="share/xmlsec1"
WWWDIR="www/xmlsec1"
ETCDIR="etc/xmlsec1"
--End PLIST_SUB--

--SUB_LIST--
DOCS=""
NO_DOCS="@comment
"
GNUTLS="@comment
"
NO_GNUTLS=""
NSS="@comment
"
NO_NSS=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/xmlsec1
DOCSDIR=/usr/local/share/doc/xmlsec1
EXAMPLESDIR=/usr/local/share/examples/xmlsec1
WWWDIR=/usr/local/www/xmlsec1
ETCDIR=/usr/local/etc/xmlsec1
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   xmlsec1-1.2.22 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_1.txz
[93amd64-quarterly-job-17] Installing pkg-1.8.7_1...
[93amd64-quarterly-job-17] Extracting pkg-1.8.7_1: .......... done
===>   xmlsec1-1.2.22 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of xmlsec1-1.2.22
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by xmlsec1-1.2.22 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by xmlsec1-1.2.22 for building
=> SHA256 Checksum OK for xmlsec1-1.2.22.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by xmlsec1-1.2.22 for building
===>  Extracting for xmlsec1-1.2.22
=> SHA256 Checksum OK for xmlsec1-1.2.22.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for xmlsec1-1.2.22
===========================================================================
=======================<phase: build-depends  >============================
===>   xmlsec1-1.2.22 depends on package: pkgconf>=0.9.10 - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12_1.txz
[93amd64-quarterly-job-17] Installing pkgconf-0.9.12_1...
[93amd64-quarterly-job-17] Extracting pkgconf-0.9.12_1: ....... done
===>   xmlsec1-1.2.22 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of xmlsec1-1.2.22
===========================================================================
=======================<phase: lib-depends    >============================
===>   xmlsec1-1.2.22 depends on shared library: libltdl.so - not found
===>   Installing existing package /packages/All/libltdl-2.4.6.txz
[93amd64-quarterly-job-17] Installing libltdl-2.4.6...
[93amd64-quarterly-job-17] Extracting libltdl-2.4.6: .......... done
===>   xmlsec1-1.2.22 depends on shared library: libltdl.so - found 
(/usr/local/lib/libltdl.so)
===>   Returning to build of xmlsec1-1.2.22
===>   xmlsec1-1.2.22 depends on shared library: libxml2.so - not found
===>   Installing existing package /packages/All/libxml2-2.9.4.txz
[93amd64-quarterly-job-17] Installing libxml2-2.9.4...
[93amd64-quarterly-job-17] `-- Installing libiconv-1.14_9...
[93amd64-quarterly-job-17] `-- Extracting libiconv-1.14_9: .......... done
[93amd64-quarterly-job-17] Extracting libxml2-2.9.4: .......... done
===>   xmlsec1-1.2.22 depends on shared library: libxml2.so - found 
(/usr/local/lib/libxml2.so)
===>   Returning to build of xmlsec1-1.2.22
===>   xmlsec1-1.2.22 depends on shared library: libxslt.so - not found
===>   Installing existing package /packages/All/libxslt-1.1.29.txz
[93amd64-quarterly-job-17] Installing libxslt-1.1.29...
[93amd64-quarterly-job-17] `-- Installing libgcrypt-1.7.3...
[93amd64-quarterly-job-17] |   `-- Installing indexinfo-0.2.4...
[93amd64-quarterly-job-17] |   `-- Extracting indexinfo-0.2.4: .... done
[93amd64-quarterly-job-17] |   `-- Installing libgpg-error-1.23...
[93amd64-quarterly-job-17] |   | `-- Installing gettext-runtime-0.19.8.1...
[93amd64-quarterly-job-17] |   | `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[93amd64-quarterly-job-17] |   `-- Extracting libgpg-error-1.23: .......... done
[93amd64-quarterly-job-17] `-- Extracting libgcrypt-1.7.3: .......... done
[93amd64-quarterly-job-17] Extracting libxslt-1.1.29: .......... done
===>   xmlsec1-1.2.22 depends on shared library: libxslt.so - found 
(/usr/local/lib/libxslt.so)
===>   Returning to build of xmlsec1-1.2.22
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for xmlsec1-1.2.22
<snip>
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd9.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for cp... /bin/cp
checking for mv... /bin/mv
checking for tar... /usr/bin/tar
checking for perl... no
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking for ANSI C header files... (cached) yes
checking for stdio.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for ctype.h... (cached) yes
checking for errno.h... (cached) yes
checking ansidecl.h usability... no
checking ansidecl.h presence... no
checking for ansidecl.h... no
checking for time.h... (cached) yes
checking for strchr... yes
checking for strrchr... yes
checking for printf... yes
checking for sprintf... yes
checking for fprintf... yes
checking for snprintf... (cached) yes
checking for vfprintf... yes
checking for vsprintf... (cached) yes
checking for vsnprintf... (cached) yes
checking for sscanf... yes
checking for timegm... yes
checking for development environment... no
checking for man pages build... no
checking for docs build... no
checking for __FUNCTION__ or __func__... __func__
checking size of size_t... 8
checking for pkg-config... yes
checking pkg-config is at least version 0.9.0... yes
checking for LIBXML... yes
checking for LIBXSLT... yes
checking for openssl libraries >= 0.9.8... yes ('0.9.8')
checking for NSS libraries... no
checking for GCRYPT... no
checking for GCRYPT... no
checking for GCRYPT... no
checking for gcrypt libraries >= 1.4.0... checking for gnutls libraries >= 
2.8.0... no
checking for mscrypto libraries... none
checking for default crypto library... yes ('openssl')
checking for MD5 support... yes
checking for RIPEMD-160 support... yes
checking for SHA1 support... yes
checking for SHA224 support... yes
checking for SHA256 support... yes
checking for SHA384 support... yes
checking for SHA512 support... yes
checking for HMAC support... yes
checking for DSA support... yes
checking for RSA support... yes
checking for x509 support... yes
checking for DES support... yes
checking for AES support... yes
checking for GOST support... no
checking for EXPERMIENTAL GOST2012 support... no
checking for XMLDSig support... yes
checking for XMLEnc support... yes
checking for xmlsec-crypto dynamic loading support... checking ltdl.h 
usability... yes
checking ltdl.h presence... no
configure: WARNING: ltdl.h: accepted by the compiler, rejected by the 
preprocessor!
configure: WARNING: ltdl.h: proceeding with the compiler's result
checking for ltdl.h... yes
checking for lt_dlopenext in -lltdl... yes
yes
checking for xmlsec-crypto dynamic loading support in command line tool... yes
checking for docs folder... $(datadir)/doc/xmlsec1
checking for Simple Keys Manager testing... yes
checking for templates testing... yes
checking for debugging... no
checking for profiling... no
checking for pedantic... no
checking for static linking... no
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating include/xmlsec/openssl/Makefile
config.status: creating src/openssl/Makefile
config.status: creating include/xmlsec/gcrypt/Makefile
config.status: creating src/gcrypt/Makefile
config.status: creating xmlsec1.pc
config.status: creating include/xmlsec/version.h
config.status: creating Makefile
config.status: creating include/Makefile
config.status: creating include/xmlsec/Makefile
config.status: creating include/xmlsec/private/Makefile
config.status: creating src/Makefile
config.status: creating apps/Makefile
config.status: creating docs/Makefile
config.status: creating docs/api/Makefile
config.status: creating man/Makefile
config.status: creating xmlsec1-openssl.pc
config.status: creating xmlsec1-gnutls.pc
config.status: creating xmlsec1-gcrypt.pc
config.status: creating xmlsec1-nss.pc
config.status: creating xmlsec1.spec
config.status: creating xmlsec1Conf.sh
config.status: creating xmlsec1-config
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
===========================================================================
=======================<phase: build          >============================
===>  Building for xmlsec1-1.2.22
/usr/bin/make  all-recursive
Making all in include
Making all in xmlsec
Making all in private
Making all in openssl
Making all in gcrypt
Making all in src
Making all in .
  CC       app.lo
  CC       base64.lo
  CC       bn.lo
bn.c: In function 'xmlSecBnFromString':
bn.c:255: warning: comparison is always true due to limited range of data type
  CC       buffer.lo
  CC       c14n.lo
  CC       dl.lo
  CC       enveloped.lo
  CC       errors.lo
  CC       io.lo
  CC       keyinfo.lo
  CC       keys.lo
  CC       keysdata.lo
  CC       keysmngr.lo
  CC       kw_aes_des.lo
  CC       list.lo
  CC       membuf.lo
  CC       nodeset.lo
  CC       parser.lo
  CC       relationship.lo
  CC       soap.lo
  CC       strings.lo
  CC       templates.lo
  CC       transforms.lo
  CC       x509.lo
  CC       xmldsig.lo
  CC       xmlenc.lo
  CC       xmlsec.lo
  CC       xmltree.lo
  CC       xpath.lo
  CC       xslt.lo
  CCLD     libxmlsec1.la
Making all in openssl
  CC       libxmlsec1_openssl_la-app.lo
  CC       libxmlsec1_openssl_la-bn.lo
  CC       libxmlsec1_openssl_la-ciphers.lo
  CC       libxmlsec1_openssl_la-crypto.lo
  CC       libxmlsec1_openssl_la-digests.lo
  CC       libxmlsec1_openssl_la-evp.lo
  CC       libxmlsec1_openssl_la-evp_signatures.lo
  CC       libxmlsec1_openssl_la-hmac.lo
  CC       libxmlsec1_openssl_la-kw_aes.lo
  CC       libxmlsec1_openssl_la-kw_des.lo
  CC       libxmlsec1_openssl_la-kt_rsa.lo
  CC       libxmlsec1_openssl_la-signatures.lo
signatures.c:36: error: expected declaration specifiers or '...' before 
'ECDSA_SIG'
signatures.c: In function 'ECDSA_SIG_get0':
signatures.c:38: error: 'sig' undeclared (first use in this function)
signatures.c:38: error: (Each undeclared identifier is reported only once
signatures.c:38: error: for each function it appears in.)
*** [libxmlsec1_openssl_la-signatures.lo] Error code 1

Stop in /wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22/src/openssl.
*** [all-recursive] Error code 1

Stop in /wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22/src.
*** [all-recursive] Error code 1

Stop in /wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22.
*** [all] Error code 1

Stop in /wrkdirs/usr/ports/security/xmlsec1/work/xmlsec1-1.2.22.
*** [do-build] Error code 1

Stop in /usr/ports/security/xmlsec1.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to