You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     a...@freebsd.org
Last committer: a...@freebsd.org
Ident:          $FreeBSD: head/emulators/mednafen/Makefile 414645 2016-05-05 
13:42:08Z acm $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/422347/logs/mednafen-0.9.38.7,1.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=422347
Log:

====>> Building emulators/mednafen
build started at Sun Sep 18 04:17:51 UTC 2016
port directory: /usr/ports/emulators/mednafen
building for: FreeBSD 93i386-default-job-18 9.3-RELEASE-p45 FreeBSD 
9.3-RELEASE-p45 i386
maintained by: a...@freebsd.org
Makefile ident:      $FreeBSD: head/emulators/mednafen/Makefile 414645 
2016-05-05 13:42:08Z acm $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 9.3-RELEASE-p45
UNAME_r=9.3-RELEASE-p45
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=mednafen-0.9.38.7,1
OSREL=9.3
_OSRELEASE=9.3-RELEASE-p45
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mednafen-0.9.38.7,1:
     DOCS=on: Build and/or install documentation
     JACK=off: support the JACK audio API
     NLS=on: Native Language Support
====> Options available for the multi EMU: you have to choose at least one of 
them
     GB=on: build with GameBoy emulation
     GBA=on: build with GameBoy Advance emulation
     LINX=on: build with Atari Lynx emulation
     MD=on: build with Sega Genesis/MegaDrive emulation
     NES=on: build with Nintendo Entertainment System emulation
     NGP=on: build with Neo Geo Pocket emulation
     PCE=on: build with PC Engine (TurboGrafx 16) emulation
     PCFX=on: build with PC-FX emulation
     PSX=on: build with Playstation emulation
     SMS=on: build with SMS+GG emulation
     SWAN=on: build with WonderSWan emulation
     VB=on: build with Virtual Boy emulation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-alsa --disable-alsatest  --with-sdl-prefix=/usr/local --disable-jack 
--enable-nls --enable-gb --enable-gba --enable-lynx --enable-md --enable-nes 
--enable-ngp --enable-pce --enable-pcfx --enable-psx --enable-sms 
--enable-wswan --enable-vb --x-libraries=/usr/local/lib 
--x-includes=/usr/local/include --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/mednafen/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/mednafen/work  
HOME=/wrkdirs/usr/ports/emulators/mednafen/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/mednafen/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/mednafen/work  
HOME=/wrkdirs/usr/ports/emulators/mednafen/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-I/usr/local/include"  
LDFLAGS=" -L/usr/local/lib" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
DOCS=""
NO_DOCS="@comment
"
JACK="@comment
"
NO_JACK=""
NLS=""
NO_NLS="@comment
"
GB=""
NO_GB="@comment
"
GBA=""
NO_GBA="@comment
"
LINX=""
NO_LINX="@comment
"
MD=""
NO_MD="@comment
"
NES=""
NO_NES="@comment
"
NGP=""
NO_NGP="@comment
"
PCE=""
NO_PCE="@comment
"
PCFX=""
NO_PCFX="@comment
"
PSX=""
NO_PSX="@comment
"
SMS=""
NO_SMS="@comment
"
SWAN=""
NO_SWAN="@comment
"
VB=""
NO_VB="@comment
"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/mednafen"
EXAMPLESDIR="share/examples/mednafen"
DATADIR="share/mednafen"
WWWDIR="www/mednafen"
ETCDIR="etc/mednafen"
--End PLIST_SUB--

--SUB_LIST--
DOCS=""
NO_DOCS="@comment
"
JACK="@comment
"
NO_JACK=""
NLS=""
NO_NLS="@comment
"
GB=""
NO_GB="@comment
"
GBA=""
NO_GBA="@comment
"
LINX=""
NO_LINX="@comment
"
MD=""
NO_MD="@comment
"
NES=""
NO_NES="@comment
"
NGP=""
NO_NGP="@comment
"
PCE=""
NO_PCE="@comment
"
PCFX=""
NO_PCFX="@comment
"
PSX=""
NO_PSX="@comment
"
SMS=""
NO_SMS="@comment
"
SWAN=""
NO_SWAN="@comment
"
VB=""
NO_VB="@comment
"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mednafen
DOCSDIR=/usr/local/share/doc/mednafen
EXAMPLESDIR=/usr/local/share/examples/mednafen
WWWDIR=/usr/local/www/mednafen
ETCDIR=/usr/local/etc/mednafen
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
<snip>
[93i386-default-job-18] |   |   | `-- Installing fixesproto-5.0...
[93i386-default-job-18] |   |   | `-- Extracting fixesproto-5.0: .... done
[93i386-default-job-18] |   |   `-- Extracting libXfixes-5.0.1_3: .......... 
done
[93i386-default-job-18] |   |   `-- Installing damageproto-1.2.1...
[93i386-default-job-18] |   |   `-- Extracting damageproto-1.2.1: .... done
[93i386-default-job-18] |   | `-- Extracting libXdamage-1.1.4_3: ...... done
[93i386-default-job-18] |   | `-- Installing libdevq-0.0.2_1...
[93i386-default-job-18] |   | `-- Extracting libdevq-0.0.2_1: ..... done
[93i386-default-job-18] |   | `-- Installing gcc-4.8.5_2...
[93i386-default-job-18] |   |   `-- Installing indexinfo-0.2.4...
[93i386-default-job-18] |   |   `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-18] |   |   `-- Installing mpc-1.0.3...
[93i386-default-job-18] |   |   | `-- Installing gmp-5.1.3_3...
[93i386-default-job-18] |   |   | `-- Extracting gmp-5.1.3_3: .......... done
[93i386-default-job-18] |   |   | `-- Installing mpfr-3.1.4...
[93i386-default-job-18] |   |   | `-- Extracting mpfr-3.1.4: .......... done
[93i386-default-job-18] |   |   `-- Extracting mpc-1.0.3: ...... done
[93i386-default-job-18] |   |   `-- Installing gcc-ecj-4.5...
[93i386-default-job-18] |   |   `-- Extracting gcc-ecj-4.5: . done
[93i386-default-job-18] |   |   `-- Installing binutils-2.27_3,1...
[93i386-default-job-18] |   |   | `-- Installing gettext-runtime-0.19.8.1...
[93i386-default-job-18] |   |   | `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[93i386-default-job-18] |   |   `-- Extracting binutils-2.27_3,1: .......... 
done
[93i386-default-job-18] |   | `-- Extracting gcc-4.8.5_2: .......... done
[93i386-default-job-18] |   | `-- Installing libXxf86vm-1.1.4_1...
[93i386-default-job-18] |   |   `-- Installing xf86vidmodeproto-2.3.1...
[93i386-default-job-18] |   |   `-- Extracting xf86vidmodeproto-2.3.1: .... done
[93i386-default-job-18] |   | `-- Extracting libXxf86vm-1.1.4_1: .......... done
[93i386-default-job-18] |   | `-- Installing libdrm-2.4.66,1...
[93i386-default-job-18] |   |   `-- Installing libpciaccess-0.13.4...
[93i386-default-job-18] |   |   | `-- Installing pciids-20160621...
[93i386-default-job-18] |   |   | `-- Extracting pciids-20160621: ..... done
[93i386-default-job-18] |   |   `-- Extracting libpciaccess-0.13.4: ...... done
[93i386-default-job-18] |   | `-- Extracting libdrm-2.4.66,1: .......... done
[93i386-default-job-18] |   | `-- Installing libxshmfence-1.2...
[93i386-default-job-18] |   | `-- Extracting libxshmfence-1.2: ......... done
[93i386-default-job-18] |   | `-- Installing libglapi-11.2.2...
[93i386-default-job-18] |   |   `-- Installing libXvMC-1.0.9...
[93i386-default-job-18] |   |   | `-- Installing libXv-1.0.10_3,1...
[93i386-default-job-18] |   |   |   `-- Installing videoproto-2.3.2...
[93i386-default-job-18] |   |   |   `-- Extracting videoproto-2.3.2: ...... done
[93i386-default-job-18] |   |   | `-- Extracting libXv-1.0.10_3,1: .......... 
done
[93i386-default-job-18] |   |   `-- Extracting libXvMC-1.0.9: .......... done
[93i386-default-job-18] |   | `-- Extracting libglapi-11.2.2: ... done
[93i386-default-job-18] |   `-- Extracting libGL-11.2.2: .......... done
[93i386-default-job-18] `-- Extracting libGLU-9.0.0_2: ...... done
[93i386-default-job-18] `-- Installing aalib-1.4.r5_11...
[93i386-default-job-18] `-- Extracting aalib-1.4.r5_11: .......... done
[93i386-default-job-18] Extracting sdl-1.2.15_7,2: .......... done
Message from gcc-4.8.5_2:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc48

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
Message from aalib-1.4.r5_11:
===>   NOTICE:

The aalib port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
Message from sdl-1.2.15_7,2:
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   mednafen-0.9.38.7,1 depends on file: /usr/local/bin/sdl-config - found
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on package: pkgconf>=0.9.10 - not found
===>   Installing existing package /packages/All/pkgconf-1.0.1.txz
[93i386-default-job-18] Installing pkgconf-1.0.1...
[93i386-default-job-18] Extracting pkgconf-1.0.1: .......... done
===>   mednafen-0.9.38.7,1 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on executable: msgfmt - not found
===>   Installing existing package /packages/All/gettext-tools-0.19.8.1.txz
[93i386-default-job-18] Installing gettext-tools-0.19.8.1...
[93i386-default-job-18] Extracting gettext-tools-0.19.8.1: .......... done
===>   mednafen-0.9.38.7,1 depends on executable: msgfmt - found
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on package: libGL>0 - found
===>   mednafen-0.9.38.7,1 depends on file: 
/usr/local/libdata/pkgconfig/glproto.pc - not found
===>   Installing existing package /packages/All/glproto-1.4.17.txz
[93i386-default-job-18] Installing glproto-1.4.17...
[93i386-default-job-18] Extracting glproto-1.4.17: ...... done
===>   mednafen-0.9.38.7,1 depends on file: 
/usr/local/libdata/pkgconfig/glproto.pc - found
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   mednafen-0.9.38.7,1 depends on file: 
/usr/local/libdata/pkgconfig/glproto.pc - found
===>   mednafen-0.9.38.7,1 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   mednafen-0.9.38.7,1 depends on shared library: libcdio.so - not found
===>   Installing existing package /packages/All/libcdio-0.93.txz
[93i386-default-job-18] Installing libcdio-0.93...
[93i386-default-job-18] `-- Installing libcddb-1.3.2_4...
[93i386-default-job-18] `-- Extracting libcddb-1.3.2_4: .......... done
[93i386-default-job-18] Extracting libcdio-0.93: .......... done
===>   mednafen-0.9.38.7,1 depends on shared library: libcdio.so - found 
(/usr/local/lib/libcdio.so)
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on shared library: libsndfile.so - not found
===>   Installing existing package /packages/All/libsndfile-1.0.26.txz
[93i386-default-job-18] Installing libsndfile-1.0.26...
[93i386-default-job-18] `-- Installing flac-1.3.1_2...
[93i386-default-job-18] |   `-- Installing libogg-1.3.2_1,4...
[93i386-default-job-18] |   `-- Extracting libogg-1.3.2_1,4: .......... done
[93i386-default-job-18] `-- Extracting flac-1.3.1_2: .......... done
[93i386-default-job-18] `-- Installing libvorbis-1.3.5,3...
[93i386-default-job-18] `-- Extracting libvorbis-1.3.5,3: .......... done
[93i386-default-job-18] Extracting libsndfile-1.0.26: .......... done
===>   mednafen-0.9.38.7,1 depends on shared library: libsndfile.so - found 
(/usr/local/lib/libsndfile.so)
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on shared library: libvorbis.so - found 
(/usr/local/lib/libvorbis.so)
===>   mednafen-0.9.38.7,1 depends on shared library: libSDL.so - found 
(/usr/local/lib/libSDL.so)
===>   mednafen-0.9.38.7,1 depends on shared library: libSDL_net.so - not found
===>   Installing existing package /packages/All/sdl_net-1.2.8_3.txz
[93i386-default-job-18] Installing sdl_net-1.2.8_3...
[93i386-default-job-18] Extracting sdl_net-1.2.8_3: ......... done
===>   mednafen-0.9.38.7,1 depends on shared library: libSDL_net.so - found 
(/usr/local/lib/libSDL_net.so)
===>   Returning to build of mednafen-0.9.38.7,1
===>   mednafen-0.9.38.7,1 depends on shared library: libiconv.so - found 
(/usr/local/lib/libiconv.so)
===>   mednafen-0.9.38.7,1 depends on shared library: libintl.so - found 
(/usr/local/lib/libintl.so)
===>   mednafen-0.9.38.7,1 depends on shared library: libGLU.so - found 
(/usr/local/lib/libGLU.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mednafen-0.9.38.7,1
configure: loading site script /usr/ports/Templates/config.site
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking whether cc understands -c and -o together... yes
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking build system type... i386-portbld-freebsd9.3
checking host system type... i386-portbld-freebsd9.3
checking target system type... i386-portbld-freebsd9.3
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking whether make supports nested variables... yes
checking dependency style of cc... gcc3
checking whether make supports nested variables... (cached) yes
checking for gcc... (cached) cc
checking whether we are using the GNU C compiler... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for cc option to accept ISO C89... (cached) none needed
checking whether cc understands -c and -o together... (cached) yes
checking how to run the C preprocessor... cpp
checking dependency style of cc... gcc3
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking how to run the C++ preprocessor... c++ -E
checking whether c++ supports C++11 features by default... no
checking whether c++ supports C++11 features with -std=gnu++11... no
checking whether c++ supports C++11 features with -std=gnu++0x... no
configure: error: *** A compiler with support for C++11 language features is 
required.
===>  Script "configure" failed unexpectedly.
Please report the problem to a...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/emulators/mednafen/work/mednafen/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/emulators/mednafen.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to