You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     swi...@freebsd.org
Last committer: swi...@freebsd.org
Ident:          $FreeBSD: 
branches/2016Q3/emulators/open-vm-tools-nox11/Makefile 413746 2016-04-21 
16:43:14Z swills $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/422268/logs/open-vm-tools-nox11-1280544_12,1.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-quarterly&build=422268
Log:

====>> Building emulators/open-vm-tools-nox11
build started at Sun Sep 18 06:08:06 UTC 2016
port directory: /usr/ports/emulators/open-vm-tools-nox11
building for: FreeBSD 110arm64-quarterly-job-02 11.0-RC3 FreeBSD 11.0-RC3 
r305786 arm64
maintained by: swi...@freebsd.org
Makefile ident:      $FreeBSD: 
branches/2016Q3/emulators/open-vm-tools-nox11/Makefile 413746 2016-04-21 
16:43:14Z swills $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RC3 r305786
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=open-vm-tools-nox11-1280544_12,1
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-quarterly/ref/.p/pool
MASTERNAME=110arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
open-vm-tools-nox11-1280544_12,1:
     DNET=on: libdnet support
     FUSE=on: FUSE (Filesystem in Userspace) support
     ICU=on: Unicode support via ICU
     LIBNOTIFY=off: Desktop notification support
     UNITY=off: liburiparser support
     X11=off: X11 (graphics) support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--without-procps --sysconfdir=/usr/local/etc --with-dnet --with-icu 
--disable-unity --without-x --without-gtk2 --without-gtkmm --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work  
HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
KMODDIR="/boot/modules" SYSDIR="/usr/src/sys" NO_XREF=yes 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work  
HOME=/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work TMPDIR="/tmp" 
NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-Wno-deprecated-declarations" 
 LDFLAGS="" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
DNET=""
NO_DNET="@comment
"
FUSE=""
NO_FUSE="@comment
"
ICU=""
NO_ICU="@comment
"
LIBNOTIFY="@comment
"
NO_LIBNOTIFY=""
UNITY="@comment
"
NO_UNITY=""
X11="@comment
"
NO_X11=""
KMODDIR="boot/modules"
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/open-vm-tools"
EXAMPLESDIR="share/examples/open-vm-tools"
DATADIR="share/open-vm-tools"
WWWDIR="www/open-vm-tools"
ETCDIR="etc/open-vm-tools"
--End PLIST_SUB--

--SUB_LIST--
DNET=""
NO_DNET="@comment
"
FUSE=""
NO_FUSE="@comment
"
ICU=""
NO_ICU="@comment
"
LIBNOTIFY="@comment
"
NO_LIBNOTIFY=""
UNITY="@comment
"
NO_UNITY=""
X11="@comment
"
NO_X11=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/open-vm-tools
DOCSDIR=/usr/local/share/doc/open-vm-tools
EXAMPLESDIR=/usr/local/share/examples/open-vm-tools
WWWDIR=/usr/local/www/open-vm-tools
ETCDIR=/usr/local/etc/open-vm-tools
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   open-vm-tools-nox11-1280544_12,1 depends on file: /usr/local/sbin/pkg - 
not found
===>   Installing existing package /packages/All/pkg-1.8.7_1.txz
[110arm64-quarterly-job-02] Installing pkg-1.8.7_1...
[110arm64-quarterly-job-02] Extracting pkg-1.8.7_1: .......... done
===>   open-vm-tools-nox11-1280544_12,1 depends on file: /usr/local/sbin/pkg - 
found
===>   Returning to build of open-vm-tools-nox11-1280544_12,1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by open-vm-tools-nox11-1280544_12,1 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by open-vm-tools-nox11-1280544_12,1 for 
building
=> SHA256 Checksum OK for open-vm-tools-9.4.0-1280544.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by open-vm-tools-nox11-1280544_12,1 for 
building
===>  Extracting for open-vm-tools-nox11-1280544_12,1
=> SHA256 Checksum OK for open-vm-tools-9.4.0-1280544.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for open-vm-tools-nox11-1280544_12,1
===>  Applying FreeBSD patches for open-vm-tools-nox11-1280544_12,1
===========================================================================
=======================<phase: build-depends  >============================
===>   open-vm-tools-nox11-1280544_12,1 depends on package: pkgconf>=0.9.10 - 
not found
===>   Installing existing package /packages/All/pkgconf-0.9.12_1.txz
[110arm64-quarterly-job-02] Installing pkgconf-0.9.12_1...
[110arm64-quarterly-job-02] Extracting pkgconf-0.9.12_1: ....... done
===>   open-vm-tools-nox11-1280544_12,1 depends on package: pkgconf>=0.9.10 - 
found
===>   Returning to build of open-vm-tools-nox11-1280544_12,1
===========================================================================
=======================<phase: lib-depends    >============================
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: libdnet.so - 
not found
===>   Installing existing package /packages/All/libdnet-1.12_1.txz
[110arm64-quarterly-job-02] Installing libdnet-1.12_1...
[110arm64-quarterly-job-02] Extracting libdnet-1.12_1: .......... done
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: libdnet.so - 
found (/usr/local/lib/libdnet.so)
===>   Returning to build of open-vm-tools-nox11-1280544_12,1
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: libicuuc.so 
- not found
===>   Installing existing package /packages/All/icu-55.1.txz
[110arm64-quarterly-job-02] Installing icu-55.1...
[110arm64-quarterly-job-02] Extracting icu-55.1: .......... done
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: libicuuc.so 
- found (/usr/local/lib/libicuuc.so)
===>   Returning to build of open-vm-tools-nox11-1280544_12,1
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: 
libglib-2.0.so - not found
===>   Installing existing package /packages/All/glib-2.46.2.txz
[110arm64-quarterly-job-02] Installing glib-2.46.2...
[110arm64-quarterly-job-02] `-- Installing libiconv-1.14_9...
[110arm64-quarterly-job-02] `-- Extracting libiconv-1.14_9: .......... done
[110arm64-quarterly-job-02] `-- Installing python27-2.7.12...
[110arm64-quarterly-job-02] |   `-- Installing libffi-3.2.1...
[110arm64-quarterly-job-02] |   | `-- Installing indexinfo-0.2.4...
[110arm64-quarterly-job-02] |   | `-- Extracting indexinfo-0.2.4: .... done
[110arm64-quarterly-job-02] |   `-- Extracting libffi-3.2.1: .......... done
[110arm64-quarterly-job-02] |   `-- Installing gettext-runtime-0.19.8.1...
[110arm64-quarterly-job-02] |   `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[110arm64-quarterly-job-02] |   `-- Installing readline-6.3.8...
[110arm64-quarterly-job-02] |   `-- Extracting readline-6.3.8: .......... done
[110arm64-quarterly-job-02] `-- Extracting python27-2.7.12: .......... done
[110arm64-quarterly-job-02] `-- Installing pcre-8.39...
[110arm64-quarterly-job-02] `-- Extracting pcre-8.39: .......... done
[110arm64-quarterly-job-02] `-- Installing perl5-5.20.3_15...
[110arm64-quarterly-job-02] `-- Extracting perl5-5.20.3_15: .......... done
[110arm64-quarterly-job-02] Extracting glib-2.46.2: .......... done
No schema files found: doing nothing.
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_15:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   open-vm-tools-nox11-1280544_12,1 depends on shared library: 
libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   Returning to build of open-vm-tools-nox11-1280544_12,1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for open-vm-tools-nox11-1280544_12,1
configure: WARNING: unrecognized options: --disable-unity
configure: loading site script /usr/ports/Templates/config.site
checking build system type... aarch64-portbld-freebsd11.0
checking host system type... aarch64-unknown-freebsd11.0
configure: error: Unknown architecture.
===>  Script "configure" failed unexpectedly.
Please report the problem to swi...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/emulators/open-vm-tools-nox11/work/open-vm-tools-9.4.0-1280544/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/open-vm-tools-nox11
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to