You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sunp...@freebsd.org
Last committer: sunp...@freebsd.org
Ident:          $FreeBSD: branches/2016Q3/databases/p5-Tie-LevelDB/Makefile 
413818 2016-04-23 06:47:22Z sunpoet $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/422268/logs/p5-Tie-LevelDB-0.07_4.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-quarterly&build=422268
Log:

====>> Building databases/p5-Tie-LevelDB
build started at Sun Sep 18 18:48:06 UTC 2016
port directory: /usr/ports/databases/p5-Tie-LevelDB
building for: FreeBSD 110arm64-quarterly-job-21 11.0-RC3 FreeBSD 11.0-RC3 
r305786 arm64
maintained by: sunp...@freebsd.org
Makefile ident:      $FreeBSD: 
branches/2016Q3/databases/p5-Tie-LevelDB/Makefile 413818 2016-04-23 06:47:22Z 
sunpoet $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RC3 r305786
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=p5-Tie-LevelDB-0.07_4
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-quarterly/ref/.p/pool
MASTERNAME=110arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
INSTALLDIRS="site" CC="cc" CCFLAGS="-O2 -pipe  -isystem /usr/local/include 
-Wno-reserved-user-defined-literal -fno-strict-aliasing" PREFIX="/usr/local"  
INSTALLPRIVLIB="/usr/local/lib" INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake CMAKE_PREFIX_PATH="/usr/local" ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work  
HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh PERL_EXTUTILS_AUTOINSTALL="--skipdeps" 
PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work  
HOME=/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -isystem /usr/local/include -Wno-reserved-user-defined-literal 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-isystem /usr/local/include"  
LDFLAGS=" -L/usr/local/lib" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -isystem 
/usr/local/include -Wno-reserved-user-defined-literal -fno-strict-aliasing  
-isystem /usr/local/include"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/Tie-LevelDB"
EXAMPLESDIR="share/examples/Tie-LevelDB"
DATADIR="share/Tie-LevelDB"
WWWDIR="www/Tie-LevelDB"
ETCDIR="etc/Tie-LevelDB"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/Tie-LevelDB
DOCSDIR=/usr/local/share/doc/Tie-LevelDB
EXAMPLESDIR=/usr/local/share/examples/Tie-LevelDB
WWWDIR=/usr/local/www/Tie-LevelDB
ETCDIR=/usr/local/etc/Tie-LevelDB
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License ART10 GPLv1 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Tie-LevelDB-0.07_4 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_1.txz
[110arm64-quarterly-job-21] Installing pkg-1.8.7_1...
[110arm64-quarterly-job-21] Extracting pkg-1.8.7_1: .......... done
===>   p5-Tie-LevelDB-0.07_4 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of p5-Tie-LevelDB-0.07_4
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Tie-LevelDB-0.07_4 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Tie-LevelDB-0.07_4 for building
=> SHA256 Checksum OK for Tie-LevelDB-0.07.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Tie-LevelDB-0.07_4 for building
===>  Extracting for p5-Tie-LevelDB-0.07_4
=> SHA256 Checksum OK for Tie-LevelDB-0.07.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Tie-LevelDB-0.07_4
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Tie-LevelDB-0.07_4 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1.txz
[110arm64-quarterly-job-21] Installing gmake-4.2.1...
[110arm64-quarterly-job-21] `-- Installing indexinfo-0.2.4...
[110arm64-quarterly-job-21] `-- Extracting indexinfo-0.2.4: .... done
[110arm64-quarterly-job-21] `-- Installing gettext-runtime-0.19.8.1...
[110arm64-quarterly-job-21] `-- Extracting gettext-runtime-0.19.8.1: .......... 
done
[110arm64-quarterly-job-21] Extracting gmake-4.2.1: .......... done
===>   p5-Tie-LevelDB-0.07_4 depends on executable: gmake - found
===>   Returning to build of p5-Tie-LevelDB-0.07_4
===>   p5-Tie-LevelDB-0.07_4 depends on package: perl5>=5.20<5.21 - not found
===>   Installing existing package /packages/All/perl5-5.20.3_15.txz
[110arm64-quarterly-job-21] Installing perl5-5.20.3_15...
[110arm64-quarterly-job-21] Extracting perl5-5.20.3_15: .......... done
Message from perl5-5.20.3_15:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   p5-Tie-LevelDB-0.07_4 depends on package: perl5>=5.20<5.21 - found
===>   Returning to build of p5-Tie-LevelDB-0.07_4
===========================================================================
=======================<phase: lib-depends    >============================
===>   p5-Tie-LevelDB-0.07_4 depends on shared library: libleveldb.so - not 
found
===>   Installing existing package /packages/All/leveldb-1.18_1.txz
[110arm64-quarterly-job-21] Installing leveldb-1.18_1...
[110arm64-quarterly-job-21] `-- Installing snappy-1.1.3...
[110arm64-quarterly-job-21] `-- Extracting snappy-1.1.3: .......... done
[110arm64-quarterly-job-21] Extracting leveldb-1.18_1: .......... done
===>   p5-Tie-LevelDB-0.07_4 depends on shared library: libleveldb.so - found 
(/usr/local/lib/libleveldb.so)
===>   Returning to build of p5-Tie-LevelDB-0.07_4
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Tie-LevelDB-0.07_4
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Tie::LevelDB
Writing MYMETA.yml and MYMETA.json
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-Tie-LevelDB-0.07_4
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work/Tie-LevelDB-0.07'
cp lib/Tie/LevelDB.pm blib/lib/Tie/LevelDB.pm
Running Mkbootstrap for Tie::LevelDB ()
chmod 644 LevelDB.bs
/usr/local/bin/perl5.20.3 /usr/local/lib/perl5/5.20/ExtUtils/xsubpp  -C++ 
-typemap /usr/local/lib/perl5/5.20/ExtUtils/typemap -typemap perlobject.map 
-typemap typemap  LevelDB.xs > LevelDB.xsc && mv LevelDB.xsc LevelDB.c
Please specify prototyping behavior for LevelDB.xs (see perlxs manual)
c++ -c  -I. -Iinclude -Iport -Iutil -O2 -pipe  -isystem /usr/local/include 
-Wno-reserved-user-defined-literal -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing   -DVERSION=\"0.07\" -DXS_VERSION=\"0.07\" -DPIC -fPIC 
"-I/usr/local/lib/perl5/5.20/mach/CORE"  -DSNAPPY -std=c++0x  -D_REENTRANT 
-DOS_FREEBSD -DLEVELDB_PLATFORM_POSIX -DLEVELDB_ATOMIC_PRESENT -std=c++0x  
-D_REENTRANT -DOS_FREEBSD -DLEVELDB_PLATFORM_POSIX -DLEVELDB_ATOMIC_PRESENT -o 
LevelDB.o LevelDB.c
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated
In file included from LevelDB.xs:13:
In file included from /usr/local/lib/perl5/5.20/mach/CORE/perl.h:5199:
/usr/local/lib/perl5/5.20/mach/CORE/inline.h:311:9: warning: nonnull parameter 
'pv' will evaluate to 'true' on first encounter [-Wpointer-bool-conversion]
    if (pv && len > 1) {
        ^~ ~~
LevelDB.c:1293:1: warning: duplicate 'extern' declaration specifier 
[-Wduplicate-decl-specifier]
XS_EXTERNAL(boot_Tie__LevelDB); /* prototype to pass -Wmissing-prototypes */
^
/usr/local/lib/perl5/5.20/mach/CORE/XSUB.h:145:33: note: expanded from macro 
'XS_EXTERNAL'
#      define XS_EXTERNAL(name) extern "C" XSPROTO(name)
                                ^
2 warnings generated.
c++ -c  -I. -Iinclude -Iport -Iutil -O2 -pipe  -isystem /usr/local/include 
-Wno-reserved-user-defined-literal -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing   -DVERSION=\"0.07\" -DXS_VERSION=\"0.07\" -DPIC -fPIC 
"-I/usr/local/lib/perl5/5.20/mach/CORE"  -DSNAPPY -std=c++0x  -D_REENTRANT 
-DOS_FREEBSD -DLEVELDB_PLATFORM_POSIX -DLEVELDB_ATOMIC_PRESENT -std=c++0x  
-D_REENTRANT -DOS_FREEBSD -DLEVELDB_PLATFORM_POSIX -DLEVELDB_ATOMIC_PRESENT -o 
port/port_posix.o port/port_posix.cc
In file included from port/port_posix.cc:5:
In file included from ./port/port_posix.h:28:
./port/atomic_pointer.h:133:2: error: Please implement AtomicPointer for this 
platform.
#error Please implement AtomicPointer for this platform.
 ^
1 error generated.
gmake[1]: *** [Makefile:352: port/port_posix.o] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/databases/p5-Tie-LevelDB/work/Tie-LevelDB-0.07'
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/p5-Tie-LevelDB
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to