You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     e...@brlcad.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2016Q3/cad/brlcad/Makefile 412344 2016-04-01 
13:29:15Z mat $
Log URL:        
http://beefy1.nyi.freebsd.org/data/110i386-quarterly/422328/logs/brlcad-7.24.0_3.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=110i386-quarterly&build=422328
Log:

====>> Building cad/brlcad
build started at Mon Sep 19 12:44:11 UTC 2016
port directory: /usr/ports/cad/brlcad
building for: FreeBSD 110i386-quarterly-job-10 11.0-RC3 FreeBSD 11.0-RC3 
r305904 i386
maintained by: e...@brlcad.org
Makefile ident:      $FreeBSD: branches/2016Q3/cad/brlcad/Makefile 412344 
2016-04-01 13:29:15Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 1100122

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 11.0-RC3 r305904
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
LINUX_OSRELEASE=2.6.32
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110i386-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=brlcad-7.24.0_3
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/110i386-quarterly/ref/.p/pool
MASTERNAME=110i386-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/cad/brlcad/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/cad/brlcad/work  
HOME=/wrkdirs/usr/ports/cad/brlcad/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/cad/brlcad/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/cad/brlcad/work  
HOME=/wrkdirs/usr/ports/cad/brlcad/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local/brlcad  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe  -I/usr/local/include -fstack-protector -fno-strict-aliasing" 
 CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -fstack-protector -fno-strict-aliasing 
"  MANPREFIX="/usr/local/brlcad/share" BSD_INSTALL_PROGRAM="install  -s -m 555" 
 BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTVERSION=7.24.0
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local/brlcad
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/brlcad"
EXAMPLESDIR="share/examples/brlcad"
DATADIR="share/brlcad"
WWWDIR="www/brlcad"
ETCDIR="etc/brlcad"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local/brlcad
LOCALBASE=/usr/local
DATADIR=/usr/local/brlcad/share/brlcad
DOCSDIR=/usr/local/brlcad/share/doc/brlcad
EXAMPLESDIR=/usr/local/brlcad/share/examples/brlcad
WWWDIR=/usr/local/brlcad/www/brlcad
ETCDIR=/usr/local/brlcad/etc/brlcad
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   brlcad-7.24.0_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_1.txz
[110i386-quarterly-job-10] Installing pkg-1.8.7_1...
[110i386-quarterly-job-10] Extracting pkg-1.8.7_1: .......... done
===>   brlcad-7.24.0_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of brlcad-7.24.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by brlcad-7.24.0_3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by brlcad-7.24.0_3 for building
=> SHA256 Checksum OK for brlcad-7.24.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by brlcad-7.24.0_3 for building
===>  Extracting for brlcad-7.24.0_3
=> SHA256 Checksum OK for brlcad-7.24.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for brlcad-7.24.0_3
===>  Applying FreeBSD patches for brlcad-7.24.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   brlcad-7.24.0_3 depends on file: /usr/local/include/tnt/jama_lu.h - not 
found
===>   Installing existing package /packages/All/jama-1.2.5.txz
[110i386-quarterly-job-10] Installing jama-1.2.5...
[110i386-quarterly-job-10] `-- Installing tnt-1.2.6...
[110i386-quarterly-job-10] `-- Extracting tnt-1.2.6: .......... done
[110i386-quarterly-job-10] Extracting jama-1.2.5: .......... done
===>   brlcad-7.24.0_3 depends on file: /usr/local/include/tnt/jama_lu.h - found
===>   Returning to build of brlcad-7.24.0_3
===>   brlcad-7.24.0_3 depends on executable: xsltproc - not found
===>   Installing existing package /packages/All/libxslt-1.1.29.txz
[110i386-quarterly-job-10] Installing libxslt-1.1.29...
[110i386-quarterly-job-10] `-- Installing libgcrypt-1.7.3...
[110i386-quarterly-job-10] |   `-- Installing indexinfo-0.2.4...
[110i386-quarterly-job-10] |   `-- Extracting indexinfo-0.2.4: .... done
[110i386-quarterly-job-10] |   `-- Installing libgpg-error-1.23...
[110i386-quarterly-job-10] |   | `-- Installing gettext-runtime-0.19.8.1...
[110i386-quarterly-job-10] |   | `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[110i386-quarterly-job-10] |   `-- Extracting libgpg-error-1.23: .......... done
[110i386-quarterly-job-10] `-- Extracting libgcrypt-1.7.3: .......... done
[110i386-quarterly-job-10] `-- Installing libxml2-2.9.4...
[110i386-quarterly-job-10] `-- Extracting libxml2-2.9.4: .......... done
[110i386-quarterly-job-10] Extracting libxslt-1.1.29: .......... done
===>   brlcad-7.24.0_3 depends on executable: xsltproc - found
===>   Returning to build of brlcad-7.24.0_3
===>   brlcad-7.24.0_3 depends on executable: bison - not found
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
[110i386-quarterly-job-10] Installing bison-2.7.1,1...
[110i386-quarterly-job-10] `-- Installing m4-1.4.17_1,1...
[110i386-quarterly-job-10] `-- Extracting m4-1.4.17_1,1: .......... done
[110i386-quarterly-job-10] Extracting bison-2.7.1,1: .......... done
===>   brlcad-7.24.0_3 depends on executable: bison - found
===>   Returning to build of brlcad-7.24.0_3
===>   brlcad-7.24.0_3 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.5.2_1.txz
[110i386-quarterly-job-10] Installing cmake-3.5.2_1...
[110i386-quarterly-job-10] `-- Installing expat-2.1.1_2...
[110i386-quarterly-job-10] `-- Extracting expat-2.1.1_2: .......... done
[110i386-quarterly-job-10] `-- Installing cmake-modules-3.5.2...
[110i386-quarterly-job-10] `-- Extracting cmake-modules-3.5.2: .......... done
[110i386-quarterly-job-10] `-- Installing curl-7.50.1...
[110i386-quarterly-job-10] |   `-- Installing ca_root_nss-3.26...
[110i386-quarterly-job-10] |   `-- Extracting ca_root_nss-3.26: ....... done
[110i386-quarterly-job-10] `-- Extracting curl-7.50.1: .......... done
[110i386-quarterly-job-10] `-- Installing libarchive-3.2.1,1...
[110i386-quarterly-job-10] |   `-- Installing liblz4-131...
[110i386-quarterly-job-10] |   `-- Extracting liblz4-131: .......... done
[110i386-quarterly-job-10] |   `-- Installing lzo2-2.09...
[110i386-quarterly-job-10] |   `-- Extracting lzo2-2.09: .......... done
[110i386-quarterly-job-10] `-- Extracting libarchive-3.2.1,1: .......... done
[110i386-quarterly-job-10] `-- Installing jsoncpp-1.7.3...
[110i386-quarterly-job-10] `-- Extracting jsoncpp-1.7.3: .......... done
[110i386-quarterly-job-10] Extracting cmake-3.5.2_1: .......... done
Message from ca_root_nss-3.26:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
<snip>
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) in src/other/openNURBS/CMakeLists.txt:
  Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
  interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  Target "openNURBS" has an INTERFACE_LINK_LIBRARIES property which differs
  from its LINK_INTERFACE_LIBRARIES properties.

  INTERFACE_LINK_LIBRARIES:

    /usr/lib/libz.so

  LINK_INTERFACE_LIBRARIES:

    

This warning is for project developers.  Use -Wno-dev to suppress it.

Elapsed configuration time..: 1 minute 36 seconds
-- Configuring incomplete, errors occurred!
See also "/wrkdirs/usr/ports/cad/brlcad/work/.build/CMakeFiles/CMakeOutput.log".
See also "/wrkdirs/usr/ports/cad/brlcad/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/cad/brlcad
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to