You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     oz...@ongs.co.jp
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/deskutils/fusenshi/Makefile 412346 2016-04-01 
14:00:51Z mat $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-default/422291/logs/fusenshi-0.9.0_14.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-default&build=422291
Log:

====>> Building deskutils/fusenshi
build started at Wed Sep 21 23:09:45 UTC 2016
port directory: /usr/ports/deskutils/fusenshi
building for: FreeBSD 110arm64-default-job-14 11.0-RC3 FreeBSD 11.0-RC3 r305786 
arm64
maintained by: oz...@ongs.co.jp
Makefile ident:      $FreeBSD: head/deskutils/fusenshi/Makefile 412346 
2016-04-01 14:00:51Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RC3 r305786
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=fusenshi-0.9.0_14
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-default/ref/.p/pool
MASTERNAME=110arm64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf ESD_CONFIG="/usr/local/bin/esd-config" 
XDG_DATA_HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work  
HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
ESD_CONFIG="/usr/local/bin/esd-config" 
XDG_DATA_HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work  
HOME=/wrkdirs/usr/ports/deskutils/fusenshi/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/fusenshi"
EXAMPLESDIR="share/examples/fusenshi"
DATADIR="share/fusenshi"
WWWDIR="www/fusenshi"
ETCDIR="etc/fusenshi"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/fusenshi
DOCSDIR=/usr/local/share/doc/fusenshi
EXAMPLESDIR=/usr/local/share/examples/fusenshi
WWWDIR=/usr/local/www/fusenshi
ETCDIR=/usr/local/etc/fusenshi
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   fusenshi-0.9.0_14 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[110arm64-default-job-14] Installing pkg-1.8.7_3...
[110arm64-default-job-14] Extracting pkg-1.8.7_3: .......... done
===>   fusenshi-0.9.0_14 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of fusenshi-0.9.0_14
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by fusenshi-0.9.0_14 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by fusenshi-0.9.0_14 for building
=> SHA256 Checksum OK for fusenshi-0.9.0.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by fusenshi-0.9.0_14 for building
===>  Extracting for fusenshi-0.9.0_14
=> SHA256 Checksum OK for fusenshi-0.9.0.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for fusenshi-0.9.0_14
===>  Applying FreeBSD patches for fusenshi-0.9.0_14
===========================================================================
=======================<phase: build-depends  >============================
===>   fusenshi-0.9.0_14 depends on executable: msgfmt - not found
===>   Installing existing package /packages/All/gettext-tools-0.19.8.1.txz
[110arm64-default-job-14] Installing gettext-tools-0.19.8.1...
[110arm64-default-job-14] `-- Installing indexinfo-0.2.4...
[110arm64-default-job-14] `-- Extracting indexinfo-0.2.4: .... done
[110arm64-default-job-14] `-- Installing gettext-runtime-0.19.8.1...
[110arm64-default-job-14] `-- Extracting gettext-runtime-0.19.8.1: .......... 
done
[110arm64-default-job-14] Extracting gettext-tools-0.19.8.1: .......... done
===>   fusenshi-0.9.0_14 depends on executable: msgfmt - found
===>   Returning to build of fusenshi-0.9.0_14
===>   fusenshi-0.9.0_14 depends on package: pkgconf>=0.9.10 - not found
===>   Installing existing package /packages/All/pkgconf-1.0.1.txz
[110arm64-default-job-14] Installing pkgconf-1.0.1...
[110arm64-default-job-14] Extracting pkgconf-1.0.1: .......... done
===>   fusenshi-0.9.0_14 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of fusenshi-0.9.0_14
===>   fusenshi-0.9.0_14 depends on file: 
/usr/local/libdata/pkgconfig/gnome-mime-data-2.0.pc - not found
===>   Installing existing package /packages/All/gnome-mime-data-2.18.0_5.txz
[110arm64-default-job-14] Installing gnome-mime-data-2.18.0_5...
[110arm64-default-job-14] Extracting gnome-mime-data-2.18.0_5: .......... done
===>   fusenshi-0.9.0_14 depends on file: 
/usr/local/libdata/pkgconfig/gnome-mime-data-2.0.pc - found
===>   Returning to build of fusenshi-0.9.0_14
===>   fusenshi-0.9.0_14 depends on file: /usr/local/libdata/pkgconfig/x11.pc - 
not found
===>   Installing existing package /packages/All/libX11-1.6.3,1.txz
[110arm64-default-job-14] Installing libX11-1.6.3,1...
[110arm64-default-job-14] `-- Installing xproto-7.0.28...
[110arm64-default-job-14] `-- Extracting xproto-7.0.28: .......... done
[110arm64-default-job-14] `-- Installing kbproto-1.0.7...
[110arm64-default-job-14] `-- Extracting kbproto-1.0.7: .......... done
[110arm64-default-job-14] `-- Installing libXdmcp-1.1.2...
[110arm64-default-job-14] `-- Extracting libXdmcp-1.1.2: ......... done
[110arm64-default-job-14] `-- Installing libxcb-1.11.1...
[110arm64-default-job-14] |   `-- Installing libxml2-2.9.4...
[110arm64-default-job-14] |   `-- Extracting libxml2-2.9.4: .......... done
[110arm64-default-job-14] |   `-- Installing libpthread-stubs-0.3_6...
[110arm64-default-job-14] |   `-- Extracting libpthread-stubs-0.3_6: ..... done
[110arm64-default-job-14] |   `-- Installing libXau-1.0.8_3...
[110arm64-default-job-14] |   `-- Extracting libXau-1.0.8_3: .......... done
[110arm64-default-job-14] `-- Extracting libxcb-1.11.1: .......... done
[110arm64-default-job-14] Extracting libX11-1.6.3,1: .......... done
===>   fusenshi-0.9.0_14 depends on file: /usr/local/libdata/pkgconfig/x11.pc - 
found
===>   Returning to build of fusenshi-0.9.0_14
===========================================================================
=======================<phase: lib-depends    >============================
===>   fusenshi-0.9.0_14 depends on shared library: libgnutls.so - not found
===>   Installing existing package /packages/All/gnutls-3.4.15.txz
[110arm64-default-job-14] Installing gnutls-3.4.15...
[110arm64-default-job-14] `-- Installing nettle-3.2...
[110arm64-default-job-14] |   `-- Installing gmp-5.1.3_3...
[110arm64-default-job-14] |   `-- Extracting gmp-5.1.3_3: .......... done
[110arm64-default-job-14] `-- Extracting nettle-3.2: .......... done
[110arm64-default-job-14] `-- Installing ca_root_nss-3.26...
<snip>
[110arm64-default-job-14] `-- Installing pangomm-2.36.0...
[110arm64-default-job-14] `-- Extracting pangomm-2.36.0: .......... done
[110arm64-default-job-14] Extracting gtkmm24-2.24.4_2: .......... done
===>   fusenshi-0.9.0_14 depends on shared library: libgtkmm-2.4.so - found 
(/usr/local/lib/libgtkmm-2.4.so)
===>   Returning to build of fusenshi-0.9.0_14
===>   fusenshi-0.9.0_14 depends on shared library: libgtksourceview-1.0.so - 
not found
===>   Installing existing package /packages/All/gtksourceview-1.8.5_10.txz
[110arm64-default-job-14] Installing gtksourceview-1.8.5_10...
[110arm64-default-job-14] `-- Installing libbonobo-2.32.0_2...
[110arm64-default-job-14] |   `-- Installing popt-1.16_1...
[110arm64-default-job-14] |   `-- Extracting popt-1.16_1: .......... done
[110arm64-default-job-14] `-- Extracting libbonobo-2.32.0_2: .......... done
[110arm64-default-job-14] `-- Installing libgnomeprintui-2.18.6_3...
[110arm64-default-job-14] |   `-- Installing gnome-icon-theme-3.12.0_1...
[110arm64-default-job-14] |   | `-- Installing 
gnome-icon-theme-symbolic-3.12.0...
[110arm64-default-job-14] |   | `-- Extracting 
gnome-icon-theme-symbolic-3.12.0: .......... done
[110arm64-default-job-14] |   `-- Extracting gnome-icon-theme-3.12.0_1: 
.......... done
[110arm64-default-job-14] |   `-- Installing libXpm-3.5.11_4...
[110arm64-default-job-14] |   `-- Extracting libXpm-3.5.11_4: .......... done
[110arm64-default-job-14] |   `-- Installing libgnomeprint-2.18.8_4...
[110arm64-default-job-14] |   | `-- Installing libgnomecups-0.2.3_8,1...
[110arm64-default-job-14] |   | `-- Extracting libgnomecups-0.2.3_8,1: 
.......... done
[110arm64-default-job-14] |   | `-- Installing libart_lgpl-2.3.21_2,1...
[110arm64-default-job-14] |   | `-- Extracting libart_lgpl-2.3.21_2,1: 
.......... done
[110arm64-default-job-14] |   `-- Extracting libgnomeprint-2.18.8_4: .......... 
done
[110arm64-default-job-14] |   `-- Installing libgnomecanvas-2.30.3_3...
[110arm64-default-job-14] |   | `-- Installing libglade2-2.6.4_8...
[110arm64-default-job-14] |   |   `-- Installing xmlcatmgr-2.2_2...
[110arm64-default-job-14] |   |   `-- Extracting xmlcatmgr-2.2_2: ......... done
 + Creating /usr/local/share/sgml/catalog
 + Registering CATALOG catalog.ports (SGML)
 + Creating /usr/local/share/sgml/catalog.ports
 + Creating /usr/local/share/xml/catalog
 + Registering nextCatalog catalog.ports (XML)
 + Creating /usr/local/share/xml/catalog.ports
[110arm64-default-job-14] |   | `-- Extracting libglade2-2.6.4_8: .......... 
done
[110arm64-default-job-14] |   `-- Extracting libgnomecanvas-2.30.3_3: 
.......... done
[110arm64-default-job-14] `-- Extracting libgnomeprintui-2.18.6_3: .......... 
done
[110arm64-default-job-14] `-- Installing libgnome-2.32.0_3...
[110arm64-default-job-14] |   `-- Installing libcanberra-0.30_3...
[110arm64-default-job-14] |   | `-- Installing libvorbis-1.3.5,3...
[110arm64-default-job-14] |   | `-- Extracting libvorbis-1.3.5,3: .......... 
done
[110arm64-default-job-14] |   | `-- Installing libltdl-2.4.6...
[110arm64-default-job-14] |   | `-- Extracting libltdl-2.4.6: .......... done
[110arm64-default-job-14] |   `-- Extracting libcanberra-0.30_3: .......... done
[110arm64-default-job-14] |   `-- Installing rarian-0.8.1_4...
[110arm64-default-job-14] |   | `-- Installing bash-4.3.46_1...
[110arm64-default-job-14] |   | `-- Extracting bash-4.3.46_1: .......... done
[110arm64-default-job-14] |   | `-- Installing docbook-xsl-1.76.1_3...
[110arm64-default-job-14] |   |   `-- Installing docbook-1.5...
[110arm64-default-job-14] |   |   | `-- Installing sdocbook-xml-1.1_2,2...
[110arm64-default-job-14] |   |   | `-- Extracting sdocbook-xml-1.1_2,2: 
.......... done
[110arm64-default-job-14] |   |   | `-- Installing docbook-sgml-4.5_1...
[110arm64-default-job-14] |   |   |   `-- Installing iso8879-1986_3...
[110arm64-default-job-14] |   |   |   `-- Extracting iso8879-1986_3: .......... 
done
[110arm64-default-job-14] |   |   | `-- Extracting docbook-sgml-4.5_1: 
.......... done
[110arm64-default-job-14] |   |   | `-- Installing docbook-xml-5.0_3...
[110arm64-default-job-14] |   |   |   `-- Installing xmlcharent-0.3_2...
[110arm64-default-job-14] |   |   |   `-- Extracting xmlcharent-0.3_2: 
.......... done
[110arm64-default-job-14] |   |   | `-- Extracting docbook-xml-5.0_3: 
.......... done
[110arm64-default-job-14] |   | `-- Extracting docbook-xsl-1.76.1_3: .......... 
done
[110arm64-default-job-14] |   | `-- Installing libxslt-1.1.29...
[110arm64-default-job-14] |   |   `-- Installing libgcrypt-1.7.3...
[110arm64-default-job-14] |   |   | `-- Installing libgpg-error-1.24...
[110arm64-default-job-14] |   |   | `-- Extracting libgpg-error-1.24: 
.......... done
[110arm64-default-job-14] |   |   `-- Extracting libgcrypt-1.7.3: .......... 
done
[110arm64-default-job-14] |   | `-- Extracting libxslt-1.1.29: .......... done
[110arm64-default-job-14] |   | `-- Installing getopt-1.1.6...
[110arm64-default-job-14] |   | `-- Extracting getopt-1.1.6: .......... done
[110arm64-default-job-14] |   `-- Extracting rarian-0.8.1_4: .......... done
[110arm64-default-job-14] `-- Extracting libgnome-2.32.0_3: .......... done
[110arm64-default-job-14] Extracting gtksourceview-1.8.5_10: .......... done
Message from xmlcatmgr-2.2_2:
The following catalogs are installed:

 1) /usr/local/share/sgml/catalog

   The top level catalog for SGML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 2) /usr/local/share/sgml/catalog.ports

   This catalog is for handling SGML stuff installed under
   /usr/local/share/sgml.  It is changed by ports/packages.

 3) /usr/local/share/xml/catalog

   The top level catalog for XML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 4) /usr/local/share/xml/catalog.ports

   This catalog is for handling XML stuff installed under
   /usr/local/share/xml.  It is changed by ports/packages.
Message from bash-4.3.46_1:
======================================================================

bash requires fdescfs(5) mounted on /dev/fd

If you have not done it yet, please do the following:

        mount -t fdescfs fdesc /dev/fd

To make it permanent, you need the following lines in /etc/fstab:

        fdesc   /dev/fd         fdescfs         rw      0       0

======================================================================
===>   fusenshi-0.9.0_14 depends on shared library: libgtksourceview-1.0.so - 
found (/usr/local/lib/libgtksourceview-1.0.so)
===>   Returning to build of fusenshi-0.9.0_14
===>   fusenshi-0.9.0_14 depends on shared library: libart_lgpl_2.so - found 
(/usr/local/lib/libart_lgpl_2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libbonobo-2.so - found 
(/usr/local/lib/libbonobo-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libglade-2.0.so - found 
(/usr/local/lib/libglade-2.0.so)
===>   fusenshi-0.9.0_14 depends on shared library: libgnome-2.so - found 
(/usr/local/lib/libgnome-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libgnomecanvas-2.so - found 
(/usr/local/lib/libgnomecanvas-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libgnomeprint-2-2.so - 
found (/usr/local/lib/libgnomeprint-2-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libgnomeprintui-2-2.so - 
found (/usr/local/lib/libgnomeprintui-2-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libIDL-2.so - found 
(/usr/local/lib/libIDL-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libsigc-2.0.so - found 
(/usr/local/lib/libsigc-2.0.so)
===>   fusenshi-0.9.0_14 depends on shared library: libxml++-2.6.so - found 
(/usr/local/lib/libxml++-2.6.so)
===>   fusenshi-0.9.0_14 depends on shared library: libxml2.so - found 
(/usr/local/lib/libxml2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libORBit-2.so - found 
(/usr/local/lib/libORBit-2.so)
===>   fusenshi-0.9.0_14 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===>   fusenshi-0.9.0_14 depends on shared library: libpangomm-1.4.so - found 
(/usr/local/lib/libpangomm-1.4.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for fusenshi-0.9.0_14
===========================================================================
=======================<phase: build          >============================
===>  Building for fusenshi-0.9.0_14
cd src; /usr/bin/make  build
c++ -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/gtkmm-2.4 
-I/usr/local/lib/gtkmm-2.4/include -I/usr/local/include/atkmm-1.6 
-I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include 
-I/usr/local/include/glibmm-2.4 -I/usr/local/lib/glibmm-2.4/include 
-I/usr/local/include/sigc++-2.0 -I/usr/local/lib/sigc++-2.0/include 
-I/usr/local/include/giomm-2.4 -I/usr/local/lib/giomm-2.4/include 
-I/usr/local/include/pangomm-1.4  -I/usr/local/lib/pangomm-1.4/include 
-I/usr/local/include/cairomm-1.0 -I/usr/local/lib/cairomm-1.0/include 
-I/usr/local/include/cairo -I/usr/local/include/pixman-1 
-I/usr/local/include/freetype2    -I/usr/local/include/freetype2 
-I/usr/local/include/libdrm -I/usr/local/include/libpng16 
-I/usr/local/include/pango-1.0 -I/usr/local/include/harfbuzz 
-I/usr/local/include/gtk-2.0 -I/usr/local/include/gdk-pixbuf-2.0 
-I/usr/local/include/gtk-unix-print-2.0 -I/usr/local/include/gdkmm-2.4 
-I/usr/local/lib/gdkmm-2.4/incl
 ude -I/usr/local/include/gtksourceview-1.0 -I/usr/local/include/libxml2 
-I/usr/local/include/libgnomeprint-2.2 -I/usr/local/include/libart-2.0 -pthread 
-D_THREAD_SAFE -I/usr/local/include/p11-kit-1   -I/usr/local/include -I. 
-I./include -Wall -O2 -DENABLE_NLS -DPACKAGE=\""fusenshi"\"  
-DGETTEXT_PACKAGE=\""fusenshi"\"  -DPACKAGE_DATA_DIR=\""/usr/local/share"\"  
-DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -DFUSENSHI_MAJOR_VERSION="0" 
-DFUSENSHI_MINOR_VERSION="9" -DFUSENSHI_MICRO_VERSION="0" -o 
crypto/selfcertificate.o -c crypto/selfcertificate.cpp
In file included from crypto/selfcertificate.cpp:36:
In file included from crypto/../include/fusenshi.h:62:
In file included from ./include/../fio/fio.h:43:
In file included from /usr/local/include/gtkmm-2.4/gtkmm.h:177:
In file included from /usr/local/include/gtkmm-2.4/gtkmm/pagesetup.h:28:
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:290:1: warning: 
'PaperSizeTraits' defined as a struct here but previously declared as a class 
[-Wmismatched-tags]
struct PaperSizeTraits
^
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:35:1: note: did you mean struct 
here?
class PaperSizeTraits;
^~~~~
struct
1 warning generated.
c++ -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/gtkmm-2.4 
-I/usr/local/lib/gtkmm-2.4/include -I/usr/local/include/atkmm-1.6 
-I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include 
-I/usr/local/include/glibmm-2.4 -I/usr/local/lib/glibmm-2.4/include 
-I/usr/local/include/sigc++-2.0 -I/usr/local/lib/sigc++-2.0/include 
-I/usr/local/include/giomm-2.4 -I/usr/local/lib/giomm-2.4/include 
-I/usr/local/include/pangomm-1.4  -I/usr/local/lib/pangomm-1.4/include 
-I/usr/local/include/cairomm-1.0 -I/usr/local/lib/cairomm-1.0/include 
-I/usr/local/include/cairo -I/usr/local/include/pixman-1 
-I/usr/local/include/freetype2    -I/usr/local/include/freetype2 
-I/usr/local/include/libdrm -I/usr/local/include/libpng16 
-I/usr/local/include/pango-1.0 -I/usr/local/include/harfbuzz 
-I/usr/local/include/gtk-2.0 -I/usr/local/include/gdk-pixbuf-2.0 
-I/usr/local/include/gtk-unix-print-2.0 -I/usr/local/include/gdkmm-2.4 
-I/usr/local/lib/gdkmm-2.4/incl
 ude -I/usr/local/include/gtksourceview-1.0 -I/usr/local/include/libxml2 
-I/usr/local/include/libgnomeprint-2.2 -I/usr/local/include/libart-2.0 -pthread 
-D_THREAD_SAFE -I/usr/local/include/p11-kit-1   -I/usr/local/include -I. 
-I./include -Wall -O2 -DENABLE_NLS -DPACKAGE=\""fusenshi"\"  
-DGETTEXT_PACKAGE=\""fusenshi"\"  -DPACKAGE_DATA_DIR=\""/usr/local/share"\"  
-DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -DFUSENSHI_MAJOR_VERSION="0" 
-DFUSENSHI_MINOR_VERSION="9" -DFUSENSHI_MICRO_VERSION="0" -o fio/XMLTool.o -c 
fio/XMLTool.cpp
In file included from fio/XMLTool.cpp:37:
In file included from ./include/fusenshi.h:62:
In file included from ./include/../fio/fio.h:43:
In file included from /usr/local/include/gtkmm-2.4/gtkmm.h:177:
In file included from /usr/local/include/gtkmm-2.4/gtkmm/pagesetup.h:28:
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:290:1: warning: 
'PaperSizeTraits' defined as a struct here but previously declared as a class 
[-Wmismatched-tags]
struct PaperSizeTraits
^
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:35:1: note: did you mean struct 
here?
class PaperSizeTraits;
^~~~~
struct
1 warning generated.
c++ -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/gtkmm-2.4 
-I/usr/local/lib/gtkmm-2.4/include -I/usr/local/include/atkmm-1.6 
-I/usr/local/include/atk-1.0 -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include 
-I/usr/local/include/glibmm-2.4 -I/usr/local/lib/glibmm-2.4/include 
-I/usr/local/include/sigc++-2.0 -I/usr/local/lib/sigc++-2.0/include 
-I/usr/local/include/giomm-2.4 -I/usr/local/lib/giomm-2.4/include 
-I/usr/local/include/pangomm-1.4  -I/usr/local/lib/pangomm-1.4/include 
-I/usr/local/include/cairomm-1.0 -I/usr/local/lib/cairomm-1.0/include 
-I/usr/local/include/cairo -I/usr/local/include/pixman-1 
-I/usr/local/include/freetype2    -I/usr/local/include/freetype2 
-I/usr/local/include/libdrm -I/usr/local/include/libpng16 
-I/usr/local/include/pango-1.0 -I/usr/local/include/harfbuzz 
-I/usr/local/include/gtk-2.0 -I/usr/local/include/gdk-pixbuf-2.0 
-I/usr/local/include/gtk-unix-print-2.0 -I/usr/local/include/gdkmm-2.4 
-I/usr/local/lib/gdkmm-2.4/incl
 ude -I/usr/local/include/gtksourceview-1.0 -I/usr/local/include/libxml2 
-I/usr/local/include/libgnomeprint-2.2 -I/usr/local/include/libart-2.0 -pthread 
-D_THREAD_SAFE -I/usr/local/include/p11-kit-1   -I/usr/local/include -I. 
-I./include -Wall -O2 -DENABLE_NLS -DPACKAGE=\""fusenshi"\"  
-DGETTEXT_PACKAGE=\""fusenshi"\"  -DPACKAGE_DATA_DIR=\""/usr/local/share"\"  
-DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -DFUSENSHI_MAJOR_VERSION="0" 
-DFUSENSHI_MINOR_VERSION="9" -DFUSENSHI_MICRO_VERSION="0" -o fio/filemanager.o 
-c fio/filemanager.cpp
In file included from fio/filemanager.cpp:36:
In file included from fio/../include/fusenshi.h:62:
In file included from ./include/../fio/fio.h:43:
In file included from /usr/local/include/gtkmm-2.4/gtkmm.h:177:
In file included from /usr/local/include/gtkmm-2.4/gtkmm/pagesetup.h:28:
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:290:1: warning: 
'PaperSizeTraits' defined as a struct here but previously declared as a class 
[-Wmismatched-tags]
struct PaperSizeTraits
^
/usr/local/include/gtkmm-2.4/gtkmm/papersize.h:35:1: note: did you mean struct 
here?
class PaperSizeTraits;
^~~~~
struct
fio/filemanager.cpp:48:22: error: cast from pointer to smaller type 'u_int32_t' 
(aka 'unsigned int') loses information
    u_int32_t nKey = (u_int32_t)pKey;
                     ^~~~~~~~~~~~~~~
fio/filemanager.cpp:91:26: error: cast from pointer to smaller type 'u_int32_t' 
(aka 'unsigned int') loses information
        lpData->result = (u_int32_t)key;
                         ^~~~~~~~~~~~~~
fio/filemanager.cpp:141:29: warning: cast to 'void *' from smaller integer type 
'u_int32_t' (aka 'unsigned int') [-Wint-to-void-pointer-cast]
                            (gpointer)++m_nMaxFileNumber,
                            ^
fio/filemanager.cpp:159:24: warning: cast to 'const void *' from smaller 
integer type 'u_int32_t' (aka 'unsigned int') [-Wint-to-void-pointer-cast]
        (m_pFileTable, (gconstpointer)nIndex);
                       ^
fio/filemanager.cpp:212:43: warning: cast to 'const void *' from smaller 
integer type 'u_int32_t' (aka 'unsigned int') [-Wint-to-void-pointer-cast]
        g_hash_table_remove(m_pFileTable, (gconstpointer)nIndex);
                                          ^
4 warnings and 2 errors generated.
*** Error code 1

Stop.
make[2]: stopped in 
/wrkdirs/usr/ports/deskutils/fusenshi/work/fusenshi-0.9.0/src
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/deskutils/fusenshi/work/fusenshi-0.9.0
*** Error code 1

Stop.
make: stopped in /usr/ports/deskutils/fusenshi
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to