You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@thelanman.net
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2016Q3/databases/py-pymssql/Makefile 412346 
2016-04-01 14:00:51Z mat $
Log URL:        
http://beefy2.nyi.freebsd.org/data/110amd64-quarterly/422452/logs/py27-pymssql-2.1.1.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=110amd64-quarterly&build=422452
Log:

====>> Building databases/py-pymssql
build started at Thu Sep 22 04:49:19 UTC 2016
port directory: /usr/ports/databases/py-pymssql
building for: FreeBSD 110amd64-quarterly-job-16 11.0-RC3 FreeBSD 11.0-RC3 
r305997 amd64
maintained by: po...@thelanman.net
Makefile ident:      $FreeBSD: branches/2016Q3/databases/py-pymssql/Makefile 
412346 2016-04-01 14:00:51Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 1100122

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RC3 r305997
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110amd64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=py27-pymssql-2.1.1
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/110amd64-quarterly/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES LINUX_OSRELEASE=2.6.32
MASTERNAME=110amd64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/py-pymssql/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/py-pymssql/work  
HOME=/wrkdirs/usr/ports/databases/py-pymssql/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/py-pymssql/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/py-pymssql/work  
HOME=/wrkdirs/usr/ports/databases/py-pymssql/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LDSHARED="cc 
-shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/pymssql"
EXAMPLESDIR="share/examples/pymssql"
DATADIR="share/pymssql"
WWWDIR="www/pymssql"
ETCDIR="etc/pymssql"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pymssql
DOCSDIR=/usr/local/share/doc/pymssql
EXAMPLESDIR=/usr/local/share/examples/pymssql
WWWDIR=/usr/local/www/pymssql
ETCDIR=/usr/local/etc/pymssql
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-pymssql-2.1.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_1.txz
[110amd64-quarterly-job-16] Installing pkg-1.8.7_1...
[110amd64-quarterly-job-16] Extracting pkg-1.8.7_1: .......... done
===>   py27-pymssql-2.1.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py27-pymssql-2.1.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by py27-pymssql-2.1.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by py27-pymssql-2.1.1 for building
=> SHA256 Checksum OK for pymssql-2.1.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by py27-pymssql-2.1.1 for building
===>  Extracting for py27-pymssql-2.1.1
=> SHA256 Checksum OK for pymssql-2.1.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-pymssql-2.1.1
===>  Applying FreeBSD patches for py27-pymssql-2.1.1
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-pymssql-2.1.1 depends on executable: cython - not found
===>   Installing existing package /packages/All/cython-0.24.txz
[110amd64-quarterly-job-16] Installing cython-0.24...
[110amd64-quarterly-job-16] `-- Installing python27-2.7.12...
[110amd64-quarterly-job-16] |   `-- Installing libffi-3.2.1...
[110amd64-quarterly-job-16] |   | `-- Installing indexinfo-0.2.4...
[110amd64-quarterly-job-16] |   | `-- Extracting indexinfo-0.2.4: .... done
[110amd64-quarterly-job-16] |   `-- Extracting libffi-3.2.1: .......... done
[110amd64-quarterly-job-16] |   `-- Installing gettext-runtime-0.19.8.1...
[110amd64-quarterly-job-16] |   `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[110amd64-quarterly-job-16] |   `-- Installing readline-6.3.8...
[110amd64-quarterly-job-16] |   `-- Extracting readline-6.3.8: .......... done
[110amd64-quarterly-job-16] `-- Extracting python27-2.7.12: .......... done
[110amd64-quarterly-job-16] `-- Installing py27-setuptools27-20.0...
[110amd64-quarterly-job-16] `-- Extracting py27-setuptools27-20.0: .......... 
done
[110amd64-quarterly-job-16] Extracting cython-0.24: .......... done
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   py27-pymssql-2.1.1 depends on executable: cython - found
===>   Returning to build of py27-pymssql-2.1.1
===>   py27-pymssql-2.1.1 depends on package: py27-setuptools-git>0 - not found
===>   Installing existing package /packages/All/py27-setuptools-git-1.1.txz
[110amd64-quarterly-job-16] Installing py27-setuptools-git-1.1...
[110amd64-quarterly-job-16] Extracting py27-setuptools-git-1.1: .......... done
Message from py27-setuptools-git-1.1:
===>   NOTICE:

The py27-setuptools-git port currently does not have a maintainer. As a result, 
it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   py27-pymssql-2.1.1 depends on package: py27-setuptools-git>0 - found
===>   Returning to build of py27-pymssql-2.1.1
===>   py27-pymssql-2.1.1 depends on package: py27-setuptools27>0 - found
===>   py27-pymssql-2.1.1 depends on file: /usr/local/bin/python2.7 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-pymssql-2.1.1 depends on shared library: libsybdb.so - not found
===>   Installing existing package /packages/All/freetds-1.00.1,1.txz
[110amd64-quarterly-job-16] Installing freetds-1.00.1,1...
[110amd64-quarterly-job-16] `-- Installing libgcrypt-1.7.3...
[110amd64-quarterly-job-16] |   `-- Installing libgpg-error-1.23...
[110amd64-quarterly-job-16] |   `-- Extracting libgpg-error-1.23: .......... 
done
[110amd64-quarterly-job-16] `-- Extracting libgcrypt-1.7.3: .......... done
[110amd64-quarterly-job-16] `-- Installing unixODBC-2.3.4...
[110amd64-quarterly-job-16] `-- Extracting unixODBC-2.3.4: .......... done
[110amd64-quarterly-job-16] Extracting freetds-1.00.1,1: .......... done
Message from unixODBC-2.3.4:
===>   NOTICE:

The unixODBC port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   py27-pymssql-2.1.1 depends on shared library: libsybdb.so - found 
(/usr/local/lib/libsybdb.so)
===>   Returning to build of py27-pymssql-2.1.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-pymssql-2.1.1
setup.py: platform.system() => 'FreeBSD'
setup.py: platform.architecture() => ('64bit', 'ELF')
setup.py: platform.libc_ver() => ('libc', '7')
setup.py: Detected FreeBSD.
    For FreeBSD, you can install FreeTDS with FreeBSD Ports or by downloading
    and compiling it yourself.
            
setup.py: Not using bundled FreeTDS
setup.py: include_dirs = ['/usr/local/include']
setup.py: library_dirs = ['/usr/local/lib']
running config
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-pymssql-2.1.1
setup.py: platform.system() => 'FreeBSD'
setup.py: platform.architecture() => ('64bit', 'ELF')
setup.py: platform.libc_ver() => ('libc', '7')
setup.py: Detected FreeBSD.
    For FreeBSD, you can install FreeTDS with FreeBSD Ports or by downloading
    and compiling it yourself.
            
setup.py: Not using bundled FreeTDS
setup.py: include_dirs = ['/usr/local/include']
setup.py: library_dirs = ['/usr/local/lib']
running build
running build_ext
building '_mssql' extension
creating build
creating build/temp.freebsd-11.0-RC3-amd64-2.7
cc -DNDEBUG -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC 
-I/usr/local/include -I/usr/local/include/python2.7 -c _mssql.c -o 
build/temp.freebsd-11.0-RC3-amd64-2.7/_mssql.o -DMSDBLIB
_mssql.c:16504:15: error: use of undeclared identifier 'DBVERSION_80'
    __pyx_r = DBVERSION_80;
              ^
1 error generated.
error: command 'cc' failed with exit status 1
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/py-pymssql
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to