You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sp...@acm.poly.edu
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/sysutils/geomWatch/Makefile 417110 2016-06-19 
11:25:29Z mat $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-default/422291/logs/geomWatch-1.3.0_2.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-default&build=422291
Log:

====>> Building sysutils/geomWatch
build started at Thu Sep 22 06:12:52 UTC 2016
port directory: /usr/ports/sysutils/geomWatch
building for: FreeBSD 110arm64-default-job-08 11.0-RC3 FreeBSD 11.0-RC3 r305786 
arm64
maintained by: sp...@acm.poly.edu
Makefile ident:      $FreeBSD: head/sysutils/geomWatch/Makefile 417110 
2016-06-19 11:25:29Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RC3 r305786
UNAME_r=11.0-RC3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=geomWatch-1.3.0_2
OSREL=11.0
_OSRELEASE=11.0-RC3
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-default/ref/.p/pool
MASTERNAME=110arm64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work  
HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work  
HOME=/wrkdirs/usr/ports/sysutils/geomWatch/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/geomWatch"
EXAMPLESDIR="share/examples/geomWatch"
DATADIR="share/geomWatch"
WWWDIR="www/geomWatch"
ETCDIR="etc/geomWatch"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/geomWatch
DOCSDIR=/usr/local/share/doc/geomWatch
EXAMPLESDIR=/usr/local/share/examples/geomWatch
WWWDIR=/usr/local/www/geomWatch
ETCDIR=/usr/local/etc/geomWatch
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   geomWatch-1.3.0_2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[110arm64-default-job-08] Installing pkg-1.8.7_3...
[110arm64-default-job-08] Extracting pkg-1.8.7_3: .......... done
===>   geomWatch-1.3.0_2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of geomWatch-1.3.0_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by geomWatch-1.3.0_2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by geomWatch-1.3.0_2 for building
=> SHA256 Checksum OK for geomWatch-1.3.0.tbz.
=> SHA256 Checksum OK for nvpair.h?revision=279437&view=co.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by geomWatch-1.3.0_2 for building
===>  Extracting for geomWatch-1.3.0_2
=> SHA256 Checksum OK for geomWatch-1.3.0.tbz.
=> SHA256 Checksum OK for nvpair.h?revision=279437&view=co.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for geomWatch-1.3.0_2
===>  Applying FreeBSD patches for geomWatch-1.3.0_2
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===>   geomWatch-1.3.0_2 depends on shared library: libesmtp.so - not found
===>   Installing existing package /packages/All/libesmtp-1.0.6_2,1.txz
[110arm64-default-job-08] Installing libesmtp-1.0.6_2,1...
[110arm64-default-job-08] Extracting libesmtp-1.0.6_2,1: .......... done
Message from libesmtp-1.0.6_2,1:
===>   NOTICE:

The libesmtp port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   geomWatch-1.3.0_2 depends on shared library: libesmtp.so - found 
(/usr/local/lib/libesmtp.so)
===>   Returning to build of geomWatch-1.3.0_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for geomWatch-1.3.0_2
===========================================================================
=======================<phase: build          >============================
===>  Building for geomWatch-1.3.0_2
c++ -Wall -Wextra -Wno-unknown-pragmas  -DWITH_ZFS=28 -DNEED_SOLARIS_BOOLEAN  
-Izfs/v28/cddl/contrib/opensolaris/lib/libzpool/common  
-Izfs/v28/cddl/compat/opensolaris/include  
-Izfs/v28/cddl/compat/opensolaris/lib/libumem  
-Izfs/v28/sys/cddl/compat/opensolaris  -Izfs/v28/cddl/contrib/opensolaris/head  
-Izfs/v28/cddl/contrib/opensolaris/lib/libzfs/common  
-Izfs/v28/cddl/contrib/opensolaris/lib/libnvpair  
-Izfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs  
-Izfs/v28/sys/cddl/contrib/opensolaris/uts/common -Izfs  -I/usr/local/include  
-L/usr/local/lib  -lzfs -lgeom -lnvpair -luutil -lesmtp -o geomWatch 
geomWatch.cpp
In file included from geomWatch.cpp:41:
In file included from ./zpool.hpp:34:
In file included from zfs/v28/cddl/contrib/opensolaris/head/libintl.h:32:
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/sys/isa_defs.h:596:2: error: 
"ISA not supported"
#error "ISA not supported"
 ^
In file included from geomWatch.cpp:41:
In file included from ./zpool.hpp:35:
In file included from 
zfs/v28/cddl/contrib/opensolaris/lib/libzfs/common/libzfs.h:38:
In file included from 
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zfs_ioctl.h:30:
In file included from 
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zio.h:29:
In file included from 
zfs/v28/cddl/contrib/opensolaris/lib/libzpool/common/sys/zfs_context.h:66:
zfs/v28/sys/cddl/compat/opensolaris/sys/atomic.h:60:2: error: use of undeclared 
identifier 'atomic_set_8'
        atomic_set_8(target, value);
        ^
In file included from geomWatch.cpp:41:
In file included from ./zpool.hpp:35:
In file included from 
zfs/v28/cddl/contrib/opensolaris/lib/libzfs/common/libzfs.h:38:
In file included from 
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zfs_ioctl.h:30:
In file included from 
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/sys/zio.h:29:
In file included from 
zfs/v28/cddl/contrib/opensolaris/lib/libzpool/common/sys/zfs_context.h:67:
zfs/v28/sys/cddl/contrib/opensolaris/uts/common/sys/sysmacros.h:367:2: error:   
One of _BIT_FIELDS_LTOH or _BIT_FIELDS_HTOL must be defined
#error  One of _BIT_FIELDS_LTOH or _BIT_FIELDS_HTOL must be defined
 ^
geomWatch.cpp:83:49: warning: comparison of constant -1 with expression of type 
'char' is always true [-Wtautological-constant-out-of-range-compare]
  while ((option = getopt(argc, argv, "c:p:t")) != -1) {
         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^  ~~
1 warning and 3 errors generated.
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/sysutils/geomWatch/work/geomWatch-1.3.0
*** Error code 1

Stop.
make: stopped in /usr/ports/sysutils/geomWatch
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to