You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     amd...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2016Q4/devel/py-ode/Makefile 412346 
2016-04-01 14:00:51Z mat $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/423629/logs/py27-ode-1.2.0_3.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-quarterly&build=423629
Log:

====>> Building devel/py-ode
build started at Tue Oct 11 06:59:08 UTC 2016
port directory: /usr/ports/devel/py-ode
building for: FreeBSD 110arm64-quarterly-job-08 11.0-RELEASE-p1 FreeBSD 
11.0-RELEASE-p1 r306420 arm64
maintained by: amd...@freebsd.org
Makefile ident:      $FreeBSD: branches/2016Q4/devel/py-ode/Makefile 412346 
2016-04-01 14:00:51Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RELEASE-p1 r306420
UNAME_r=11.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=py27-ode-1.2.0_3
OSREL=11.0
_OSRELEASE=11.0-RELEASE-p1
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-quarterly/ref/.p/pool
MASTERNAME=110arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for py27-ode-1.2.0_3:
     TRIMESH=on: Trimesh support (sync with OPCODE opt of devel/ode)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-ode/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-ode/work  
HOME=/wrkdirs/usr/ports/devel/py-ode/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-ode/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-ode/work  
HOME=/wrkdirs/usr/ports/devel/py-ode/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES LDSHARED="cc 
-shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/ode"
EXAMPLESDIR="share/examples/ode"
DATADIR="share/ode"
WWWDIR="www/ode"
ETCDIR="etc/ode"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/ode
DOCSDIR=/usr/local/share/doc/ode
EXAMPLESDIR=/usr/local/share/examples/ode
WWWDIR=/usr/local/www/ode
ETCDIR=/usr/local/etc/ode
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-ode-1.2.0_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[110arm64-quarterly-job-08] Installing pkg-1.8.7_3...
[110arm64-quarterly-job-08] Extracting pkg-1.8.7_3: .......... done
===>   py27-ode-1.2.0_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py27-ode-1.2.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by py27-ode-1.2.0_3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by py27-ode-1.2.0_3 for building
=> SHA256 Checksum OK for python/PyODE-1.2.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by py27-ode-1.2.0_3 for building
===>  Extracting for py27-ode-1.2.0_3
=> SHA256 Checksum OK for python/PyODE-1.2.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-ode-1.2.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-ode-1.2.0_3 depends on file: /usr/local/lib/libode.a - not found
===>   Installing existing package /packages/All/ode-0.13_2,1.txz
[110arm64-quarterly-job-08] Installing ode-0.13_2,1...
[110arm64-quarterly-job-08] `-- Installing libGLU-9.0.0_2...
[110arm64-quarterly-job-08] |   `-- Installing libGL-11.2.2...
[110arm64-quarterly-job-08] |   | `-- Installing expat-2.2.0...
[110arm64-quarterly-job-08] |   | `-- Extracting expat-2.2.0: .......... done
[110arm64-quarterly-job-08] |   | `-- Installing dri2proto-2.8...
[110arm64-quarterly-job-08] |   | `-- Extracting dri2proto-2.8: .... done
[110arm64-quarterly-job-08] |   | `-- Installing libXdamage-1.1.4_3...
[110arm64-quarterly-job-08] |   |   `-- Installing libXfixes-5.0.1_3...
[110arm64-quarterly-job-08] |   |   | `-- Installing xproto-7.0.28...
[110arm64-quarterly-job-08] |   |   | `-- Extracting xproto-7.0.28: .......... 
done
[110arm64-quarterly-job-08] |   |   | `-- Installing fixesproto-5.0...
[110arm64-quarterly-job-08] |   |   | `-- Extracting fixesproto-5.0: .... done
[110arm64-quarterly-job-08] |   |   | `-- Installing libX11-1.6.3,1...
[110arm64-quarterly-job-08] |   |   |   `-- Installing kbproto-1.0.7...
[110arm64-quarterly-job-08] |   |   |   `-- Extracting kbproto-1.0.7: 
.......... done
[110arm64-quarterly-job-08] |   |   |   `-- Installing libXdmcp-1.1.2...
[110arm64-quarterly-job-08] |   |   |   `-- Extracting libXdmcp-1.1.2: 
......... done
[110arm64-quarterly-job-08] |   |   |   `-- Installing libxcb-1.11.1...
[110arm64-quarterly-job-08] |   |   |   | `-- Installing libxml2-2.9.4...
[110arm64-quarterly-job-08] |   |   |   | `-- Extracting libxml2-2.9.4: 
.......... done
[110arm64-quarterly-job-08] |   |   |   | `-- Installing 
libpthread-stubs-0.3_6...
[110arm64-quarterly-job-08] |   |   |   | `-- Extracting 
libpthread-stubs-0.3_6: ..... done
[110arm64-quarterly-job-08] |   |   |   | `-- Installing libXau-1.0.8_3...
[110arm64-quarterly-job-08] |   |   |   | `-- Extracting libXau-1.0.8_3: 
.......... done
[110arm64-quarterly-job-08] |   |   |   `-- Extracting libxcb-1.11.1: 
.......... done
[110arm64-quarterly-job-08] |   |   | `-- Extracting libX11-1.6.3,1: .......... 
done
[110arm64-quarterly-job-08] |   |   `-- Extracting libXfixes-5.0.1_3: 
.......... done
[110arm64-quarterly-job-08] |   |   `-- Installing damageproto-1.2.1...
[110arm64-quarterly-job-08] |   |   `-- Extracting damageproto-1.2.1: .... done
[110arm64-quarterly-job-08] |   | `-- Extracting libXdamage-1.1.4_3: ...... done
[110arm64-quarterly-job-08] |   | `-- Installing libdevq-0.0.2_1...
[110arm64-quarterly-job-08] |   | `-- Extracting libdevq-0.0.2_1: ..... done
[110arm64-quarterly-job-08] |   | `-- Installing libXxf86vm-1.1.4_1...
[110arm64-quarterly-job-08] |   |   `-- Installing xf86vidmodeproto-2.3.1...
[110arm64-quarterly-job-08] |   |   `-- Extracting xf86vidmodeproto-2.3.1: .... 
done
[110arm64-quarterly-job-08] |   |   `-- Installing libXext-1.3.3_1,1...
[110arm64-quarterly-job-08] |   |   | `-- Installing xextproto-7.3.0...
[110arm64-quarterly-job-08] |   |   | `-- Extracting xextproto-7.3.0: 
.......... done
[110arm64-quarterly-job-08] |   |   `-- Extracting libXext-1.3.3_1,1: 
.......... done
[110arm64-quarterly-job-08] |   | `-- Extracting libXxf86vm-1.1.4_1: .......... 
done
[110arm64-quarterly-job-08] |   | `-- Installing libdrm-2.4.66,1...
[110arm64-quarterly-job-08] |   |   `-- Installing libpciaccess-0.13.4...
[110arm64-quarterly-job-08] |   |   | `-- Installing pciids-20160621...
[110arm64-quarterly-job-08] |   |   | `-- Extracting pciids-20160621: ..... done
[110arm64-quarterly-job-08] |   |   `-- Extracting libpciaccess-0.13.4: ...... 
done
[110arm64-quarterly-job-08] |   | `-- Extracting libdrm-2.4.66,1: .......... 
done
[110arm64-quarterly-job-08] |   | `-- Installing libxshmfence-1.2...
[110arm64-quarterly-job-08] |   | `-- Extracting libxshmfence-1.2: ......... 
done
[110arm64-quarterly-job-08] |   | `-- Installing libglapi-11.2.2...
[110arm64-quarterly-job-08] |   |   `-- Installing libXvMC-1.0.9...
[110arm64-quarterly-job-08] |   |   | `-- Installing libXv-1.0.10_3,1...
[110arm64-quarterly-job-08] |   |   |   `-- Installing videoproto-2.3.2...
[110arm64-quarterly-job-08] |   |   |   `-- Extracting videoproto-2.3.2: ...... 
done
[110arm64-quarterly-job-08] |   |   | `-- Extracting libXv-1.0.10_3,1: 
.......... done
[110arm64-quarterly-job-08] |   |   `-- Extracting libXvMC-1.0.9: .......... 
done
[110arm64-quarterly-job-08] |   | `-- Extracting libglapi-11.2.2: ... done
[110arm64-quarterly-job-08] |   `-- Extracting libGL-11.2.2: .......... done
[110arm64-quarterly-job-08] `-- Extracting libGLU-9.0.0_2: ...... done
[110arm64-quarterly-job-08] Extracting ode-0.13_2,1: .......... done
===>   py27-ode-1.2.0_3 depends on file: /usr/local/lib/libode.a - found
===>   Returning to build of py27-ode-1.2.0_3
===>   py27-ode-1.2.0_3 depends on package: py27-setuptools27>0 - not found
===>   Installing existing package /packages/All/py27-setuptools27-23.1.0.txz
[110arm64-quarterly-job-08] Installing py27-setuptools27-23.1.0...
[110arm64-quarterly-job-08] `-- Installing python27-2.7.12...
[110arm64-quarterly-job-08] |   `-- Installing libffi-3.2.1...
[110arm64-quarterly-job-08] |   | `-- Installing indexinfo-0.2.5...
[110arm64-quarterly-job-08] |   | `-- Extracting indexinfo-0.2.5: .... done
[110arm64-quarterly-job-08] |   `-- Extracting libffi-3.2.1: .......... done
[110arm64-quarterly-job-08] |   `-- Installing gettext-runtime-0.19.8.1...
[110arm64-quarterly-job-08] |   `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[110arm64-quarterly-job-08] |   `-- Installing readline-6.3.8...
[110arm64-quarterly-job-08] |   `-- Extracting readline-6.3.8: .......... done
[110arm64-quarterly-job-08] `-- Extracting python27-2.7.12: .......... done
[110arm64-quarterly-job-08] Extracting py27-setuptools27-23.1.0: .......... done
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   py27-ode-1.2.0_3 depends on package: py27-setuptools27>0 - found
===>   Returning to build of py27-ode-1.2.0_3
===>   py27-ode-1.2.0_3 depends on file: /usr/local/bin/python2.7 - found
===>   py27-ode-1.2.0_3 depends on executable: python2 - not found
===>   Installing existing package /packages/All/python2-2_3.txz
[110arm64-quarterly-job-08] Installing python2-2_3...
[110arm64-quarterly-job-08] Extracting python2-2_3: ...... done
===>   py27-ode-1.2.0_3 depends on executable: python2 - found
===>   Returning to build of py27-ode-1.2.0_3
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-ode-1.2.0_3
INFO: <ode/ode.h> found in /usr/local/include
INFO: ode_trimesh.c is up to date
INFO: ode_notrimesh.c is up to date
INFO: Installing with trimesh support.
running config
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-ode-1.2.0_3
INFO: <ode/ode.h> found in /usr/local/include
INFO: ode_trimesh.c is up to date
INFO: ode_notrimesh.c is up to date
INFO: Installing with trimesh support.
running build
running build_py
creating build
creating build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7
creating build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/__init__.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/transform.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/geom.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/node.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/parser.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/joint.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/body.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
copying xode/errors.py -> build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/xode
running build_ext
building 'ode' extension
creating build/temp.freebsd-11.0-RELEASE-p1-arm64-2.7
cc -DNDEBUG -O2 -pipe -fno-strict-aliasing -fPIC -I/usr/include 
-I/usr/local/include -I/opt/local/include -I/usr/local/include/python2.7 -c 
ode_trimesh.c -o build/temp.freebsd-11.0-RELEASE-p1-arm64-2.7/ode_trimesh.o
ode_trimesh.c:596:3: warning: 'dMassSetCappedCylinder' is deprecated 
[-Wdeprecated-declarations]
  dMassSetCappedCylinder((&((struct __pyx_obj_3ode_Mass 
*)__pyx_v_self)->_mass),__pyx_1,__pyx_2,__pyx_3,__pyx_4);
  ^
/usr/local/include/ode/mass.h:84:33: note: 'dMassSetCappedCylinder' has been 
explicitly marked deprecated here
ODE_API ODE_API_DEPRECATED void dMassSetCappedCylinder(dMass *a, dReal b, int 
c, dReal d, dReal e);
                                ^
ode_trimesh.c:637:3: warning: 'dMassSetCappedCylinderTotal' is deprecated 
[-Wdeprecated-declarations]
  dMassSetCappedCylinderTotal((&((struct __pyx_obj_3ode_Mass 
*)__pyx_v_self)->_mass),__pyx_1,__pyx_2,__pyx_3,__pyx_4);
  ^
/usr/local/include/ode/mass.h:85:33: note: 'dMassSetCappedCylinderTotal' has 
been explicitly marked deprecated here
ODE_API ODE_API_DEPRECATED void dMassSetCappedCylinderTotal(dMass *a, dReal b, 
int c, dReal d, dReal e);
                                ^
ode_trimesh.c:14174:174: warning: passing 'int (*)' to parameter of type 'const 
dTriIndex *' (aka 'const unsigned int *') converts between pointers to integer 
types with different sign [-Wpointer-sign]
  dGeomTriMeshDataBuildSimple(((struct __pyx_obj_3ode_TriMeshData 
*)__pyx_v_self)->tmdid,((struct __pyx_obj_3ode_TriMeshData 
*)__pyx_v_self)->vertex_buffer,__pyx_v_numverts,((struct 
__pyx_obj_3ode_TriMeshData *)__pyx_v_self)->face_buffer,(__pyx_v_numfaces * 3));
                                                                                
                                                                                
             ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/local/include/ode/collision_trimesh.h:98:51: note: passing argument to 
parameter 'Indices' here
                                 const dTriIndex* Indices, int IndexCount);
                                                  ^
ode_trimesh.c:14653:27: warning: comparison of distinct pointer types ('struct 
__pyx_obj_3ode_Body *' and 'PyObject *' (aka 'struct _object *')) 
[-Wcompare-distinct-pointer-types]
  __pyx_2 = __pyx_v_body1 == __pyx_1;
            ~~~~~~~~~~~~~ ^  ~~~~~~~
ode_trimesh.c:14668:27: warning: comparison of distinct pointer types ('struct 
__pyx_obj_3ode_Body *' and 'PyObject *' (aka 'struct _object *')) 
[-Wcompare-distinct-pointer-types]
  __pyx_2 = __pyx_v_body2 == __pyx_1;
            ~~~~~~~~~~~~~ ^  ~~~~~~~
ode_trimesh.c:17768:3: warning: incompatible pointer types initializing 
'lenfunc' (aka 'long (*)(struct _object *)') with an expression of type 'int 
(PyObject *)' (aka 'int (struct _object *)') [-Wincompatible-pointer-types]
  __pyx_f_3ode_9SpaceBase___len__, /*sq_length*/
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ode_trimesh.c:17781:3: warning: incompatible pointer types initializing 
'lenfunc' (aka 'long (*)(struct _object *)') with an expression of type 'int 
(PyObject *)' (aka 'int (struct _object *)') [-Wincompatible-pointer-types]
  __pyx_f_3ode_9SpaceBase___len__, /*mp_length*/
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
7 warnings generated.
cc -shared -O2 -pipe -fno-strict-aliasing 
build/temp.freebsd-11.0-RELEASE-p1-arm64-2.7/ode_trimesh.o -L/usr/lib 
-L/usr/local/lib -L/opt/local/lib -L/usr/local/lib -lode -lstdc++ -lpython2.7 
-o build/lib.freebsd-11.0-RELEASE-p1-arm64-2.7/ode.so
/usr/bin/ld: /usr/local/lib/libode.a(convex.o): relocation 
R_AARCH64_ADR_PREL_PG_HI21 against external symbol `__stdoutp@@FBSD_1.0' can 
not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: /usr/local/lib/libode.a(convex.o)(.text+0xe4): unresolvable 
R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `__stdoutp@@FBSD_1.0'
/usr/bin/ld: final link failed: Bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
error: command 'cc' failed with exit status 1
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-ode
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to