You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     k...@freebsd.org
Last committer: tcber...@freebsd.org
Ident:          $FreeBSD: head/devel/libdbusmenu-qt5/Makefile 422409 2016-09-18 
20:36:31Z tcberner $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p423739_s307008/logs/libdbusmenu-qt5-0.9.3.160420160218_1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p423739_s307008
Log:

====>> Building devel/libdbusmenu-qt5
build started at Wed Oct 12 18:41:06 UTC 2016
port directory: /usr/ports/devel/libdbusmenu-qt5
building for: FreeBSD head-armv6-default-job-11 12.0-CURRENT FreeBSD 
12.0-CURRENT r307008 arm
maintained by: k...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/libdbusmenu-qt5/Makefile 422409 
2016-09-18 20:36:31Z tcberner $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 1200012




!!! Jail is newer than host. (Jail: 1200012, Host: 1200005) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 12.0-CURRENT r307008
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=armv6
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=libdbusmenu-qt5-0.9.3.160420160218_1
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200012
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
libdbusmenu-qt5-0.9.3.160420160218_1:
     DOXYGEN=on: Build documentation (requires doxygen)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt5  --with-qt-libraries=/usr/local/lib  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work  
HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh QTDIR="/usr/local" QMAKE="/usr/local/lib/qt5/bin/qmake"  
MOC="/usr/local/lib/qt5/bin/moc" RCC="/usr/local/lib/qt5/bin/rcc" 
UIC="/usr/local/lib/qt5/bin/uic"  
QMAKESPEC="/usr/local/lib/qt5/mkspecs/freebsd-$(ccver="$(/nxb-bin/usr/bin/c++ 
--version)"; case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work  
HOME=/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe  -fno-strict-aliasing"  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
QTVER_SUFFIX="5"
DOXYGEN=""
NO_DOXYGEN="@comment
"
QT_PREFIX="/usr/local"
QT_BINDIR="lib/qt5/bin"
QT_INCDIR="include/qt5"
QT_LIBDIR="lib"
QT_ARCHDIR="lib/qt5"
QT_PLUGINDIR="lib/qt5/plugins"
QT_LIBEXECDIR="libexec/qt5"
QT_IMPORTDIR="lib/qt5/imports"
QT_QMLDIR="lib/qt5/qml"
QT_DATADIR="share/qt5"
QT_DOCDIR="share/doc/qt5"
QT_L10NDIR="share/qt5/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt5"
QT_TESTDIR="share/qt5/tests"
QT_MKSPECDIR="lib/qt5/mkspecs"
CMAKE_BUILD_TYPE="release"
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/libdbusmenu-qt"
EXAMPLESDIR="share/examples/libdbusmenu-qt"
DATADIR="share/libdbusmenu-qt"
WWWDIR="www/libdbusmenu-qt"
ETCDIR="etc/libdbusmenu-qt"
--End PLIST_SUB--

--SUB_LIST--
DOXYGEN=""
NO_DOXYGEN="@comment
"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/libdbusmenu-qt
DOCSDIR=/usr/local/share/doc/libdbusmenu-qt
EXAMPLESDIR=/usr/local/share/examples/libdbusmenu-qt
WWWDIR=/usr/local/www/libdbusmenu-qt
ETCDIR=/usr/local/etc/libdbusmenu-qt
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
<snip>
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from ca_root_nss-3.27.1:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
Message from trousers-0.3.13_1:
To run tcsd automatically, add the following line to /etc/rc.conf:

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

If you want to use tcsd with software TPM emulator, use the following
configuration in /etc/rc.conf:

tcsd_enable="YES"
tcsd_mode="emulator"
tpmd_enable="YES"

To use TPM, add your_account to '_tss' group like following:

# pw groupmod _tss -m your_account
Message from ghostscript9-agpl-base-9.16_5:
Note: in order to use the script "dvipdf", dvips must be installed.
This program is provided by another package print/tex-dvipsk.

FAPIfontmap and FAPIcidfmap in /usr/local/share/ghostscript/9.16/Resource/Init
have to be configured if you want to use FAPI feature.
Message from zziplib-0.13.62_2:
===>   NOTICE:

The zziplib port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on executable: doxygen - 
found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.6.2.txz
[head-armv6-default-job-11] Installing cmake-3.6.2...
[head-armv6-default-job-11] `-- Installing cmake-modules-3.6.2...
[head-armv6-default-job-11] `-- Extracting cmake-modules-3.6.2: .......... done
[head-armv6-default-job-11] `-- Installing curl-7.50.3_1...
[head-armv6-default-job-11] `-- Extracting curl-7.50.3_1: .......... done
[head-armv6-default-job-11] `-- Installing libarchive-3.2.1,1...
[head-armv6-default-job-11] |   `-- Installing liblz4-131...
[head-armv6-default-job-11] |   `-- Extracting liblz4-131: .......... done
[head-armv6-default-job-11] |   `-- Installing lzo2-2.09...
[head-armv6-default-job-11] |   `-- Extracting lzo2-2.09: .......... done
[head-armv6-default-job-11] `-- Extracting libarchive-3.2.1,1: .......... done
[head-armv6-default-job-11] `-- Installing jsoncpp-1.7.7...
[head-armv6-default-job-11] `-- Extracting jsoncpp-1.7.7: .......... done
[head-armv6-default-job-11] Extracting cmake-3.6.2: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/bin/cmake - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/qt5/bin/moc - not found
===>   Installing existing package /packages/All/qt5-buildtools-5.6.1.txz
[head-armv6-default-job-11] Installing qt5-buildtools-5.6.1...
[head-armv6-default-job-11] Extracting qt5-buildtools-5.6.1: ......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/qt5/bin/moc - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Core.so - not found
===>   Installing existing package /packages/All/qt5-core-5.6.1_1.txz
[head-armv6-default-job-11] Installing qt5-core-5.6.1_1...
[head-armv6-default-job-11] Extracting qt5-core-5.6.1_1: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Core.so - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5DBus.so - not found
===>   Installing existing package /packages/All/qt5-dbus-5.6.1.txz
[head-armv6-default-job-11] Installing qt5-dbus-5.6.1...
[head-armv6-default-job-11] Extracting qt5-dbus-5.6.1: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5DBus.so - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Gui.so - not found
===>   Installing existing package /packages/All/qt5-gui-5.6.1.txz
[head-armv6-default-job-11] Installing qt5-gui-5.6.1...
[head-armv6-default-job-11] `-- Installing xcb-util-image-0.4.0_1...
[head-armv6-default-job-11] `-- Extracting xcb-util-image-0.4.0_1: ........ done
[head-armv6-default-job-11] `-- Installing xcb-util-wm-0.4.1_3...
[head-armv6-default-job-11] `-- Extracting xcb-util-wm-0.4.1_3: .......... done
[head-armv6-default-job-11] `-- Installing qt5-network-5.6.1...
[head-armv6-default-job-11] |   `-- Installing libproxy-0.4.12...
[head-armv6-default-job-11] |   `-- Extracting libproxy-0.4.12: ........ done
[head-armv6-default-job-11] `-- Extracting qt5-network-5.6.1: .......... done
[head-armv6-default-job-11] `-- Installing libxkbcommon-0.5.0_1...
[head-armv6-default-job-11] `-- Extracting libxkbcommon-0.5.0_1: .......... done
[head-armv6-default-job-11] `-- Installing xcb-util-keysyms-0.4.0_1...
[head-armv6-default-job-11] `-- Extracting xcb-util-keysyms-0.4.0_1: ...... done
[head-armv6-default-job-11] `-- Installing libXi-1.7.7,1...
[head-armv6-default-job-11] |   `-- Installing inputproto-2.3.1...
[head-armv6-default-job-11] |   `-- Extracting inputproto-2.3.1: ..... done
[head-armv6-default-job-11] `-- Extracting libXi-1.7.7,1: .......... done
[head-armv6-default-job-11] `-- Installing xdg-utils-1.1.1...
[head-armv6-default-job-11] |   `-- Installing hicolor-icon-theme-0.15...
[head-armv6-default-job-11] |   `-- Extracting hicolor-icon-theme-0.15: . done
[head-armv6-default-job-11] |   `-- Installing xset-1.2.3_1...
[head-armv6-default-job-11] |   | `-- Installing libXfontcache-1.0.5_3...
[head-armv6-default-job-11] |   |   `-- Installing fontcacheproto-0.1.3...
[head-armv6-default-job-11] |   |   `-- Extracting fontcacheproto-0.1.3: .... 
done
[head-armv6-default-job-11] |   | `-- Extracting libXfontcache-1.0.5_3: 
.......... done
[head-armv6-default-job-11] |   `-- Extracting xset-1.2.3_1: .. done
[head-armv6-default-job-11] |   `-- Installing xprop-1.2.2...
[head-armv6-default-job-11] |   `-- Extracting xprop-1.2.2: .. done
[head-armv6-default-job-11] `-- Extracting xdg-utils-1.1.1: .......... done
[head-armv6-default-job-11] Extracting qt5-gui-5.6.1: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Gui.so - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/qt5/bin/qmake - not found
===>   Installing existing package /packages/All/qt5-qmake-5.6.1.txz
[head-armv6-default-job-11] Installing qt5-qmake-5.6.1...
[head-armv6-default-job-11] Extracting qt5-qmake-5.6.1: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/qt5/bin/qmake - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Widgets.so - not found
===>   Installing existing package /packages/All/qt5-widgets-5.6.1.txz
[head-armv6-default-job-11] Installing qt5-widgets-5.6.1...
[head-armv6-default-job-11] Extracting qt5-widgets-5.6.1: .......... done
===>   libdbusmenu-qt5-0.9.3.160420160218_1 depends on file: 
/usr/local/lib/libQt5Widgets.so - found
===>   Returning to build of libdbusmenu-qt5-0.9.3.160420160218_1
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for libdbusmenu-qt5-0.9.3.160420160218_1
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/devel/libdbusmenu-qt5/work/.build
-- The C compiler identification is Clang 3.8.0
-- The CXX compiler identification is Clang 3.8.0
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_af235/fast"
-- Detecting CXX compiler ABI info - failed
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Performing Test __DBUSMENU_HAVE_GCC_VISIBILITY
-- Performing Test __DBUSMENU_HAVE_GCC_VISIBILITY - Success
-- Performing Test __DBUSMENU_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __DBUSMENU_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __DBUSMENU_HAVE_CXX11
-- Performing Test __DBUSMENU_HAVE_CXX11 - Success
-- Performing Test __DBUSMENU_HAVE_W_ALL
-- Performing Test __DBUSMENU_HAVE_W_ALL - Success
-- Performing Test HAVE_QICON_NAME
-- Performing Test HAVE_QICON_NAME - Success
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work/.build/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/devel/libdbusmenu-qt5/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/libdbusmenu-qt5
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to