You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sunp...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2016Q4/math/p5-Math-GSL/Makefile 412348 
2016-04-01 14:16:16Z mat $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/423819/logs/p5-Math-GSL-0.36.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-quarterly&build=423819
Log:

====>> Building math/p5-Math-GSL
build started at Thu Oct 13 11:00:53 UTC 2016
port directory: /usr/ports/math/p5-Math-GSL
building for: FreeBSD 110arm64-quarterly-job-19 11.0-RELEASE-p1 FreeBSD 
11.0-RELEASE-p1 r306420 arm64
maintained by: sunp...@freebsd.org
Makefile ident:      $FreeBSD: branches/2016Q4/math/p5-Math-GSL/Makefile 412348 
2016-04-01 14:16:16Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RELEASE-p1 r306420
UNAME_r=11.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=p5-Math-GSL-0.36
OSREL=11.0
_OSRELEASE=11.0-RELEASE-p1
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-quarterly/ref/.p/pool
MASTERNAME=110arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--install_path lib="/usr/local/lib/perl5/site_perl"  --install_path 
arch="/usr/local/lib/perl5/site_perl/mach/5.20"  --install_path 
script="/usr/local/bin"  --install_path bin="/usr/local/bin"  --install_path 
libdoc="/usr/local/lib/perl5/site_perl/man/man3"  --install_path 
bindoc="/usr/local/lib/perl5/site_perl/man/man1" --destdir 
/wrkdirs/usr/ports/math/p5-Math-GSL/work/stage --create_packlist 1 CC="cc" 
CCFLAGS="-O2 -pipe  -fno-strict-aliasing" PREFIX="/usr/local"  
INSTALLPRIVLIB="/usr/local/lib" INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work  
HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh PERL_EXTUTILS_AUTOINSTALL="--skipdeps" 
PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work  
HOME=/wrkdirs/usr/ports/math/p5-Math-GSL/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/Math-GSL"
EXAMPLESDIR="share/examples/Math-GSL"
DATADIR="share/Math-GSL"
WWWDIR="www/Math-GSL"
ETCDIR="etc/Math-GSL"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/Math-GSL
DOCSDIR=/usr/local/share/doc/Math-GSL
EXAMPLESDIR=/usr/local/share/examples/Math-GSL
WWWDIR=/usr/local/www/Math-GSL
ETCDIR=/usr/local/etc/Math-GSL
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License ART10 GPLv1 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Math-GSL-0.36 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[110arm64-quarterly-job-19] Installing pkg-1.8.7_3...
[110arm64-quarterly-job-19] Extracting pkg-1.8.7_3: .......... done
===>   p5-Math-GSL-0.36 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of p5-Math-GSL-0.36
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Math-GSL-0.36 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Math-GSL-0.36 for building
=> SHA256 Checksum OK for Math-GSL-0.36.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Math-GSL-0.36 for building
===>  Extracting for p5-Math-GSL-0.36
=> SHA256 Checksum OK for Math-GSL-0.36.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Math-GSL-0.36
===>  Applying FreeBSD patches for p5-Math-GSL-0.36
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Math-GSL-0.36 depends on package: p5-PkgConfig>=0.07720 - not found
===>   Installing existing package /packages/All/p5-PkgConfig-0.12026.txz
[110arm64-quarterly-job-19] Installing p5-PkgConfig-0.12026...
[110arm64-quarterly-job-19] `-- Installing perl5-5.20.3_15...
[110arm64-quarterly-job-19] `-- Extracting perl5-5.20.3_15: .......... done
[110arm64-quarterly-job-19] Extracting p5-PkgConfig-0.12026: .......... done
Message from perl5-5.20.3_15:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   p5-Math-GSL-0.36 depends on package: p5-PkgConfig>=0.07720 - found
===>   Returning to build of p5-Math-GSL-0.36
===>   p5-Math-GSL-0.36 depends on package: p5-Module-Build>=0.4206 - not found
===>   Installing existing package /packages/All/p5-Module-Build-0.4220.txz
[110arm64-quarterly-job-19] Installing p5-Module-Build-0.4220...
[110arm64-quarterly-job-19] `-- Installing p5-CPAN-Meta-2.150005...
[110arm64-quarterly-job-19] `-- Extracting p5-CPAN-Meta-2.150005: .......... 
done
[110arm64-quarterly-job-19] Extracting p5-Module-Build-0.4220: .......... done
===>   p5-Math-GSL-0.36 depends on package: p5-Module-Build>=0.4206 - found
===>   Returning to build of p5-Math-GSL-0.36
===>   p5-Math-GSL-0.36 depends on package: perl5>=5.20<5.21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   p5-Math-GSL-0.36 depends on shared library: libgsl.so - not found
===>   Installing existing package /packages/All/gsl-1.16_2.txz
[110arm64-quarterly-job-19] Installing gsl-1.16_2...
[110arm64-quarterly-job-19] `-- Installing indexinfo-0.2.5...
[110arm64-quarterly-job-19] `-- Extracting indexinfo-0.2.5: .... done
[110arm64-quarterly-job-19] Extracting gsl-1.16_2: .......... done
Message from gsl-1.16_2:
===>   NOTICE:

The gsl port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   p5-Math-GSL-0.36 depends on shared library: libgsl.so - found 
(/usr/local/lib/libgsl.so)
===>   Returning to build of p5-Math-GSL-0.36
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Math-GSL-0.36

Checking for GSL using gsl-config
Found GSL 1.16 (via gsl-config) installed in /usr/local, 
CFLAGS=-I/usr/local/include, -L/usr/local/lib -lgsl -lgslcblas -lm
Checking if cc supports "-Wall"...yes
Checking if cc supports "-Wno-unused-function"...yes
Checking if cc supports "-Wno-unused-value"...yes
Checking if cc supports "-Wno-unused-function"...yes
Checking if cc supports "-Wno-unused-variable"...yes
Checking if cc supports "-Wno-gnu"...yes
Checking if cc supports "-g"...yes

Configured with flags...
  linker: -shared -L/usr/local/lib -lgsl -lgslcblas -lm
  compiler: -I/usr/local/include -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H 
-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -Wall 
-Wno-unused-function -Wno-unused-value -Wno-unused-function 
-Wno-unused-variable -Wno-gnu -g 

Checking prerequisites...
  build_requires:
    !  Test::Class is not installed
    !  Test::Exception is not installed
    !  Test::Most is not installed
    !  Test::Taint is not installed

ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation

Run 'Build installdeps' to install missing prerequisites.

Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Math-GSL' version '0.36'
Have a great day!
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-Math-GSL-0.36
Building Math-GSL
Process XS files version 1.16 (GSL version 1.16)
In file included from xs/BLAS_wrap.1.16.c:720:
In file included from /usr/local/lib/perl5/5.20/mach/CORE/perl.h:5199:
/usr/local/lib/perl5/5.20/mach/CORE/inline.h:311:9: warning: nonnull parameter 
'pv' will evaluate to 'true' on first encounter [-Wpointer-bool-conversion]
    if (pv && len > 1) {
        ^~ ~~
xs/BLAS_wrap.1.16.c:3819:11: warning: variable 'arg2' is uninitialized when 
used here [-Wuninitialized]
      if (arg2) free(arg2);
          ^~~~
xs/BLAS_wrap.1.16.c:3739:17: note: initialize the variable 'arg2' to silence 
this warning
    double *arg2 ;
                ^
                 = NULL
xs/BLAS_wrap.1.16.c:3816:11: warning: variable 'arg1' is uninitialized when 
used here [-Wuninitialized]
      if (arg1) free(arg1);
          ^~~~
xs/BLAS_wrap.1.16.c:3738:17: note: initialize the variable 'arg1' to silence 
this warning
    double *arg1 ;
                ^
                 = NULL
xs/BLAS_wrap.1.16.c:4010:11: warning: variable 'arg3' is uninitialized when 
used here [-Wuninitialized]
      if (arg3) free(arg3);
          ^~~~
xs/BLAS_wrap.1.16.c:3958:17: note: initialize the variable 'arg3' to silence 
this warning
    double *arg3 ;
                ^
                 = NULL
4 warnings generated.
/usr/bin/ld: xs/BLAS_wrap.1.16.o: relocation R_AARCH64_ADR_PREL_PG_HI21 against 
external symbol `PL_thr_key' can not be used when making a shared object; 
recompile with -fPIC
/usr/bin/ld: xs/BLAS_wrap.1.16.o(.text+0x15c): unresolvable 
R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `PL_thr_key'
/usr/bin/ld: final link failed: Bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
error building blib/arch/auto/Math/GSL/BLAS/BLAS.so file from 
'xs/BLAS_wrap.1.16.o' at inc/GSLBuilder.pm line 276.
*** Error code 2

Stop.
make: stopped in /usr/ports/math/p5-Math-GSL
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to