You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     z...@freebsd.org
Last committer: z...@freebsd.org
Ident:          $FreeBSD: head/security/snort/Makefile 417339 2016-06-23 
01:56:42Z zi $
Log URL:        
http://beefy7.nyi.freebsd.org/data/head-mips-default/p423899_s307159/logs/snort-2.9.8.3.log
Build URL:      
http://beefy7.nyi.freebsd.org/build.html?mastername=head-mips-default&build=p423899_s307159
Log:

====>> Building security/snort
build started at Sun Oct 16 03:45:37 UTC 2016
port directory: /usr/ports/security/snort
building for: FreeBSD head-mips-default-job-08 12.0-CURRENT FreeBSD 
12.0-CURRENT r307159 mips
maintained by: z...@freebsd.org
Makefile ident:      $FreeBSD: head/security/snort/Makefile 417339 2016-06-23 
01:56:42Z zi $
Poudriere version: 3.1.14
Host OSVERSION: 1200005
Jail OSVERSION: 1200013




!!! Jail is newer than host. (Jail: 1200013, Host: 1200005) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 12.0-CURRENT r307159
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=mips
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-mips-default/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=snort-2.9.8.3
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-mips-default/ref/.p/pool
MASTERNAME=head-mips-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200013
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for snort-2.9.8.3:
     APPID=off: Build with application id support (EXPERIMENTAL)
     DOCS=on: Build and/or install documentation
     FILEINSPECT=off: Build with extended file inspection features 
(EXPERIMENTAL)
     GRE=on: GRE support
     HA=off: Enable high-availability state sharing (EXPERIMENTAL)
     IPV6=on: IPv6 in snort.conf
     LRGPCAP=off: Pcaps larger than 2GB
     NONETHER=off: Non-Ethernet Decoders
     NORMALIZER=on: Normalizer
     PERFPROFILE=on: Performance profiling
     SOURCEFIRE=on: Sourcefire recommended build options
====> Depend on 3rd party addons
     BARNYARD=on: Depend on barnyard2 (supports also snortsam)
     PULLEDPORK=on: Depend on pulledpork
====> Developer options
     DBGSNORT=off: Enable debugging symbols+core dumps
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-open-appid --disable-file-inspect --enable-gre --disable-ha 
--disable-large-pcap --disable-non-ether-decoders --enable-normalizer 
--enable-perfprofiling --enable-ppm --enable-sourcefire --disable-corefiles 
--disable-debug --enable-reload  --enable-mpls --enable-targetbased  
--enable-reload-error-restart --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/security/snort/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/snort/work  
HOME=/wrkdirs/usr/ports/security/snort/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/security/snort/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/snort/work  
HOME=/wrkdirs/usr/ports/security/snort/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0  -fstack-protector 
-fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" 
LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 -fstack-protector 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
APPID="@comment
"
NO_APPID=""
DOCS=""
NO_DOCS="@comment
"
FILEINSPECT="@comment
"
NO_FILEINSPECT=""
GRE=""
NO_GRE="@comment
"
HA="@comment
"
NO_HA=""
IPV6=""
NO_IPV6="@comment
"
LRGPCAP="@comment
"
NO_LRGPCAP=""
NONETHER="@comment
"
NO_NONETHER=""
NORMALIZER=""
NO_NORMALIZER="@comment
"
PERFPROFILE=""
NO_PERFPROFILE="@comment
"
SOURCEFIRE=""
NO_SOURCEFIRE="@comment
"
BARNYARD=""
NO_BARNYARD="@comment
"
PULLEDPORK=""
NO_PULLEDPORK="@comment
"
DBGSNORT="@comment
"
NO_DBGSNORT=""
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/snort"
EXAMPLESDIR="share/examples/snort"
DATADIR="share/snort"
WWWDIR="www/snort"
ETCDIR="etc/snort"
--End PLIST_SUB--

--SUB_LIST--
APPID="@comment
"
NO_APPID=""
DOCS=""
NO_DOCS="@comment
"
FILEINSPECT="@comment
"
NO_FILEINSPECT=""
GRE=""
NO_GRE="@comment
"
HA="@comment
"
NO_HA=""
IPV6=""
NO_IPV6="@comment
"
LRGPCAP="@comment
"
NO_LRGPCAP=""
NONETHER="@comment
"
NO_NONETHER=""
NORMALIZER=""
NO_NORMALIZER="@comment
"
PERFPROFILE=""
NO_PERFPROFILE="@comment
"
SOURCEFIRE=""
NO_SOURCEFIRE="@comment
"
BARNYARD=""
NO_BARNYARD="@comment
"
PULLEDPORK=""
NO_PULLEDPORK="@comment
"
DBGSNORT="@comment
"
NO_DBGSNORT=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/snort
DOCSDIR=/usr/local/share/doc/snort
EXAMPLESDIR=/usr/local/share/examples/snort
WWWDIR=/usr/local/www/snort
ETCDIR=/usr/local/etc/snort
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=mips
MACHINE_ARCH=mips
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   snort-2.9.8.3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[head-mips-default-job-08] Installing pkg-1.8.7_3...
[head-mips-default-job-08] Extracting pkg-1.8.7_3: .......... done
===>   snort-2.9.8.3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of snort-2.9.8.3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by snort-2.9.8.3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by snort-2.9.8.3 for building
=> SHA256 Checksum OK for snort-2.9.8.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by snort-2.9.8.3 for building
===>  Extracting for snort-2.9.8.3
=> SHA256 Checksum OK for snort-2.9.8.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for snort-2.9.8.3
===>  Applying FreeBSD patches for snort-2.9.8.3
===========================================================================
=======================<phase: build-depends  >============================
===>   snort-2.9.8.3 depends on package: daq>=2.0.0 - not found
===>   Installing existing package /packages/All/daq-2.0.6_1.txz
[head-mips-default-job-08] Installing daq-2.0.6_1...
[head-mips-default-job-08] `-- Installing libdnet-1.12_1...
[head-mips-default-job-08] `-- Extracting libdnet-1.12_1: .......... done
[head-mips-default-job-08] `-- Installing libpcap-1.8.0_1...
[head-mips-default-job-08] `-- Extracting libpcap-1.8.0_1: .......... done
[head-mips-default-job-08] Extracting daq-2.0.6_1: .......... done
===>   snort-2.9.8.3 depends on package: daq>=2.0.0 - found
===>   Returning to build of snort-2.9.8.3
===========================================================================
=======================<phase: lib-depends    >============================
===>   snort-2.9.8.3 depends on shared library: libpcre.so - not found
===>   Installing existing package /packages/All/pcre-8.39.txz
[head-mips-default-job-08] Installing pcre-8.39...
[head-mips-default-job-08] Extracting pcre-8.39: .......... done
===>   snort-2.9.8.3 depends on shared library: libpcre.so - found 
(/usr/local/lib/libpcre.so)
===>   Returning to build of snort-2.9.8.3
===>   snort-2.9.8.3 depends on shared library: libdnet.so - found 
(/usr/local/lib/libdnet.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for snort-2.9.8.3
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for style of include used by make... GNU
checking for gcc... /nxb-bin/usr/bin/cc
checking whether the C compiler works... no
configure: error: in `/wrkdirs/usr/ports/security/snort/work/snort-2.9.8.3':
configure: error: C compiler cannot create executables
See `config.log' for more details
===>  Script "configure" failed unexpectedly.
Please report the problem to z...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/security/snort/work/snort-2.9.8.3/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/security/snort
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to