You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: amd...@freebsd.org
Ident:          $FreeBSD: branches/2016Q4/databases/py-sqlrelay/Makefile 382093 
2015-03-24 13:30:42Z amdmi3 $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/110arm64-quarterly/423994/logs/py27-sqlrelay-0.65.0_2.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=110arm64-quarterly&build=423994
Log:

====>> Building databases/py-sqlrelay
build started at Tue Oct 18 05:32:11 UTC 2016
port directory: /usr/ports/databases/py-sqlrelay
building for: FreeBSD 110arm64-quarterly-job-08 11.0-RELEASE-p1 FreeBSD 
11.0-RELEASE-p1 r306420 arm64
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: branches/2016Q4/databases/py-sqlrelay/Makefile 
382093 2015-03-24 13:30:42Z amdmi3 $
Poudriere version: 3.1.14
Host OSVERSION: 1100121
Jail OSVERSION: 1100122




!!! Jail is newer than host. (Jail: 1100122, Host: 1100121) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 11.0-RELEASE-p1 r306420
UNAME_r=11.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=aarch64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110arm64-quarterly/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=py27-sqlrelay-0.65.0_2
OSREL=11.0
_OSRELEASE=11.0-RELEASE-p1
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=48
PWD=/usr/local/poudriere/data/.m/110arm64-quarterly/ref/.p/pool
MASTERNAME=110arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--localstatedir=/var  --with-rudiments-prefix="/usr/local"  
--with-python-prefix="/usr/local" --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work  
HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work  
HOME=/wrkdirs/usr/ports/databases/py-sqlrelay/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/sqlrelay"
EXAMPLESDIR="share/examples/sqlrelay"
DATADIR="share/sqlrelay"
WWWDIR="www/sqlrelay"
ETCDIR="etc/sqlrelay"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/sqlrelay
DOCSDIR=/usr/local/share/doc/sqlrelay
EXAMPLESDIR=/usr/local/share/examples/sqlrelay
WWWDIR=/usr/local/www/sqlrelay
ETCDIR=/usr/local/etc/sqlrelay
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>   NOTICE:

The sqlrelay port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-sqlrelay-0.65.0_2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.8.7_3.txz
[110arm64-quarterly-job-08] Installing pkg-1.8.7_3...
[110arm64-quarterly-job-08] Extracting pkg-1.8.7_3: .......... done
===>   py27-sqlrelay-0.65.0_2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py27-sqlrelay-0.65.0_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

The sqlrelay port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===> Fetching all distfiles required by py27-sqlrelay-0.65.0_2 for building
===>  License LGPL20 accepted by the user
===> Fetching all distfiles required by sqlrelay-0.65.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>   NOTICE:

The sqlrelay port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===> Fetching all distfiles required by py27-sqlrelay-0.65.0_2 for building
===>  License LGPL20 accepted by the user
===> Fetching all distfiles required by sqlrelay-0.65.0 for building
===========================================================================
=======================<phase: extract-depends>============================
===>  License LGPL20 accepted by the user
===>   sqlrelay-0.65.0 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by sqlrelay-0.65.0 for building
===>  Extracting for sqlrelay-0.65.0
=> SHA256 Checksum OK for sqlrelay-0.65.0.tar.gz.
===>  Patching for sqlrelay-0.65.0
===>  Applying FreeBSD patches for sqlrelay-0.65.0
/usr/bin/sed -i.bak -E  -e 's,\$\(initroot\),\$\(initroot\)/usr/local,g'  -e 
's,/etc/rc.conf,/etc/defaults/rc.conf,g'  
/wrkdirs/usr/ports/databases/sqlrelay/work/sqlrelay-0.65.0/init/Makefile
/usr/bin/find /wrkdirs/usr/ports/databases/sqlrelay/work/sqlrelay-0.65.0 -name 
Makefile | /usr/bin/xargs /usr/bin/sed -i.bak -E  -e 's#-release 
\$\(SQLR_VERSION\)##g;'
===>   Returning to build of py27-sqlrelay-0.65.0_2
===========================================================================
=======================<phase: extract        >============================
===>   NOTICE:

The sqlrelay port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===> Fetching all distfiles required by py27-sqlrelay-0.65.0_2 for building
===>  License LGPL20 accepted by the user
===> Fetching all distfiles required by sqlrelay-0.65.0 for building
===>  Extracting for py27-sqlrelay-0.65.0_2
/bin/mkdir -p /wrkdirs/usr/ports/databases/py-sqlrelay/work
/bin/ln -fs `cd /usr/ports/databases/sqlrelay && /usr/bin/make -V WRKSRC` 
/wrkdirs/usr/ports/databases/py-sqlrelay/work/sqlrelay
===========================================================================
=======================<phase: patch-depends  >============================
===>   py27-sqlrelay-0.65.0_2 depends on package: perl5>=5.20<5.21 - not found
===>   Installing existing package /packages/All/perl5-5.20.3_15.txz
[110arm64-quarterly-job-08] Installing perl5-5.20.3_15...
[110arm64-quarterly-job-08] Extracting perl5-5.20.3_15: .......... done
Message from perl5-5.20.3_15:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   py27-sqlrelay-0.65.0_2 depends on package: perl5>=5.20<5.21 - found
===>   Returning to build of py27-sqlrelay-0.65.0_2
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-sqlrelay-0.65.0_2
/usr/local/bin/perl -i -p  -e 's,"2\.4" "2\.3" "2\.2" "2\.1",2.7,g;'  
/wrkdirs/usr/ports/databases/py-sqlrelay/work/sqlrelay/configure
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-sqlrelay-0.65.0_2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[110arm64-quarterly-job-08] Installing gmake-4.2.1_1...
[110arm64-quarterly-job-08] `-- Installing indexinfo-0.2.5...
[110arm64-quarterly-job-08] `-- Extracting indexinfo-0.2.5: .... done
[110arm64-quarterly-job-08] `-- Installing gettext-runtime-0.19.8.1...
[110arm64-quarterly-job-08] `-- Extracting gettext-runtime-0.19.8.1: .......... 
done
[110arm64-quarterly-job-08] Extracting gmake-4.2.1_1: .......... done
===>   py27-sqlrelay-0.65.0_2 depends on executable: gmake - found
===>   Returning to build of py27-sqlrelay-0.65.0_2
===>   py27-sqlrelay-0.65.0_2 depends on file: /usr/local/bin/python2.7 - not 
found
===>   Installing existing package /packages/All/python27-2.7.12.txz
[110arm64-quarterly-job-08] Installing python27-2.7.12...
[110arm64-quarterly-job-08] `-- Installing libffi-3.2.1...
[110arm64-quarterly-job-08] `-- Extracting libffi-3.2.1: .......... done
[110arm64-quarterly-job-08] `-- Installing readline-6.3.8...
[110arm64-quarterly-job-08] `-- Extracting readline-6.3.8: .......... done
[110arm64-quarterly-job-08] Extracting python27-2.7.12: .......... done
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   py27-sqlrelay-0.65.0_2 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of py27-sqlrelay-0.65.0_2
===>   py27-sqlrelay-0.65.0_2 depends on package: perl5>=5.20<5.21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-sqlrelay-0.65.0_2 depends on shared library: libsqlrclient.so - not 
found
===>   Installing existing package /packages/All/sqlrelay-0.65.0.txz
[110arm64-quarterly-job-08] Installing sqlrelay-0.65.0...
[110arm64-quarterly-job-08] `-- Installing rudiments-0.55.0...
[110arm64-quarterly-job-08] `-- Extracting rudiments-0.55.0: .......... done
[110arm64-quarterly-job-08] Extracting sqlrelay-0.65.0: .......... done
===>   py27-sqlrelay-0.65.0_2 depends on shared library: libsqlrclient.so - 
found (/usr/local/lib/libsqlrclient.so)
===>   Returning to build of py27-sqlrelay-0.65.0_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-sqlrelay-0.65.0_2
configure: loading site script /usr/ports/Templates/config.site

***** Programs ***************
checking for GNU Make... yes
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking how to run the C preprocessor... cpp
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets $(MAKE)... yes
******************************

***** Libtool ****************
checking build system type... Invalid configuration 
`aarch64-portbld-freebsd11.0': machine `aarch64-portbld' not recognized
configure: error: /bin/sh ./config.sub aarch64-portbld-freebsd11.0 failed
===>  Script "configure" failed unexpectedly.
Please report the problem to po...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/databases/py-sqlrelay/work/sqlrelay/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/py-sqlrelay
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to