You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     k...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/devel/py-qt4-dbussupport/Makefile 412346 
2016-04-01 14:00:51Z mat $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p427466_s309339/logs/py27-qt4-dbussupport-4.11.4_1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p427466_s309339
Log:

====>> Building devel/py-qt4-dbussupport
build started at Thu Dec  1 08:05:27 UTC 2016
port directory: /usr/ports/devel/py-qt4-dbussupport
building for: FreeBSD head-armv6-default-job-02 12.0-CURRENT FreeBSD 
12.0-CURRENT r309339 arm
maintained by: k...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/py-qt4-dbussupport/Makefile 412346 
2016-04-01 14:00:51Z mat $
Poudriere version: 3.1.14
Host OSVERSION: 1200010
Jail OSVERSION: 1200017
Job Id: 02




!!! Jail is newer than host. (Jail: 1200017, Host: 1200010) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 12.0-CURRENT r309339
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=armv6
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=py27-qt4-dbussupport-4.11.4_1
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200017
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
py27-qt4-dbussupport-4.11.4_1:
     DEBUG=off: Build with debugging support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--enable QtCore -b /usr/local/bin  -d /usr/local/lib/python2.7/site-packages  
-q /usr/local/bin/qmake-qt4  --confirm-license  --sipdir 
/usr/local/share/py-sip/PyQt4
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe  -fno-strict-aliasing"  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
QT_PREFIX="/usr/local"
QT_INCDIR="include/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd12
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
PYQT_SIPDIR=share/py-sip/PyQt4
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/dbussupport"
EXAMPLESDIR="share/examples/dbussupport"
DATADIR="share/dbussupport"
WWWDIR="www/dbussupport"
ETCDIR="etc/dbussupport"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/dbussupport
DOCSDIR=/usr/local/share/doc/dbussupport
EXAMPLESDIR=/usr/local/share/examples/dbussupport
WWWDIR=/usr/local/www/dbussupport
ETCDIR=/usr/local/etc/dbussupport
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.9.3.txz
[head-armv6-default-job-02] Installing pkg-1.9.3...
[head-armv6-default-job-02] Extracting pkg-1.9.3: .......... done
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/sbin/pkg - 
found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by py27-qt4-dbussupport-4.11.4_1 for 
building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by py27-qt4-dbussupport-4.11.4_1 for 
building
=> SHA256 Checksum OK for PyQt-x11-gpl-4.11.4.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by py27-qt4-dbussupport-4.11.4_1 for 
building
===>  Extracting for py27-qt4-dbussupport-4.11.4_1
=> SHA256 Checksum OK for PyQt-x11-gpl-4.11.4.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-qt4-dbussupport-4.11.4_1
===>  Applying FreeBSD patches for py27-qt4-dbussupport-4.11.4_1
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: py27-dbus>=0.8 - not 
found
===>   Installing existing package /packages/All/py27-dbus-1.2.0_1.txz
[head-armv6-default-job-02] Installing py27-dbus-1.2.0_1...
[head-armv6-default-job-02] `-- Installing dbus-glib-0.104...
[head-armv6-default-job-02] |   `-- Installing dbus-1.10.12...
[head-armv6-default-job-02] |   | `-- Installing expat-2.2.0...
[head-armv6-default-job-02] |   | `-- Extracting expat-2.2.0: .......... done
[head-armv6-default-job-02] |   | `-- Installing gnome_subr-1.0...
[head-armv6-default-job-02] |   | `-- Extracting gnome_subr-1.0: . done
[head-armv6-default-job-02] |   | `-- Installing libX11-1.6.4,1...
[head-armv6-default-job-02] |   |   `-- Installing xproto-7.0.31...
[head-armv6-default-job-02] |   |   `-- Extracting xproto-7.0.31: .......... 
done
[head-armv6-default-job-02] |   |   `-- Installing kbproto-1.0.7...
[head-armv6-default-job-02] |   |   `-- Extracting kbproto-1.0.7: .......... 
done
[head-armv6-default-job-02] |   |   `-- Installing libXdmcp-1.1.2...
[head-armv6-default-job-02] |   |   `-- Extracting libXdmcp-1.1.2: ......... 
done
[head-armv6-default-job-02] |   |   `-- Installing libxcb-1.12...
[head-armv6-default-job-02] |   |   | `-- Installing libxml2-2.9.4...
[head-armv6-default-job-02] |   |   | `-- Extracting libxml2-2.9.4: .......... 
done
[head-armv6-default-job-02] |   |   | `-- Installing libpthread-stubs-0.3_6...
[head-armv6-default-job-02] |   |   | `-- Extracting libpthread-stubs-0.3_6: 
..... done
[head-armv6-default-job-02] |   |   | `-- Installing libXau-1.0.8_3...
[head-armv6-default-job-02] |   |   | `-- Extracting libXau-1.0.8_3: .......... 
done
[head-armv6-default-job-02] |   |   `-- Extracting libxcb-1.12: .......... done
[head-armv6-default-job-02] |   | `-- Extracting libX11-1.6.4,1: .......... done
[head-armv6-default-job-02] |   | `-- Installing libICE-1.0.9_1,1...
[head-armv6-default-job-02] |   | `-- Extracting libICE-1.0.9_1,1: .......... 
done
[head-armv6-default-job-02] |   | `-- Installing libSM-1.2.2_3,1...
[head-armv6-default-job-02] |   | `-- Extracting libSM-1.2.2_3,1: .......... 
done
===> Creating groups.
Creating group 'messagebus' with gid '556'.
===> Creating users
Creating user 'messagebus' with uid '556'.
[head-armv6-default-job-02] |   `-- Extracting dbus-1.10.12: ......... done
[head-armv6-default-job-02] |   `-- Installing gettext-runtime-0.19.8.1...
[head-armv6-default-job-02] |   | `-- Installing indexinfo-0.2.6...
[head-armv6-default-job-02] |   | `-- Extracting indexinfo-0.2.6: .... done
[head-armv6-default-job-02] |   `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[head-armv6-default-job-02] |   `-- Installing glib-2.46.2_4...
[head-armv6-default-job-02] |   | `-- Installing libiconv-1.14_9...
[head-armv6-default-job-02] |   | `-- Extracting libiconv-1.14_9: .......... 
done
[head-armv6-default-job-02] |   | `-- Installing python27-2.7.12...
[head-armv6-default-job-02] |   |   `-- Installing libffi-3.2.1...
[head-armv6-default-job-02] |   |   `-- Extracting libffi-3.2.1: .......... done
[head-armv6-default-job-02] |   |   `-- Installing readline-6.3.8...
[head-armv6-default-job-02] |   |   `-- Extracting readline-6.3.8: .......... 
done
[head-armv6-default-job-02] |   | `-- Extracting python27-2.7.12: .......... 
done
[head-armv6-default-job-02] |   | `-- Installing pcre-8.39...
[head-armv6-default-job-02] |   | `-- Extracting pcre-8.39: .......... done
[head-armv6-default-job-02] |   | `-- Installing perl5-5.24.1.r4...
[head-armv6-default-job-02] |   | `-- Extracting perl5-5.24.1.r4: .......... 
done
[head-armv6-default-job-02] |   `-- Extracting glib-2.46.2_4: .......... done
No schema files found: doing nothing.
[head-armv6-default-job-02] `-- Extracting dbus-glib-0.104: .......... done
[head-armv6-default-job-02] `-- Installing pydbus-common-1.2.0_1...
[head-armv6-default-job-02] `-- Extracting pydbus-common-1.2.0_1: .......... 
done
[head-armv6-default-job-02] `-- Installing python2-2_3...
[head-armv6-default-job-02] `-- Extracting python2-2_3: ...... done
[head-armv6-default-job-02] Extracting py27-dbus-1.2.0_1: .......... done
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.24.1.r4:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: py27-dbus>=0.8 - found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: pkgconf>=0.9.10 - not 
found
===>   Installing existing package /packages/All/pkgconf-1.0.2.txz
[head-armv6-default-job-02] Installing pkgconf-1.0.2...
[head-armv6-default-job-02] Extracting pkgconf-1.0.2: .......... done
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/bin/python2.7 
- found
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: py27-sip>=4.18 - not 
found
===>   Installing existing package /packages/All/py27-sip-4.18,1.txz
[head-armv6-default-job-02] Installing py27-sip-4.18,1...
[head-armv6-default-job-02] Extracting py27-sip-4.18,1: .......... done
===>   py27-qt4-dbussupport-4.11.4_1 depends on package: py27-sip>=4.18 - found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/bin/moc-qt4 - 
not found
===>   Installing existing package /packages/All/qt4-moc-4.8.7_1.txz
[head-armv6-default-job-02] Installing qt4-moc-4.8.7_1...
[head-armv6-default-job-02] Extracting qt4-moc-4.8.7_1: .... done
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/bin/moc-qt4 - 
found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/bin/qmake-qt4 
- not found
===>   Installing existing package /packages/All/qt4-qmake-4.8.7.txz
[head-armv6-default-job-02] Installing qt4-qmake-4.8.7...
[head-armv6-default-job-02] Extracting qt4-qmake-4.8.7: .......... done
===>   py27-qt4-dbussupport-4.11.4_1 depends on file: /usr/local/bin/qmake-qt4 
- found
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-qt4-dbussupport-4.11.4_1 depends on shared library: libQtCore.so - 
not found
===>   Installing existing package /packages/All/qt4-corelib-4.8.7_6.txz
[head-armv6-default-job-02] Installing qt4-corelib-4.8.7_6...
[head-armv6-default-job-02] `-- Installing icu-58.1,1...
[head-armv6-default-job-02] `-- Extracting icu-58.1,1: .......... done
[head-armv6-default-job-02] Extracting qt4-corelib-4.8.7_6: .......... done
Message from qt4-corelib-4.8.7_6:
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
===>   py27-qt4-dbussupport-4.11.4_1 depends on shared library: libQtCore.so - 
found (/usr/local/lib/qt4/libQtCore.so)
===>   Returning to build of py27-qt4-dbussupport-4.11.4_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-qt4-dbussupport-4.11.4_1
cd /wrkdirs/usr/ports/devel/py-qt4-dbussupport/work/PyQt-x11-gpl-4.11.4 && 
/usr/bin/env PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work  
HOME=/wrkdirs/usr/ports/devel/py-qt4-dbussupport/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh  /usr/local/bin/python2.7 configure.py 
--enable QtCore -b /usr/local/bin  -d /usr/local/lib/python2.7/site-packages  
-q /usr/local/bin/qmake-qt4  --confirm-license  --sipdir 
/usr/local/share/py-sip/PyQt4
Error: ./qtdirs failed to create qtdirs.out. Make sure your Qt installation is
correct.
Determining the layout of your Qt installation...
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-qt4-dbussupport
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to