You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sh...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: head/emulators/x49gp/Makefile 426566 2016-11-20 
09:38:08Z gerald $
Log URL:        
http://beefy5.nyi.freebsd.org/data/101i386-default/427466/logs/x49gp-20100425_1.log
Build URL:      
http://beefy5.nyi.freebsd.org/build.html?mastername=101i386-default&build=427466
Log:

====>> Building emulators/x49gp
build started at Thu Dec  1 16:27:22 UTC 2016
port directory: /usr/ports/emulators/x49gp
building for: FreeBSD 101i386-default-job-05 10.1-RELEASE-p42 FreeBSD 
10.1-RELEASE-p42 i386
maintained by: sh...@freebsd.org
Makefile ident:      $FreeBSD: head/emulators/x49gp/Makefile 426566 2016-11-20 
09:38:08Z gerald $
Poudriere version: 3.1.14
Host OSVERSION: 1200010
Jail OSVERSION: 1001000
Job Id: 05

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 10.1-RELEASE-p42
UNAME_r=10.1-RELEASE-p42
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/101i386-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=x49gp-20100425_1
OSREL=10.1
_OSRELEASE=10.1-RELEASE-p42
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/101i386-default/ref/.p/pool
MASTERNAME=101i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1001000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for x49gp-20100425_1:
     GRAYSCALE=on: Apply patch for grayscale support
====> Options available for the single FIRMWARE: you have to select exactly one 
of them
     FIRMWARE_215=on: Calculator ROM firmware version 2.15
     FIRMWARE_209=off: Calculator ROM firmware version 2.09
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/x49gp/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/x49gp/work  
HOME=/wrkdirs/usr/ports/emulators/x49gp/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/x49gp/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/x49gp/work  
HOME=/wrkdirs/usr/ports/emulators/x49gp/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc49" CFLAGS="-O2 -pipe  
-fstack-protector -Wl,-rpath=/usr/local/lib/gcc49 -fno-strict-aliasing"  
CPP="cpp49" CPPFLAGS=""  LDFLAGS=" -fstack-protector 
-Wl,-rpath=/usr/local/lib/gcc49 -L/usr/local/lib/gcc49" LIBS=""  CXX="g++49" 
CXXFLAGS="-O2 -pipe -fstack-protector -Wl,-rpath=/usr/local/lib/g
 cc49 -fno-strict-aliasing  -Wl,-rpath=/usr/local/lib/gcc49"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
OSREL=10.1
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/x49gp"
EXAMPLESDIR="share/examples/x49gp"
DATADIR="share/x49gp"
WWWDIR="www/x49gp"
ETCDIR="etc/x49gp"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/x49gp
DOCSDIR=/usr/local/share/doc/x49gp
EXAMPLESDIR=/usr/local/share/examples/x49gp
WWWDIR=/usr/local/www/x49gp
ETCDIR=/usr/local/etc/x49gp
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   x49gp-20100425_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.9.3.txz
[101i386-default-job-05] Installing pkg-1.9.3...
[101i386-default-job-05] Extracting pkg-1.9.3: .......... done
===>   x49gp-20100425_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of x49gp-20100425_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by x49gp-20100425_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by x49gp-20100425_1 for building
=> SHA256 Checksum OK for x49gp-20100425.tar.gz.
=> SHA256 Checksum OK for sdcard64.tar.gz.
=> SHA256 Checksum OK for hp4950v215.zip.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by x49gp-20100425_1 for building
===>  Extracting for x49gp-20100425_1
=> SHA256 Checksum OK for x49gp-20100425.tar.gz.
=> SHA256 Checksum OK for sdcard64.tar.gz.
=> SHA256 Checksum OK for hp4950v215.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for x49gp-20100425_1
===>  Applying extra patch /usr/ports/emulators/x49gp/files/grayscale.diff
===>  Applying FreeBSD patches for x49gp-20100425_1
===========================================================================
=======================<phase: build-depends  >============================
===>   x49gp-20100425_1 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[101i386-default-job-05] Installing gmake-4.2.1_1...
[101i386-default-job-05] `-- Installing indexinfo-0.2.6...
[101i386-default-job-05] `-- Extracting indexinfo-0.2.6: .... done
[101i386-default-job-05] `-- Installing gettext-runtime-0.19.8.1...
[101i386-default-job-05] `-- Extracting gettext-runtime-0.19.8.1: .......... 
done
[101i386-default-job-05] Extracting gmake-4.2.1_1: .......... done
===>   x49gp-20100425_1 depends on executable: gmake - found
===>   Returning to build of x49gp-20100425_1
===>   x49gp-20100425_1 depends on package: pkgconf>=0.9.10 - not found
===>   Installing existing package /packages/All/pkgconf-1.0.2.txz
[101i386-default-job-05] Installing pkgconf-1.0.2...
[101i386-default-job-05] Extracting pkgconf-1.0.2: .......... done
===>   x49gp-20100425_1 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of x49gp-20100425_1
===>   x49gp-20100425_1 depends on executable: gcc49 - not found
===>   Installing existing package /packages/All/gcc-4.9.4.txz
[101i386-default-job-05] Installing gcc-4.9.4...
[101i386-default-job-05] `-- Installing mpc-1.0.3...
[101i386-default-job-05] |   `-- Installing gmp-5.1.3_3...
[101i386-default-job-05] |   `-- Extracting gmp-5.1.3_3: .......... done
[101i386-default-job-05] |   `-- Installing mpfr-3.1.5...
[101i386-default-job-05] |   `-- Extracting mpfr-3.1.5: .......... done
[101i386-default-job-05] `-- Extracting mpc-1.0.3: ...... done
[101i386-default-job-05] `-- Installing binutils-2.27_5,1...
[101i386-default-job-05] `-- Extracting binutils-2.27_5,1: .......... done
[101i386-default-job-05] `-- Installing gcc-ecj-4.5...
[101i386-default-job-05] `-- Extracting gcc-ecj-4.5: . done
[101i386-default-job-05] Extracting gcc-4.9.4: .......... done
Message from gcc-4.9.4:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc49

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   x49gp-20100425_1 depends on executable: gcc49 - found
===>   Returning to build of x49gp-20100425_1
===>   x49gp-20100425_1 depends on file: /usr/local/bin/as - found
===>   x49gp-20100425_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - 
not found
===>   Installing existing package /packages/All/libX11-1.6.4,1.txz
[101i386-default-job-05] Installing libX11-1.6.4,1...
[101i386-default-job-05] `-- Installing xproto-7.0.31...
<snip>
Creating user 'messagebus' with uid '556'.
[101i386-default-job-05] |   |   `-- Extracting dbus-1.10.12: ......... done
[101i386-default-job-05] |   | `-- Extracting dbus-glib-0.104: .......... done
===> Creating groups.
Creating group 'avahi' with gid '558'.
===> Creating users
Creating user 'avahi' with uid '558'.
[101i386-default-job-05] |   `-- Extracting avahi-app-0.6.31_5: .......... done
[101i386-default-job-05] |   `-- Installing gnutls-3.4.16...
[101i386-default-job-05] |   | `-- Installing nettle-3.2...
[101i386-default-job-05] |   | `-- Extracting nettle-3.2: .......... done
[101i386-default-job-05] |   | `-- Installing ca_root_nss-3.27.1...
[101i386-default-job-05] |   | `-- Extracting ca_root_nss-3.27.1: ........ done
[101i386-default-job-05] |   | `-- Installing libtasn1-4.9...
[101i386-default-job-05] |   | `-- Extracting libtasn1-4.9: .......... done
[101i386-default-job-05] |   | `-- Installing trousers-0.3.14_1...
[101i386-default-job-05] |   |   `-- Installing tpm-emulator-0.7.4_1...
===> Creating groups.
Creating group '_tss' with gid '601'.
===> Creating users
Creating user '_tss' with uid '601'.
[101i386-default-job-05] |   |   `-- Extracting tpm-emulator-0.7.4_1: ......... 
done
===> Creating groups.
Using existing group '_tss'.
===> Creating users
Using existing user '_tss'.
[101i386-default-job-05] |   | `-- Extracting trousers-0.3.14_1: .......... done
[101i386-default-job-05] |   | `-- Installing p11-kit-0.23.2...
[101i386-default-job-05] |   | `-- Extracting p11-kit-0.23.2: .......... done
[101i386-default-job-05] |   | `-- Installing libidn-1.33_1...
[101i386-default-job-05] |   | `-- Extracting libidn-1.33_1: .......... done
[101i386-default-job-05] |   `-- Extracting gnutls-3.4.16: .......... done
[101i386-default-job-05] |   `-- Installing libpaper-1.1.24.4...
[101i386-default-job-05] |   `-- Extracting libpaper-1.1.24.4: .......... done
===> Creating groups.
Creating group 'cups' with gid '193'.
===> Creating users
Creating user 'cups' with uid '193'.
[101i386-default-job-05] `-- Extracting cups-2.2.1: .......... done
[101i386-default-job-05] Extracting gtk2-2.24.29_3: .......... done
Message from dejavu-2.37:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
Message from jasper-1.900.1_16:
===>   NOTICE:

The jasper port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
Message from ca_root_nss-3.27.1:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
Message from trousers-0.3.14_1:
To run tcsd automatically, add the following line to /etc/rc.conf:

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

If you want to use tcsd with software TPM emulator, use the following
configuration in /etc/rc.conf:

tcsd_enable="YES"
tcsd_mode="emulator"
tpmd_enable="YES"

To use TPM, add your_account to '_tss' group like following:

# pw groupmod _tss -m your_account
===>   x49gp-20100425_1 depends on shared library: libgtk-x11-2.0.so - found 
(/usr/local/lib/libgtk-x11-2.0.so)
===>   Returning to build of x49gp-20100425_1
===>   x49gp-20100425_1 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for x49gp-20100425_1
cd /wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git && 
./configure-small --extra-cflags=-DX49GP --cc="gcc49"
Source path       
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git
C compiler        gcc49
Host C compiler   gcc
CFLAGS            -O2 -g 
QEMU_CFLAGS       -m32 -Wold-style-definition -Wold-style-declaration -I. 
-I$(SRC_PATH) -U_FORTIFY_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -Wstrict-prototypes -Wredundant-decls -Wall -Wundef 
-Wendif-labels -Wwrite-strings -Wmissing-prototypes -fno-strict-aliasing 
-DX49GP 
LDFLAGS           -Wl,--warn-common -m32 -g 
make              gmake
host CPU          i386
host big endian   no
target list       arm-softmmu
tcg debug enabled no
gprof enabled     no
sparse enabled    no
strip binaries    yes
profiler          no
static build      no
-Werror enabled   no
mingw32 support   no
Block whitelist   
preadv support    yes
fdatasync         no
===========================================================================
=======================<phase: build          >============================
===>  Building for x49gp-20100425_1
cd /wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code && /usr/bin/env -u 
MAKELEVEL -u MAKEFLAGS gmake CC="gcc49" FIRMWARE=4950_215.bin 
DESTDIR=/wrkdirs/usr/ports/emulators/x49gp/work/stage
( cd qemu/qemu-git; \
./configure-small --extra-cflags=-DX49GP; \
gmake -f Makefile-small )
Source path       
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git
C compiler        gcc
Host C compiler   gcc
CFLAGS            -O2 -g 
QEMU_CFLAGS       -m32 -Wold-style-definition -Wold-style-declaration -I. 
-I$(SRC_PATH) -U_FORTIFY_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -Wstrict-prototypes -Wredundant-decls -Wall -Wundef 
-Wendif-labels -Wwrite-strings -Wmissing-prototypes -fno-strict-aliasing 
-DX49GP 
LDFLAGS           -Wl,--warn-common -m32 -g 
make              gmake
host CPU          i386
host big endian   no
target list       arm-softmmu
tcg debug enabled no
gprof enabled     no
sparse enabled    no
strip binaries    yes
profiler          no
static build      no
-Werror enabled   no
mingw32 support   no
Block whitelist   
preadv support    yes
fdatasync         no
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git'
  GEN   arm-softmmu/config-devices.mak
  GEN   config-all-devices.mak
  GEN   config-host.h
  CC    cutils.o
  CC    qemu-malloc.o
  CC    tcg-runtime.o
  CC    host-utils.o
  GEN   config-target.h
  CC    arm-softmmu/exec.o
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/exec.c: 
In function 'qemu_ram_addr_from_host':
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/exec.c:2515:16:
 warning: variable 'prevp' set but not used [-Wunused-but-set-variable]
     RAMBlock **prevp;
                ^
  CC    arm-softmmu/translate-all.o
  CC    arm-softmmu/cpu-exec.o
In file included from 
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/target-arm/exec.h:26:0,
                 from 
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/cpu-exec.c:20:
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/cpu-exec.c:
 In function 'cpu_arm_exec':
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/target-arm/cpu.h:409:18:
 error: frame pointer required, but reserved
 #define cpu_exec cpu_arm_exec
                  ^
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/cpu-exec.c:214:5:
 note: in expansion of macro 'cpu_exec'
 int cpu_exec(CPUState *env1)
     ^
In file included from 
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/cpu-exec.c:20:0:
/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/target-arm/exec.h:22:30:
 note: for 'env'
 register struct CPUARMState *env asm(AREG0);
                              ^
gmake[2]: *** 
[/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git/rules.mak:18:
 cpu-exec.o] Error 1
gmake[1]: *** [Makefile-small:69: subdir-arm-softmmu] Error 2
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/emulators/x49gp/work/x49gp/x49gp-code/qemu/qemu-git'
gmake: *** [Makefile:267: qemu/qemu-git/config-host.h] Error 2
*** Error code 2

Stop.
make: stopped in /usr/ports/emulators/x49gp
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to