You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sunp...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: head/lang/v8-devel/Makefile 426566 2016-11-20 
09:38:08Z gerald $
Log URL:        
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p427466_s309339/logs/v8-devel-3.27.7_8.log
Build URL:      
http://beefy12.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p427466_s309339
Log:

====>> Building lang/v8-devel
build started at Thu Dec  1 17:35:33 UTC 2016
port directory: /usr/ports/lang/v8-devel
building for: FreeBSD head-amd64-default-job-16 12.0-CURRENT FreeBSD 
12.0-CURRENT r309339 amd64
maintained by: sunp...@freebsd.org
Makefile ident:      $FreeBSD: head/lang/v8-devel/Makefile 426566 2016-11-20 
09:38:08Z gerald $
Poudriere version: 3.1.14
Host OSVERSION: 1200010
Jail OSVERSION: 1200017
Job Id: 16




!!! Jail is newer than host. (Jail: 1200017, Host: 1200010) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 12.0-CURRENT r309339
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=v8-devel-3.27.7_8
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES OPSYS=FreeBSD
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200017
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/lang/v8-devel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/lang/v8-devel/work  
HOME=/wrkdirs/usr/ports/lang/v8-devel/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
CC.host=cc CXX.host=c++ LINK.host=c++ LINK.target=c++ LINK=clang++ 
AR=/usr/bin/ar XDG_DATA_HOME=/wrkdirs/usr/ports/lang/v8-devel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/lang/v8-devel/work  
HOME=/wrkdirs/usr/ports/lang/v8-devel/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  
LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing  -Wno-nested-anon-types 
-Wno-unused-function -Wno-unused-private-field -Wno-unused-variable 
-Wno-unused-const-variable -Wno-tautological-undefined-compare"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd12
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/v8"
EXAMPLESDIR="share/examples/v8"
DATADIR="share/v8"
WWWDIR="www/v8"
ETCDIR="etc/v8"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/v8
DOCSDIR=/usr/local/share/doc/v8
EXAMPLESDIR=/usr/local/share/examples/v8
WWWDIR=/usr/local/www/v8
ETCDIR=/usr/local/etc/v8
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   v8-devel-3.27.7_8 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.9.3.txz
[head-amd64-default-job-16] Installing pkg-1.9.3...
[head-amd64-default-job-16] Extracting pkg-1.9.3: .......... done
===>   v8-devel-3.27.7_8 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of v8-devel-3.27.7_8
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by v8-devel-3.27.7_8 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by v8-devel-3.27.7_8 for building
=> SHA256 Checksum OK for v8-3.27.7.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by v8-devel-3.27.7_8 for building
===>  Extracting for v8-devel-3.27.7_8
=> SHA256 Checksum OK for v8-3.27.7.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for v8-devel-3.27.7_8
===>  Applying FreeBSD patches for v8-devel-3.27.7_8
===========================================================================
=======================<phase: build-depends  >============================
===>   v8-devel-3.27.7_8 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[head-amd64-default-job-16] Installing gmake-4.2.1_1...
[head-amd64-default-job-16] `-- Installing indexinfo-0.2.6...
[head-amd64-default-job-16] `-- Extracting indexinfo-0.2.6: .... done
[head-amd64-default-job-16] `-- Installing gettext-runtime-0.19.8.1...
[head-amd64-default-job-16] `-- Extracting gettext-runtime-0.19.8.1: .......... 
done
[head-amd64-default-job-16] Extracting gmake-4.2.1_1: .......... done
===>   v8-devel-3.27.7_8 depends on executable: gmake - found
===>   Returning to build of v8-devel-3.27.7_8
===>   v8-devel-3.27.7_8 depends on file: /usr/local/bin/python2.7 - not found
===>   Installing existing package /packages/All/python27-2.7.12.txz
[head-amd64-default-job-16] Installing python27-2.7.12...
[head-amd64-default-job-16] `-- Installing libffi-3.2.1...
[head-amd64-default-job-16] `-- Extracting libffi-3.2.1: .......... done
[head-amd64-default-job-16] `-- Installing readline-6.3.8...
[head-amd64-default-job-16] `-- Extracting readline-6.3.8: .......... done
[head-amd64-default-job-16] Extracting python27-2.7.12: .......... done
Message from python27-2.7.12:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   v8-devel-3.27.7_8 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of v8-devel-3.27.7_8
===>   v8-devel-3.27.7_8 depends on executable: python2 - not found
===>   Installing existing package /packages/All/python2-2_3.txz
[head-amd64-default-job-16] Installing python2-2_3...
[head-amd64-default-job-16] Extracting python2-2_3: ...... done
===>   v8-devel-3.27.7_8 depends on executable: python2 - found
===>   Returning to build of v8-devel-3.27.7_8
===========================================================================
=======================<phase: lib-depends    >============================
===>   v8-devel-3.27.7_8 depends on shared library: libicui18n.so - not found
===>   Installing existing package /packages/All/icu-58.1,1.txz
[head-amd64-default-job-16] Installing icu-58.1,1...
[head-amd64-default-job-16] Extracting icu-58.1,1: .......... done
===>   v8-devel-3.27.7_8 depends on shared library: libicui18n.so - found 
(/usr/local/lib/libicui18n.so)
===>   Returning to build of v8-devel-3.27.7_8
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for v8-devel-3.27.7_8
===========================================================================
=======================<phase: build          >============================
===>  Building for v8-devel-3.27.7_8
gmake[1]: Entering directory '/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7'
PYTHONPATH="/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/build/gyp/pylib:/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/tools/generate_shim_headers:"
 \
GYP_GENERATORS=make \
build/gyp/gyp --generator-output="out" build/all.gyp \
              -Ibuild/standalone.gypi --depth=. -S.native  
-Dcomponent=shared_library -Dclang=1 -Duse_system_icu=1 -Dv8_enable_backtrace=1 
-Darm_fpu=default -Darm_float_abi=default
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out'
  TOUCH 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/tools/gyp/v8_libbase.x64.stamp
  TOUCH 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/third_party/icu/system_icu.stamp
  ACTION Generating icui18n shim headers. 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj/gen/shim_headers/icui18n/target/third_party/icu/source/i18n/unicode/basictz.h
  TOUCH 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/third_party/icu/icui18n.stamp
  ACTION Generating icuuc shim headers. 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj/gen/shim_headers/icuuc/target/third_party/icu/source/common/unicode/brkiter.h
  TOUCH 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/third_party/icu/icuuc.stamp
  CXX(target) 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/v8_base/src/accessors.o
In file included from ../src/accessors.cc:5:
In file included from .././src/v8.h:29:
././include/v8.h:5690:54: error: 'CreateHandle' is a protected member of 
'v8::HandleScope'
  return Handle<T>(reinterpret_cast<T*>(HandleScope::CreateHandle(
                                        ~~~~~~~~~~~~~^~~~~~~~~~~~
././include/v8.h:820:29: note: declared protected here
  static internal::Object** CreateHandle(internal::Isolate* isolate,
                            ^
1 error generated.
gmake[2]: *** [tools/gyp/v8_base.target.native.mk:340: 
/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out/native/obj.target/v8_base/src/accessors.o]
 Error 1
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7/out'
gmake[1]: *** [Makefile:293: native] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/lang/v8-devel/work/v8-3.27.7'
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/v8-devel
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to