You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     t...@tobik.me
Last committer: jbe...@freebsd.org
Ident:          $FreeBSD: head/devel/kore/Makefile 426630 2016-11-20 20:58:37Z 
jbeich $
Log URL:        
http://beefy13.nyi.freebsd.org/data/head-mips64-default/p427350_s309274/logs/kore-2.0.0_1.log
Build URL:      
http://beefy13.nyi.freebsd.org/build.html?mastername=head-mips64-default&build=p427350_s309274
Log:

====>> Building devel/kore
build started at Thu Dec  1 18:17:34 UTC 2016
port directory: /usr/ports/devel/kore
building for: FreeBSD head-mips64-default-job-11 12.0-CURRENT FreeBSD 
12.0-CURRENT r309274 mips
maintained by: t...@tobik.me
Makefile ident:      $FreeBSD: head/devel/kore/Makefile 426630 2016-11-20 
20:58:37Z jbeich $
Poudriere version: 3.1.14
Host OSVERSION: 1200010
Jail OSVERSION: 1200017
Job Id: 11




!!! Jail is newer than host. (Jail: 1200017, Host: 1200010) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips64
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 12.0-CURRENT r309274
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=mips64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-mips64-default/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=kore-2.0.0_1
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=28
PWD=/usr/local/poudriere/data/.m/head-mips64-default/ref/.p/pool
MASTERNAME=head-mips64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200017
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for kore-2.0.0_1:
     DEBUG=off: Build with debugging support
     HTTP=on: Build with HTTP support
     JSONRPC=on: Build with JSON-RPC support
     PGSQL=on: PostgreSQL database support
     TASKS=on: Build with tasks support
     TLS=on: Secure network connection support via TLS
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/devel/kore/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/kore/work  
HOME=/wrkdirs/usr/ports/devel/kore/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include 
OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/devel/kore/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/kore/work  
HOME=/wrkdirs/usr/ports/devel/kore/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0 -EB -msoft-float  
-fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -EB  -L/usr/local/lib" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 -EB -msoft-float 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/kore"
EXAMPLESDIR="share/examples/kore"
DATADIR="share/kore"
WWWDIR="www/kore"
ETCDIR="etc/kore"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/kore
DOCSDIR=/usr/local/share/doc/kore
EXAMPLESDIR=/usr/local/share/examples/kore
WWWDIR=/usr/local/www/kore
ETCDIR=/usr/local/etc/kore
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=mips
MACHINE_ARCH=mips64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License ISCL accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   kore-2.0.0_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.9.3.txz
[head-mips64-default-job-11] Installing pkg-1.9.3...
[head-mips64-default-job-11] Extracting pkg-1.9.3: .......... done
===>   kore-2.0.0_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of kore-2.0.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by kore-2.0.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by kore-2.0.0_1 for building
=> SHA256 Checksum OK for jorisvink-kore-2.0.0-release_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ISCL accepted by the user
===> Fetching all distfiles required by kore-2.0.0_1 for building
===>  Extracting for kore-2.0.0_1
=> SHA256 Checksum OK for jorisvink-kore-2.0.0-release_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for kore-2.0.0_1
===>  Applying FreeBSD patches for kore-2.0.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   kore-2.0.0_1 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[head-mips64-default-job-11] Installing gmake-4.2.1_1...
[head-mips64-default-job-11] `-- Installing indexinfo-0.2.6...
[head-mips64-default-job-11] `-- Extracting indexinfo-0.2.6: .... done
[head-mips64-default-job-11] `-- Installing gettext-runtime-0.19.8.1...
[head-mips64-default-job-11] `-- Extracting gettext-runtime-0.19.8.1: 
.......... done
[head-mips64-default-job-11] Extracting gmake-4.2.1_1: .......... done
===>   kore-2.0.0_1 depends on executable: gmake - found
===>   Returning to build of kore-2.0.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   kore-2.0.0_1 depends on shared library: libyajl.so - not found
===>   Installing existing package /packages/All/yajl-2.1.0.txz
[head-mips64-default-job-11] Installing yajl-2.1.0...
[head-mips64-default-job-11] Extracting yajl-2.1.0: .......... done
Message from yajl-2.1.0:
===>   NOTICE:

The yajl port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   kore-2.0.0_1 depends on shared library: libyajl.so - found 
(/usr/local/lib/libyajl.so)
===>   Returning to build of kore-2.0.0_1
===>   kore-2.0.0_1 depends on shared library: libpq.so.5 - not found
===>   Installing existing package 
/packages/All/postgresql93-client-9.3.15_1.txz
[head-mips64-default-job-11] Installing postgresql93-client-9.3.15_1...
[head-mips64-default-job-11] `-- Installing perl5-5.24.1.r4...
[head-mips64-default-job-11] `-- Extracting perl5-5.24.1.r4: .......... done
[head-mips64-default-job-11] `-- Installing readline-6.3.8...
[head-mips64-default-job-11] `-- Extracting readline-6.3.8: .......... done
[head-mips64-default-job-11] Extracting postgresql93-client-9.3.15_1: 
.......... done
Message from perl5-5.24.1.r4:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from postgresql93-client-9.3.15_1:
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-PyGreSQL
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
===>   kore-2.0.0_1 depends on shared library: libpq.so.5 - found 
(/usr/local/lib/libpq.so.5)
===>   Returning to build of kore-2.0.0_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for kore-2.0.0_1
===========================================================================
=======================<phase: build          >============================
===>  Building for kore-2.0.0_1
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/devel/kore/work/kore-2.0.0-release'
/nxb-bin/usr/bin/cc -O2 -pipe -G0 -EB -msoft-float  -fno-strict-aliasing -Wall 
-Werror -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations 
-Wshadow -Wpointer-arith -Wcast-qual -Wsign-compare -Iincludes -std=c99 
-pedantic -Wno-error=c11-extensions -DPREFIX='"/usr/local"' 
-I/usr/local/include -DKORE_USE_PGSQL 
-DPGSQL_INCLUDE_PATH="\"/usr/local/include\"" -DKORE_USE_TASKS 
-DKORE_USE_JSONRPC -I/usr/local/include -c src/kore.c -o obj/kore.o
cc1: error: -Werror=c11-extensions: No option -Wc11-extensions
gmake[1]: *** [Makefile:106: obj/kore.o] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/devel/kore/work/kore-2.0.0-release'
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/kore
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to