You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     ni...@freebsd.org
Last committer: amd...@freebsd.org
Ident:          $FreeBSD: head/www/xpi-u2f4moz/Makefile 425965 2016-11-12 
16:27:06Z amdmi3 $
Log URL:        
http://beefy13.nyi.freebsd.org/data/head-mips64-default/p427350_s309274/logs/xpi-u2f4moz-v1.0.log
Build URL:      
http://beefy13.nyi.freebsd.org/build.html?mastername=head-mips64-default&build=p427350_s309274
Log:

====>> Building www/xpi-u2f4moz
build started at Thu Dec  1 19:10:33 UTC 2016
port directory: /usr/ports/www/xpi-u2f4moz
building for: FreeBSD head-mips64-default-job-12 12.0-CURRENT FreeBSD 
12.0-CURRENT r309274 mips
maintained by: ni...@freebsd.org
Makefile ident:      $FreeBSD: head/www/xpi-u2f4moz/Makefile 425965 2016-11-12 
16:27:06Z amdmi3 $
Poudriere version: 3.1.14
Host OSVERSION: 1200010
Jail OSVERSION: 1200017
Job Id: 12




!!! Jail is newer than host. (Jail: 1200017, Host: 1200010) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips64
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 12.0-CURRENT r309274
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=mips64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-mips64-default/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=xpi-u2f4moz-v1.0
OSREL=12.0
_OSRELEASE=12.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=28
PWD=/usr/local/poudriere/data/.m/head-mips64-default/ref/.p/pool
MASTERNAME=head-mips64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1200017
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work  
HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work  
HOME=/wrkdirs/usr/ports/www/xpi-u2f4moz/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0 -EB -msoft-float  
-DLIBICONV_PLUG -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS="-DLIBICONV_PLUG"  LDFLAGS=" -EB" LIBS=""  CXX="/nxb-bin/usr/bin/c++" 
CXXFLAGS="-O2 -pipe -G0 -EB -msoft-float -DLIBICONV_PLUG -fno-strict-aliasing  
-DLIBICONV_PLUG"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 
555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
SYSTEM_PROCESSOR=x86
CMAKE_BUILD_TYPE="release"
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/u2f4moz"
EXAMPLESDIR="share/examples/u2f4moz"
DATADIR="share/u2f4moz"
WWWDIR="www/u2f4moz"
ETCDIR="etc/u2f4moz"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/u2f4moz
DOCSDIR=/usr/local/share/doc/u2f4moz
EXAMPLESDIR=/usr/local/share/examples/u2f4moz
WWWDIR=/usr/local/www/u2f4moz
ETCDIR=/usr/local/etc/u2f4moz
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=mips
MACHINE_ARCH=mips64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   xpi-u2f4moz-v1.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.9.3.txz
[head-mips64-default-job-12] Installing pkg-1.9.3...
[head-mips64-default-job-12] Extracting pkg-1.9.3: .......... done
===>   xpi-u2f4moz-v1.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of xpi-u2f4moz-v1.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by xpi-u2f4moz-v1.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by xpi-u2f4moz-v1.0 for building
=> SHA256 Checksum OK for prefiks-u2f4moz-v1.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by xpi-u2f4moz-v1.0 for building
===>  Extracting for xpi-u2f4moz-v1.0
=> SHA256 Checksum OK for prefiks-u2f4moz-v1.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for xpi-u2f4moz-v1.0
===>  Applying FreeBSD patches for xpi-u2f4moz-v1.0
===========================================================================
=======================<phase: build-depends  >============================
===>   xpi-u2f4moz-v1.0 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.6.3.txz
[head-mips64-default-job-12] Installing cmake-3.6.3...
[head-mips64-default-job-12] `-- Installing expat-2.2.0...
[head-mips64-default-job-12] `-- Extracting expat-2.2.0: .......... done
[head-mips64-default-job-12] `-- Installing cmake-modules-3.6.3...
[head-mips64-default-job-12] `-- Extracting cmake-modules-3.6.3: .......... done
[head-mips64-default-job-12] `-- Installing curl-7.51.0_1...
[head-mips64-default-job-12] |   `-- Installing ca_root_nss-3.27.1...
[head-mips64-default-job-12] |   `-- Extracting ca_root_nss-3.27.1: ........ 
done
[head-mips64-default-job-12] `-- Extracting curl-7.51.0_1: .......... done
[head-mips64-default-job-12] `-- Installing libarchive-3.2.2,1...
[head-mips64-default-job-12] |   `-- Installing liblz4-131...
[head-mips64-default-job-12] |   `-- Extracting liblz4-131: .......... done
[head-mips64-default-job-12] |   `-- Installing lzo2-2.09...
[head-mips64-default-job-12] |   `-- Extracting lzo2-2.09: .......... done
[head-mips64-default-job-12] `-- Extracting libarchive-3.2.2,1: .......... done
[head-mips64-default-job-12] `-- Installing jsoncpp-1.7.7...
[head-mips64-default-job-12] `-- Extracting jsoncpp-1.7.7: .......... done
[head-mips64-default-job-12] Extracting cmake-3.6.3: .......... done
Message from ca_root_nss-3.27.1:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   xpi-u2f4moz-v1.0 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of xpi-u2f4moz-v1.0
===>   xpi-u2f4moz-v1.0 depends on package: pkgconf>=0.9.10 - not found
===>   Installing existing package /packages/All/pkgconf-1.0.2.txz
[head-mips64-default-job-12] Installing pkgconf-1.0.2...
[head-mips64-default-job-12] Extracting pkgconf-1.0.2: .......... done
===>   xpi-u2f4moz-v1.0 depends on package: pkgconf>=0.9.10 - found
===>   Returning to build of xpi-u2f4moz-v1.0
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for xpi-u2f4moz-v1.0
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/www/xpi-u2f4moz/work/u2f4moz-1.0
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: pkgconf (found version "1.0.2") 
-- Checking for module 'libusb-1.0'
--   Found libusb-1.0, version 1.0.13
-- Looking for include file fcntl.h
-- Looking for include file fcntl.h - found
-- Looking for include file fcntl.h
-- Looking for include file fcntl.h - found
-- Looking for include file limits.h
-- Looking for include file limits.h - found
-- Looking for include file strings.h
-- Looking for include file strings.h - found
-- Looking for include file syslog.h
-- Looking for include file syslog.h - found
-- Looking for include file unistd.h
-- Looking for include file unistd.h - found
-- Looking for include file sys/cdefs.h
-- Looking for include file sys/cdefs.h - found
-- Looking for include file sys/param.h
-- Looking for include file sys/param.h - found
-- Looking for include file stdarg.h
-- Looking for include file stdarg.h - found
-- Looking for include file locale.h
-- Looking for include file locale.h - found
-- Looking for include file endian.h
-- Looking for include file endian.h - not found
-- Looking for include file inttypes.h
-- Looking for include file inttypes.h - found
-- Looking for include file stdalign.h
-- Looking for include file stdalign.h - found
-- Looking for vprintf
-- Looking for vprintf - found
-- Looking for _doprnt
-- Looking for _doprnt - not found
-- Looking for memcpm
-- Looking for memcpm - not found
-- Looking for realloc
-- Looking for realloc - found
-- Looking for strcasecmp
-- Looking for strcasecmp - found
-- Looking for strdup
-- Looking for strdup - found
-- Looking for strerror
-- Looking for strerror - found
-- Looking for snprintf
-- Looking for snprintf - found
-- Looking for vsnprintf
-- Looking for vsnprintf - found
-- Looking for vasprintf
-- Looking for vasprintf - found
-- Looking for open
-- Looking for open - found
-- Looking for vsyslog
-- Looking for vsyslog - found
-- Looking for strncasecmp
-- Looking for strncasecmp - found
-- Looking for setlocale
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_268be/fast"
-- Looking for setlocale - not found
-- Looking for INFINITY
-- Looking for INFINITY - found
-- Looking for NAN
-- Looking for NAN - found
-- Looking for isnan
-- Looking for isnan - found
-- Looking for isinf
-- Looking for isinf - found
-- Looking for _isinf
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_628ca/fast"
-- Looking for _isinf - not found
-- Looking for _finite
-- Looking for _finite - not found
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/www/xpi-u2f4moz/work/u2f4moz-1.0/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/www/xpi-u2f4moz/work/u2f4moz-1.0/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/www/xpi-u2f4moz
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to