You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: branches/2017Q1/math/xlapack/Makefile 367888 
2014-09-10 20:50:31Z gerald $
Log URL:        
http://beefy15.nyi.freebsd.org/data/110armv6-quarterly/434150/logs/xlapack-3.5.0_3.log
Build URL:      
http://beefy15.nyi.freebsd.org/build.html?mastername=110armv6-quarterly&build=434150
Log:

====>> Building math/xlapack
build started at Thu Feb 16 09:19:14 UTC 2017
port directory: /usr/ports/math/xlapack
building for: FreeBSD 110armv6-quarterly-job-18 11.0-RELEASE-p5 FreeBSD 
11.0-RELEASE-p5 r309692 arm
maintained by: m...@freebsd.org
Makefile ident:      $FreeBSD: branches/2017Q1/math/xlapack/Makefile 367888 
2014-09-10 20:50:31Z gerald $
Poudriere version: 3.1.14
Host OSVERSION: 1200018
Jail OSVERSION: 1100122
Job Id: 18

---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 11.0-RELEASE-p5 r309692
UNAME_r=11.0-RELEASE-p5
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=armv6
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110armv6-quarterly/ref
QEMU_EMULATING=1
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=xlapack-3.5.0_3
OSREL=11.0
_OSRELEASE=11.0-RELEASE-p5
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=28
PWD=/usr/local/poudriere/data/.m/110armv6-quarterly/ref/.p/pool
MASTERNAME=110armv6-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.14
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100122
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for xlapack-3.5.0_3:
     PROFILE=off: Build profiling libraries
     SHARED=on: Build shared libraries and PIC archives
     STATIC=on: Build (non-PIC) archives
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
F77="gfortran49" FC="gfortran49" FFLAGS="-O -Wl,-rpath=/usr/local/lib/gcc49" 
FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc49" PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/xlapack/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/xlapack/work  
HOME=/wrkdirs/usr/ports/math/xlapack/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
BLASLIB="-L/usr/local/lib -lblas" USEXBLAS=yes XBLASLIB="-L/usr/local/lib 
-lxblas" F77="gfortran49" FC="gfortran49" FFLAGS="-O 
-Wl,-rpath=/usr/local/lib/gcc49" FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc49" 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/xlapack/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/xlapack/work  
HOME=/wrkdirs/usr/ports/math/xlapack/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" 
 -Wl,-rpath=/usr/local/lib/gcc49  -L/usr/local/lib/gcc49 -B/usr/local/bin" 
LIBS="lapack tmglib"  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
SVERSION="4"
BLAS="@comment
"
LAPACK="@comment
"
XLAPACK=""
LAPACKE="@comment
"
PROFILE="@comment
"
SHARED=""
STATIC=""
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/xlapack"
EXAMPLESDIR="share/examples/xlapack"
DATADIR="share/xlapack"
WWWDIR="www/xlapack"
ETCDIR="etc/xlapack"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/xlapack
DOCSDIR=/usr/local/share/doc/xlapack
EXAMPLESDIR=/usr/local/share/examples/xlapack
WWWDIR=/usr/local/www/xlapack
ETCDIR=/usr/local/etc/xlapack
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   xlapack-3.5.0_3 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.9.4_1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-18] Installing pkg-1.9.4_1...
[110armv6-quarterly-job-18] Extracting pkg-1.9.4_1: .......... done
===>   xlapack-3.5.0_3 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of xlapack-3.5.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by xlapack-3.5.0_3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by xlapack-3.5.0_3 for building
=> SHA256 Checksum OK for lapack/lapack-3.5.0.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by xlapack-3.5.0_3 for building
===>  Extracting for xlapack-3.5.0_3
=> SHA256 Checksum OK for lapack/lapack-3.5.0.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for xlapack-3.5.0_3
===>  Applying FreeBSD patches for xlapack-3.5.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   xlapack-3.5.0_3 depends on executable: gfortran49 - not found
===>   Installing existing package /packages/All/gcc-4.9.4.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-18] Installing gcc-4.9.4...
[110armv6-quarterly-job-18] `-- Installing indexinfo-0.2.6...
[110armv6-quarterly-job-18] `-- Extracting indexinfo-0.2.6: .... done
[110armv6-quarterly-job-18] `-- Installing mpc-1.0.3...
[110armv6-quarterly-job-18] |   `-- Installing gmp-5.1.3_3...
[110armv6-quarterly-job-18] |   `-- Extracting gmp-5.1.3_3: .......... done
[110armv6-quarterly-job-18] |   `-- Installing mpfr-3.1.5...
[110armv6-quarterly-job-18] |   `-- Extracting mpfr-3.1.5: .......... done
[110armv6-quarterly-job-18] `-- Extracting mpc-1.0.3: ...... done
[110armv6-quarterly-job-18] `-- Installing binutils-2.27_5,1...
[110armv6-quarterly-job-18] |   `-- Installing gettext-runtime-0.19.8.1_1...
[110armv6-quarterly-job-18] |   `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[110armv6-quarterly-job-18] `-- Extracting binutils-2.27_5,1: .......... done
[110armv6-quarterly-job-18] Extracting gcc-4.9.4: .......... done
Message from gcc-4.9.4:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc49

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   xlapack-3.5.0_3 depends on executable: gfortran49 - found
===>   Returning to build of xlapack-3.5.0_3
===>   xlapack-3.5.0_3 depends on file: /usr/local/bin/python2.7 - not found
===>   Installing existing package /packages/All/python27-2.7.13_1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-18] Installing python27-2.7.13_1...
[110armv6-quarterly-job-18] `-- Installing libffi-3.2.1...
[110armv6-quarterly-job-18] `-- Extracting libffi-3.2.1: .......... done
[110armv6-quarterly-job-18] `-- Installing readline-6.3.8...
[110armv6-quarterly-job-18] `-- Extracting readline-6.3.8: .......... done
[110armv6-quarterly-job-18] Extracting python27-2.7.13_1: .......... done
Message from python27-2.7.13_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   xlapack-3.5.0_3 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of xlapack-3.5.0_3
===>   xlapack-3.5.0_3 depends on file: /usr/local/bin/as - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   xlapack-3.5.0_3 depends on shared library: libblas.so - not found
===>   Installing existing package /packages/All/blas-3.5.0_3.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-18] Installing blas-3.5.0_3...
[110armv6-quarterly-job-18] Extracting blas-3.5.0_3: ....... done
===>   xlapack-3.5.0_3 depends on shared library: libblas.so - found 
(/usr/local/lib/libblas.so)
===>   Returning to build of xlapack-3.5.0_3
===>   xlapack-3.5.0_3 depends on shared library: libxblas.so - not found
===>   Installing existing package /packages/All/xblas-1.0.248.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-18] Installing xblas-1.0.248...
[110armv6-quarterly-job-18] Extracting xblas-1.0.248: .......... done
Message from xblas-1.0.248:
===>   NOTICE:

The xblas port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
===>   xlapack-3.5.0_3 depends on shared library: libxblas.so - found 
(/usr/local/lib/libxblas.so)
===>   Returning to build of xlapack-3.5.0_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for xlapack-3.5.0_3
===========================================================================
=======================<phase: build          >============================
===>  Building for xlapack-3.5.0_3
/usr/bin/printf "\n\nBuilding shared libraries:\n\n\n"


Building shared libraries:


cd /wrkdirs/usr/ports/math/xlapack/work/lapack-3.5.0_SHARED; /usr/bin/env 
BLASLIB="-L/usr/local/lib -lblas" USEXBLAS=yes XBLASLIB="-L/usr/local/lib 
-lxblas" F77="gfortran49" FC="gfortran49" FFLAGS="-O 
-Wl,-rpath=/usr/local/lib/gcc49" FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc49" 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/xlapack/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/xlapack/work  
HOME=/wrkdirs/usr/ports/math/xlapack/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe 
  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" 
-Wl,-rpath=/usr/local/lib/gcc49  -L/usr/local/lib/gcc49 -B/usr/local/bin" 
LIBS="lapack tmglib"  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444" 
EXTRAFLAGS="-fpic"  /nxb-bin/usr/bin/make  
DESTDIR=/wrkdirs/usr/ports/math/xlapack/work/stage ARCH="/usr/local/bin/ar" lib
( cd INSTALL; /nxb-bin/usr/bin/make; ./testlsame; ./testslamch; ./testdlamch;  
./testsecond; ./testdsecnd; ./testieee; ./testversion )
gfortran49 -O -Wl,-rpath=/usr/local/lib/gcc49 -fpic -c lsame.f -o lsame.o
gfortran49 -O -Wl,-rpath=/usr/local/lib/gcc49 -fpic -c lsametst.f -o lsametst.o
gfortran49  -Wl,-rpath=/usr/local/lib/gcc49  -L/usr/local/lib/gcc49 
-B/usr/local/bin -fpic -o testlsame lsame.o lsametst.o
/usr/local/lib/gcc49/libgfortran.so: undefined reference to `fpgetsticky'
collect2: error: ld returned 1 exit status
*** Error code 1

Stop.
make[2]: stopped in 
/wrkdirs/usr/ports/math/xlapack/work/lapack-3.5.0_SHARED/INSTALL
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/math/xlapack/work/lapack-3.5.0_SHARED
*** Error code 1

Stop.
make: stopped in /usr/ports/math/xlapack
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to