You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jlaff...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/print/libharu/Makefile 412348 2016-04-01 
14:16:16Z mat $
Log URL:        
http://beefy13.nyi.freebsd.org/data/head-mips64-default/p436460_s315527/logs/libharu-2.3.0_1.log
Build URL:      
http://beefy13.nyi.freebsd.org/build.html?mastername=head-mips64-default&build=p436460_s315527
Log:

====>> Building print/libharu
build started at Mon Mar 20 07:16:17 UTC 2017
port directory: /usr/ports/print/libharu
building for: FreeBSD head-mips64-default-job-16 12.0-CURRENT FreeBSD 
12.0-CURRENT r315527 mips
maintained by: jlaff...@freebsd.org
Makefile ident:      $FreeBSD: head/print/libharu/Makefile 412348 2016-04-01 
14:16:16Z mat $
Poudriere version: 3.1.15-2-g0a86c900
Host OSVERSION: 1200020
Jail OSVERSION: 1200025
Job Id: 16




!!! Jail is newer than host. (Jail: 1200025, Host: 1200020) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips64
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1200025
UNAME_v=FreeBSD 12.0-CURRENT r315527
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-mips64-default/ref
QEMU_EMULATING=1
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=libharu-2.3.0_1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-mips64-default/ref/.p/pool
MASTERNAME=head-mips64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.15-2-g0a86c900
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for libharu-2.3.0_1:
     EXAMPLES=on: Build and/or install examples
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/print/libharu/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/print/libharu/work  
HOME=/wrkdirs/usr/ports/print/libharu/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/print/libharu/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/print/libharu/work  
HOME=/wrkdirs/usr/ports/print/libharu/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0 -EB -msoft-float  
-fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -EB" 
LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 -EB -msoft-float 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
SOVERSION=2
CMAKE_BUILD_TYPE="release"
OSREL=12.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/libharu"
EXAMPLESDIR="share/examples/libharu"
DATADIR="share/libharu"
WWWDIR="www/libharu"
ETCDIR="etc/libharu"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/libharu
DOCSDIR=/usr/local/share/doc/libharu
EXAMPLESDIR=/usr/local/share/examples/libharu
WWWDIR=/usr/local/www/libharu
ETCDIR=/usr/local/etc/libharu
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=mips
MACHINE_ARCH=mips64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=mips64
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=12.0
OSVERSION=1200025
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native\|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
_OSRELEASE=12.0-CURRENT
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  131072
stack size              (kbytes, -s)  8192
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   libharu-2.3.0_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.0_2.txz
[head-mips64-default-job-16] Installing pkg-1.10.0_2...
[head-mips64-default-job-16] Extracting pkg-1.10.0_2: .......... done
===>   libharu-2.3.0_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of libharu-2.3.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by libharu-2.3.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by libharu-2.3.0_1 for building
=> SHA256 Checksum OK for libharu-libharu-RELEASE_2_3_0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by libharu-2.3.0_1 for building
===>  Extracting for libharu-2.3.0_1
=> SHA256 Checksum OK for libharu-libharu-RELEASE_2_3_0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for libharu-2.3.0_1
===>  Applying FreeBSD patches for libharu-2.3.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   libharu-2.3.0_1 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.7.2.txz
[head-mips64-default-job-16] Installing cmake-3.7.2...
[head-mips64-default-job-16] `-- Installing cmake-modules-3.7.2...
[head-mips64-default-job-16] `-- Extracting cmake-modules-3.7.2: .......... done
[head-mips64-default-job-16] `-- Installing curl-7.53.1...
[head-mips64-default-job-16] |   `-- Installing ca_root_nss-3.30...
[head-mips64-default-job-16] |   `-- Extracting ca_root_nss-3.30: ........ done
[head-mips64-default-job-16] |   `-- Installing libnghttp2-1.20.0...
[head-mips64-default-job-16] |   `-- Extracting libnghttp2-1.20.0: .......... 
done
[head-mips64-default-job-16] `-- Extracting curl-7.53.1: .......... done
[head-mips64-default-job-16] `-- Installing expat-2.2.0_1...
[head-mips64-default-job-16] `-- Extracting expat-2.2.0_1: .......... done
[head-mips64-default-job-16] `-- Installing jsoncpp-1.8.0_1...
[head-mips64-default-job-16] `-- Extracting jsoncpp-1.8.0_1: .......... done
[head-mips64-default-job-16] `-- Installing libarchive-3.2.2,1...
[head-mips64-default-job-16] |   `-- Installing liblz4-1.7.5,1...
[head-mips64-default-job-16] |   `-- Extracting liblz4-1.7.5,1: .......... done
[head-mips64-default-job-16] |   `-- Installing lzo2-2.09...
[head-mips64-default-job-16] |   `-- Extracting lzo2-2.09: .......... done
[head-mips64-default-job-16] `-- Extracting libarchive-3.2.2,1: .......... done
[head-mips64-default-job-16] `-- Installing libuv-1.11.0...
[head-mips64-default-job-16] `-- Extracting libuv-1.11.0: .......... done
[head-mips64-default-job-16] Extracting cmake-3.7.2: .......... done
Message from ca_root_nss-3.30:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   libharu-2.3.0_1 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of libharu-2.3.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   libharu-2.3.0_1 depends on shared library: libpng.so - not found
===>   Installing existing package /packages/All/png-1.6.28.txz
[head-mips64-default-job-16] Installing png-1.6.28...
[head-mips64-default-job-16] Extracting png-1.6.28: .......... done
===>   libharu-2.3.0_1 depends on shared library: libpng.so - found 
(/usr/local/lib/libpng.so)
===>   Returning to build of libharu-2.3.0_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for libharu-2.3.0_1
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/print/libharu/work/.build
-- The C compiler identification is GNU 4.2.1
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Looking for include file dlfcn.h
-- Looking for include file dlfcn.h - found
-- Looking for include file inttypes.h
-- Looking for include file inttypes.h - found
-- Looking for include file memory.h
-- Looking for include file memory.h - found
-- Looking for include file stdint.h
-- Looking for include file stdint.h - found
-- Looking for include file stdlib.h
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_a31b0/fast"
-- Looking for include file stdlib.h - not found
-- Looking for include file strings.h
-- Looking for include file strings.h - found
-- Looking for include file string.h
-- Looking for include file string.h - found
-- Looking for include file sys/stat.h
-- Looking for include file sys/stat.h - found
-- Looking for include file sys/types.h
-- Looking for include file sys/types.h - found
-- Looking for include file unistd.h
-- Looking for include file unistd.h - found
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.11") 
-- Found PNG: /usr/local/lib/libpng.so (found version "1.6.28+apng") 

Summary of CMake build system results for the haru library

Install location variables which can be set by the user:
CMAKE_INSTALL_PREFIX:      /usr/local
CMAKE_INSTALL_EXEC_PREFIX  
CMAKE_INSTALL_BINDIR       
CMAKE_INSTALL_LIBDIR       
CMAKE_INSTALL_INCLUDEDIR   

Other important CMake variables:

CMAKE_SYSTEM_NAME:      FreeBSD
UNIX:                   1
WIN32:                  
APPLE:                  
MSVC:                           (MSVC_VERSION:  )
MINGW:                  
MSYS:                   
CYGWIN:                 
BORLAND:                
WATCOM:           

CMAKE_BUILD_TYPE:       Release
CMAKE_C_COMPILER CMAKE_C_FLAGS:                 /nxb-bin/usr/bin/cc -O2 -pipe 
-G0 -EB -msoft-float  -fno-strict-aliasing

Library options:
LIBHPDF_SHARED:         ON
LIBHPDF_STATIC:         ON
LIBHPDF_EXAMPLES:       ON
DEVPAK:                 OFF

Optional libraries:
HAVE_LIBZ:              TRUE
HAVE_LIBPNG:            TRUE

-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/print/libharu/work/.build/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/print/libharu/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/print/libharu
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to