You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@skylord.ru
Last committer: t...@freebsd.org
Ident:          $FreeBSD: 
branches/2017Q2/net-p2p/verlihub-plugins-luascript/Makefile 428143 2016-12-08 
17:26:09Z tijl $
Log URL:        
http://beefy15.nyi.freebsd.org/data/110armv6-quarterly/440108/logs/verlihub-plugins-luascript-1.8.1_3.log
Build URL:      
http://beefy15.nyi.freebsd.org/build.html?mastername=110armv6-quarterly&build=440108
Log:

====>> Building net-p2p/verlihub-plugins-luascript
build started at Sat May  6 01:18:57 UTC 2017
port directory: /usr/ports/net-p2p/verlihub-plugins-luascript
building for: FreeBSD 110armv6-quarterly-job-02 11.0-RELEASE-p10 FreeBSD 
11.0-RELEASE-p10 r317487 arm
maintained by: m...@skylord.ru
Makefile ident:      $FreeBSD: 
branches/2017Q2/net-p2p/verlihub-plugins-luascript/Makefile 428143 2016-12-08 
17:26:09Z tijl $
Poudriere version: 3.1.17-10-ge01cc509
Host OSVERSION: 1200028
Jail OSVERSION: 1100122
Job Id: 02

---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100122
UNAME_v=FreeBSD 11.0-RELEASE-p10 r317487
UNAME_r=11.0-RELEASE-p10
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110armv6-quarterly/ref
QEMU_EMULATING=1
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=verlihub-plugins-luascript-1.8.1_3
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/110armv6-quarterly/ref/.p/pool
MASTERNAME=110armv6-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.17-10-ge01cc509
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
verlihub-plugins-luascript-1.8.1_3:
     SOCKET=off: Build with LuaSocket support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work  
HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh ADDR2LINE="/usr/local/bin/addr2line" 
AR="/usr/local/bin/ar" AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
LUA_MODLIBDIR=/usr/local/lib/lua/5.1  LUA_MODSHAREDIR=/usr/local/share/lua/5.1  
LUA_VER=5.1  LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work  
HOME=/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work TMPDIR="/tmp" 
NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc5" CFLAGS="-O2 -pipe  
-Wl,-rpath=/usr/local/lib/gcc5 -fno-strict-aliasing"  CPP="cpp5" CPP
 FLAGS="-I/usr/local/include/lua51"  LDFLAGS=" -L/usr/local/lib 
-Wl,-rpath=/usr/local/lib/gcc5 -L/usr/local/lib/gcc5" LIBS=""  CXX="g++5" 
CXXFLAGS="-O2 -pipe -Wl,-rpath=/usr/local/lib/gcc5 -fno-strict-aliasing   
-L/usr/local/lib -Wl,-rpath=/usr/local/lib/gcc5 -L/usr/local/lib/gcc5 
-Wl,-rpath=/usr/local/lib/gcc5"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
LUA_MODLIBDIR=lib/lua/5.1
LUA_MODSHAREDIR=share/lua/5.1
LUA_VER=5.1
LUA_INCDIR=include/lua51
LUA_LIBDIR=lib
LUA_VER_STR=51
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/luascript"
EXAMPLESDIR="share/examples/luascript"
DATADIR="share/luascript"
WWWDIR="www/luascript"
ETCDIR="etc/luascript"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/luascript
DOCSDIR=/usr/local/share/doc/luascript
EXAMPLESDIR=/usr/local/share/examples/luascript
WWWDIR=/usr/local/www/luascript
ETCDIR=/usr/local/etc/luascript
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=armv6
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=11.0
OSVERSION=1100122
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native\|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
_OSRELEASE=11.0-RELEASE-p10
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   verlihub-plugins-luascript-1.8.1_3 depends on file: /usr/local/sbin/pkg 
- not found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-02] Installing pkg-1.10.1...
[110armv6-quarterly-job-02] Extracting pkg-1.10.1: .......... done
===>   verlihub-plugins-luascript-1.8.1_3 depends on file: /usr/local/sbin/pkg 
- found
===>   Returning to build of verlihub-plugins-luascript-1.8.1_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by verlihub-plugins-luascript-1.8.1_3 for 
building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by verlihub-plugins-luascript-1.8.1_3 for 
building
=> SHA256 Checksum OK for lua-1.8.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by verlihub-plugins-luascript-1.8.1_3 for 
building
===>  Extracting for verlihub-plugins-luascript-1.8.1_3
=> SHA256 Checksum OK for lua-1.8.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for verlihub-plugins-luascript-1.8.1_3
===========================================================================
=======================<phase: build-depends  >============================
===>   verlihub-plugins-luascript-1.8.1_3 depends on file: 
/usr/local/bin/verlihub - not found
===>   Installing existing package /packages/All/verlihub-0.9.8.e.r2_7,1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-02] Installing verlihub-0.9.8.e.r2_7,1...
<snip>
      before the first run!
    - You need to rerun vh_install as during the first installation

-------------------------------------------------------------------
===>   verlihub-plugins-luascript-1.8.1_3 depends on file: 
/usr/local/bin/verlihub - found
===>   Returning to build of verlihub-plugins-luascript-1.8.1_3
===>   verlihub-plugins-luascript-1.8.1_3 depends on executable: gcc5 - not 
found
===>   Installing existing package /packages/All/gcc-5.4.0.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-02] Installing gcc-5.4.0...
[110armv6-quarterly-job-02] `-- Installing binutils-2.28,1...
[110armv6-quarterly-job-02] `-- Extracting binutils-2.28,1: .......... done
[110armv6-quarterly-job-02] `-- Installing gmp-6.1.2...
[110armv6-quarterly-job-02] `-- Extracting gmp-6.1.2: .......... done
[110armv6-quarterly-job-02] `-- Installing mpc-1.0.3...
[110armv6-quarterly-job-02] |   `-- Installing mpfr-3.1.5_1...
[110armv6-quarterly-job-02] |   `-- Extracting mpfr-3.1.5_1: .......... done
[110armv6-quarterly-job-02] `-- Extracting mpc-1.0.3: ...... done
[110armv6-quarterly-job-02] Extracting gcc-5.4.0: .......... done
Message from gcc-5.4.0:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc5

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   verlihub-plugins-luascript-1.8.1_3 depends on executable: gcc5 - found
===>   Returning to build of verlihub-plugins-luascript-1.8.1_3
===>   verlihub-plugins-luascript-1.8.1_3 depends on file: /usr/local/bin/as - 
found
===========================================================================
=======================<phase: lib-depends    >============================
===>   verlihub-plugins-luascript-1.8.1_3 depends on shared library: 
liblua-5.1.so - not found
===>   Installing existing package /packages/All/lua51-5.1.5_9.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-02] Installing lua51-5.1.5_9...
[110armv6-quarterly-job-02] Extracting lua51-5.1.5_9: ......... done
===>   verlihub-plugins-luascript-1.8.1_3 depends on shared library: 
liblua-5.1.so - found (/usr/local/lib/liblua-5.1.so)
===>   Returning to build of verlihub-plugins-luascript-1.8.1_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for verlihub-plugins-luascript-1.8.1_3
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work/lua-1.8.1/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work/lua-1.8.1/configure
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++5 accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++5... gcc3
checking build system type... armv6-portbld-freebsd11.0
checking host system type... armv6-portbld-freebsd11.0
checking for gcc... gcc5
checking whether we are using the GNU C compiler... yes
checking whether gcc5 accepts -g... yes
checking for gcc5 option to accept ISO C89... none needed
checking dependency style of gcc5... gcc3
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ld used by gcc5... /usr/local/bin/ld
checking if the linker (/usr/local/bin/ld) is GNU ld... yes
checking for /usr/local/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/local/bin/nm
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking how to run the C preprocessor... cpp5
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for dlfcn.h... (cached) yes
checking how to run the C++ preprocessor... g++5 -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... gfortran
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether gfortran accepts -g... yes
checking the maximum length of command line arguments... (cached) 262144
checking command to parse /usr/local/bin/nm output from gcc5 object... ok
checking for objdir... .libs
checking for ar... /usr/local/bin/ar
checking for ranlib... /usr/local/bin/ranlib
checking for strip... strip
checking for correct ltmain.sh version... yes
checking if gcc5 supports -fno-rtti -fno-exceptions... no
checking for gcc5 option to produce PIC... -fPIC
checking if gcc5 PIC flag -fPIC works... yes
checking if gcc5 static flag -static works... yes
checking if gcc5 supports -c -o file.o... yes
checking whether the gcc5 linker (/usr/local/bin/ld) supports shared 
libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd11.0 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++5... /usr/local/bin/ld
checking if the linker (/usr/local/bin/ld) is GNU ld... yes
checking whether the g++5 linker (/usr/local/bin/ld) supports shared 
libraries... yes
checking for g++5 option to produce PIC... -fPIC
checking if g++5 PIC flag -fPIC works... yes
checking if g++5 static flag -static works... yes
checking if g++5 supports -c -o file.o... yes
checking whether the g++5 linker (/usr/local/bin/ld) supports shared 
libraries... yes
checking dynamic linker characteristics... freebsd11.0 ld.so
(cached) (cached) checking how to hardcode library paths into programs... 
immediate
appending configuration tag "F77" to libtool
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for gfortran option to produce PIC... -fPIC
checking if gfortran PIC flag -fPIC works... yes
checking if gfortran static flag -static works... yes
checking if gfortran supports -c -o file.o... yes
checking whether the gfortran linker (/usr/local/bin/ld) supports shared 
libraries... yes
checking dynamic linker characteristics... freebsd11.0 ld.so
(cached) (cached) checking how to hardcode library paths into programs... 
immediate
checking whether to enable maintainer-specific portions of Makefiles... no
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for sys/socket.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for unistd.h... (cached) yes
checking ostream usability... yes
checking ostream presence... yes
checking for ostream... yes
checking string usability... yes
checking string presence... yes
checking for string... yes
checking for errno.h... (cached) yes
checking for sys/poll.h... (cached) yes
checking for lua headers...
checking lua.h usability... yes
checking lua.h presence... yes
checking for lua.h... yes
checking lualib.h usability... yes
checking lualib.h presence... yes
checking for lualib.h... yes
checking lauxlib.h usability... yes
checking lauxlib.h presence... yes
checking for lauxlib.h... yes
checking for lua libraries...
checking for lua_call in -llua... no
checking for lua_call in -llua50... no
checking for lua_call in -llua-5.1... yes
checking for luaL_register in -llua-5.1... yes
checking for verlihub_config... /usr/local/bin/verlihub_config
checking for VERLIHUB CFLAGS... -I/usr/local/include 
-I/usr/local/include/verlihub -I/usr/local/include/mysql -isystem 
/usr/local/include -fno-strict-aliasing -g -fno-omit-frame-pointer 
-fno-strict-aliasing -I/usr/local/include -I/usr/local/include
checking for VERLIHUB LIBS... -L/usr/local/lib -Wl,-R/usr/local/lib -lpcre 
-L/usr/local/lib/mysql -lmysqlclient -pthread -lz -lm -lexecinfo -lssl -lcrypto 
-lc -lcrypt -L/usr/local/lib -lGeoIP -D_THREAD_SAFE -pthread -L/usr/local/lib 
-lverlihub
checking for VERLIHUB VERSION... verlihub version: 0.9.8e-r2 Monday Jul 20 2009
checking for VERLIHUB - version >= 0... no
*** The test program failed to compile or link.  See the file
*** config.log for the exact error that occured.  This usually
*** means VERLIHUB was not installed, was incorrectly installed
*** or that you have moved VERLIHUB since it was installed.  In
*** the latter case, you may want to edit the $ac_path_lib_verlihub_config
*** script: $VERLIHUB_CONFIG
Install verlihub devel, or you need a path for the 
verlihub_config script, you may also wat to try some --with-verlihub=/prefix 
agruments
exit: Illegal number: -1
===>  Script "configure" failed unexpectedly.
Please report the problem to m...@skylord.ru [maintainer] and attach the
"/wrkdirs/usr/ports/net-p2p/verlihub-plugins-luascript/work/lua-1.8.1/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/net-p2p/verlihub-plugins-luascript
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to