You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     amd...@freebsd.org
Last committer: amd...@freebsd.org
Ident:          $FreeBSD: head/devel/osc/Makefile 446310 2017-07-21 12:09:44Z 
amdmi3 $
Log URL:        
http://package19.nyi.freebsd.org/data/103i386-default-build-as-user/447379/logs/osc-0.159.0.log
Build URL:      
http://package19.nyi.freebsd.org/build.html?mastername=103i386-default-build-as-user&build=447379
Log:

====>> Building devel/osc
build started at Sat Aug  5 14:40:27 UTC 2017
port directory: /usr/ports/devel/osc
building for: FreeBSD 103i386-default-build-as-user-job-16 10.3-RELEASE-p20 
FreeBSD 10.3-RELEASE-p20 i386
maintained by: amd...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/osc/Makefile 446310 2017-07-21 
12:09:44Z amdmi3 $
Poudriere version: 3.1.19-61-ga8829ba9
Host OSVERSION: 1200033
Jail OSVERSION: 1003000
Job Id: 16

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1003000
UNAME_v=FreeBSD 10.3-RELEASE-p20
UNAME_r=10.3-RELEASE-p20
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/poudriere/data/.m/103i386-default-build-as-user/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=osc-0.159.0
OLDPWD=/
PWD=/poudriere/data/.m/103i386-default-build-as-user/ref/.p/pool
MASTERNAME=103i386-default-build-as-user
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.19-61-ga8829ba9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
GID=0
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for osc-0.159.0:
     CA_BUNDLE=on: Install CA Certificates
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/osc/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/osc/work  
HOME=/wrkdirs/usr/ports/devel/osc/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/osc/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/osc/work  
HOME=/wrkdirs/usr/ports/devel/osc/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
LDSHARED="cc -shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  
LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd10
PYTHON_PYOEXTENSION=pyo
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_SUFFIX=27
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
PYTHON2=""
PYTHON3="@comment
"
OSREL=10.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/osc"
EXAMPLESDIR="share/examples/osc"
DATADIR="share/osc"
WWWDIR="www/osc"
ETCDIR="etc/osc"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/osc
DOCSDIR=/usr/local/share/doc/osc
EXAMPLESDIR=/usr/local/share/examples/osc
WWWDIR=/usr/local/www/osc
ETCDIR=/usr/local/etc/osc
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
FORCE_PACKAGE=yes
PACKAGE_BUILDING=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=i386
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=10.3
OSVERSION=1003000
PYTHONBASE=/usr/local
_JAVA_OS_LIST_REGEXP=native|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk|oracle|sun
_JAVA_VERSION_LIST_REGEXP=1.6|1.7|1.8|1.6\+|1.7\+|1.8\+
_OSRELEASE=10.3-RELEASE-p20
#### Misc Poudriere ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
sbsize                   (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   osc-0.159.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
[103i386-default-build-as-user-job-16] Installing pkg-1.10.1...
[103i386-default-build-as-user-job-16] Extracting pkg-1.10.1: .......... done
===>   osc-0.159.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of osc-0.159.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by osc-0.159.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by osc-0.159.0 for building
=> SHA256 Checksum OK for openSUSE-osc-0.159.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by osc-0.159.0 for building
===>  Extracting for osc-0.159.0
=> SHA256 Checksum OK for openSUSE-osc-0.159.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for osc-0.159.0
===========================================================================
=======================<phase: build-depends  >============================
===>   osc-0.159.0 depends on package: py27-urlgrabber>0 - not found
===>   Installing existing package /packages/All/py27-urlgrabber-3.10.2.txz
[103i386-default-build-as-user-job-16] Installing py27-urlgrabber-3.10.2...
[103i386-default-build-as-user-job-16] `-- Installing py27-setuptools-36.0.1...
[103i386-default-build-as-user-job-16] |   `-- Installing python27-2.7.13_7...
[103i386-default-build-as-user-job-16] |   | `-- Installing 
gettext-runtime-0.19.8.1_1...
[103i386-default-build-as-user-job-16] |   |   `-- Installing indexinfo-0.2.6...
[103i386-default-build-as-user-job-16] |   |   `-- Extracting indexinfo-0.2.6: 
.... done
[103i386-default-build-as-user-job-16] |   | `-- Extracting 
gettext-runtime-0.19.8.1_1: .......... done
[103i386-default-build-as-user-job-16] |   | `-- Installing libffi-3.2.1...
[103i386-default-build-as-user-job-16] |   | `-- Extracting libffi-3.2.1: 
.......... done
[103i386-default-build-as-user-job-16] |   | `-- Installing readline-7.0.3...
[103i386-default-build-as-user-job-16] |   | `-- Extracting readline-7.0.3: 
.......... done
[103i386-default-build-as-user-job-16] |   `-- Extracting python27-2.7.13_7: 
.......... done
[103i386-default-build-as-user-job-16] `-- Extracting py27-setuptools-36.0.1: 
.......... done
[103i386-default-build-as-user-job-16] Extracting py27-urlgrabber-3.10.2: 
.......... done
Message from python27-2.7.13_7:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   osc-0.159.0 depends on package: py27-urlgrabber>0 - found
===>   Returning to build of osc-0.159.0
===>   osc-0.159.0 depends on package: py27-setuptools>0 - found
===>   osc-0.159.0 depends on file: /usr/local/bin/python2.7 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for osc-0.159.0
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 11, in <module>
    from osc import babysitter
  File "osc/babysitter.py", line 14, in <module>
    from urlgrabber.grabber import URLGrabError
  File "/usr/local/lib/python2.7/site-packages/urlgrabber/__init__.py", line 
55, in <module>
    from grabber import urlgrab, urlopen, urlread
  File "/usr/local/lib/python2.7/site-packages/urlgrabber/grabber.py", line 
532, in <module>
    import pycurl
ImportError: No module named pycurl
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/osc
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to