You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     olg...@freebsd.org
Last committer: olg...@freebsd.org
Ident:          $FreeBSD: head/devel/elixir-stemmer/Makefile 446930 2017-07-30 
13:13:44Z olgeni $
Log URL:        
http://beefy5.nyi.freebsd.org/data/103i386-default/447436/logs/elixir-stemmer-1.0.2.log
Build URL:      
http://beefy5.nyi.freebsd.org/build.html?mastername=103i386-default&build=447436
Log:

====>> Building devel/elixir-stemmer
build started at Sun Aug  6 02:13:56 UTC 2017
port directory: /usr/ports/devel/elixir-stemmer
building for: FreeBSD 103i386-default-job-18 10.3-RELEASE-p20 FreeBSD 
10.3-RELEASE-p20 i386
maintained by: olg...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/elixir-stemmer/Makefile 446930 
2017-07-30 13:13:44Z olgeni $
Poudriere version: 3.1.19-61-ga8829ba9
Host OSVERSION: 1200033
Jail OSVERSION: 1003000
Job Id: 18

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1003000
UNAME_v=FreeBSD 10.3-RELEASE-p20
UNAME_r=10.3-RELEASE-p20
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/103i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=elixir-stemmer-1.0.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/103i386-default/ref/.p/pool
MASTERNAME=103i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.19-61-ga8829ba9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work  
HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work  
HOME=/wrkdirs/usr/ports/devel/elixir-stemmer/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  
LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/stemmer"
EXAMPLESDIR="share/examples/stemmer"
DATADIR="share/stemmer"
WWWDIR="www/stemmer"
ETCDIR="etc/stemmer"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/stemmer
DOCSDIR=/usr/local/share/doc/stemmer
EXAMPLESDIR=/usr/local/share/examples/stemmer
WWWDIR=/usr/local/www/stemmer
ETCDIR=/usr/local/etc/stemmer
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=i386
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=10.3
OSVERSION=1003000
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk|oracle|sun
_JAVA_VERSION_LIST_REGEXP=1.6|1.7|1.8|1.6\+|1.7\+|1.8\+
_OSRELEASE=10.3-RELEASE-p20
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
sbsize                   (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   elixir-stemmer-1.0.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
[103i386-default-job-18] Installing pkg-1.10.1...
[103i386-default-job-18] Extracting pkg-1.10.1: .......... done
===>   elixir-stemmer-1.0.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of elixir-stemmer-1.0.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by elixir-stemmer-1.0.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by elixir-stemmer-1.0.2 for building
=> SHA256 Checksum OK for fredwu-stemmer-v1.0.2_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by elixir-stemmer-1.0.2 for building
===>  Extracting for elixir-stemmer-1.0.2
=> SHA256 Checksum OK for fredwu-stemmer-v1.0.2_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for elixir-stemmer-1.0.2
===========================================================================
=======================<phase: build-depends  >============================
===>   elixir-stemmer-1.0.2 depends on executable: elixir - not found
===>   Installing existing package /packages/All/elixir-1.4.5_1.txz
[103i386-default-job-18] Installing elixir-1.4.5_1...
[103i386-default-job-18] `-- Installing erlang-19.3.6.2,4...
[103i386-default-job-18] `-- Extracting erlang-19.3.6.2,4: .......... done
[103i386-default-job-18] Extracting elixir-1.4.5_1: .......... done
Message from erlang-19.3.6.2,4:
===========================================================================
Installation tips:

You can find an emacs mode for Erlang here:

    /usr/local/lib/erlang/lib/tools-2.9.1/emacs

===========================================================================
===>   elixir-stemmer-1.0.2 depends on executable: elixir - found
===>   Returning to build of elixir-stemmer-1.0.2
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for elixir-stemmer-1.0.2
===========================================================================
=======================<phase: build          >============================
===>  Building for elixir-stemmer-1.0.2
** (Mix) You're trying to run :stemmer on Elixir v1.4.5 but it has declared in 
its mix.exs file it supports only Elixir ~> 1.5
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/elixir-stemmer
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to