You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     r...@freebsd.org
Last committer: swi...@freebsd.org
Ident:          $FreeBSD: head/textproc/rubygem-compass-rails/Makefile 414136 
2016-04-27 21:57:31Z swills $
Log URL:        
http://beefy10.nyi.freebsd.org/data/110i386-default/447436/logs/rubygem-compass-rails-3.0.2.log
Build URL:      
http://beefy10.nyi.freebsd.org/build.html?mastername=110i386-default&build=447436
Log:

====>> Building textproc/rubygem-compass-rails
build started at Sun Aug  6 03:29:13 UTC 2017
port directory: /usr/ports/textproc/rubygem-compass-rails
building for: FreeBSD 110i386-default-job-15 11.0-RELEASE-p11 FreeBSD 
11.0-RELEASE-p11 i386
maintained by: r...@freebsd.org
Makefile ident:      $FreeBSD: head/textproc/rubygem-compass-rails/Makefile 
414136 2016-04-27 21:57:31Z swills $
Poudriere version: 3.1.19-61-ga8829ba9
Host OSVERSION: 1200033
Jail OSVERSION: 1100122
Job Id: 15

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1100122
UNAME_v=FreeBSD 11.0-RELEASE-p11
UNAME_r=11.0-RELEASE-p11
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=rubygem-compass-rails-3.0.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/110i386-default/ref/.p/pool
MASTERNAME=110i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.19-61-ga8829ba9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work  
HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work  
HOME=/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work TMPDIR="/tmp" 
NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" 
LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing " 
 MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.3"
RUBY_ARCHLIBDIR="lib/ruby/2.3/i386-freebsd11"
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.3"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.3/i386-freebsd11"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.3"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.3/i386-freebsd11"
RUBY_MODDOCDIR="share/doc/ruby23/compass-rails"
RUBY_MODEXAMPLESDIR="share/examples/ruby23/compass-rails"
RUBY_DOCDIR="share/doc/ruby23"
RUBY_EXAMPLESDIR="share/examples/ruby23"
RUBY_RIDIR="share/ri/2.3/system"
RUBY_SITERIDIR="share/ri/2.3/site"
RUBY_VERSION="2.3.4"
RUBY_VER="2.3"
RUBY_SHLIBVER="23"
RUBY_ARCH="i386-freebsd11"
RUBY_SUFFIX="23"
RUBY_NAME="ruby23"
RUBY_DEFAULT_SUFFIX="23"
RUBY22="@comment
"
RUBY23=""
RUBY24="@comment
"
PORTVERSION="3.0.2"
REV=""
GEMS_BASE_DIR="lib/ruby/gems/2.3"
GEMS_DIR="lib/ruby/gems/2.3/gems"
DOC_DIR="lib/ruby/gems/2.3/doc"
CACHE_DIR="lib/ruby/gems/2.3/cache"
SPEC_DIR="lib/ruby/gems/2.3/specifications"
EXT_DIR="lib/ruby/gems/2.3/extensions"
PORT="compass-rails-3.0.2"
GEM_NAME="compass-rails-3.0.2"
GEM_LIB_DIR="lib/ruby/gems/2.3/gems/compass-rails-3.0.2"
GEM_DOC_DIR="lib/ruby/gems/2.3/doc/compass-rails-3.0.2"
GEM_SPEC="lib/ruby/gems/2.3/specifications/compass-rails-3.0.2.gemspec"
GEM_CACHE="lib/ruby/gems/2.3/cache/compass-rails-3.0.2.gem"
EXTRACT_SUFX=".gem"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/compass-rails"
EXAMPLESDIR="share/examples/compass-rails"
DATADIR="share/compass-rails"
WWWDIR="www/compass-rails"
ETCDIR="etc/compass-rails"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/compass-rails
DOCSDIR=/usr/local/share/doc/compass-rails
EXAMPLESDIR=/usr/local/share/examples/compass-rails
WWWDIR=/usr/local/www/compass-rails
ETCDIR=/usr/local/etc/compass-rails
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=i386
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=11.0
OSVERSION=1100122
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk|oracle|sun
_JAVA_VERSION_LIST_REGEXP=1.6|1.7|1.8|1.6\+|1.7\+|1.8\+
_OSRELEASE=11.0-RELEASE-p11
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
[110i386-default-job-15] Installing pkg-1.10.1...
[110i386-default-job-15] Extracting pkg-1.10.1: .......... done
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rubygem-compass-rails-3.0.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by rubygem-compass-rails-3.0.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by rubygem-compass-rails-3.0.2 for building
=> SHA256 Checksum OK for rubygem/compass-rails-3.0.2.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/ruby23 - not 
found
<snip>
[110i386-default-job-15] Installing ruby-2.3.4_2,1...
[110i386-default-job-15] `-- Installing libedit-3.1.20170329_2,1...
[110i386-default-job-15] `-- Extracting libedit-3.1.20170329_2,1: .......... 
done
[110i386-default-job-15] `-- Installing libffi-3.2.1...
[110i386-default-job-15] |   `-- Installing indexinfo-0.2.6...
[110i386-default-job-15] |   `-- Extracting indexinfo-0.2.6: .... done
[110i386-default-job-15] `-- Extracting libffi-3.2.1: .......... done
[110i386-default-job-15] `-- Installing libunwind-20170113_1...
[110i386-default-job-15] `-- Extracting libunwind-20170113_1: .......... done
[110i386-default-job-15] `-- Installing libyaml-0.1.6_2...
[110i386-default-job-15] `-- Extracting libyaml-0.1.6_2: ......... done
[110i386-default-job-15] Extracting ruby-2.3.4_2,1: .......... done
Message from ruby-2.3.4_2,1:
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/ruby23 - 
found
===>   Returning to build of rubygem-compass-rails-3.0.2
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/gem23 - not 
found
===>   Installing existing package /packages/All/ruby23-gems-2.6.12.txz
[110i386-default-job-15] Installing ruby23-gems-2.6.12...
[110i386-default-job-15] Extracting ruby23-gems-2.6.12: .......... done
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/gem23 - found
===>   Returning to build of rubygem-compass-rails-3.0.2
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by rubygem-compass-rails-3.0.2 for building
===>  Extracting for rubygem-compass-rails-3.0.2
=> SHA256 Checksum OK for rubygem/compass-rails-3.0.2.gem.
Unpacked gem: 
'/wrkdirs/usr/ports/textproc/rubygem-compass-rails/work/compass-rails-3.0.2'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/ruby23 - 
found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-compass-rails-3.0.2
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/ruby23 - 
found
===>   rubygem-compass-rails-3.0.2 depends on file: /usr/local/bin/gem23 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-compass-rails-3.0.2
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-compass-rails-3.0.2
  Successfully built RubyGem
  Name: compass-rails
  Version: 3.0.2
  File: compass-rails-3.0.2.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-compass-rails-3.0.2 depends on package: rubygem-compass>=1.0.0 - 
not found
===>   Installing existing package /packages/All/rubygem-compass-1.0.3_1.txz
[110i386-default-job-15] Installing rubygem-compass-1.0.3_1...
[110i386-default-job-15] `-- Installing rubygem-chunky_png-1.3.8...
[110i386-default-job-15] `-- Extracting rubygem-chunky_png-1.3.8: .......... 
done
[110i386-default-job-15] `-- Installing rubygem-compass-core-1.0.3_1...
[110i386-default-job-15] |   `-- Installing rubygem-multi_json-1.12.1...
[110i386-default-job-15] |   | `-- Installing rubygem-json_pure-2.1.0...
[110i386-default-job-15] |   | `-- Extracting rubygem-json_pure-2.1.0: 
.......... done
[110i386-default-job-15] |   `-- Extracting rubygem-multi_json-1.12.1: 
.......... done
[110i386-default-job-15] |   `-- Installing rubygem-sass34-3.4.25...
[110i386-default-job-15] |   `-- Extracting rubygem-sass34-3.4.25: .......... 
done
[110i386-default-job-15] `-- Extracting rubygem-compass-core-1.0.3_1: 
.......... done
[110i386-default-job-15] `-- Installing rubygem-compass-import-once-1.0.5_1...
[110i386-default-job-15] `-- Extracting rubygem-compass-import-once-1.0.5_1: 
.......... done
[110i386-default-job-15] `-- Installing rubygem-rb-fsevent-0.10.2...
[110i386-default-job-15] `-- Extracting rubygem-rb-fsevent-0.10.2: .......... 
done
[110i386-default-job-15] `-- Installing rubygem-rb-inotify-0.9.10...
[110i386-default-job-15] |   `-- Installing libinotify-20170711_1...
[110i386-default-job-15] |   `-- Extracting libinotify-20170711_1: .......... 
done
[110i386-default-job-15] |   `-- Installing rubygem-ffi-1.9.18...
[110i386-default-job-15] |   `-- Extracting rubygem-ffi-1.9.18: .......... done
[110i386-default-job-15] `-- Extracting rubygem-rb-inotify-0.9.10: .......... 
done
[110i386-default-job-15] Extracting rubygem-compass-1.0.3_1: .......... done
Message from libinotify-20170711_1:
============================================================================

Libinotify functionality on FreeBSD is missing support for

  - detecting a file being moved into or out of a directory within the
    same filesystem
  - certain modifications to a symbolic link (rather than the
    file it points to.)

in addition to the known limitations on all platforms using kqueue(2)
where various open and close notifications are unimplemented.

This means the following regression tests will fail:

Directory notifications:
   IN_MOVED_FROM
   IN_MOVED_TO

Open/close notifications:
   IN_OPEN
   IN_CLOSE_NOWRITE
   IN_CLOSE_WRITE

Symbolic Link notifications:
   IN_DONT_FOLLOW
   IN_ATTRIB
   IN_MOVE_SELF
   IN_DELETE_SELF

Kernel patches to address the missing directory and symbolic link
notifications are available from:

https://github.com/libinotify-kqueue/libinotify-kqueue/tree/master/patches

=============================================================================
You might want to consider increasing the kern.maxfiles tunable if you plan
to use this library for applications that need to monitor activity of a lot
of files.

If the default on your system is too low, add the following line to
/boot/loader.conf, then reboot the system:

    kern.maxfiles="25000"
=============================================================================
===>   rubygem-compass-rails-3.0.2 depends on package: rubygem-compass>=1.0.0 - 
found
===>   Returning to build of rubygem-compass-rails-3.0.2
===>   rubygem-compass-rails-3.0.2 depends on package: rubygem-sass-rails5>=0 - 
not found
===>   Installing existing package /packages/All/rubygem-sass-rails5-5.0.6.txz
[110i386-default-job-15] Installing rubygem-sass-rails5-5.0.6...
[110i386-default-job-15] `-- Installing rubygem-railties4-4.2.9...
[110i386-default-job-15] |   `-- Installing rubygem-actionpack4-4.2.9_1...
[110i386-default-job-15] |   | `-- Installing rubygem-actionview4-4.2.9...
[110i386-default-job-15] |   |   `-- Installing rubygem-activesupport4-4.2.9...
[110i386-default-job-15] |   |   | `-- Installing rubygem-i18n-0.8.6,2...
[110i386-default-job-15] |   |   | `-- Extracting rubygem-i18n-0.8.6,2: 
.......... done
[110i386-default-job-15] |   |   | `-- Installing rubygem-minitest-5.10.3...
[110i386-default-job-15] |   |   | `-- Extracting rubygem-minitest-5.10.3: 
.......... done
[110i386-default-job-15] |   |   | `-- Installing rubygem-thread_safe-0.3.6...
[110i386-default-job-15] |   |   | `-- Extracting rubygem-thread_safe-0.3.6: 
.......... done
[110i386-default-job-15] |   |   | `-- Installing rubygem-tzinfo-1.2.3...
[110i386-default-job-15] |   |   | `-- Extracting rubygem-tzinfo-1.2.3: 
.......... done
[110i386-default-job-15] |   |   `-- Extracting rubygem-activesupport4-4.2.9: 
.......... done
[110i386-default-job-15] |   |   `-- Installing rubygem-builder-3.2.3...
[110i386-default-job-15] |   |   `-- Extracting rubygem-builder-3.2.3: 
.......... done
[110i386-default-job-15] |   |   `-- Installing rubygem-erubis-2.7.0_1...
[110i386-default-job-15] |   |   `-- Extracting rubygem-erubis-2.7.0_1: 
.......... done
[110i386-default-job-15] |   |   `-- Installing 
rubygem-rails-dom-testing1-1.0.8...
[110i386-default-job-15] |   |   | `-- Installing rubygem-nokogiri-1.8.0_1...
[110i386-default-job-15] |   |   |   `-- Installing libgcrypt-1.8.0...
[110i386-default-job-15] |   |   |   | `-- Installing libgpg-error-1.27...
[110i386-default-job-15] |   |   |   |   `-- Installing 
gettext-runtime-0.19.8.1_1...
[110i386-default-job-15] |   |   |   |   `-- Extracting 
gettext-runtime-0.19.8.1_1: .......... done
[110i386-default-job-15] |   |   |   | `-- Extracting libgpg-error-1.27: 
.......... done
[110i386-default-job-15] |   |   |   `-- Extracting libgcrypt-1.8.0: .......... 
done
[110i386-default-job-15] |   |   |   `-- Installing libxml2-2.9.4...
[110i386-default-job-15] |   |   |   `-- Extracting libxml2-2.9.4: .......... 
done
[110i386-default-job-15] |   |   |   `-- Installing libxslt-1.1.29_1...
[110i386-default-job-15] |   |   |   `-- Extracting libxslt-1.1.29_1: 
.......... done
[110i386-default-job-15] |   |   |   `-- Installing rubygem-pkg-config-1.2.3...
[110i386-default-job-15] |   |   |   `-- Extracting rubygem-pkg-config-1.2.3: 
.......... done
[110i386-default-job-15] |   |   | `-- Extracting rubygem-nokogiri-1.8.0_1: 
.......... done
[110i386-default-job-15] |   |   | `-- Installing 
rubygem-rails-deprecated_sanitizer-1.0.3...
[110i386-default-job-15] |   |   | `-- Extracting 
rubygem-rails-deprecated_sanitizer-1.0.3: .......... done
[110i386-default-job-15] |   |   `-- Extracting 
rubygem-rails-dom-testing1-1.0.8: .......... done
[110i386-default-job-15] |   |   `-- Installing 
rubygem-rails-html-sanitizer-1.0.3...
[110i386-default-job-15] |   |   | `-- Installing rubygem-loofah-2.0.3...
[110i386-default-job-15] |   |   | `-- Extracting rubygem-loofah-2.0.3: 
.......... done
[110i386-default-job-15] |   |   `-- Extracting 
rubygem-rails-html-sanitizer-1.0.3: .......... done
[110i386-default-job-15] |   | `-- Extracting rubygem-actionview4-4.2.9: 
.......... done
[110i386-default-job-15] |   | `-- Installing rubygem-rack-test-0.7.0...
[110i386-default-job-15] |   |   `-- Installing rubygem-rack16-1.6.8...
[110i386-default-job-15] |   |   `-- Extracting rubygem-rack16-1.6.8: 
.......... done
[110i386-default-job-15] |   | `-- Extracting rubygem-rack-test-0.7.0: 
.......... done
[110i386-default-job-15] |   `-- Extracting rubygem-actionpack4-4.2.9_1: 
.......... done
[110i386-default-job-15] |   `-- Installing rubygem-rake-12.0.0_1...
[110i386-default-job-15] |   `-- Extracting rubygem-rake-12.0.0_1: .......... 
done
[110i386-default-job-15] |   `-- Installing rubygem-thor-0.19.4...
[110i386-default-job-15] |   `-- Extracting rubygem-thor-0.19.4: .......... done
[110i386-default-job-15] `-- Extracting rubygem-railties4-4.2.9: .......... done
[110i386-default-job-15] `-- Installing rubygem-sass-3.5.1...
[110i386-default-job-15] |   `-- Installing rubygem-sass-listen-4.0.0...
[110i386-default-job-15] |   `-- Extracting rubygem-sass-listen-4.0.0: 
.......... done
pkg-static: rubygem-sass-3.5.1 conflicts with rubygem-sass34-3.4.25 (installs 
files into the same place).  Problematic file: /usr/local/bin/sass

Failed to install the following 1 package(s): 
/packages/All/rubygem-sass-rails5-5.0.6.txz
*** Error code 70

Stop.
make: stopped in /usr/ports/textproc/rubygem-compass-rails
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to