You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: r...@freebsd.org
Ident:          $FreeBSD: branches/2017Q3/graphics/pygts/Makefile 422694 
2016-09-23 20:21:37Z rm $
Log URL:        
http://beefy15.nyi.freebsd.org/data/110armv6-quarterly/447639/logs/pygts-0.3.1_5.log
Build URL:      
http://beefy15.nyi.freebsd.org/build.html?mastername=110armv6-quarterly&build=447639
Log:

====>> Building graphics/pygts
build started at Thu Aug 10 09:08:46 UTC 2017
port directory: /usr/ports/graphics/pygts
building for: FreeBSD 110armv6-quarterly-job-12 11.0-RELEASE-p11 FreeBSD 
11.0-RELEASE-p11 1100122 arm
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: branches/2017Q3/graphics/pygts/Makefile 422694 
2016-09-23 20:21:37Z rm $
Poudriere version: 3.1.19-61-ga8829ba9
Host OSVERSION: 1200033
Jail OSVERSION: 1100122
Job Id: 12

---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100122
UNAME_v=FreeBSD 11.0-RELEASE-p11 1100122
UNAME_r=11.0-RELEASE-p11
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110armv6-quarterly/ref
QEMU_EMULATING=1
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=pygts-0.3.1_5
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/110armv6-quarterly/ref/.p/pool
MASTERNAME=110armv6-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.19-61-ga8829ba9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/pygts/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/pygts/work  
HOME=/wrkdirs/usr/ports/graphics/pygts/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/pygts/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/pygts/work  
HOME=/wrkdirs/usr/ports/graphics/pygts/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LDSHARED="/nxb-bin/usr/bin/cc -shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe  -fno-strict-aliasing"  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_PYOEXTENSION=pyo
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_SUFFIX=27
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
PYTHON2=""
PYTHON3="@comment
"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/pygts"
EXAMPLESDIR="share/examples/pygts"
DATADIR="share/pygts"
WWWDIR="www/pygts"
ETCDIR="etc/pygts"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pygts
DOCSDIR=/usr/local/share/doc/pygts
EXAMPLESDIR=/usr/local/share/examples/pygts
WWWDIR=/usr/local/www/pygts
ETCDIR=/usr/local/etc/pygts
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=armv6
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=11.0
OSVERSION=1100122
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native\|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
_OSRELEASE=11.0-RELEASE-p11
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>   NOTICE:

The pygts port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===>  License GPLv2+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   pygts-0.3.1_5 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-12] Installing pkg-1.10.1...
[110armv6-quarterly-job-12] Extracting pkg-1.10.1: .......... done
===>   pygts-0.3.1_5 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of pygts-0.3.1_5
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

The pygts port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by pygts-0.3.1_5 for building
===========================================================================
=======================<phase: checksum       >============================
===>   NOTICE:

The pygts port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by pygts-0.3.1_5 for building
=> SHA256 Checksum OK for pygts-0.3.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>   NOTICE:

The pygts port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port

===>  License GPLv2+ accepted by the user
===> Fetching all distfiles required by pygts-0.3.1_5 for building
===>  Extracting for pygts-0.3.1_5
=> SHA256 Checksum OK for pygts-0.3.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for pygts-0.3.1_5
===========================================================================
=======================<phase: build-depends  >============================
===>   pygts-0.3.1_5 depends on file: 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py - not found
===>   Installing existing package /packages/All/py27-numpy-1.11.2_3,1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-12] Installing py27-numpy-1.11.2_3,1...
[110armv6-quarterly-job-12] `-- Installing blas-3.5.0_3...
[110armv6-quarterly-job-12] |   `-- Installing gcc5-5.4.0_3...
[110armv6-quarterly-job-12] |   | `-- Installing binutils-2.28,1...
[110armv6-quarterly-job-12] |   |   `-- Installing gettext-runtime-0.19.8.1_1...
[110armv6-quarterly-job-12] |   |   | `-- Installing indexinfo-0.2.6...
[110armv6-quarterly-job-12] |   |   | `-- Extracting indexinfo-0.2.6: .... done
[110armv6-quarterly-job-12] |   |   `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[110armv6-quarterly-job-12] |   | `-- Extracting binutils-2.28,1: .......... 
done
[110armv6-quarterly-job-12] |   | `-- Installing gmp-6.1.2...
[110armv6-quarterly-job-12] |   | `-- Extracting gmp-6.1.2: .......... done
[110armv6-quarterly-job-12] |   | `-- Installing mpc-1.0.3...
[110armv6-quarterly-job-12] |   |   `-- Installing mpfr-3.1.5_1...
[110armv6-quarterly-job-12] |   |   `-- Extracting mpfr-3.1.5_1: .......... done
[110armv6-quarterly-job-12] |   | `-- Extracting mpc-1.0.3: ...... done
[110armv6-quarterly-job-12] |   `-- Extracting gcc5-5.4.0_3: .......... done
[110armv6-quarterly-job-12] `-- Extracting blas-3.5.0_3: ....... done
[110armv6-quarterly-job-12] `-- Installing cblas-1.0_6...
[110armv6-quarterly-job-12] `-- Extracting cblas-1.0_6: ......... done
[110armv6-quarterly-job-12] `-- Installing lapack-3.5.0_2...
[110armv6-quarterly-job-12] `-- Extracting lapack-3.5.0_2: .......... done
[110armv6-quarterly-job-12] `-- Installing py27-setuptools-36.0.1...
[110armv6-quarterly-job-12] |   `-- Installing python27-2.7.13_6...
[110armv6-quarterly-job-12] |   | `-- Installing libffi-3.2.1...
[110armv6-quarterly-job-12] |   | `-- Extracting libffi-3.2.1: .......... done
[110armv6-quarterly-job-12] |   | `-- Installing readline-7.0.3...
[110armv6-quarterly-job-12] |   | `-- Extracting readline-7.0.3: .......... done
[110armv6-quarterly-job-12] |   `-- Extracting python27-2.7.13_6: .......... 
done
[110armv6-quarterly-job-12] `-- Extracting py27-setuptools-36.0.1: .......... 
done
[110armv6-quarterly-job-12] `-- Installing suitesparse-4.0.2_6...
[110armv6-quarterly-job-12] |   `-- Installing openblas-0.2.19_1,1...
[110armv6-quarterly-job-12] |   `-- Extracting openblas-0.2.19_1,1: ......... 
done
[110armv6-quarterly-job-12] `-- Extracting suitesparse-4.0.2_6: .......... done
[110armv6-quarterly-job-12] Extracting py27-numpy-1.11.2_3,1: .......... done
Message from gcc5-5.4.0_3:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc5

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
Message from cblas-1.0_6:
===>   NOTICE:

The cblas port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
Message from python27-2.7.13_6:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   pygts-0.3.1_5 depends on file: 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py - found
===>   Returning to build of pygts-0.3.1_5
===>   pygts-0.3.1_5 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-1.3.7,1.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-12] Installing pkgconf-1.3.7,1...
[110armv6-quarterly-job-12] Extracting pkgconf-1.3.7,1: .......... done
===>   pygts-0.3.1_5 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of pygts-0.3.1_5
===>   pygts-0.3.1_5 depends on package: py27-setuptools>0 - found
===>   pygts-0.3.1_5 depends on file: /usr/local/bin/python2.7 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   pygts-0.3.1_5 depends on shared library: libgts.so - not found
===>   Installing existing package /packages/All/gts-0.7.6_4.txz
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static 
install -f pkg" recommended
[110armv6-quarterly-job-12] Installing gts-0.7.6_4...
[110armv6-quarterly-job-12] `-- Installing glib-2.50.2_3,1...
[110armv6-quarterly-job-12] |   `-- Installing libiconv-1.14_10...
[110armv6-quarterly-job-12] |   `-- Extracting libiconv-1.14_10: .......... done
[110armv6-quarterly-job-12] |   `-- Installing pcre-8.40_1...
[110armv6-quarterly-job-12] |   `-- Extracting pcre-8.40_1: .......... done
[110armv6-quarterly-job-12] |   `-- Installing perl5-5.24.1_1...
[110armv6-quarterly-job-12] |   `-- Extracting perl5-5.24.1_1: .......... done
/usr/local/lib/perl5/site_perl/man//mandoc.db: unlink: No such file or directory
[110armv6-quarterly-job-12] `-- Extracting glib-2.50.2_3,1: .......... done
No schema files found: doing nothing.
[110armv6-quarterly-job-12] Extracting gts-0.7.6_4: .......... done
Message from perl5-5.24.1_1:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   pygts-0.3.1_5 depends on shared library: libgts.so - found 
(/usr/local/lib/libgts.so)
===>   Returning to build of pygts-0.3.1_5
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for pygts-0.3.1_5
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 37, in <module>
    import numpy, numpy.distutils
  File "/usr/local/lib/python2.7/site-packages/numpy/__init__.py", line 142, in 
<module>
    from . import add_newdocs
  File "/usr/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, 
in <module>
    from numpy.lib import add_newdoc
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 8, 
in <module>
    from .type_check import *
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/type_check.py", line 
11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/local/lib/python2.7/site-packages/numpy/core/__init__.py", line 
14, in <module>
    from . import multiarray
ImportError: /usr/local/lib/gcc5/libgfortran.so.3: Undefined symbol 
"__aeabi_ldivmod"
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/pygts
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to