You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     t...@niemueller.de
Last committer: tcber...@freebsd.org
Ident:          $FreeBSD: branches/2017Q3/devel/yaml-cpp03/Makefile 422359 
2016-09-18 09:07:36Z tcberner $
Log URL:        
http://beefy16.nyi.freebsd.org/data/110mips64-quarterly/447785/logs/yaml-cpp03-0.3.0.log
Build URL:      
http://beefy16.nyi.freebsd.org/build.html?mastername=110mips64-quarterly&build=447785
Log:

====>> Building devel/yaml-cpp03
build started at Sat Aug 12 05:25:09 UTC 2017
port directory: /usr/ports/devel/yaml-cpp03
building for: FreeBSD 110mips64-quarterly-job-26 11.0-RELEASE-p12 FreeBSD 
11.0-RELEASE-p12 1100122 mips
maintained by: t...@niemueller.de
Makefile ident:      $FreeBSD: branches/2017Q3/devel/yaml-cpp03/Makefile 422359 
2016-09-18 09:07:36Z tcberner $
Poudriere version: 3.1.19-61-ga8829ba9
Host OSVERSION: 1200033
Jail OSVERSION: 1100122
Job Id: 26

---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips64
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100122
UNAME_v=FreeBSD 11.0-RELEASE-p12 1100122
UNAME_r=11.0-RELEASE-p12
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/110mips64-quarterly/ref
QEMU_EMULATING=1
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=yaml-cpp03-0.3.0
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/110mips64-quarterly/ref/.p/pool
MASTERNAME=110mips64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.19-61-ga8829ba9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work  
HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work  
HOME=/wrkdirs/usr/ports/devel/yaml-cpp03/work TMPDIR="/tmp" NO_PIE=yes 
MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
DESTDIR=/wrkdirs/usr/ports/devel/yaml-cpp03/work/stage PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe -G0  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  
LDFLAGS="" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/yaml-cpp"
EXAMPLESDIR="share/examples/yaml-cpp"
DATADIR="share/yaml-cpp"
WWWDIR="www/yaml-cpp"
ETCDIR="etc/yaml-cpp"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/yaml-cpp
DOCSDIR=/usr/local/share/doc/yaml-cpp
EXAMPLESDIR=/usr/local/share/examples/yaml-cpp
WWWDIR=/usr/local/www/yaml-cpp
ETCDIR=/usr/local/etc/yaml-cpp
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
MACHINE=mips
MACHINE_ARCH=mips64
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=mips64
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=11.0
OSVERSION=1100122
PYTHONBASE=/usr/local
UID=0
_JAVA_OS_LIST_REGEXP=native\|linux
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
_OSRELEASE=11.0-RELEASE-p12
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  131072
stack size              (kbytes, -s)  8192
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   yaml-cpp03-0.3.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.1.txz
[110mips64-quarterly-job-26] Installing pkg-1.10.1...
[110mips64-quarterly-job-26] Extracting pkg-1.10.1: .......... done
===>   yaml-cpp03-0.3.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of yaml-cpp03-0.3.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by yaml-cpp03-0.3.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by yaml-cpp03-0.3.0 for building
=> SHA256 Checksum OK for jbeder-yaml-cpp-release-0.3.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by yaml-cpp03-0.3.0 for building
===>  Extracting for yaml-cpp03-0.3.0
=> SHA256 Checksum OK for jbeder-yaml-cpp-release-0.3.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for yaml-cpp03-0.3.0
===>  Applying FreeBSD patches for yaml-cpp03-0.3.0
===========================================================================
=======================<phase: build-depends  >============================
===>   yaml-cpp03-0.3.0 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.8.2.txz
[110mips64-quarterly-job-26] Installing cmake-3.8.2...
[110mips64-quarterly-job-26] `-- Installing cmake-modules-3.8.2...
[110mips64-quarterly-job-26] `-- Extracting cmake-modules-3.8.2: .......... done
[110mips64-quarterly-job-26] `-- Installing curl-7.55.0...
[110mips64-quarterly-job-26] |   `-- Installing ca_root_nss-3.32...
[110mips64-quarterly-job-26] |   `-- Extracting ca_root_nss-3.32: ........ done
[110mips64-quarterly-job-26] |   `-- Installing libnghttp2-1.23.1...
[110mips64-quarterly-job-26] |   `-- Extracting libnghttp2-1.23.1: .......... 
done
[110mips64-quarterly-job-26] `-- Extracting curl-7.55.0: .......... done
[110mips64-quarterly-job-26] `-- Installing expat-2.2.1...
[110mips64-quarterly-job-26] `-- Extracting expat-2.2.1: .......... done
[110mips64-quarterly-job-26] `-- Installing jsoncpp-1.8.1...
[110mips64-quarterly-job-26] `-- Extracting jsoncpp-1.8.1: .......... done
[110mips64-quarterly-job-26] `-- Installing libarchive-3.3.1,1...
[110mips64-quarterly-job-26] |   `-- Installing liblz4-1.7.5,1...
[110mips64-quarterly-job-26] |   `-- Extracting liblz4-1.7.5,1: .......... done
[110mips64-quarterly-job-26] |   `-- Installing lzo2-2.10_1...
[110mips64-quarterly-job-26] |   `-- Extracting lzo2-2.10_1: .......... done
[110mips64-quarterly-job-26] `-- Extracting libarchive-3.3.1,1: .......... done
[110mips64-quarterly-job-26] `-- Installing libuv-1.12.0...
[110mips64-quarterly-job-26] `-- Extracting libuv-1.12.0: .......... done
[110mips64-quarterly-job-26] `-- Installing rhash-1.3.4...
[110mips64-quarterly-job-26] `-- Extracting rhash-1.3.4: .......... done
[110mips64-quarterly-job-26] Extracting cmake-3.8.2: .......... done
Message from ca_root_nss-3.32:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   yaml-cpp03-0.3.0 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of yaml-cpp03-0.3.0
===>   yaml-cpp03-0.3.0 depends on executable: ninja - not found
===>   Installing existing package /packages/All/ninja-1.7.2,2.txz
[110mips64-quarterly-job-26] Installing ninja-1.7.2,2...
[110mips64-quarterly-job-26] `-- Installing python27-2.7.13_6...
[110mips64-quarterly-job-26] |   `-- Installing gettext-runtime-0.19.8.1_1...
[110mips64-quarterly-job-26] |   | `-- Installing indexinfo-0.2.6...
[110mips64-quarterly-job-26] |   | `-- Extracting indexinfo-0.2.6: .... done
[110mips64-quarterly-job-26] |   `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[110mips64-quarterly-job-26] |   `-- Installing libffi-3.2.1...
[110mips64-quarterly-job-26] |   `-- Extracting libffi-3.2.1: .......... done
[110mips64-quarterly-job-26] |   `-- Installing readline-7.0.3...
[110mips64-quarterly-job-26] |   `-- Extracting readline-7.0.3: .......... done
[110mips64-quarterly-job-26] `-- Extracting python27-2.7.13_6: .......... done
[110mips64-quarterly-job-26] Extracting ninja-1.7.2,2: ....... done
Message from python27-2.7.13_6:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   yaml-cpp03-0.3.0 depends on executable: ninja - found
===>   Returning to build of yaml-cpp03-0.3.0
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for yaml-cpp03-0.3.0
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/devel/yaml-cpp03/work/yaml-cpp-release-0.3.0
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Performing Test FLAG_WEXTRA
-- Performing Test FLAG_WEXTRA - Success
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_COLOR_MAKEFILE
    CMAKE_C_FLAGS_DEBUG
    CMAKE_C_FLAGS_RELEASE
    CMAKE_EXE_LINKER_FLAGS
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_VERBOSE_MAKEFILE
    THREADS_HAVE_PTHREAD_ARG


-- Build files have been written to: 
/wrkdirs/usr/ports/devel/yaml-cpp03/work/yaml-cpp-release-0.3.0
===========================================================================
=======================<phase: build          >============================
===>  Building for yaml-cpp03-0.3.0
ninja: error: build.ninja:381: bad $-escape (literal $ must be written as $$)

*** Error code 1

Stop.
make: stopped in /usr/ports/devel/yaml-cpp03
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to