You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     y...@rawbw.com
Last committer: ult...@freebsd.org
Ident:          $FreeBSD: head/audio/x42-plugins-lv2/Makefile 447778 2017-08-11 
17:07:11Z ultima $
Log URL:        
http://beefy12.nyi.freebsd.org/data/head-amd64-default/p459797_s328300/logs/x42-plugins-lv2-20170428.log
Build URL:      
http://beefy12.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p459797_s328300
Log:

=>> Building audio/x42-plugins-lv2
build started at Wed Jan 24 01:32:22 UTC 2018
port directory: /usr/ports/audio/x42-plugins-lv2
package name: x42-plugins-lv2-20170428
building for: FreeBSD head-amd64-default-job-11 12.0-CURRENT FreeBSD 
12.0-CURRENT 1200056 amd64
maintained by: y...@rawbw.com
Makefile ident:      $FreeBSD: head/audio/x42-plugins-lv2/Makefile 447778 
2017-08-11 17:07:11Z ultima $
Poudriere version: 3.2.4
Host OSVERSION: 1200054
Jail OSVERSION: 1200056
Job Id: 11




!!! Jail is newer than host. (Jail: 1200056, Host: 1200054) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1200056
UNAME_v=FreeBSD 12.0-CURRENT 1200056
UNAME_r=12.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
OLDPWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
P_PYTHON_MAJOR_VER=2
POUDRIERE_VERSION=3.2.4
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
y...@rawbw.com
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work  
HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh CMAKE_PREFIX_PATH="/usr/local"
--End CONFIGURE_ENV--

--MAKE_ENV--
BUILDOPENGL=yes BUILDGTK=no LV2DIR=/usr/local/lib/lv2 
MANDIR=/usr/local/man/man1 
XDG_DATA_HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work  
HOME=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -fstack-protector -isystem /usr/local/include -fno-strict-aliasing"  
CPP="cpp" CPPFLAGS="-isystem /usr/local/include"  LDFLAGS=" -fstack-protector" 
LIBS="-L/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 5
 55"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTDOCS="" PORTEXAMPLES="" GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0" 
OSREL=12.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/x42-plugins"  EXAMPLESDIR="share/examples/x42-plugins"  
DATADIR="share/x42-plugins"  WWWDIR="www/x42-plugins"  ETCDIR="etc/x42-plugins"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/x42-plugins 
DOCSDIR=/usr/local/share/doc/x42-plugins 
EXAMPLESDIR=/usr/local/share/examples/x42-plugins  
WWWDIR=/usr/local/www/x42-plugins ETCDIR=/usr/local/etc/x42-plugins
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=amd64
CONFIGURE_MAX_CMD_LEN=262144
HAVE_COMPAT_IA32_KERN=YES
OPSYS=FreeBSD
OSREL=12.0
OSVERSION=1200056
PYTHONBASE=/usr/local
UID=0
_OSRELEASE=12.0-CURRENT
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   x42-plugins-lv2-20170428 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.4.txz
[head-amd64-default-job-11] Installing pkg-1.10.4...
[head-amd64-default-job-11] Extracting pkg-1.10.4: .......... done
===>   x42-plugins-lv2-20170428 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of x42-plugins-lv2-20170428
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by x42-plugins-lv2-20170428 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by x42-plugins-lv2-20170428 for building
=> SHA256 Checksum OK for x42-plugins-20170428.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by x42-plugins-lv2-20170428 for building
===>  Extracting for x42-plugins-lv2-20170428
=> SHA256 Checksum OK for x42-plugins-20170428.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for x42-plugins-lv2-20170428
/usr/bin/sed -i.bak 's/__APPLE__/__FreeBSD__/'  
/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/tuna.lv2/src/spectr.c
  
/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/meters.lv2/src/spectr.c
/usr/bin/sed -i.bak 's|$(mandir)/man1|$(MANDIR)|'  
/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/sisco.lv2/Makefile
===========================================================================
=======================<phase: build-depends  >============================
===>   x42-plugins-lv2-20170428 depends on package: lv2>0 - not found
===>   Installing existing package /packages/All/lv2-1.14.0_1.txz
[head-amd64-default-job-11] Installing lv2-1.14.0_1...
[head-amd64-default-job-11] `-- Installing atk-2.24.0...
[head-amd64-default-job-11] |   `-- Installing gettext-runtime-0.19.8.1_1...
[head-amd64-default-job-11] |   | `-- Installing indexinfo-0.3.1...
[head-amd64-default-job-11] |   | `-- Extracting indexinfo-0.3.1: .... done
[head-amd64-default-job-11] |   `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[head-amd64-default-job-11] |   `-- Installing glib-2.50.2_7,1...
[head-amd64-default-job-11] |   | `-- Installing libffi-3.2.1_2...
[head-amd64-default-job-11] |   | `-- Extracting libffi-3.2.1_2: .......... done
[head-amd64-default-job-11] |   | `-- Installing libiconv-1.14_11...
[head-amd64-default-job-11] |   | `-- Extracting libiconv-1.14_11: .......... 
done
[head-amd64-default-job-11] |   | `-- Installing pcre-8.40_1...
[head-amd64-default-job-11] |   | `-- Extracting pcre-8.40_1: .......... done
[head-amd64-default-job-11] |   | `-- Installing perl5-5.24.3...
[head-amd64-default-job-11] |   | `-- Extracting perl5-5.24.3: .......... done
[head-amd64-default-job-11] |   | `-- Installing python27-2.7.14_1...
[head-amd64-default-job-11] |   |   `-- Installing readline-7.0.3_1...
[head-amd64-default-job-11] |   |   `-- Extracting readline-7.0.3_1: .......... 
done
[head-amd64-default-job-11] |   | `-- Extracting python27-2.7.14_1: .......... 
done
[head-amd64-default-job-11] |   `-- Extracting glib-2.50.2_7,1: .......... done
No schema files found: doing nothing.
[head-amd64-default-job-11] `-- Extracting atk-2.24.0: .......... done
[head-amd64-default-job-11] `-- Installing cairo-1.14.8_1,2...
[head-amd64-default-job-11] |   `-- Installing dri2proto-2.8...
[head-amd64-default-job-11] |   `-- Extracting dri2proto-2.8: .... done
[head-amd64-default-job-11] |   `-- Installing fontconfig-2.12.1,1...
[head-amd64-default-job-11] |   | `-- Installing expat-2.2.5...
[head-amd64-default-job-11] |   | `-- Extracting expat-2.2.5: .......... done
[head-amd64-default-job-11] |   | `-- Installing freetype2-2.8_1...
[head-amd64-default-job-11] |   | `-- Extracting freetype2-2.8_1: .......... 
done
[head-amd64-default-job-11] |   `-- Extracting fontconfig-2.12.1,1: .......... 
done
<snip>
  ../robtk/jackwrap.c ../robtk/ui_gl.c ../robtk/pugl/pugl_x11.c   \
  zita-resampler/resampler.cc zita-resampler/resampler-table.cc src/sisco.c \
   -fstack-protector -lm `pkg-config  --libs pangocairo glu gl` -lX11 
`pkg-config  --libs cairo pangocairo pango glu gl`   `pkg-config  --libs jack` 
`pkg-config  --libs liblo`
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
strip -s build/x42-scope
c++ -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -I. `pkg-config --cflags 
glu` -pthread -DHAVE_IDLE_IFACE -I. -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 `pkg-config --cflags 
lv2` -fPIC -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer -O3 
-fno-finite-math-only -DNDEBUG -DVERSION="\"0.7.2\"" `pkg-config --cflags cairo 
pango`  -DUSE_GUI_THREAD \
  -DUINQHACK="151675778160137" \
  -DPLUGIN_SOURCE="\"gui/sisco.c\"" \
  -o build/siscoUI_gl.so ../robtk/ui_gl.c \
  ../robtk/pugl/pugl_x11.c \
  zita-resampler/resampler.cc zita-resampler/resampler-table.cc \
  -shared -Wl,-Bstatic -Wl,-Bdynamic -Wl,--as-needed -pthread  
-fstack-protector -lX11 `pkg-config  --libs cairo pangocairo pango glu gl` 
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
strip -s build/siscoUI_gl.so
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/sisco.lv2'
gmake -C stepseq.lv2 all
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/stepseq.lv2'
Version: 0.4.1 -> 0 4 1 
LV2 Version: 1026 0
test -d .git -a .gitmodules -a -f Makefile.git && gmake -f Makefile.git 
submodule_check
gmake[2]: [Makefile:218: submodule_check] Error 1 (ignored)
sed "s/@LV2NAME@/stepseq/g;s/@URISUFFIX@/s8n8/;s/@LIB_EXT@/.so/" \
  lv2ttl/manifest.ttl.in > build/manifest.ttl
sed 
"s/@LV2NAME@/stepseq/g;s/@URISUFFIX@/s8n8/;s/@LIB_EXT@/.so/;s/@UI_TYPE@/ui:X11UI/;s/@LV2GUI@/stepseqUI_gl/g"
 \
        lv2ttl/manifest.gui.in >> build/manifest.ttl
sed 
"s/@LV2NAME@/stepseq/g;s/@SIGNATURE@//;s/@NAMESUFFIX@/8x8/;s/@URISUFFIX@/s8n8/;s/@VERSION@/lv2:microVersion
 0 ;lv2:minorVersion 1026 ;/g;s/@UITTL@/ui:ui stepseq:ui_gl 
;/;s/@MODBRAND@//;s/@MODLABEL@//;s/@STEPS@/8/" \
        lv2ttl/stepseq.ttl.in > build/stepseq.ttl
./gridgen.sh 8 8 >> build/stepseq.ttl
echo "]; ." >> build/stepseq.ttl
sed 
"s/@LV2NAME@/stepseq/g;s/@URISUFFIX@/s8n8/;s/@UI_TYPE@/ui:X11UI/;s/@UI_REQ@/lv2:requiredFeature
 ui:idleInterface; lv2:extensionData ui:idleInterface;/" \
    lv2ttl/stepseq.gui.in >> build/stepseq.ttl
cc -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DVERSION="\"0.4.1\"" `pkg-config --cflags lv2` -fPIC -fvisibility=hidden 
-DN_NOTES=8 -DN_STEPS=8  -std=c99 \
  -o build/stepseq.so src/stepseq.c \
  -shared -Wl,-Bstatic -Wl,-Bdynamic -Wl,--as-needed -pthread  
-fstack-protector -lm `pkg-config --libs lv2` 
strip -s build/stepseq.so
c++ -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DVERSION="\"0.4.1\"" `pkg-config --cflags lv2` -fPIC -fvisibility=hidden 
-DN_NOTES=8 -DN_STEPS=8 -I. `pkg-config --cflags glu` -pthread 
-DHAVE_IDLE_IFACE `pkg-config --cflags cairo pango` -O2 -pipe  
-fstack-protector -isystem /usr/local/include -fno-strict-aliasing 
-DHAVE_LV2_1_8 -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer -O3 
-fno-finite-math-only -DVERSION="\"0.4.1\"" `pkg-config --cflags lv2` -fPIC 
-fvisibility=hidden -DN_NOTES=8 -DN_STEPS=8  \
  -DUINQHACK="151675779067489" \
  -DPLUGIN_SOURCE="\"gui/stepseq.c\"" \
  -o build/stepseqUI_gl.so ../robtk/ui_gl.c \
  ../robtk/pugl/pugl_x11.c \
   \
  -shared -Wl,-Bstatic -Wl,-Bdynamic -Wl,--as-needed -pthread  
-fstack-protector -lX11 `pkg-config  --libs cairo pango pangocairo glu gl` 
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
strip -s build/stepseqUI_gl.so
c++ -isystem /usr/local/include -I. -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DVERSION="\"0.4.1\"" `pkg-config --cflags lv2` -fPIC -fvisibility=hidden 
-DN_NOTES=8 -DN_STEPS=8  `pkg-config --cflags jack lv2 pango pangocairo glu gl` 
-pthread `pkg-config  --cflags liblo` -DHAVE_LIBLO -DDEFAULT_NOT_ONTOP \
  -DXTERNAL_UI -DHAVE_IDLE_IFACE \
  -DRTK_DESCRIPTOR="lv2ui_descriptor" \
  -DPLUGIN_SOURCE="\"gui/stepseq.c\"" \
  -DJACK_DESCRIPT="\"lv2ttl/stepseq.h\"" \
  -DAPPNAME="\"stepseq\"" \
  -o x42/x42-stepseq \
  ../robtk/jackwrap.c ../robtk/ui_gl.c ../robtk/pugl/pugl_x11.c   \
  src/stepseq.c \
   -fstack-protector -lm -lX11 `pkg-config  --libs cairo pango pangocairo glu 
gl`   -lm `pkg-config --libs lv2` `pkg-config  --libs jack` `pkg-config  --libs 
liblo`
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
strip -s x42/x42-stepseq
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/stepseq.lv2'
gmake -C stereoroute.lv2 all
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/stereoroute.lv2'
Version: 0.1.1 -> 0 1 1 
LV2 Version: 258 0
sed "s/@LV2NAME@/stereoroute/;s/@LIB_EXT@/.so/" \
  manifest.ttl.in > build/manifest.ttl
sed "s/@VERSION@/lv2:microVersion 0 ;lv2:minorVersion 258 ;/g" \
        stereoroute.ttl.in > build/stereoroute.ttl
cc -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -fPIC -std=c99 `pkg-config --cflags 
lv2` \
  -o build/stereoroute.so stereoroute.c \
  -shared -Wl,-Bstatic -Wl,-Bdynamic  -fstack-protector -lm
strip -s build/stereoroute.so
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/stereoroute.lv2'
gmake -C testsignal.lv2 all
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/testsignal.lv2'
Version: 0.4.0 -> 0 4 0 
LV2 Version: 1024 0
sed "s/@LV2NAME@/testsignal/;s/@LIB_EXT@/.so/" \
  manifest.ttl.in > build/manifest.ttl
sed "s/@VERSION@/lv2:microVersion 0 ;lv2:minorVersion 1024 ;/g" \
        testsignal.ttl.in > build/testsignal.ttl
cc -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -fPIC -std=c99 `pkg-config --cflags 
lv2` \
  -o build/testsignal.so testsignal.c \
  -shared -Wl,-Bstatic -Wl,-Bdynamic  -fstack-protector -lm
strip -s build/testsignal.so
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/testsignal.lv2'
gmake -C tuna.lv2 all
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/tuna.lv2'
Version: 0.4.3 -> 0 4 3 
LV2 Version: 1030 0
test -d .git -a .gitmodules -a -f Makefile.git && gmake -f Makefile.git 
submodule_check
gmake[2]: [Makefile:219: submodule_check] Error 1 (ignored)
sed "s/@LV2NAME@/tuna/g;s/@LIB_EXT@/.so/g" \
        lv2ttl/manifest.ttl.in > build/manifest.ttl
sed "s/@INSTANCE@/one/g;s/@LV2NAME@/tuna/g;s/@LIB_EXT@/.so/g" \
    lv2ttl/manifest.lv2.ttl.in >> build/manifest.ttl
sed "s/@INSTANCE@/two/g;s/@LV2NAME@/tuna/g;s/@LIB_EXT@/.so/g" \
    lv2ttl/manifest.lv2.ttl.in >> build/manifest.ttl
sed 
"s/@LV2NAME@/tuna/g;s/@LIB_EXT@/.so/g;s/@UI_TYPE@/ui:X11UI/;s/@LV2GUI@/tunaUI_gl/g"
 \
        lv2ttl/manifest.gui.in >> build/manifest.ttl
sed "s/@LV2NAME@/tuna/g" \
        lv2ttl/tuna.ttl.in > build/tuna.ttl
sed "s/@LV2NAME@/tuna/g;s/@UI_TYPE@/ui:X11UI/;s/@UI_REQ@/ lv2:requiredFeature 
ui:idleInterface; lv2:extensionData ui:idleInterface;/;" \
    lv2ttl/tuna.gui.ttl.in >> build/tuna.ttl
sed "s/@INSTANCE@/one/g;s/@LV2NAME@/tuna/g;s/@NAME_SUFFIX@//g;s/@UITTL@/ui:ui 
tuna:ui_gl 
;/g;s/@MODBRAND@//;s/@MODLABEL@//;s/@SIGNATURE@//;s/@VERSION@/lv2:microVersion 
0 ;lv2:minorVersion 1030 ;/g" \
  lv2ttl/tuna.lv2.ttl.in >> build/tuna.ttl
sed 
"s/@INSTANCE@/two/g;s/@LV2NAME@/tuna/g;s/@NAME_SUFFIX@/[Spectrum]/g;s/@UITTL@/ui:ui
 tuna:ui_gl 
;/g;s/@MODBRAND@//;s/@MODLABEL@//;s/@SIGNATURE@//;s/@VERSION@/lv2:microVersion 
0 ;lv2:minorVersion 1030 ;/g" \
  lv2ttl/tuna.lv2.ttl.in >> build/tuna.ttl
cc -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -g -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DNDEBUG -DVERSION="\"0.4.3\"" `pkg-config --cflags lv2 fftw3f` -fPIC 
-fvisibility=hidden   -std=c99 \
  -o build/tuna.so src/tuna.c \
  -shared -Wl,-Bstatic -Wl,-Bdynamic -Wl,--as-needed -pthread  
-fstack-protector -lm `pkg-config --libs lv2 fftw3f` 
src/tuna.c:806:9: warning: absolute value function 'fabsf' given an argument of 
type 'double' but has parameter of type 'float' which may cause truncation of 
value [-Wabsolute-value]
                                if (fabsf(self->dll_e0 * freq / self->rate) > 
.02) {
                                    ^
src/tuna.c:806:9: note: use function 'fabs' instead
                                if (fabsf(self->dll_e0 * freq / self->rate) > 
.02) {
                                    ^~~~~
                                    fabs
1 warning generated.
strip -s build/tuna.so
c++ -isystem /usr/local/include -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -g -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DNDEBUG -DVERSION="\"0.4.3\"" `pkg-config --cflags lv2 fftw3f` -fPIC 
-fvisibility=hidden -I. `pkg-config --cflags glu` -DHAVE_IDLE_IFACE `pkg-config 
--cflags cairo pango`  \
  -DUINQHACK="151675780475172" \
  -DPLUGIN_SOURCE="\"gui/tuna.c\"" \
  -o build/tunaUI_gl.so ../robtk/ui_gl.c \
  ../robtk/pugl/pugl_x11.c \
   \
  -shared -Wl,-Bstatic -Wl,-Bdynamic -Wl,--as-needed -pthread  
-fstack-protector -lX11 `pkg-config  --libs cairo pango pangocairo glu gl` 
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
strip -s build/tunaUI_gl.so
c++ -isystem /usr/local/include -I. -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -g -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DNDEBUG -DVERSION="\"0.4.3\"" `pkg-config --cflags lv2 fftw3f` -fPIC 
-fvisibility=hidden -O2 -pipe -fstack-protector -isystem /usr/local/include 
-fno-strict-aliasing  -isystem /usr/local/include  `pkg-config --cflags jack 
lv2 pango pangocairo glu gl` -pthread `pkg-config  --cflags liblo` -DHAVE_LIBLO 
\
  -DXTERNAL_UI -DHAVE_IDLE_IFACE -DDEFAULT_NOT_ONTOP \
  -DRTK_DESCRIPTOR="lv2ui_descriptor" \
  -DPLUGIN_SOURCE="\"gui/tuna.c\"" \
  -o x42/x42-tuna.o \
  -c ../robtk/ui_gl.c
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++ -isystem /usr/local/include -I. -O2 -pipe  -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing -DHAVE_LV2_1_8 -g -msse -msse2 
-mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only 
-DNDEBUG -DVERSION="\"0.4.3\"" `pkg-config --cflags lv2 fftw3f` -fPIC 
-fvisibility=hidden -O2 -pipe -fstack-protector -isystem /usr/local/include 
-fno-strict-aliasing  -isystem /usr/local/include  `pkg-config --cflags jack 
lv2 pango pangocairo glu gl` -pthread `pkg-config  --cflags liblo` -DHAVE_LIBLO 
-DDEFAULT_NOT_ONTOP \
  -DXTERNAL_UI -DHAVE_IDLE_IFACE \
  -DJACK_DESCRIPT="\"lv2ttl/plugins.h\"" \
  -DAPPNAME="\"tuna\"" \
  -o x42/x42-tuna-collection \
  ../robtk/jackwrap.c ../robtk/pugl/pugl_x11.c   \
  -DX42_MULTIPLUGIN src/tuna.c x42/x42-tuna.o \
   -fstack-protector -lm -lm `pkg-config --libs lv2 fftw3f` -lX11 `pkg-config  
--libs cairo pango pangocairo glu gl`   `pkg-config  --libs jack` `pkg-config  
--libs liblo`
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
c++: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is 
deprecated [-Wdeprecated]
In file included from src/tuna.c:70:
src/spectr.c:136:32: error: implicit conversion from '_Complex int' to 'double' 
is not permitted in C++
                complex_t p = cos (omega) +  _I * sin (omega);
                                             ^~
src/spectr.c:33:26: note: expanded from macro '_I'
# define _I ((complex_t)(1i))
             ~           ^~
src/spectr.c:148:66: error: implicit conversion from '_Complex int' to 'double' 
is not permitted in C++
                const complex_t u0 = ab_2 + creal(v * -1.) + ab_2 * creal(c) + 
_I * (cimag(v * -1.) + ab_2 * cimag(c));
                                                                               
^~
src/spectr.c:33:26: note: expanded from macro '_I'
# define _I ((complex_t)(1i))
             ~           ^~
src/spectr.c:149:61: error: implicit conversion from '_Complex int' to 'double' 
is not permitted in C++
                const complex_t u1 = ab_2 + creal( v) + ab_2 * creal(c) + _I * 
(cimag( v) + ab_2 * cimag(c));
                                                                          ^~
src/spectr.c:33:26: note: expanded from macro '_I'
# define _I ((complex_t)(1i))
             ~           ^~
src/spectr.c:175:8: error: implicit conversion from '_Complex int' to 'double' 
is not permitted in C++
                          + _I * ((fb->f[i].W[b1] * sin_w) + sin_w2);
                            ^~
src/spectr.c:33:26: note: expanded from macro '_I'
# define _I ((complex_t)(1i))
             ~           ^~
src/spectr.c:177:8: error: implicit conversion from '_Complex int' to 'double' 
is not permitted in C++
                          + _I * ((fb->f[i].W[a1] * sin_w) + fb->f[i].W[a2] * 
sin_w2);
                            ^~
src/spectr.c:33:26: note: expanded from macro '_I'
# define _I ((complex_t)(1i))
             ~           ^~
src/tuna.c:806:9: warning: absolute value function 'fabsf' given an argument of 
type 'double' but has parameter of type 'float' which may cause truncation of 
value [-Wabsolute-value]
                                if (fabsf(self->dll_e0 * freq / self->rate) > 
.02) {
                                    ^
src/tuna.c:806:9: note: use function 'std::abs' instead
                                if (fabsf(self->dll_e0 * freq / self->rate) > 
.02) {
                                    ^~~~~
                                    std::abs
1 warning and 5 errors generated.
gmake[2]: *** [../robtk/robtk.mk:123: x42/x42-tuna-collection] Error 1
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428/tuna.lv2'
gmake[1]: *** [Makefile:17: tuna.lv2] Error 2
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/audio/x42-plugins-lv2/work/x42-plugins-20170428'
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/x42-plugins-lv2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to