You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/net/yptransitd/Makefile 327755 2013-09-20 
22:10:23Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/yptransitd-0.5_5.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building net/yptransitd
build started at Fri Dec 13 22:39:54 UTC 2013
port directory: /usr/ports/net/yptransitd
building for: FreeBSD head-amd64-default-job-03 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/net/yptransitd/Makefile 327755 2013-09-20 
22:10:23Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=35231
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=yptransitd-0.5_5
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-ldap-prefix=/usr/local --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -DLDAP_DEPRECATED 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -DLDAP_DEPRECATED -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/yptransitd
DOCSDIR=/usr/local/share/doc/yptransitd
EXAMPLESDIR=/usr/local/share/examples/yptransitd
WWWDIR=/usr/local/www/yptransitd
ETCDIR=/usr/local/etc/yptransitd
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for yptransitd-0.5_5
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   yptransitd-0.5_5 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of yptransitd-0.5_5
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by yptransitd-0.5_5 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by yptransitd-0.5_5 for building
=> SHA256 Checksum OK for yptransitd-0.5.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by yptransitd-0.5_5 for building
===>  Extracting for yptransitd-0.5_5
=> SHA256 Checksum OK for yptransitd-0.5.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for yptransitd-0.5_5
===>  Applying FreeBSD patches for yptransitd-0.5_5
===========================================================================
=======================<phase: build-depends  >============================
===>   yptransitd-0.5_5 depends on executable: bison - not found
===>    Verifying install for bison in /usr/ports/devel/bison
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
Installing bison-2.7.1,1...Installing m4-1.4.17,1... done
Installing gettext-0.18.3.1... done
 done
===>   Returning to build of yptransitd-0.5_5
===========================================================================
=======================<phase: lib-depends    >============================
===>   yptransitd-0.5_5 depends on shared library: ldap-2.4.8 - not found
===>    Verifying install for ldap-2.4.8 in /usr/ports/net/openldap24-client
===>   Installing existing package /packages/All/openldap-client-2.4.38.txz
Installing openldap-client-2.4.38... done
************************************************************

The OpenLDAP client package has been successfully installed.

Edit
  /usr/local/etc/openldap/ldap.conf
to change the system-wide client defaults.

Try `man ldap.conf' and visit the OpenLDAP FAQ-O-Matic at
  http://www.OpenLDAP.org/faq/index.cgi?file=3
for more information.

************************************************************
===>   Returning to build of yptransitd-0.5_5
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for yptransitd-0.5_5
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net/yptransitd/work/yptransitd-0.5/configure
loading site script /usr/ports/Templates/config.site
creating cache ./config.cache
checking for gcc... cc
checking whether the C compiler (cc -O2 -pipe -DLDAP_DEPRECATED 
-fno-strict-aliasing ) works... yes
checking whether the C compiler (cc -O2 -pipe -DLDAP_DEPRECATED 
-fno-strict-aliasing ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether cc accepts -g... yes
checking for ranlib... ranlib
checking for flex... flex
checking for yywrap in -lfl... yes
checking for bison... bison -y
checking for a BSD compatible install... /usr/bin/install -c -o root -g wheel
checking for main in -lnsl... no
checking for connect in -lsocket... no
checking for dlsym in -ldl... no
checking for inet_aton in -lresolv... no
checking for ldap_init in -lldap... yes
checking for rpcgen... /usr/bin/rpcgen
checking host system type... amd64-portbld-freebsd11.0
checking how to run the C preprocessor... cpp
checking for ANSI C header files... (cached) yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking for string.h... (cached) yes
checking for err.h... yes
checking for sys/cdefs.h... (cached) yes
checking for rpc/svc_soc.h... yes
checking for machine/limits.h... no
checking for limits.h... (cached) yes
checking for strings.h... (cached) yes
checking for working const... yes
checking whether time.h and sys/time.h may both be included... yes
checking for strdup... (cached) yes
checking for strerror... (cached) yes
checking for vsyslog... yes
checking for pthread.h... yes
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking for cc_r... cc
updating cache ./config.cache
creating ./config.status
creating lib/Makefile
creating src/Makefile
creating src/modules/Makefile
creating src/modules/ldap/Makefile
creating Makefile
creating autoconf.h
===========================================================================
=======================<phase: build          >============================
===>  Building for yptransitd-0.5_5
making all in lib
gcc -c -I/usr/local/include -I/usr/local/include -O2 -pipe -DLDAP_DEPRECATED 
-fno-strict-aliasing getopt_long.c
make[2]: exec(gcc) failed (No such file or directory)
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/net/yptransitd/work/yptransitd-0.5/lib
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/net/yptransitd/work/yptransitd-0.5
*** Error code 1

Stop.
make: stopped in /usr/ports/net/yptransitd
===>  Cleaning for yptransitd-0.5_5
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to