You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     al...@pajunas.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/www/pglogd/Makefile 327776 2013-09-20 23:36:50Z 
bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/pglogd-2.3_2.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building www/pglogd
build started at Fri Dec 13 23:39:46 UTC 2013
port directory: /usr/ports/www/pglogd
building for: FreeBSD head-amd64-default-job-10 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: al...@pajunas.com
Makefile ident:      $FreeBSD: head/www/pglogd/Makefile 327776 2013-09-20 
23:36:50Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=24807
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=pglogd-2.3_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pglogd
DOCSDIR=/usr/local/share/doc/pglogd
EXAMPLESDIR=/usr/local/share/examples/pglogd
WWWDIR=/usr/local/www/pglogd
ETCDIR=/usr/local/etc/pglogd
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for pglogd-2.3_2
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   pglogd-2.3_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of pglogd-2.3_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by pglogd-2.3_2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by pglogd-2.3_2 for building
=> SHA256 Checksum OK for pglogd-2.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by pglogd-2.3_2 for building
===>  Extracting for pglogd-2.3_2
=> SHA256 Checksum OK for pglogd-2.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for pglogd-2.3_2
===>  Applying FreeBSD patches for pglogd-2.3_2
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===>   pglogd-2.3_2 depends on shared library: pq.5 - not found
===>    Verifying install for pq.5 in /usr/ports/databases/postgresql90-client
===>   Installing existing package /packages/All/postgresql90-client-9.0.15.txz
Installing postgresql90-client-9.0.15...Installing libxml2-2.8.0_3... done
Installing gettext-0.18.3.1... done
 done
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk 
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-PyGreSQL
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
===>   Returning to build of pglogd-2.3_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for pglogd-2.3_2
===========================================================================
=======================<phase: build          >============================
===>  Building for pglogd-2.3_2
gcc -o pglogd -O2 -pipe -fno-strict-aliasing  -I/usr/local/include  
-L/usr/local/lib -L/usr/local/lib -lpq pglogd.c
make[1]: exec(gcc) failed (No such file or directory)
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/www/pglogd/work/pglogd-2.3
*** Error code 1

Stop.
make: stopped in /usr/ports/www/pglogd
===>  Cleaning for pglogd-2.3_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to