You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jhix...@gmail.com
Last committer: vani...@freebsd.org
Ident:          $FreeBSD: branches/2018Q1/net/libstorj/Makefile 457016 
2017-12-23 02:16:57Z vanilla $
Log URL:        
http://thunderx1.nyi.freebsd.org/data/111arm64-quarterly/460130/logs/libstorj-1.0.2.log
Build URL:      
http://thunderx1.nyi.freebsd.org/build.html?mastername=111arm64-quarterly&build=460130
Log:

=>> Building net/libstorj
build started at Sun Jan 28 18:21:21 UTC 2018
port directory: /usr/ports/net/libstorj
package name: libstorj-1.0.2
building for: FreeBSD 111arm64-quarterly-job-21 11.1-RELEASE-p6 FreeBSD 
11.1-RELEASE-p6 1101001 arm64
maintained by: jhix...@gmail.com
Makefile ident:      $FreeBSD: branches/2018Q1/net/libstorj/Makefile 457016 
2017-12-23 02:16:57Z vanilla $
Poudriere version: 3.2.4-20-g3ab5fc55
Host OSVERSION: 1200054
Jail OSVERSION: 1101001
Job Id: 21

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1101001
UNAME_v=FreeBSD 11.1-RELEASE-p6 1101001
UNAME_r=11.1-RELEASE-p6
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/111arm64-quarterly/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
OLDPWD=/usr/local/poudriere/data/.m/111arm64-quarterly/ref/.p
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
PWD=/usr/local/poudriere/data/.m/111arm64-quarterly/ref/.p/pool
MASTERNAME=111arm64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
P_PYTHON_MAJOR_VER=2
POUDRIERE_VERSION=3.2.4-20-g3ab5fc55
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
jhix...@gmail.com
--End MAINTAINER--

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/net/libstorj/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net/libstorj/work  
HOME=/wrkdirs/usr/ports/net/libstorj/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/net/libstorj/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh CMAKE_PREFIX_PATH="/usr/local" 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/net/libstorj/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net/libstorj/work  
HOME=/wrkdirs/usr/ports/net/libstorj/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/net/libstorj/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe  -isystem /usr/local/include -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-isystem /usr/local/include"  LDFLAGS="" LIBS="-L/usr/local/lib"  
CXX="c++" CXXFLAGS="-O2 -pipe -isystem /usr/local/include -fno-strict-aliasing  
-isystem /usr/local/include"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.1 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local PORTDOCS="" 
PORTEXAMPLES="" LIB32DIR=lib DOCSDIR="share/doc/libstorj"  
EXAMPLESDIR="share/examples/libstorj"  DATADIR="share/libstorj"  
WWWDIR="www/libstorj"  ETCDIR="etc/libstorj"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/libstorj 
DOCSDIR=/usr/local/share/doc/libstorj 
EXAMPLESDIR=/usr/local/share/examples/libstorj  WWWDIR=/usr/local/www/libstorj 
ETCDIR=/usr/local/etc/libstorj
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=aarch64
CONFIGURE_MAX_CMD_LEN=262144
OPSYS=FreeBSD
OSREL=11.1
OSVERSION=1101001
PYTHONBASE=/usr/local
UID=0
_OSRELEASE=11.1-RELEASE-p6
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  1048576
stack size              (kbytes, -s)  1048576
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License LGPL21+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   libstorj-1.0.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.3_1.txz
[111arm64-quarterly-job-21] Installing pkg-1.10.3_1...
[111arm64-quarterly-job-21] Extracting pkg-1.10.3_1: .......... done
===>   libstorj-1.0.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of libstorj-1.0.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by libstorj-1.0.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by libstorj-1.0.2 for building
=> SHA256 Checksum OK for Storj-libstorj-v1.0.2_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21+ accepted by the user
===> Fetching all distfiles required by libstorj-1.0.2 for building
===>  Extracting for libstorj-1.0.2
=> SHA256 Checksum OK for Storj-libstorj-v1.0.2_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for libstorj-1.0.2
===========================================================================
=======================<phase: build-depends  >============================
===>   libstorj-1.0.2 depends on executable: autoconf-2.69 - not found
===>   Installing existing package /packages/All/autoconf-2.69_1.txz
[111arm64-quarterly-job-21] Installing autoconf-2.69_1...
[111arm64-quarterly-job-21] `-- Installing autoconf-wrapper-20131203...
[111arm64-quarterly-job-21] `-- Extracting autoconf-wrapper-20131203: ........ 
done
[111arm64-quarterly-job-21] `-- Installing indexinfo-0.3.1...
[111arm64-quarterly-job-21] `-- Extracting indexinfo-0.3.1: .... done
[111arm64-quarterly-job-21] `-- Installing m4-1.4.18,1...
[111arm64-quarterly-job-21] `-- Extracting m4-1.4.18,1: .......... done
[111arm64-quarterly-job-21] `-- Installing perl5-5.24.3...
[111arm64-quarterly-job-21] `-- Extracting perl5-5.24.3: .......... done
[111arm64-quarterly-job-21] Extracting autoconf-2.69_1: .......... done
Message from perl5-5.24.3:

The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   libstorj-1.0.2 depends on executable: autoconf-2.69 - found
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on executable: autoheader-2.69 - found
===>   libstorj-1.0.2 depends on executable: autoreconf-2.69 - found
===>   libstorj-1.0.2 depends on executable: aclocal-1.15 - not found
===>   Installing existing package /packages/All/automake-1.15.1.txz
[111arm64-quarterly-job-21] Installing automake-1.15.1...
[111arm64-quarterly-job-21] `-- Installing automake-wrapper-20131203...
[111arm64-quarterly-job-21] `-- Extracting automake-wrapper-20131203: ... done
[111arm64-quarterly-job-21] Extracting automake-1.15.1: .......... done
===>   libstorj-1.0.2 depends on executable: aclocal-1.15 - found
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on executable: automake-1.15 - found
===>   libstorj-1.0.2 depends on executable: libtoolize - not found
===>   Installing existing package /packages/All/libtool-2.4.6.txz
[111arm64-quarterly-job-21] Installing libtool-2.4.6...
[111arm64-quarterly-job-21] Extracting libtool-2.4.6: .......... done
===>   libstorj-1.0.2 depends on executable: libtoolize - found
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[111arm64-quarterly-job-21] Installing gmake-4.2.1_1...
[111arm64-quarterly-job-21] `-- Installing gettext-runtime-0.19.8.1_1...
[111arm64-quarterly-job-21] `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[111arm64-quarterly-job-21] Extracting gmake-4.2.1_1: .......... done
===>   libstorj-1.0.2 depends on executable: gmake - found
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-1.3.10,1.txz
[111arm64-quarterly-job-21] Installing pkgconf-1.3.10,1...
[111arm64-quarterly-job-21] Extracting pkgconf-1.3.10,1: .......... done
===>   libstorj-1.0.2 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of libstorj-1.0.2
===========================================================================
=======================<phase: lib-depends    >============================
===>   libstorj-1.0.2 depends on shared library: libjson-c.so - not found
===>   Installing existing package /packages/All/json-c-0.13.txz
[111arm64-quarterly-job-21] Installing json-c-0.13...
[111arm64-quarterly-job-21] Extracting json-c-0.13: .......... done
===>   libstorj-1.0.2 depends on shared library: libjson-c.so - found 
(/usr/local/lib/libjson-c.so)
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on shared library: libuv.so - not found
===>   Installing existing package /packages/All/libuv-1.18.0.txz
[111arm64-quarterly-job-21] Installing libuv-1.18.0...
[111arm64-quarterly-job-21] Extracting libuv-1.18.0: .......... done
===>   libstorj-1.0.2 depends on shared library: libuv.so - found 
(/usr/local/lib/libuv.so)
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on shared library: libcurl.so - not found
===>   Installing existing package /packages/All/curl-7.57.0.txz
[111arm64-quarterly-job-21] Installing curl-7.57.0...
[111arm64-quarterly-job-21] `-- Installing ca_root_nss-3.34.1...
[111arm64-quarterly-job-21] `-- Extracting ca_root_nss-3.34.1: ........ done
[111arm64-quarterly-job-21] `-- Installing libnghttp2-1.29.0...
[111arm64-quarterly-job-21] `-- Extracting libnghttp2-1.29.0: .......... done
[111arm64-quarterly-job-21] Extracting curl-7.57.0: .......... done
Message from ca_root_nss-3.34.1:

********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   libstorj-1.0.2 depends on shared library: libcurl.so - found 
(/usr/local/lib/libcurl.so)
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on shared library: libnettle.so - not found
===>   Installing existing package /packages/All/nettle-3.4.txz
[111arm64-quarterly-job-21] Installing nettle-3.4...
[111arm64-quarterly-job-21] `-- Installing gmp-6.1.2...
[111arm64-quarterly-job-21] `-- Extracting gmp-6.1.2: .......... done
[111arm64-quarterly-job-21] Extracting nettle-3.4: .......... done
===>   libstorj-1.0.2 depends on shared library: libnettle.so - found 
(/usr/local/lib/libnettle.so)
===>   Returning to build of libstorj-1.0.2
===>   libstorj-1.0.2 depends on shared library: libmicrohttpd.so - not found
===>   Installing existing package /packages/All/libmicrohttpd-0.9.58.txz
[111arm64-quarterly-job-21] Installing libmicrohttpd-0.9.58...
[111arm64-quarterly-job-21] Extracting libmicrohttpd-0.9.58: .......... done
===>   libstorj-1.0.2 depends on shared library: libmicrohttpd.so - found 
(/usr/local/lib/libmicrohttpd.so)
===>   Returning to build of libstorj-1.0.2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for libstorj-1.0.2
aclocal-1.15: warning: couldn't open directory 'build-aux/m4': No such file or 
directory
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'build-aux'.
libtoolize: copying file 'build-aux/ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'build-aux/m4'.
libtoolize: copying file 'build-aux/m4/libtool.m4'
libtoolize: copying file 'build-aux/m4/ltoptions.m4'
libtoolize: copying file 'build-aux/m4/ltsugar.m4'
libtoolize: copying file 'build-aux/m4/ltversion.m4'
libtoolize: copying file 'build-aux/m4/lt~obsolete.m4'
configure.ac:5: installing 'build-aux/compile'
configure.ac:5: installing 'build-aux/config.guess'
configure.ac:5: installing 'build-aux/config.sub'
configure.ac:4: installing 'build-aux/install-sh'
configure.ac:4: installing 'build-aux/missing'
src/Makefile.am: installing 'build-aux/depcomp'
parallel-tests: installing 'build-aux/test-driver'
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether gmake supports nested variables... yes
checking build system type... aarch64-portbld-freebsd11.1
checking host system type... aarch64-portbld-freebsd11.1
checking how to print strings... printf
checking for style of include used by gmake... GNU
checking for gcc... cc
checking whether the C compiler works... no
configure: error: in `/wrkdirs/usr/ports/net/libstorj/work/libstorj-1.0.2':
configure: error: C compiler cannot create executables
See `config.log' for more details
===>  Script "configure" failed unexpectedly.
Please report the problem to jhix...@gmail.com [maintainer] and attach the
"/wrkdirs/usr/ports/net/libstorj/work/libstorj-1.0.2/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/net/libstorj
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to