You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     joh...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/games/freeciv-nox11/Makefile 329275 2013-10-04 
09:36:32Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/freeciv-nox11-2.4.0_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building games/freeciv-nox11
build started at Sat Dec 14 01:21:40 UTC 2013
port directory: /usr/ports/games/freeciv-nox11
building for: FreeBSD head-amd64-default-job-07 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: joh...@freebsd.org
Makefile ident:      $FreeBSD: head/games/freeciv-nox11/Makefile 329275 
2013-10-04 09:36:32Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=38603
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=freeciv-nox11-2.4.0_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
freeciv-nox11-2.4.0_1:
     IPV6=on: IPv6 protocol support
     MYSQL=off: MySQL database support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
 --program-transform-name=  --enable-aimodules --enable-shared  
--enable-fcdb=sqlite3 --enable-client=no --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" MAKE=gmake 
PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" 
-L/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/freeciv
DOCSDIR=/usr/local/share/doc/freeciv
EXAMPLESDIR=/usr/local/share/examples/freeciv
WWWDIR=/usr/local/www/freeciv
ETCDIR=/usr/local/etc/freeciv
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for freeciv-nox11-2.4.0_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   freeciv-nox11-2.4.0_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of freeciv-nox11-2.4.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by freeciv-nox11-2.4.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by freeciv-nox11-2.4.0_1 for building
=> SHA256 Checksum OK for freeciv-2.4.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by freeciv-nox11-2.4.0_1 for building
===>  Extracting for freeciv-nox11-2.4.0_1
=> SHA256 Checksum OK for freeciv-2.4.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for freeciv-nox11-2.4.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   freeciv-nox11-2.4.0_1 depends on file: /usr/local/bin/python2.7 - not 
found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_1.txz
Installing python27-2.7.6_1...Installing gettext-0.18.3.1... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of freeciv-nox11-2.4.0_1
===>   freeciv-nox11-2.4.0_1 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of freeciv-nox11-2.4.0_1
===>   freeciv-nox11-2.4.0_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of freeciv-nox11-2.4.0_1
===>   freeciv-nox11-2.4.0_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of freeciv-nox11-2.4.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   freeciv-nox11-2.4.0_1 depends on shared library: libintl.so - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for freeciv-nox11-2.4.0_1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv-nox11/work/freeciv-2.4.0/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv-nox11/work/freeciv-2.4.0/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv-nox11/work/freeciv-2.4.0/bootstrap/config.rpath
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd11.0
checking host system type... amd64-portbld-freebsd11.0
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether byte ordering is bigendian... no
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking for style of include used by gmake... GNU
checking dependency style of cc... gcc3
checking whether gmake supports nested variables... yes
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for SQLite3 library >= 3.0.0... not found
configure: error: fcdb database sqlite3 not available
===>  Script "configure" failed unexpectedly.
Please report the problem to joh...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/games/freeciv-nox11/work/freeciv-2.4.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/games/freeciv-nox11
===>  Cleaning for freeciv-nox11-2.4.0_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to