You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     wait...@waitman.net
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/devel/mongo-cxx-driver/Makefile 335888 
2013-12-08 13:24:03Z mva $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/mongo-cxx-driver-2.4.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building devel/mongo-cxx-driver
build started at Sat Dec 14 02:59:42 UTC 2013
port directory: /usr/ports/devel/mongo-cxx-driver
building for: FreeBSD head-amd64-default-job-08 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: wait...@waitman.net
Makefile ident:      $FreeBSD: head/devel/mongo-cxx-driver/Makefile 335888 
2013-12-08 13:24:03Z mva $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=43115
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=mongo-cxx-driver-2.4
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mongo-cxx-driver
DOCSDIR=/usr/local/share/doc/mongo-cxx-driver
EXAMPLESDIR=/usr/local/share/examples/mongo-cxx-driver
WWWDIR=/usr/local/www/mongo-cxx-driver
ETCDIR=/usr/local/etc/mongo-cxx-driver
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for mongo-cxx-driver-2.4
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mongo-cxx-driver-2.4 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of mongo-cxx-driver-2.4
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by mongo-cxx-driver-2.4 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by mongo-cxx-driver-2.4 for building
=> SHA256 Checksum OK for mongo-cxx-driver-2.4.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by mongo-cxx-driver-2.4 for building
===>  Extracting for mongo-cxx-driver-2.4
=> SHA256 Checksum OK for mongo-cxx-driver-2.4.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mongo-cxx-driver-2.4
===========================================================================
=======================<phase: build-depends  >============================
===>   mongo-cxx-driver-2.4 depends on file: /usr/local/bin/python2.7 - not 
found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_1.txz
Installing python27-2.7.6_1...Installing gettext-0.18.3.1... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of mongo-cxx-driver-2.4
===>   mongo-cxx-driver-2.4 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of mongo-cxx-driver-2.4
===>   mongo-cxx-driver-2.4 depends on executable: python2 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   mongo-cxx-driver-2.4 depends on shared library: boost_system - not found
===>    Verifying install for boost_system in /usr/ports/devel/boost-libs
===>   Installing existing package /packages/All/boost-libs-1.52.0_2.txz
Installing boost-libs-1.52.0_2...Installing icu-50.1.2... done
 done
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   Returning to build of mongo-cxx-driver-2.4
===>   mongo-cxx-driver-2.4 depends on shared library: sasl2 - not found
===>    Verifying install for sasl2 in /usr/ports/security/cyrus-sasl2
===>   Installing existing package /packages/All/cyrus-sasl-2.1.26_3.txz
Installing cyrus-sasl-2.1.26_3...*** Added group `cyrus' (id 60)
*** Added user `cyrus' (id 60)
 done
You can use sasldb2 for authentication, to add users use:

        saslpasswd2 -c username

If you want to enable SMTP AUTH with the system Sendmail, read
Sendmail.README

NOTE: This port has been compiled with a default pwcheck_method of
      auxprop.  If you want to authenticate your user by /etc/passwd,
      PAM or LDAP, install ports/security/cyrus-sasl2-saslauthd and
      set sasl_pwcheck_method to saslauthd after installing the
      Cyrus-IMAPd 2.X port.  You should also check the
      /usr/local/lib/sasl2/*.conf files for the correct
      pwcheck_method.
===>   Returning to build of mongo-cxx-driver-2.4
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mongo-cxx-driver-2.4
===========================================================================
=======================<phase: build          >============================
===>  Building for mongo-cxx-driver-2.4
mkdir ./build
mkdir ./build/mongo
mkdir ./build/mongo/base
mkdir ./build/mongo/bson
mkdir ./build/mongo/bson/util
mkdir ./build/mongo/client
mkdir ./build/mongo/db
mkdir ./build/mongo/db/auth
mkdir ./build/mongo/db/ops
mkdir ./build/mongo/db/repl
mkdir ./build/mongo/db/stats
mkdir ./build/mongo/platform
mkdir ./build/mongo/s
mkdir ./build/mongo/scripting
mkdir ./build/mongo/shell
mkdir ./build/mongo/util
mkdir ./build/mongo/util/concurrency
mkdir ./build/mongo/util/mongoutils
mkdir ./build/mongo/util/net
mkdir ./build/third_party
mkdir ./build/third_party/murmurhash3/
/usr/local/bin/python2 src/mongo/base/generate_error_codes.py 
src/mongo/base/error_codes.err build/mongo/base/error_codes.h 
build/mongo/base/error_codes.cpp
c++ -o build/mongo/base/configuration_variable_manager.o -c 
-DMONGO_EXPOSE_MACROS -Ibuild -Isrc -Ibuild/mongo -Isrc/mongo 
-I/usr/local/include src/mongo/base/configuration_variable_manager.cpp
In file included from src/mongo/base/configuration_variable_manager.cpp:16:
In file included from src/mongo/base/configuration_variable_manager.h:24:
src/mongo/platform/unordered_map.h:51:16: error: no member named 'tr1' in 
namespace 'std'
    using std::tr1::unordered_map;
          ~~~~~^
In file included from src/mongo/base/configuration_variable_manager.cpp:16:
src/mongo/base/configuration_variable_manager.h:99:17: error: no template named 
'unordered_map'; did you mean 'std::unordered_map'?
        typedef unordered_map<std::string, SetFromStringFn> VariableMap;
                ^~~~~~~~~~~~~
                std::unordered_map
/usr/include/c++/v1/tr1/unordered_map:614:24: note: 'std::unordered_map' 
declared here
class _LIBCPP_TYPE_VIS unordered_map
                       ^
2 errors generated.
*** Error code 1

Stop.
make[1]: stopped in 
/wrkdirs/usr/ports/devel/mongo-cxx-driver/work/waitman-mongo-cxx-driver-41691d5
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/mongo-cxx-driver
===>  Cleaning for mongo-cxx-driver-2.4
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to