You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     da...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/games/netradiant/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/netradiant-20130630_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building games/netradiant
build started at Sat Dec 14 03:11:38 UTC 2013
port directory: /usr/ports/games/netradiant
building for: FreeBSD head-amd64-default-job-13 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: da...@freebsd.org
Makefile ident:      $FreeBSD: head/games/netradiant/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=40136
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=netradiant-20130630_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
BUILD=release DOWNLOAD_GAMEPACKS=no LIBS_DL=""  RADIANT_ABOUTMSG="For FreeBSD 
11.0 (amd64)" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" 
-L/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
ARCH=amd64
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/netradiant
DOCSDIR=/usr/local/share/doc/netradiant
EXAMPLESDIR=/usr/local/share/examples/netradiant
WWWDIR=/usr/local/www/netradiant
ETCDIR=/usr/local/etc/netradiant
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for netradiant-20130630_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   netradiant-20130630_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of netradiant-20130630_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by netradiant-20130630_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by netradiant-20130630_1 for building
=> SHA256 Checksum OK for netradiant-20130630-src.tar.bz2.
=> SHA256 Checksum OK for q3map2.6.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by netradiant-20130630_1 for building
===>  Extracting for netradiant-20130630_1
=> SHA256 Checksum OK for netradiant-20130630-src.tar.bz2.
=> SHA256 Checksum OK for q3map2.6.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for netradiant-20130630_1
===>  Applying FreeBSD patches for netradiant-20130630_1
===========================================================================
=======================<phase: build-depends  >============================
===>   netradiant-20130630_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of netradiant-20130630_1
===>   netradiant-20130630_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of netradiant-20130630_1
===>   netradiant-20130630_1 depends on file: 
/usr/local/libdata/pkgconfig/glproto.pc - not found
===>    Verifying install for /usr/local/libdata/pkgconfig/glproto.pc in 
/usr/ports/x11/glproto
===>   Installing existing package /packages/All/glproto-1.4.16.txz
Installing glproto-1.4.16... done
===>   Returning to build of netradiant-20130630_1
===>   netradiant-20130630_1 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - not found
===>    Verifying install for /usr/local/libdata/pkgconfig/dri2proto.pc in 
/usr/ports/x11/dri2proto
===>   Installing existing package /packages/All/dri2proto-2.8.txz
Installing dri2proto-2.8... done
===>   Returning to build of netradiant-20130630_1
===>   netradiant-20130630_1 depends on file: /usr/local/bin/intltool-extract - 
not found
===>    Verifying install for /usr/local/bin/intltool-extract in 
/usr/ports/textproc/intltool
===>   Installing existing package /packages/All/intltool-0.50.2.txz
Installing intltool-0.50.2...Installing p5-XML-Parser-2.41_1...Installing 
expat-2.1.0... done
Installing perl5-5.16.3_4...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl5
Done.
 done
 done
 done
===>   Returning to build of netradiant-20130630_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   netradiant-20130630_1 depends on shared library: libgtkglext-x11-1.0.so 
- not found
===>    Verifying for libgtkglext-x11-1.0.so in /usr/ports/x11-toolkits/gtkglext
===>   Installing existing package /packages/All/gtkglext-1.2.0_12.txz
Installing gtkglext-1.2.0_12...Installing xproto-7.0.24... done
Installing xineramaproto-1.2.1... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing xcb-util-renderutil-0.3.8...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxcb-1.9.1_1...Installing libxml2-2.8.0_3... done
 done
Installing xcb-util-0.3.9_1,1... done
 done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing pixman-0.30.2... done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXinerama-1.1.3,1... done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libXcursor-1.1.14... done
Installing libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing pangox-compat-0.0.2...Installing pango-1.34.1_1...Installing 
xorg-fonts-truetype-7.7_1...Installing mkfontscale-1.1.1...Installing 
libfontenc-1.1.2... done
Installing freetype2-2.5.0.1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.95,1...Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
<snip>
file=install/modules/image.so; mkdir -p ${file%/*}
c++ plugins/image/bmp.o plugins/image/dds.o plugins/image/image.o 
plugins/image/jpeg.o plugins/image/pcx.o plugins/image/tga.o libddslib.a  
-L/usr/local/lib  -s  -fPIC -ljpeg -lpthread  -shared -o 
install/modules/image.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/image.so 2>&1 1>/dev/null | tee 
/dev/stderr`" ] || { rm -f install/modules/image.so; exit 1; }
c++ plugins/imagehl/hlw.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imagehl/hlw.o
In file included from plugins/imagehl/hlw.cpp:40:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
plugins/imagehl/hlw.cpp:101:10: warning: cast from 'byte *' (aka 'unsigned char 
*') to 'LPWAD3_MIP' (aka 'WAD3_MIP *') increases required alignment from 1 to 4 
[-Wcast-align]
        lpMip = (LPWAD3_MIP)buffer; //!\todo Make endian-safe.
                ^~~~~~~~~~~~~~~~~~
2 warnings generated.
c++ plugins/imagehl/imagehl.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imagehl/imagehl.o
c++ plugins/imagehl/mip.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imagehl/mip.o
In file included from plugins/imagehl/mip.cpp:32:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
c++ plugins/imagehl/sprite.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imagehl/sprite.o
In file included from plugins/imagehl/sprite.cpp:34:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
plugins/imagehl/sprite.cpp:120:11: warning: cast from 'byte *' (aka 'unsigned 
char *') to 'dspriteheader_t *' (aka 'dspriteheader_s *') increases required 
alignment from 1 to 4 [-Wcast-align]
        header = (dspriteheader_t *)buffer;
                 ^~~~~~~~~~~~~~~~~~~~~~~~~
plugins/imagehl/sprite.cpp:181:16: warning: cast from 'byte *' (aka 'unsigned 
char *') to 'dspriteframe_t *' increases required alignment from 1 to 4 
[-Wcast-align]
        spriteframe = (dspriteframe_t *)( palette + ( 256 * 3 ) + 4 ); // what 
are those 4 extra bytes ? what's missing ?
                      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
3 warnings generated.
file=install/modules/imagehl.so; mkdir -p ${file%/*}
c++ plugins/imagehl/hlw.o plugins/imagehl/imagehl.o plugins/imagehl/mip.o 
plugins/imagehl/sprite.o  -L/usr/local/lib  -s  -fPIC  -lpthread  -shared -o 
install/modules/imagehl.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/imagehl.so 2>&1 1>/dev/null | tee 
/dev/stderr`" ] || { rm -f install/modules/imagehl.so; exit 1; }
c++ plugins/imagepng/plugin.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -I/usr/local/include/libpng15   -Ilibs 
-Iinclude   -DPOSIX -DXWINDOWS -I/usr/local/include 
-DRADIANT_VERSION="\"1.5.0n\"" -DRADIANT_MAJOR_VERSION="\"5\"" 
-DRADIANT_MINOR_VERSION="\"0\"" -DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 
(amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" -DRADIANT_EXECUTABLE="\"amd64\""  -c 
-o plugins/imagepng/plugin.o
In file included from plugins/imagepng/plugin.cpp:29:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
file=install/modules/imagepng.so; mkdir -p ${file%/*}
c++ plugins/imagepng/plugin.o  -L/usr/local/lib  -s  -fPIC -L/usr/local/lib   
-lpng15   -lpthread  -shared -o install/modules/imagepng.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/imagepng.so 2>&1 1>/dev/null | tee 
/dev/stderr`" ] || { rm -f install/modules/imagepng.so; exit 1; }
c++ plugins/imagewebp/plugin.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -I/usr/local/include   -Ilibs -Iinclude   
-DPOSIX -DXWINDOWS -I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imagewebp/plugin.o
In file included from plugins/imagewebp/plugin.cpp:27:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
file=install/modules/imagewebp.so; mkdir -p ${file%/*}
c++ plugins/imagewebp/plugin.o  -L/usr/local/lib  -s  -fPIC -L/usr/local/lib   
-lwebp   -lpthread  -shared -o install/modules/imagewebp.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/imagewebp.so 2>&1 1>/dev/null | 
tee /dev/stderr`" ] || { rm -f install/modules/imagewebp.so; exit 1; }
c++ plugins/imageq2/imageq2.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imageq2/imageq2.o
c++ plugins/imageq2/wal32.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imageq2/wal32.o
In file included from plugins/imageq2/wal32.cpp:27:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
c++ plugins/imageq2/wal.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/imageq2/wal.o
In file included from plugins/imageq2/wal.cpp:29:
libs/imagelib.h:51:2: warning: delete called on 'RGBAImage' that has virtual 
functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
file=install/modules/imageq2.so; mkdir -p ${file%/*}
c++ plugins/imageq2/imageq2.o plugins/imageq2/wal32.o plugins/imageq2/wal.o  
-L/usr/local/lib  -s  -fPIC  -lpthread  -shared -o install/modules/imageq2.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/imageq2.so 2>&1 1>/dev/null | tee 
/dev/stderr`" ] || { rm -f install/modules/imageq2.so; exit 1; }
c++ plugins/mapq3/parse.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/mapq3/parse.o
In file included from plugins/mapq3/parse.cpp:22:
In file included from plugins/mapq3/parse.h:43:
libs/scenelib.h:236:2: warning: delete called on 'scene::NullNode' that has 
virtual functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
c++ plugins/mapq3/plugin.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/mapq3/plugin.o
In file included from plugins/mapq3/plugin.cpp:31:
libs/scenelib.h:236:2: warning: delete called on 'scene::NullNode' that has 
virtual functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
plugins/mapq3/plugin.cpp:113:15: warning: comparison of integers of different 
signs: 'std::size_t' (aka 'unsigned long') and 'Value' (aka 'int') 
[-Wsign-compare]
        if ( version != MapVersion() ) {
             ~~~~~~~ ^  ~~~~~~~~~~~~
plugins/mapq3/plugin.cpp:184:15: warning: comparison of integers of different 
signs: 'std::size_t' (aka 'unsigned long') and 'Value' (aka 'int') 
[-Wsign-compare]
        if ( version != MapVersion() ) {
             ~~~~~~~ ^  ~~~~~~~~~~~~
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:59:2: warning: delete called on 
'MapDoom3API' that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DependenciesAPIConstructor<MapDoom3API, 
MapDoom3Dependencies>::destroyAPI' requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:138:16: note: in instantiation of member function 
'SingletonModule<MapDoom3API, MapDoom3Dependencies, 
DependenciesAPIConstructor<MapDoom3API, MapDoom3Dependencies> >::release' 
requested here
MapDoom3Module g_MapDoom3Module;
               ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:59:2: warning: delete called on 
'MapQuake4API' that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DependenciesAPIConstructor<MapQuake4API, 
MapDoom3Dependencies>::destroyAPI' requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:209:17: note: in instantiation of member function 
'SingletonModule<MapQuake4API, MapDoom3Dependencies, 
DependenciesAPIConstructor<MapQuake4API, MapDoom3Dependencies> >::release' 
requested here
MapQuake4Module g_MapQuake4Module;
                ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 'MapQ3API' 
that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapQ3API, MapDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:299:13: note: in instantiation of member function 
'SingletonModule<MapQ3API, MapDependencies, DefaultAPIConstructor<MapQ3API, 
MapDependencies> >::release' requested here
MapQ3Module g_MapQ3Module;
            ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 'MapQ1API' 
that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapQ1API, MapDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:342:13: note: in instantiation of member function 
'SingletonModule<MapQ1API, MapDependencies, DefaultAPIConstructor<MapQ1API, 
MapDependencies> >::release' requested here
MapQ1Module g_MapQ1Module;
            ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 
'MapHalfLifeAPI' that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapHalfLifeAPI, MapDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:385:19: note: in instantiation of member function 
'SingletonModule<MapHalfLifeAPI, MapDependencies, 
DefaultAPIConstructor<MapHalfLifeAPI, MapDependencies> >::release' requested 
here
MapHalfLifeModule g_MapHalfLifeModule;
                  ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 'MapQ2API' 
that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapQ2API, MapDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:427:13: note: in instantiation of member function 
'SingletonModule<MapQ2API, MapDependencies, DefaultAPIConstructor<MapQ2API, 
MapDependencies> >::release' requested here
MapQ2Module g_MapQ2Module;
            ^
In file included from plugins/mapq3/plugin.cpp:36:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 'MapVMFAPI' 
that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapVMFAPI, MapDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapq3/plugin.cpp:583:14: note: in instantiation of member function 
'SingletonModule<MapVMFAPI, MapDependencies, DefaultAPIConstructor<MapVMFAPI, 
MapDependencies> >::release' requested here
MapVMFModule g_MapVMFModule;
             ^
10 warnings generated.
c++ plugins/mapq3/write.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -Ilibs -Iinclude   -DPOSIX -DXWINDOWS 
-I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/mapq3/write.o
In file included from plugins/mapq3/write.cpp:24:
In file included from include/ientity.h:28:
libs/scenelib.h:236:2: warning: delete called on 'scene::NullNode' that has 
virtual functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
1 warning generated.
file=install/modules/mapq3.so; mkdir -p ${file%/*}
c++ plugins/mapq3/parse.o plugins/mapq3/plugin.o plugins/mapq3/write.o  
-L/usr/local/lib  -s  -fPIC  -lpthread  -shared -o install/modules/mapq3.so
[ -z "ldd " ] || [ -z "`ldd  install/modules/mapq3.so 2>&1 1>/dev/null | tee 
/dev/stderr`" ] || { rm -f install/modules/mapq3.so; exit 1; }
c++ plugins/mapxml/plugin.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -I/usr/local/include/libxml2   
-I/usr/local/include/glib-2.0 -I/usr/local/include   -Ilibs -Iinclude   -DPOSIX 
-DXWINDOWS -I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/mapxml/plugin.o
In file included from plugins/mapxml/plugin.cpp:30:
libs/modulesystem/singletonmodule.h:43:2: warning: delete called on 'MapXMLAPI' 
that has virtual functions but non-virtual destructor 
[-Wdelete-non-virtual-dtor]
        delete api;
        ^
libs/modulesystem/singletonmodule.h:123:20: note: in instantiation of member 
function 'DefaultAPIConstructor<MapXMLAPI, MapXMLDependencies>::destroyAPI' 
requested here
                        APIConstructor::destroyAPI( m_api );
                                        ^
plugins/mapxml/plugin.cpp:87:14: note: in instantiation of member function 
'SingletonModule<MapXMLAPI, MapXMLDependencies, 
DefaultAPIConstructor<MapXMLAPI, MapXMLDependencies> >::release' requested here
MapXMLModule g_MapXMLModule;
             ^
1 warning generated.
c++ plugins/mapxml/xmlparse.cpp -O2 -pipe -fno-strict-aliasing -O2 -pipe 
-fno-strict-aliasing -MMD -W -Wall -Wcast-align -Wcast-qual 
-Wno-unused-parameter -fno-strict-aliasing -fPIC -Wno-non-virtual-dtor 
-Wreorder -fno-exceptions -fno-rtti -I/usr/local/include/libxml2   
-I/usr/local/include/glib-2.0 -I/usr/local/include   -Ilibs -Iinclude   -DPOSIX 
-DXWINDOWS -I/usr/local/include -DRADIANT_VERSION="\"1.5.0n\"" 
-DRADIANT_MAJOR_VERSION="\"5\"" -DRADIANT_MINOR_VERSION="\"0\"" 
-DRADIANT_ABOUTMSG="\"For FreeBSD 11.0 (amd64)\"" -DQ3MAP_VERSION="\"2.5.17n\"" 
-DRADIANT_EXECUTABLE="\"amd64\""  -c -o plugins/mapxml/xmlparse.o
In file included from plugins/mapxml/xmlparse.cpp:30:
In file included from include/ientity.h:28:
libs/scenelib.h:236:2: warning: delete called on 'scene::NullNode' that has 
virtual functions but non-virtual destructor [-Wdelete-non-virtual-dtor]
        delete this;
        ^
In file included from plugins/mapxml/xmlparse.cpp:36:
libs/xml/xmlparser.h:108:25: error: no matching function for call to 'vsnprintf'
        ostream.write( buffer, vsnprintf( buffer, 1023, formatted.m_format, 
formatted.m_arguments ) );
                               ^~~~~~~~~
/usr/include/stdio.h:284:6: note: candidate function not viable: no known 
conversion from 'const va_list' (aka 'const __builtin_va_list') to 
'__va_list_tag *' for 4th argument
int      vsnprintf(char * __restrict, size_t, const char * __restrict,
         ^
1 warning and 1 error generated.
gmake[1]: *** [plugins/mapxml/xmlparse.o] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/games/netradiant/work/netradiant-20130630-src'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/netradiant
===>  Cleaning for netradiant-20130630_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to