You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/multimedia/aegisub/Makefile 327747 2013-09-20 
20:57:48Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/aegisub-2.1.9_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building multimedia/aegisub
build started at Sat Dec 14 03:13:59 UTC 2013
port directory: /usr/ports/multimedia/aegisub
building for: FreeBSD head-amd64-default-job-22 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/multimedia/aegisub/Makefile 327747 
2013-09-20 20:57:48Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=64436
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=aegisub-2.1.9_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for aegisub-2.1.9_1:
     ALSA=off: ALSA audio architecture support
     ASS=on: libASS subtitle provider
     DEBUG=off: Install debug symbols
     DOCS=on: Build and/or install documentation
     EFENCE=off: Electric Fence (require profiling)
     FFMPEG=on: FFmpeg support (WMA, AIFF, AC3, APE...)
     GCOV=off: GCOV (require profiling)
     HUNSPELL=on: Spell checking via Hunspell
     LUA=on: Lua scripting language support
     OPENAL=off: OpenAL support
     PORTAUDIO=off: PortAudio library support
     PROFILE=off: Build with profiling support
     PULSEAUDIO=on: PulseAudio sound server support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-gcc-prec --without-lua50 --without-alsa --without-openal 
--without-portaudio --with-provider-video=ffmpegsource  
--with-provider-audio=ffmpegsource 
--with-wx-config=/usr/local/bin/wxgtk2u-2.8-config --x-libraries=/usr/local/lib 
--x-includes=/usr/local/include --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" 
FFMS_CFLAGS="-I/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/include"
 
FFMS_LIBS="/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/src/core/.libs/libffms2.a
  `pkg-config --libs libavcodec libavformat libswscale libavutil`" 
LUA_CFLAGS="-I/usr/local/include/lua51"  LUA_LDFLAGS="-L/usr/local/lib/lua51 
-llua" TMPDIR="/tmp" PKG_CONFIG=pkgconf MAKE=gmake SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES LUA_VER="5.1" 
LUA_VER_SH="1" LUA_VER_STR="51" LUA_PREFIX="/usr/local" LUA_SUBDIR="lua51" 
LUA_BINDIR="/usr/local/bin/lua51" LUA_INCDIR="/usr/local/include/lua51" 
LUA_LIBDIR="/usr/local/lib/lua51" LUA_MODLIBDIR="/usr/local/lib/lua/5.1" 
LUA_MODSHAREDIR="/usr/local/share/lua/5.1" 
WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-I/usr/local/include -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include 
-I/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/include 
-I/usr/local/include/lua51"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INST
 ALL_MAN="install  -o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/aegisub
DOCSDIR=/usr/local/share/doc/aegisub
EXAMPLESDIR=/usr/local/share/examples/aegisub
WWWDIR=/usr/local/www/aegisub
ETCDIR=/usr/local/etc/aegisub
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for aegisub-2.1.9_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   aegisub-2.1.9_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of aegisub-2.1.9_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by aegisub-2.1.9_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by aegisub-2.1.9_1 for building
=> SHA256 Checksum OK for aegisub-2.1.9.tar.gz.
=> SHA256 Checksum OK for ffms-2.17-src.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by aegisub-2.1.9_1 for building
===>  Extracting for aegisub-2.1.9_1
=> SHA256 Checksum OK for aegisub-2.1.9.tar.gz.
=> SHA256 Checksum OK for ffms-2.17-src.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for aegisub-2.1.9_1
===>  Applying FreeBSD patches for aegisub-2.1.9_1
===========================================================================
=======================<phase: build-depends  >============================
===>   aegisub-2.1.9_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on file: /usr/local/libdata/pkgconfig/glproto.pc 
- not found
===>    Verifying install for /usr/local/libdata/pkgconfig/glproto.pc in 
/usr/ports/x11/glproto
===>   Installing existing package /packages/All/glproto-1.4.16.txz
Installing glproto-1.4.16... done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - not found
===>    Verifying install for /usr/local/libdata/pkgconfig/dri2proto.pc in 
/usr/ports/x11/dri2proto
===>   Installing existing package /packages/All/dri2proto-2.8.txz
Installing dri2proto-2.8... done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on executable: gtk-update-icon-cache - not found
===>    Verifying install for gtk-update-icon-cache in 
/usr/ports/graphics/gtk-update-icon-cache
===>   Installing existing package 
/packages/All/gtk-update-icon-cache-2.24.19.txz
Installing gtk-update-icon-cache-2.24.19...Installing xproto-7.0.24... done
Installing xineramaproto-1.2.1... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing xcb-util-renderutil-0.3.8...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxcb-1.9.1_1...Installing libxml2-2.8.0_3... done
 done
Installing xcb-util-0.3.9_1,1... done
 done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing pixman-0.30.2... done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXinerama-1.1.3,1... done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libXcursor-1.1.14... done
Installing libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing pango-1.34.1_1...Installing xorg-fonts-truetype-7.7_1...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
Installing freetype2-2.5.0.1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.95,1...Installing expat-2.1.0... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
<snip>
Creating group 'polkit' with gid '562'.
Creating user 'polkit' with uid '562'.
 done
Installing hal-0.5.14_22...Installing dmidecode-2.12... done
Installing consolekit-0.4.3... done
Installing libvolume_id-0.81.1... done
===> Creating users and/or groups.
Creating group 'haldaemon' with gid '560'.
Creating user 'haldaemon' with uid '560'.
 done
Installing avahi-app-0.6.31...Installing libdaemon-0.14... done
Installing gdbm-1.10... done
===> Creating users and/or groups.
Creating group 'avahi' with gid '558'.
Creating user 'avahi' with uid '558'.
 done
Installing libltdl-2.4.2_2... done
Installing libIDL-0.8.14_1... done
Installing gconf2-2.32.0_3...Installing dconf-0.14.1... done
Installing ORBit2-2.14.19... done
 done
Installing speex-1.2.r1_5,1...Installing libogg-1.3.1,4... done
 done
Installing libvorbis-1.3.3_1,3... done
Installing libsndfile-1.0.25_3...Installing flac-1.3.0_1... done
 done
Installing libsamplerate-0.1.8_4... done
===> Creating users and/or groups.
Creating group 'pulse' with gid '563'.
Creating group 'pulse-access' with gid '564'.
Creating group 'pulse-rt' with gid '557'.
Creating user 'pulse' with uid '563'.
 done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on shared library: avcodec - not found
===>    Verifying install for avcodec in /usr/ports/multimedia/ffmpeg
===>   Installing existing package /packages/All/ffmpeg-2.1.1_1,1.txz
Installing ffmpeg-2.1.1_1,1...Installing ca_root_nss-3.15.2_1... done
Installing gmp-5.1.3... done
Installing gnutls-2.12.23_2...Installing p11-kit-0.20.1...Installing 
libtasn1-3.3... done
 done
Installing nettle-2.7.1... done
Installing libgpg-error-1.12... done
 done
Installing gpac-libgpac-0.5.0,1... done
Installing libtheora-1.1.1_3... done
Installing libvpx-1.2.0... done
Installing opencv-core-2.4.7... done
Installing orc-0.4.18... done
Installing schroedinger-1.0.11_1... done
Installing x264-0.136.2358_1... done
Installing xvid-1.3.2,1... done
 done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on shared library: hunspell-1.3 - not found
===>    Verifying install for hunspell-1.3 in /usr/ports/textproc/hunspell
===>   Installing existing package /packages/All/hunspell-1.3.2_3.txz
Installing hunspell-1.3.2_3... done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on shared library: lua-5.1.1 - not found
===>    Verifying install for lua-5.1.1 in /usr/ports/lang/lua
===>   Installing existing package /packages/All/lua-5.1.5_6.txz
Installing lua-5.1.5_6... done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on shared library: wx_baseu-2.8 - not found
===>    Verifying install for wx_baseu-2.8 in 
/usr/ports/x11-toolkits/wxgtk28-unicode
===>   Installing existing package /packages/All/wxgtk2-unicode-2.8.12_2.txz
Installing wxgtk2-unicode-2.8.12_2...Installing videoproto-2.3.2... done
Installing libXv-1.0.10,1... done
Installing wxgtk2-common-2.8.12_2...Installing pangox-compat-0.0.2... done
Installing gstreamer-plugins-0.10.36_3,3...Installing gstreamer-0.10.36... done
 done
Installing libmspack-0.4... done
 done
 done
===>   Returning to build of aegisub-2.1.9_1
===>   aegisub-2.1.9_1 depends on shared library: wx_gtk2u_fl-2.8 - not found
===>    Verifying install for wx_gtk2u_fl-2.8 in 
/usr/ports/x11-toolkits/wxgtk28-unicode-contrib
===>   Installing existing package 
/packages/All/wxgtk2-unicode-contrib-2.8.12_2.txz
Installing wxgtk2-unicode-contrib-2.8.12_2...Installing 
wxgtk2-contrib-common-2.8.12_2... done
 done
===>   Returning to build of aegisub-2.1.9_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for aegisub-2.1.9_1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/aegisub-2.1.9/acinclude.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/aegisub-2.1.9/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/aegisub-2.1.9/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/m4/libtool.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src/configure
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... (cached) /usr/bin/install
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking if debug build is enabled... no
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for style of include used by gmake... GNU
checking dependency style of cc... gcc3
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking build system type... amd64-unknown-freebsd11.0
checking host system type... amd64-unknown-freebsd11.0
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for fgrep... (cached) /usr/bin/fgrep
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... (cached) 262144
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... no
checking how to convert amd64-unknown-freebsd11.0 file names to 
amd64-unknown-freebsd11.0 format... func_convert_file_noop
checking how to convert amd64-unknown-freebsd11.0 file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... yes
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd11.0 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... c++ -E
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd11.0 ld.so
checking how to hardcode library paths into programs... immediate
checking for size_t... (cached) yes
checking for working alloca.h... no
checking for alloca... yes
checking if -fvisibility=hidden works... yes
checking for zlib.h... (cached) yes
checking for inflateEnd in -lz... yes
checking for CoUninitialize in -lole32... no
checking pkg-config is at least version 0.22... yes
checking for LIBAV... yes
checking whether linking with FFmpeg or Libav... FFmpeg
checking whether FFmpeg works... no
configure: error: in `/wrkdirs/usr/ports/multimedia/aegisub/work/ffms-2.17-src':
configure: error: cannot link with FFmpeg
See `config.log' for more details
*** Error code 1

Stop.
make: stopped in /usr/ports/multimedia/aegisub
===>  Cleaning for aegisub-2.1.9_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to