You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     joh...@freebsd.org
Last committer: joh...@freebsd.org
Ident:          $FreeBSD: head/games/freeciv/Makefile 330187 2013-10-12 
20:47:03Z johans $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s/logs/freeciv-2.4.0_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-12-13_10h32m20s
Log:

====>> Building games/freeciv
build started at Sat Dec 14 03:16:22 UTC 2013
port directory: /usr/ports/games/freeciv
building for: FreeBSD head-amd64-default-job-05 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: joh...@freebsd.org
Makefile ident:      $FreeBSD: head/games/freeciv/Makefile 330187 2013-10-12 
20:47:03Z johans $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=4917
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=freeciv-2.4.0_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for freeciv-2.4.0_1:
     IPV6=on: IPv6 protocol support
     MYSQL=off: MySQL database support
     SDL=off: Simple Direct Media Layer support
     X11=on: X11 (graphics) support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
 --program-transform-name=  --enable-aimodules --enable-shared  
--enable-fcdb=sqlite3 --enable-client=gtk --x-libraries=/usr/local/lib 
--x-includes=/usr/local/include --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" 
SDL_CONFIG=/usr/local/bin/sdl-config MAKE=gmake PKG_CONFIG=pkgconf 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SDL_CONFIG=/usr/local/bin/sdl-config SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/freeciv
DOCSDIR=/usr/local/share/doc/freeciv
EXAMPLESDIR=/usr/local/share/examples/freeciv
WWWDIR=/usr/local/www/freeciv
ETCDIR=/usr/local/etc/freeciv
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for freeciv-2.4.0_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   freeciv-2.4.0_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.3.txz
Installing pkg-1.2.3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of freeciv-2.4.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by freeciv-2.4.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by freeciv-2.4.0_1 for building
=> SHA256 Checksum OK for freeciv-2.4.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by freeciv-2.4.0_1 for building
===>  Extracting for freeciv-2.4.0_1
=> SHA256 Checksum OK for freeciv-2.4.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for freeciv-2.4.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   freeciv-2.4.0_1 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_1.txz
Installing python27-2.7.6_1...Installing gettext-0.18.3.1... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on file: /usr/local/bin/sdl-config - not found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_2,2.txz
Installing sdl-1.2.15_2,2...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing libxcb-1.9.1_1...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.8.0_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing pciids-20131130... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4... done
 done
Installing aalib-1.4.r5_6... done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on file: /usr/local/libdata/pkgconfig/xpm.pc - 
not found
===>    Verifying install for /usr/local/libdata/pkgconfig/xpm.pc in 
/usr/ports/x11/libXpm
===>   Installing existing package /packages/All/libXpm-3.5.11.txz
Installing libXpm-3.5.11...Installing libSM-1.2.2,1...Installing 
libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on executable: gtk-update-icon-cache - not found
===>    Verifying install for gtk-update-icon-cache in 
/usr/ports/graphics/gtk-update-icon-cache
===>   Installing existing package 
/packages/All/gtk-update-icon-cache-2.24.19.txz
Installing gtk-update-icon-cache-2.24.19...Installing xineramaproto-1.2.1... 
done
<snip>
Installing libXcursor-1.1.14... done
Installing libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing pango-1.34.1_1...Installing xorg-fonts-truetype-7.7_1...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
Installing freetype2-2.5.0.1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.95,1...Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing font-util-1.3.0... done
Installing font-misc-meltho-1.0.3... done
Installing font-misc-ethiopic-1.0.3... done
Installing font-bh-ttf-1.0.3... done
Installing encodings-1.0.4,1... done
Installing dejavu-2.34... done
 done
Installing libXft-2.3.1... done
Installing harfbuzz-0.9.19...Installing perl5-5.16.3_4...Removing 
/usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl5
Done.
 done
Installing png-1.5.17... done
Installing graphite2-1.2.3... done
Installing cairo-1.10.2_6,2...Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
Installing icu-50.1.2... done
 done
Installing gnomehier-3.0... done
 done
Installing libXmu-1.1.2,1... done
Installing shared-mime-info-1.1... done
Installing hicolor-icon-theme-0.12... done
Installing tiff-4.0.3...Installing freeglut-2.8.1... done
Installing jbigkit-1.6... done
Installing jpeg-8_4... done
 done
Installing jasper-1.900.1_12... done
Installing gdk-pixbuf2-2.28.2... done
Installing atk-2.8.0... done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on file: /usr/local/bin/intltool-extract - not 
found
===>    Verifying install for /usr/local/bin/intltool-extract in 
/usr/ports/textproc/intltool
===>   Installing existing package /packages/All/intltool-0.50.2.txz
Installing intltool-0.50.2...Installing p5-XML-Parser-2.41_1... done
 done
===>   Returning to build of freeciv-2.4.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   freeciv-2.4.0_1 depends on shared library: libtiff.so - found
===>   freeciv-2.4.0_1 depends on shared library: libpng15.so - found
===>   freeciv-2.4.0_1 depends on shared library: libcurl.so - not found
===>    Verifying for libcurl.so in /usr/ports/ftp/curl
===>   Installing existing package /packages/All/curl-7.33.0_1.txz
Installing curl-7.33.0_1...Installing ca_root_nss-3.15.2_1... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on shared library: libggz.so - not found
===>    Verifying for libggz.so in /usr/ports/games/libggz
===>   Installing existing package /packages/All/libggz-0.0.14.1_11.txz
Installing libggz-0.0.14.1_11...Installing libgpg-error-1.12... done
Installing libgcrypt-1.5.3... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on shared library: libggz-gtk.so - not found
===>    Verifying for libggz-gtk.so in /usr/ports/games/ggz-gtk-client
===>   Installing existing package /packages/All/ggz-gtk-client-0.0.14.1_6.txz
Installing ggz-gtk-client-0.0.14.1_6...Installing gtk2-2.24.19_2...Installing 
cups-client-1.5.4_1... done
 done
Installing ggz-client-libs-0.0.14.1_2... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on shared library: libggzcore.so - found
===>   freeciv-2.4.0_1 depends on shared library: libggzmod.so - found
===>   freeciv-2.4.0_1 depends on shared library: libintl.so - found
===>   freeciv-2.4.0_1 depends on shared library: libatk-1.0.so - found
===>   freeciv-2.4.0_1 depends on shared library: libgdk_pixbuf-2.0.so - found
===>   freeciv-2.4.0_1 depends on shared library: libglib-2.0.so - found
===>   freeciv-2.4.0_1 depends on shared library: libpcre.so - found
===>   freeciv-2.4.0_1 depends on shared library: libgtk-x11-2.0.so - found
===>   freeciv-2.4.0_1 depends on shared library: libpango-1.0.so - found
===>   freeciv-2.4.0_1 depends on shared library: SDL-1.2 - found
===>   freeciv-2.4.0_1 depends on shared library: SDL_mixer-1.2 - not found
===>    Verifying install for SDL_mixer-1.2 in /usr/ports/audio/sdl_mixer
===>   Installing existing package /packages/All/sdl_mixer-1.2.12_4.txz
Installing sdl_mixer-1.2.12_4...Installing smpeg-0.4.4_10... done
Installing timidity-0.2i_1... done
Installing libvorbis-1.3.3_1,3...Installing libogg-1.3.1,4... done
 done
Installing flac-1.3.0_1... done
 done
===>   Returning to build of freeciv-2.4.0_1
===>   freeciv-2.4.0_1 depends on shared library: sqlite3.8 - not found
===>    Verifying install for sqlite3.8 in /usr/ports/databases/sqlite3
===>   Installing existing package /packages/All/sqlite3-3.8.0.2.txz
Installing sqlite3-3.8.0.2... done
===>   Returning to build of freeciv-2.4.0_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for freeciv-2.4.0_1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv/work/freeciv-2.4.0/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv/work/freeciv-2.4.0/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/games/freeciv/work/freeciv-2.4.0/bootstrap/config.rpath
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd11.0
checking host system type... amd64-portbld-freebsd11.0
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether byte ordering is bigendian... no
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking for style of include used by gmake... GNU
checking dependency style of cc... gcc3
checking whether gmake supports nested variables... yes
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for SQLite3 library >= 3.0.0... yes
checking for getaddrinfo... (cached) yes
checking for inet_pton... yes
checking for inet_ntop... (cached) yes
checking for getnameinfo... (cached) yes
checking for AF_INET6... yes
checking for MagickWand-config in default path... no
configure: WARNING: for requested client 'gtk' enabled gtk2-client, but that 
default may change in the future
checking whether can build modules... no
configure: error: cannot build loadable AI modules as requested
===>  Script "configure" failed unexpectedly.
Please report the problem to joh...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/games/freeciv/work/freeciv-2.4.0/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/games/freeciv
===>  Cleaning for freeciv-2.4.0_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to