You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     hask...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: branches/2014Q1/www/hs-wai-app-static/Makefile 331644 
2013-10-26 00:52:33Z gerald $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2013-12-16_15h18m40s/logs/hs-wai-app-static-1.3.1.2_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2013-12-16_15h18m40s
Log:

====>> Building www/hs-wai-app-static
build started at Mon Dec 16 20:10:26 UTC 2013
port directory: /usr/ports/www/hs-wai-app-static
building for: FreeBSD 10i386-quarterly-job-09 10.0-RC1 FreeBSD 10.0-RC1 i386
maintained by: hask...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q1/www/hs-wai-app-static/Makefile 
331644 2013-10-26 00:52:33Z gerald $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RC1
UNAME_r=10.0-RC1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=22291
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=hs-wai-app-static-1.3.1.2_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/home/bdrewery
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
hs-wai-app-static-1.3.1.2_2:
     DOCS=on: Build and/or install documentation
     DYNAMIC=on: Add support for dynamic linking
     HSCOLOUR=off: Colorize generated documentation by HsColour
     LLVM=off: Use the LLVM backend for code generation
     PROFILE=off: Add support for profiling
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--libdir=/usr/local/lib/cabal/ghc-7.6.3 --libsubdir=wai-app-static-1.3.1.2 
--with-gcc=gcc46 --with-ld=/usr/local/bin/ld --with-ar=/usr/local/bin/ar  
--with-ranlib=/usr/local/bin/ranlib --haddock-options=-w 
--with-haddock=/usr/local/bin/haddock --enable-shared 
--enable-executable-dynamic "--ghc-option=-optl -rpath" "--ghc-option=-optl 
/usr/local/lib/cabal/ghc-7.6.3/wai-app-static-1.3.1.2" 
--disable-executable-profiling --disable-library-profiling
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc46" CFLAGS="-O2 -pipe 
-I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing"  
CPP="cpp46" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib 
-Wl,-rpath=/usr/local/lib/gcc46 -L/usr/local/lib/gcc46"  CXX="g++46" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -Wl,-rpath=/usr/local/lib/gcc46 
-fno-strict-aliasing -Wl,-rpath=/usr/local/lib/gcc46"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -
 m 444"  BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/cabal/ghc-7.6.3/wai-app-static-1.3.1.2
DOCSDIR=/usr/local/share/doc/cabal/ghc-7.6.3/wai-app-static-1.3.1.2
EXAMPLESDIR=/usr/local/share/examples/cabal/ghc-7.6.3/wai-app-static-1.3.1.2
WWWDIR=/usr/local/www/wai-app-static
ETCDIR=/usr/local/etc/wai-app-static
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for hs-wai-app-static-1.3.1.2_2
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   hs-wai-app-static-1.3.1.2_2 depends on file: /usr/local/sbin/pkg - not 
found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.4_1.txz
Installing pkg-1.2.4_1... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by hs-wai-app-static-1.3.1.2_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by hs-wai-app-static-1.3.1.2_2 for building
=> SHA256 Checksum OK for cabal/wai-app-static-1.3.1.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by hs-wai-app-static-1.3.1.2_2 for building
===>  Extracting for hs-wai-app-static-1.3.1.2_2
=> SHA256 Checksum OK for cabal/wai-app-static-1.3.1.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for hs-wai-app-static-1.3.1.2_2
===========================================================================
=======================<phase: build-depends  >============================
===>   hs-wai-app-static-1.3.1.2_2 depends on executable: ghc - not found
===>    Verifying install for ghc in /usr/ports/lang/ghc
===>   Installing existing package /packages/All/ghc-7.6.3_1.txz
Installing ghc-7.6.3_1...Installing mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-1.0.1... done
Installing gcc-ecj-4.5... done
Installing gcc-4.6.4...Installing binutils-2.23.2...Installing 
gettext-0.18.3.1... done
 done
 done
Installing libffi-3.0.13... done
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: ghc>=7.6.3 - found
===>   hs-wai-app-static-1.3.1.2_2 depends on package: 
hs-base64-bytestring>=0.1 - not found
===>    Verifying install for hs-base64-bytestring>=0.1 in 
/usr/ports/devel/hs-base64-bytestring
===>   Installing existing package 
/packages/All/hs-base64-bytestring-1.0.0.1_2.txz
Installing hs-base64-bytestring-1.0.0.1_2...Reading package info from stdin ... 
done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: 
hs-blaze-builder>=0.2.1.4 - not found
===>    Verifying install for hs-blaze-builder>=0.2.1.4 in 
/usr/ports/devel/hs-blaze-builder
===>   Installing existing package /packages/All/hs-blaze-builder-0.3.1.1_1.txz
Installing hs-blaze-builder-0.3.1.1_1...Installing hs-text-0.11.3.1_1...Reading 
package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-blaze-html>=0.5 - not 
found
===>    Verifying install for hs-blaze-html>=0.5 in 
/usr/ports/textproc/hs-blaze-html
===>   Installing existing package /packages/All/hs-blaze-html-0.6.1.1_1.txz
Installing hs-blaze-html-0.6.1.1_1...Installing 
hs-blaze-markup-0.5.1.5_1...Reading package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-blaze-markup>=0.5.1 - 
found
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-cereal>=0.3.5 - not 
found
===>    Verifying install for hs-cereal>=0.3.5 in /usr/ports/devel/hs-cereal
===>   Installing existing package /packages/All/hs-cereal-0.3.5.2_4.txz
Installing hs-cereal-0.3.5.2_4...Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-crypto-conduit>=0.4 - 
not found
===>    Verifying install for hs-crypto-conduit>=0.4 in 
/usr/ports/security/hs-crypto-conduit
===>   Installing existing package /packages/All/hs-crypto-conduit-0.5.2_1.txz
Installing hs-crypto-conduit-0.5.2_1...Installing hs-entropy-0.2.1_6...Reading 
package info from stdin ... done.
 done
Installing hs-crypto-api-0.12.1_1...Installing 
hs-transformers-0.3.0.0_5...Reading package info from stdin ... done.
 done
Installing hs-tagged-0.6_1...Reading package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
Installing hs-semigroups-0.9.1_1...Installing hs-nats-0.1_2...Reading package 
info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
Installing hs-void-0.6_1...Installing hs-hashable-1.1.2.5_1,1...Reading package 
info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
Installing hs-transformers-base-0.4.1_6...Reading package info from stdin ... 
done.
 done
Installing hs-resourcet-0.4.7.1_1...Installing hs-mtl-2.1.2_3...WARNING: cache 
is out of date: /usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
Installing hs-monad-control-0.3.2.1_1...Installing 
hs-base-unicode-symbols-0.2.2.4_3...Reading package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
Installing hs-mmorph-1.0.0_1...Reading package info from stdin ... done.
 done
Installing hs-lifted-base-0.2.0.5_1...Reading package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
Installing hs-conduit-1.0.5_1...Reading package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-cryptohash>=0.7 - not 
found
===>    Verifying install for hs-cryptohash>=0.7 in 
/usr/ports/security/hs-cryptohash
===>   Installing existing package /packages/All/hs-cryptohash-0.9.0_1.txz
Installing hs-cryptohash-0.9.0_1...Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-file-embed>=0.0.3.1 - 
not found
===>    Verifying install for hs-file-embed>=0.0.3.1 in 
/usr/ports/devel/hs-file-embed
===>   Installing existing package /packages/All/hs-file-embed-0.0.4.7_2.txz
Installing hs-file-embed-0.0.4.7_2...Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-http-date>=0 - not 
found
===>    Verifying install for hs-http-date>=0 in /usr/ports/www/hs-http-date
===>   Installing existing package /packages/All/hs-http-date-0.0.4_3.txz
Installing hs-http-date-0.0.4_3...Installing hs-attoparsec-0.10.4.0_2...Reading 
package info from stdin ... done.
 done
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-http-types>=0.7 - not 
found
===>    Verifying install for hs-http-types>=0.7 in /usr/ports/www/hs-http-types
===>   Installing existing package /packages/All/hs-http-types-0.8.0_2.txz
Installing hs-http-types-0.8.0_2...Installing 
hs-case-insensitive-1.0.0.2_1...Reading package info from stdin ... done.
 done
WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-mime-types>=0.1 - not 
found
===>    Verifying install for hs-mime-types>=0.1 in 
/usr/ports/mail/hs-mime-types
===>   Installing existing package /packages/All/hs-mime-types-0.1.0.3_2.txz
Installing hs-mime-types-0.1.0.3_2...Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-system-fileio>=0.3 - 
not found
===>    Verifying install for hs-system-fileio>=0.3 in 
/usr/ports/devel/hs-system-fileio
===>   Installing existing package /packages/All/hs-system-fileio-0.3.11_2.txz
Installing hs-system-fileio-0.3.11_2...Installing 
hs-system-filepath-0.4.7_3...Reading package info from stdin ... done.
 done
WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-system-filepath>=0.4 
- found
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-text>=0.7 - found
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-transformers>=0.2.2 - 
found
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-unix-compat>=0.2 - 
not found
===>    Verifying install for hs-unix-compat>=0.2 in 
/usr/ports/devel/hs-unix-compat
===>   Installing existing package /packages/All/hs-unix-compat-0.4.1.1_1.txz
Installing hs-unix-compat-0.4.1.1_1...WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on package: hs-wai>=1.3 - not found
===>    Verifying install for hs-wai>=1.3 in /usr/ports/www/hs-wai
===>   Installing existing package /packages/All/hs-wai-1.4.0_2.txz
Installing hs-wai-1.4.0_2...Installing hs-parsec-3.1.3_3...WARNING: cache is 
out of date: /usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
Installing hs-network-2.4.1.2_1...Reading package info from stdin ... done.
 done
Installing hs-vault-0.2.0.4_2...Installing 
hs-unordered-containers-0.2.3.1_1...WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
WARNING: cache is out of date: 
/usr/local/lib/ghc-7.6.3/package.conf.d/package.cache
  use 'ghc-pkg recache' to fix.
Reading package info from stdin ... done.
 done
===>   Returning to build of hs-wai-app-static-1.3.1.2_2
===>   hs-wai-app-static-1.3.1.2_2 depends on executable: gcc46 - found
===>   hs-wai-app-static-1.3.1.2_2 depends on file: /usr/local/bin/as - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for hs-wai-app-static-1.3.1.2_2
[1 of 1] Compiling Main             ( Setup.lhs, Setup.o )
Linking ./setup ...
Configuring wai-app-static-1.3.1.2...
===========================================================================
=======================<phase: build          >============================
===>  Building for hs-wai-app-static-1.3.1.2_2
Building wai-app-static-1.3.1.2...
Preprocessing library wai-app-static-1.3.1.2...
[1 of 6] Compiling WaiAppStatic.Types ( WaiAppStatic/Types.hs, 
dist/build/WaiAppStatic/Types.o )
[2 of 6] Compiling Util             ( Util.hs, dist/build/Util.o )
[3 of 6] Compiling WaiAppStatic.Listing ( WaiAppStatic/Listing.hs, 
dist/build/WaiAppStatic/Listing.o )
[4 of 6] Compiling WaiAppStatic.Storage.Filesystem ( 
WaiAppStatic/Storage/Filesystem.hs, 
dist/build/WaiAppStatic/Storage/Filesystem.o )

WaiAppStatic/Storage/Filesystem.hs:121:40: Warning:
    In the use of type constructor or class `MD5'
    (imported from Crypto.Hash.MD5):
    Deprecated: "Future cryptohash versions will not export crypto-api hash 
instances here.
                 you can either :
                   - carry using cryptoapi types and definitions by using the
                     cryptohash-cryptoapi package and importing 
Crypto.Hash.CryptoAPI
                     instead of Crypto.Hash.MD5.
                   - use cryptohash's centralized API by importing Crypto.Hash"
[5 of 6] Compiling WaiAppStatic.Storage.Embedded ( 
WaiAppStatic/Storage/Embedded.hs, dist/build/WaiAppStatic/Storage/Embedded.o )
[6 of 6] Compiling Network.Wai.Application.Static ( 
Network/Wai/Application/Static.hs, dist/build/Network/Wai/Application/Static.o )
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... ghc: 
/usr/local/lib/ghc-7.6.3/base-4.6.0.1/HSbase-4.6.0.1.o: unknown symbol 
`iconv_open'
ghc: unable to load package `base'
*** Error code 1

Stop.
make: stopped in /usr/ports/www/hs-wai-app-static
===>  Cleaning for hs-wai-app-static-1.3.1.2_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to