You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     d...@freebsd.org
Last committer: nemy...@freebsd.org
Ident:          $FreeBSD: branches/2014Q1/devel/synfig/Makefile 334422 
2013-11-20 14:25:28Z nemysis $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2013-12-16_15h18m40s/logs/synfig-0.63.05_5.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2013-12-16_15h18m40s
Log:

====>> Building devel/synfig
build started at Mon Dec 16 21:12:32 UTC 2013
port directory: /usr/ports/devel/synfig
building for: FreeBSD 10i386-quarterly-job-05 10.0-RC1 FreeBSD 10.0-RC1 i386
maintained by: d...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q1/devel/synfig/Makefile 334422 
2013-11-20 14:25:28Z nemysis $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RC1
UNAME_r=10.0-RC1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=78538
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=synfig-0.63.05_5
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/home/bdrewery
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/synfig
DOCSDIR=/usr/local/share/doc/synfig
EXAMPLESDIR=/usr/local/share/examples/synfig
WWWDIR=/usr/local/www/synfig
ETCDIR=/usr/local/etc/synfig
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for synfig-0.63.05_5
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   synfig-0.63.05_5 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.4_1.txz
Installing pkg-1.2.4_1... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of synfig-0.63.05_5
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by synfig-0.63.05_5 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by synfig-0.63.05_5 for building
=> SHA256 Checksum OK for synfig-0.63.05.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by synfig-0.63.05_5 for building
===>  Extracting for synfig-0.63.05_5
=> SHA256 Checksum OK for synfig-0.63.05.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for synfig-0.63.05_5
/bin/mv /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/no_NO.gmo 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/no.gmo
/bin/mv /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/pl_PL.gmo 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/pl.gmo
/bin/mv /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/sk_SK.gmo 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/sk.gmo
/bin/mv /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/el_GR.gmo 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/po/el.gmo
===========================================================================
=======================<phase: build-depends  >============================
===>   synfig-0.63.05_5 depends on file: /usr/local/libdata/pkgconfig/ETL.pc - 
not found
===>    Verifying install for /usr/local/libdata/pkgconfig/ETL.pc in 
/usr/ports/devel/etl
===>   Installing existing package /packages/All/etl-0.04.15.txz
Installing etl-0.04.15... done
===>   Returning to build of synfig-0.63.05_5
===========================================================================
=======================<phase: lib-depends    >============================
===>   synfig-0.63.05_5 depends on shared library: libintl.so - not found
===>    Verifying for libintl.so in /usr/ports/devel/gettext
===>   Installing existing package /packages/All/gettext-0.18.3.1.txz
Installing gettext-0.18.3.1... done
===>   Returning to build of synfig-0.63.05_5
===>   synfig-0.63.05_5 depends on shared library: libglib-2.0.so - not found
===>    Verifying for libglib-2.0.so in /usr/ports/devel/glib20
===>   Installing existing package /packages/All/glib-2.36.3.txz
Installing glib-2.36.3...Installing python27-2.7.6_1... done
Installing python2-2_2... done
Installing python-2.7_1,2... done
Installing perl5-5.16.3_4...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl5
Done.
 done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
No schema files found: doing nothing.
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of synfig-0.63.05_5
===>   synfig-0.63.05_5 depends on shared library: libpcre.so - found
===>   synfig-0.63.05_5 depends on shared library: glibmm-2.4.1 - not found
===>    Verifying install for glibmm-2.4.1 in /usr/ports/devel/glibmm
===>   Installing existing package /packages/All/glibmm-2.36.2,1.txz
Installing glibmm-2.36.2,1...Installing libsigc++-2.3.1... done
 done
===>   Returning to build of synfig-0.63.05_5
===>   synfig-0.63.05_5 depends on shared library: MagickWand - not found
===>    Verifying install for MagickWand in /usr/ports/graphics/ImageMagick
===>   Installing existing package /packages/All/ImageMagick-6.8.0.7_3.txz
Installing ImageMagick-6.8.0.7_3...Installing xproto-7.0.24... done
Installing xineramaproto-1.2.1... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing xcb-util-renderutil-0.3.8...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxcb-1.9.1_1...Installing libxml2-2.8.0_3... done
 done
Installing xcb-util-0.3.9_1,1... done
 done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing pixman-0.30.2... done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXinerama-1.1.3,1... done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libXcursor-1.1.14... done
<snip>
In file included from ./valuenode_blinecalcwidth.h:32:
In file included from ./valuenode.h:32:
In file included from ./vector.h:206:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
/usr/local/include/ETL/_bezier.h:313:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
In file included from valuenode_blinecalcwidth.cpp:34:
In file included from ./valuenode_blinecalcwidth.h:32:
In file included from ./valuenode.h:33:
In file included from ./value.h:39:
./general.h:113:12: warning: private field 'end' is not used 
[-Wunused-private-field]
        int start,end,tot;
                  ^
3 warnings and 3 errors generated.
--- libsynfig_la-layer_mime.lo ---
20 errors generated.
--- libsynfig_la-value.lo ---
*** [libsynfig_la-value.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-layer_polygon.lo ---
*** [libsynfig_la-layer_polygon.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-layer_mime.lo ---
*** [libsynfig_la-layer_mime.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-layer_motionblur.lo ---
2 warnings and 20 errors generated.
*** [libsynfig_la-layer_motionblur.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_blinecalcwidth.lo ---
*** [libsynfig_la-valuenode_blinecalcwidth.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-target_scanline.lo ---
2 warnings and 20 errors generated.
*** [libsynfig_la-target_scanline.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-target_multi.lo ---
2 warnings and 20 errors generated.
*** [libsynfig_la-target_multi.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-target_tile.lo ---
2 warnings and 20 errors generated.
*** [libsynfig_la-target_tile.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_atan2.lo ---
In file included from valuenode_atan2.cpp:34:
In file included from ./valuenode_atan2.h:32:
In file included from ./valuenode.h:32:
In file included from ./vector.h:206:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
/usr/local/include/ETL/_bezier.h:313:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
In file included from valuenode_atan2.cpp:34:
In file included from ./valuenode_atan2.h:32:
In file included from ./valuenode.h:33:
In file included from ./value.h:39:
./general.h:113:12: warning: private field 'end' is not used 
[-Wunused-private-field]
        int start,end,tot;
                  ^
3 warnings and 3 errors generated.
--- libsynfig_la-valuenode_animated.lo ---
In file included from valuenode_animated.cpp:39:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
/usr/local/include/ETL/_bezier.h:313:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
In file included from valuenode_animated.cpp:48:
In file included from ./canvas.h:40:
In file included from ./valuenode.h:33:
In file included from ./value.h:39:
./general.h:113:12: warning: private field 'end' is not used 
[-Wunused-private-field]
        int start,end,tot;
                  ^
3 warnings and 3 errors generated.
--- libsynfig_la-valuenode_atan2.lo ---
*** [libsynfig_la-valuenode_atan2.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_animated.lo ---
*** [libsynfig_la-valuenode_animated.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_blinecalcvertex.lo ---
In file included from valuenode_blinecalcvertex.cpp:34:
In file included from ./valuenode_blinecalcvertex.h:31:
In file included from ./valuenode.h:32:
In file included from ./vector.h:206:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
/usr/local/include/ETL/_bezier.h:313:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
In file included from valuenode_blinecalcvertex.cpp:34:
In file included from ./valuenode_blinecalcvertex.h:31:
In file included from ./valuenode.h:33:
In file included from ./value.h:39:
./general.h:113:12: warning: private field 'end' is not used 
[-Wunused-private-field]
        int start,end,tot;
                  ^
3 warnings and 3 errors generated.
*** [libsynfig_la-valuenode_blinecalcvertex.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_bline.lo ---
valuenode_bline.cpp:977:19: error: implicit instantiation of undefined template 
'std::basic_string<char, std::char_traits<char>, std::allocator<char> >'
                synfig::warning(string("ValueNode_BLine::operator()():")+_("No 
entries in list"));
                                ^
./string_decl.h:41:66: note: template is declared here
template<typename _CharT, typename _Traits,typename _Alloc>class basic_string;
                                                                 ^
valuenode_bline.cpp:980:19: error: implicit instantiation of undefined template 
'std::basic_string<char, std::char_traits<char>, std::allocator<char> >'
                synfig::warning(string("ValueNode_BLine::operator()():")+_("No 
entries in ret_list"));
                                ^
./string_decl.h:41:66: note: template is declared here
template<typename _CharT, typename _Traits,typename _Alloc>class basic_string;
                                                                 ^
--- libsynfig_la-layer_duplicate.lo ---
In file included from layer_duplicate.cpp:34:
In file included from ./layer_duplicate.h:31:
In file included from ./valuenode_duplicate.h:32:
In file included from ./valuenode.h:32:
In file included from ./vector.h:206:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
/usr/local/include/ETL/_bezier.h:313:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
2 warnings and 3 errors generated.
*** [libsynfig_la-layer_duplicate.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
--- libsynfig_la-valuenode_bline.lo ---
In file included from valuenode_bline.cpp:34:
In file included from ./valuenode_bline.h:35:
In file included from ./valuenode.h:32:
In file included from ./vector.h:206:
In file included from /usr/local/include/ETL/bezier:32:
/usr/local/include/ETL/_bezier.h:233:37: warning: private field 'affine_func' 
is not used [-Wunused-private-field]
        affine_combo<value_type,time_type> affine_func;
                                           ^
In file included from valuenode_bline.cpp:34:
In file included from ./valuenode_bline.h:35:
In file included from ./valuenode.h:33:
In file included from ./value.h:39:
./general.h:113:12: warning: private field 'end' is not used 
[-Wunused-private-field]
        int start,end,tot;
                  ^
2 warnings and 5 errors generated.
*** [libsynfig_la-valuenode_bline.lo] Error code 1

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
23 errors

make[4]: stopped in 
/wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src/synfig
*** [all-recursive] Error code 1

make[3]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src
1 error

make[3]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05/src
*** [all-recursive] Error code 1

make[2]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05
1 error

make[2]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05
*** [all] Error code 2

make[1]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05
1 error

make[1]: stopped in /wrkdirs/usr/ports/devel/synfig/work/synfig-0.63.05
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/synfig
===>  Cleaning for synfig-0.63.05_5
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to