You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     marty...@freebsd.org
Last committer: marty...@freebsd.org
Ident:          $FreeBSD: branches/2014Q1/deskutils/notecase/Makefile 335549 
2013-12-03 08:34:29Z martymac $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2013-12-16_15h18m43s/logs/notecase-1.9.8_10.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2013-12-16_15h18m43s
Log:

====>> Building deskutils/notecase
build started at Mon Dec 16 23:46:12 UTC 2013
port directory: /usr/ports/deskutils/notecase
building for: FreeBSD 10amd64-quarterly-job-06 10.0-RC1 FreeBSD 10.0-RC1 amd64
maintained by: marty...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q1/deskutils/notecase/Makefile 
335549 2013-12-03 08:34:29Z martymac $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RC1
UNAME_r=10.0-RC1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-quarterly/ref
PKG_EXT=txz
tpid=19833
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=notecase-1.9.8_10
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/notecase
DOCSDIR=/usr/local/share/doc/notecase
EXAMPLESDIR=/usr/local/share/examples/notecase
WWWDIR=/usr/local/www/notecase
ETCDIR=/usr/local/etc/notecase
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for notecase-1.9.8_10
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   notecase-1.9.8_10 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.4_1.txz
Installing pkg-1.2.4_1... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of notecase-1.9.8_10
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by notecase-1.9.8_10 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by notecase-1.9.8_10 for building
=> SHA256 Checksum OK for notecase-1.9.8_src.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by notecase-1.9.8_10 for building
===>  Extracting for notecase-1.9.8_10
=> SHA256 Checksum OK for notecase-1.9.8_src.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for notecase-1.9.8_10
===>   Converting DOS text files to UNIX text files
===>  Applying FreeBSD patches for notecase-1.9.8_10
===========================================================================
=======================<phase: build-depends  >============================
===>   notecase-1.9.8_10 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on executable: update-desktop-database - not 
found
===>    Verifying install for update-desktop-database in 
/usr/ports/devel/desktop-file-utils
===>   Installing existing package /packages/All/desktop-file-utils-0.22_1.txz
Installing desktop-file-utils-0.22_1...Installing glib-2.36.3...Installing 
python27-2.7.6_1... done
Installing python2-2_2... done
Installing python-2.7_1,2... done
Installing perl5-5.16.3_4...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.16.3 to /usr/bin/perl5
Done.
 done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
No schema files found: doing nothing.
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on executable: update-mime-database - not found
===>    Verifying install for update-mime-database in 
/usr/ports/misc/shared-mime-info
===>   Installing existing package /packages/All/shared-mime-info-1.1.txz
Installing shared-mime-info-1.1...Installing libxml2-2.8.0_3... done
 done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on file: 
/usr/local/libdata/pkgconfig/gnome-mime-data-2.0.pc - not found
===>    Verifying install for 
/usr/local/libdata/pkgconfig/gnome-mime-data-2.0.pc in 
/usr/ports/misc/gnome-mime-data
===>   Installing existing package /packages/All/gnome-mime-data-2.18.0_4.txz
Installing gnome-mime-data-2.18.0_4...Installing gnomehier-3.0... done
 done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on file: /usr/local/bin/intltool-extract - not 
found
===>    Verifying install for /usr/local/bin/intltool-extract in 
/usr/ports/textproc/intltool
===>   Installing existing package /packages/All/intltool-0.50.2.txz
Installing intltool-0.50.2...Installing p5-XML-Parser-2.41_1...Installing 
expat-2.1.0... done
 done
 done
===>   Returning to build of notecase-1.9.8_10
===========================================================================
=======================<phase: lib-depends    >============================
===>   notecase-1.9.8_10 depends on shared library: libintl.so - found
===>   notecase-1.9.8_10 depends on shared library: libatk-1.0.so - not found
===>    Verifying for libatk-1.0.so in /usr/ports/accessibility/atk
===>   Installing existing package /packages/All/atk-2.8.0.txz
Installing atk-2.8.0... done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on shared library: libgconf-2.so - not found
===>    Verifying for libgconf-2.so in /usr/ports/devel/gconf2
===>   Installing existing package /packages/All/gconf2-2.32.0_3.txz
Installing gconf2-2.32.0_3...Installing xproto-7.0.24... done
Installing xineramaproto-1.2.1... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing xcb-util-renderutil-0.3.8...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxcb-1.9.1_1... done
Installing xcb-util-0.3.9_1,1... done
 done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
<snip>
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on shared library: libglib-2.0.so - found
===>   notecase-1.9.8_10 depends on shared library: libpcre.so - found
===>   notecase-1.9.8_10 depends on shared library: libgnomevfs-2.so - not found
===>    Verifying for libgnomevfs-2.so in /usr/ports/devel/gnome-vfs
===>   Installing existing package /packages/All/gnome-vfs-2.24.4_1.txz
Installing gnome-vfs-2.24.4_1...Installing policykit-0.9_6...===> Creating 
users and/or groups.
Creating group 'polkit' with gid '562'.
Creating user 'polkit' with uid '562'.
 done
Installing hal-0.5.14_22...Installing dmidecode-2.12... done
Installing consolekit-0.4.3... done
Installing libvolume_id-0.81.1... done
===> Creating users and/or groups.
Creating group 'haldaemon' with gid '560'.
Creating user 'haldaemon' with uid '560'.
 done
Installing samba36-libsmbclient-3.6.22...Installing tevent-0.9.18...Installing 
talloc-2.0.8... done
 done
Installing tdb-1.2.12,1... done
 done
Installing avahi-app-0.6.31...Installing gdbm-1.10... done
Installing libdaemon-0.14... done
===> Creating users and/or groups.
Creating group 'avahi' with gid '558'.
Creating user 'avahi' with uid '558'.
 done
Installing gamin-0.1.10_6... done
 done
===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

For a typical desktop, add the following line to /boot/loader.conf, then
reboot the system:

    kern.maxfiles="25000"

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files.  In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on shared library: libgtk-x11-2.0.so - found
===>   notecase-1.9.8_10 depends on shared library: libgtksourceview-2.0.so - 
not found
===>    Verifying for libgtksourceview-2.0.so in 
/usr/ports/x11-toolkits/gtksourceview2
===>   Installing existing package /packages/All/gtksourceview2-2.10.5_1.txz
Installing gtksourceview2-2.10.5_1... done
===>   Returning to build of notecase-1.9.8_10
===>   notecase-1.9.8_10 depends on shared library: libIDL-2.so - found
===>   notecase-1.9.8_10 depends on shared library: libxml2.so - found
===>   notecase-1.9.8_10 depends on shared library: libORBit-2.so - found
===>   notecase-1.9.8_10 depends on shared library: libpango-1.0.so - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for notecase-1.9.8_10
===========================================================================
=======================<phase: build          >============================
===>  Building for notecase-1.9.8_10
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/deskutils/notecase/work/notecase-1.9.8'
Configuration: 
GNOME_VFS=1;GTKSOURCEVIEW=1;DEBUG=;PROFILE=;BYTE_ORDER=-DSHA1_LITTLE_ENDIAN 
-DORDER_DCBA;PLATFORM="FreeBsd"
#@sed -i.bak 's:\#define INSTALL_PREFIX .*:\#define INSTALL_PREFIX 
"/wrkdirs/usr/ports/deskutils/notecase/work/stage/usr/local":' ./src/config.h
===> Compiling src/main.cpp
===> Compiling src/support.cpp
===> Compiling src/callbacks.cpp
===> Compiling src/interface.cpp
./src/interface.cpp:485:3: warning: format string is not a string literal 
(potentially insecure) [-Wformat-security]
                szText);
                ^~~~~~
1 warning generated.
===> Compiling src/mru.cpp
./src/mru.cpp:131:88: warning: cast to 'void *' from smaller integer type 'int' 
[-Wint-to-pointer-cast]
                g_signal_connect (GTK_OBJECT (menuitem5),  "activate", 
G_CALLBACK (on_MRU_activate), (void *)i);
                                                                                
                     ^
/usr/local/include/glib-2.0/gobject/gsignal.h:475:73: note: expanded from macro 
'g_signal_connect'
    g_signal_connect_data ((instance), (detailed_signal), (c_handler), (data), 
NULL, (GConnectFlags) 0)
                                                                        ^
./src/mru.cpp:140:88: warning: cast to 'void *' from smaller integer type 'int' 
[-Wint-to-pointer-cast]
                g_signal_connect (GTK_OBJECT (menuitem5),  "activate", 
G_CALLBACK (on_MRU_activate), (void *)i);
                                                                                
                     ^
/usr/local/include/glib-2.0/gobject/gsignal.h:475:73: note: expanded from macro 
'g_signal_connect'
    g_signal_connect_data ((instance), (detailed_signal), (c_handler), (data), 
NULL, (GConnectFlags) 0)
                                                                        ^
2 warnings generated.
===> Compiling src/lib/EnumDirectory.cpp
===> Compiling src/lib/DocActionManager.cpp
./src/lib/DocActionManager.cpp:92:10: warning: comparison of unsigned 
expression < 0 is always false [-Wtautological-compare]
        if(nPos < 0 || nPos > m_lstHistory.size()) return NULL;
           ~~~~ ^ ~
1 warning generated.
===> Compiling src/DocAction.cpp
===> Compiling src/DocActionSort.cpp
===> Compiling src/OptionsDialog.cpp
===> Compiling src/gui/GuiLanguage.cpp
===> Compiling src/lib/TextSearch.cpp
./src/lib/TextSearch.cpp:66:15: warning: comparison of unsigned expression < 0 
is always false [-Wtautological-compare]
        if(nStartPos < 0 || nStartPos >= m_nBlkSize)
           ~~~~~~~~~ ^ ~
1 warning generated.
===> Compiling src/gui/FileDialog.cpp
===> Compiling src/gui/Dialog.cpp
===> Compiling src/FindDialog.cpp
===> Compiling src/PasswordDialog.cpp
===> Compiling src/lib/FilePath.cpp
===> Compiling src/lib/IniFile.cpp
===> Compiling src/lib/blowfish.cpp
===> Compiling src/lib/DocumentIterator.cpp
===> Compiling src/lib/FormatIOExecutable.cpp
===> Compiling src/lib/IOLayerEnc.cpp
===> Compiling src/lib/File64.cpp
===> Compiling src/lib/FormatIOEncHtml.cpp
===> Compiling src/lib/FormatIOHtml.cpp
./src/lib/FormatIOHtml.cpp:451:5: warning: 'gdk_pixbuf_ref' is deprecated 
[-Wdeprecated-declarations]
                                gdk_pixbuf_ref (pixbuf); // make sure we keep a 
reference to it
                                ^
/usr/local/include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-core.h:241:12: note: 
'gdk_pixbuf_ref' declared here
GdkPixbuf *gdk_pixbuf_ref      (GdkPixbuf *pixbuf);
           ^
1 warning generated.
===> Compiling src/lib/FormatIOGjots2.cpp
===> Compiling src/lib/HtmlParser.cpp
===> Compiling src/lib/NoteDocument.cpp
===> Compiling src/lib/FormatIOBase.cpp
===> Compiling src/lib/NoteNode.cpp
===> Compiling src/lib/SHA1.cpp
===> Compiling src/PortableTrayIcon.cpp
===> Compiling src/lib/Base64.cpp
===> Compiling src/_unx/SingleInstance.cpp
===> Compiling src/TreeView.cpp
===> Compiling src/TextView.cpp
===> Compiling src/MainWnd.cpp
===> Compiling src/lib/FormatIOStickyNotes.cpp
===> Compiling src/NodePropertiesDlg.cpp
===> Compiling src/lib/debug.cpp
===> Compiling src/lib/IOProcess.cpp
./src/lib/IOProcess.cpp:56:12: warning: comparison of unsigned expression >= 0 
is always true [-Wtautological-compare]
                        if(nIdx >= 0 && m_lstLayers.size() > nIdx)
                           ~~~~ ^  ~
1 warning generated.
===> Compiling src/lib/IOLayerZlib.cpp
===> Compiling src/lib/IOLayerFile64.cpp
===> Compiling src/lib/IOLayerBase.cpp
===> Compiling src/lib/IOLayerRedirect.cpp
===> Compiling src/FileExportDlg.cpp
===> Compiling src/lib/FormatIOTxt.cpp
===> Compiling src/FindReplaceDlg.cpp
===> Compiling src/FindReplaceInfo.cpp
===> Compiling src/lib/LinkInfo.cpp
===> Compiling src/LinkPropertiesDlg.cpp
===> Compiling src/_unx/ExecuteFile.cpp
===> Compiling src/FileSaveAsDlg.cpp
===> Compiling src/lib/CircularBuffer.cpp
===> Compiling src/lib/FormatIOMMLX.cpp
===> Compiling src/gui/ProgressDlg.cpp
===> Compiling src/DocActionPix.cpp
===> Compiling src/DocActionFinish.cpp
===> Compiling src/DocActionFmt.cpp
===> Compiling src/lib/FmtInfo.cpp
===> Compiling src/FileAttachmentDlg.cpp
===> Compiling src/DocActionAtt.cpp
===> Compiling src/PixPropertiesDlg.cpp
===> Compiling src/DocActionFinishDel.cpp
===> Compiling src/ShortcutsList.cpp
===> Compiling src/ShortcutsListDlg.cpp
===> Compiling src/DateTimeDlg.cpp
===> Compiling src/AboutDlg.cpp
===> Compiling src/EditDlg.cpp
===> Compiling src/lib/Thread.cpp
===> Compiling src/_unx/eggtrayicon.cpp
===> Linking bin/notecase
/usr/bin/ld: ¬: invalid DSO for symbol `XFlush' definition
//usr/local/lib/libX11.so.6: could not read symbols: Bad value
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[1]: *** [bin/notecase] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/deskutils/notecase/work/notecase-1.9.8'
*** Error code 1

Stop.
make: stopped in /usr/ports/deskutils/notecase
===>  Cleaning for notecase-1.9.8_10
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to