You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     david.k.ge...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: branches/2014Q1/accessibility/eflite/Makefile 336152 
2013-12-11 09:51:36Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2013-12-16_15h18m43s/logs/eflite-0.4.1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2013-12-16_15h18m43s
Log:

====>> Building accessibility/eflite
build started at Tue Dec 17 00:07:13 UTC 2013
port directory: /usr/ports/accessibility/eflite
building for: FreeBSD 10amd64-quarterly-job-21 10.0-RC1 FreeBSD 10.0-RC1 amd64
maintained by: david.k.ge...@gmail.com
Makefile ident:      $FreeBSD: branches/2014Q1/accessibility/eflite/Makefile 
336152 2013-12-11 09:51:36Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RC1
UNAME_r=10.0-RC1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-quarterly/ref
PKG_EXT=txz
tpid=53813
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=eflite-0.4.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-audio=freebsd --with-vox=cmu_us_kal16 --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
flite_dir=/usr/local TMPDIR="/tmp" MAKE=gmake SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/eflite
DOCSDIR=/usr/local/share/doc/eflite
EXAMPLESDIR=/usr/local/share/examples/eflite
WWWDIR=/usr/local/www/eflite
ETCDIR=/usr/local/etc/eflite
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for eflite-0.4.1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   eflite-0.4.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.4_1.txz
Installing pkg-1.2.4_1... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of eflite-0.4.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  You can set FL_LANG, FL_LEX and/or FL_VOX
      to link the appropriate libflite_* libraries
      (i.e. "make FL_VOX=cmu_us_kal".)
===> Fetching all distfiles required by eflite-0.4.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  You can set FL_LANG, FL_LEX and/or FL_VOX
      to link the appropriate libflite_* libraries
      (i.e. "make FL_VOX=cmu_us_kal".)
===> Fetching all distfiles required by eflite-0.4.1 for building
=> SHA256 Checksum OK for eflite-0.4.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  You can set FL_LANG, FL_LEX and/or FL_VOX
      to link the appropriate libflite_* libraries
      (i.e. "make FL_VOX=cmu_us_kal".)
===> Fetching all distfiles required by eflite-0.4.1 for building
===>  Extracting for eflite-0.4.1
=> SHA256 Checksum OK for eflite-0.4.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for eflite-0.4.1
===>  Applying FreeBSD patches for eflite-0.4.1
===========================================================================
=======================<phase: build-depends  >============================
===>   eflite-0.4.1 depends on executable: flite - not found
===>    Verifying install for flite in /usr/ports/audio/flite
===>   Installing existing package /packages/All/flite-1.4.txz
Installing flite-1.4... done
===>   Returning to build of eflite-0.4.1
===>   eflite-0.4.1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of eflite-0.4.1
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for eflite-0.4.1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1/configure
configure: loading site script /usr/ports/Templates/config.site
checking for gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for connect in -lsocket... no
checking for library containing pthread_create... -lpthread
Using /usr/local as FLite prefix.
Using /usr/local/include/flite as FLite include directory.
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/soundcard.h usability... yes
checking sys/soundcard.h presence... yes
checking for sys/soundcard.h... yes
checking machine/soundcard.h usability... no
checking machine/soundcard.h presence... no
checking for machine/soundcard.h... no
checking sys/audioio.h usability... no
checking sys/audioio.h presence... no
checking for sys/audioio.h... no
checking alsa/asoundlib.h usability... no
checking alsa/asoundlib.h presence... no
checking for alsa/asoundlib.h... no
checking mmsystem.h usability... no
checking mmsystem.h presence... no
checking for mmsystem.h... no
configure: creating ./config.status
config.status: creating Makefile
===========================================================================
=======================<phase: build          >============================
===>  Building for eflite-0.4.1
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1'
cc -O2 -pipe -fno-strict-aliasing -Wall -DCST_AUDIO_LINUX -I. 
-I/usr/local/include/flite -DREGISTER_VOX=register_cmu_us_kal16 -DSTANDALONE 
-DEFLITE -c -o fs.o fs.c
fs.c:982:18: warning: comparison of unsigned enum expression >= 0 is always 
true [-Wtautological-compare]
                                                          if (par >= 0 && par < 
S_MAX) {
                                                              ~~~ ^  ~
1 warning generated.
cc -O2 -pipe -fno-strict-aliasing -Wall   -c -o es.o es.c
es.c:570:44: warning: too many arguments in call to 'es_synthesize'
    if (text_buffered) es_synthesize(client);
                       ~~~~~~~~~~~~~       ^
es.c:580:44: warning: too many arguments in call to 'es_synthesize'
    if (text_buffered) es_synthesize(client);
                       ~~~~~~~~~~~~~       ^
2 warnings generated.
cc -O2 -pipe -fno-strict-aliasing -Wall   -c -o soccon.o soccon.c
soccon.c:27:3: warning: implicitly declaring library function 'strncpy' with 
type 'char *(char *, const char *, unsigned long)'
  strncpy(addr.sun_path, fname, sizeof(addr.sun_path));
  ^
soccon.c:27:3: note: please include the header <string.h> or explicitly provide 
a declaration for 'strncpy'
soccon.c:45:7: warning: implicitly declaring library function 'strstr' with 
type 'char *(const char *, const char *)'
  p = strstr(port, ":");
      ^
soccon.c:45:7: note: please include the header <string.h> or explicitly provide 
a declaration for 'strstr'
soccon.c:53:3: warning: implicitly declaring library function 'memcpy' with 
type 'void *(void *, const void *, unsigned long)'
  memcpy(host, port, len);
  ^
soccon.c:53:3: note: please include the header <string.h> or explicitly provide 
a declaration for 'memcpy'
soccon.c:60:3: warning: implicitly declaring library function 'memset' with 
type 'void *(void *, int, unsigned long)'
  memset(&servaddr, 0, sizeof(servaddr));
  ^
soccon.c:60:3: note: please include the header <string.h> or explicitly provide 
a declaration for 'memset'
soccon.c:84:7: warning: implicitly declaring library function 'strchr' with 
type 'char *(const char *, int)'
  if (strchr(name, ':')) return sockconnect_tcp(name);
      ^
soccon.c:84:7: note: please include the header <string.h> or explicitly provide 
a declaration for 'strchr'
5 warnings generated.
cc -O2 -pipe -fno-strict-aliasing -Wall   -c -o sockopen.o sockopen.c
sockopen.c:26:3: warning: implicitly declaring library function 'strncpy' with 
type 'char *(char *, const char *, unsigned long)'
  strncpy(addr.sun_path, fname, sizeof(addr.sun_path));
  ^
sockopen.c:26:3: note: please include the header <string.h> or explicitly 
provide a declaration for 'strncpy'
sockopen.c:47:7: warning: implicitly declaring library function 'strchr' with 
type 'char *(const char *, int)'
  p = strchr(name, ':');
      ^
sockopen.c:47:7: note: please include the header <string.h> or explicitly 
provide a declaration for 'strchr'
sockopen.c:54:3: warning: implicitly declaring library function 'memset' with 
type 'void *(void *, int, unsigned long)'
  memset(&serv_addr, 0, sizeof(struct sockaddr));
  ^
sockopen.c:54:3: note: please include the header <string.h> or explicitly 
provide a declaration for 'memset'
3 warnings generated.
cc -O2 -pipe -fno-strict-aliasing -Wall -I/usr/local/include/flite -DEFLITE -c 
-o tone.o tone.c
cc  -o eflite fs.o es.o soccon.o sockopen.o tone.o -lm -lpthread  
-L/usr/local/lib -lflite_cmu_us_kal16 -lflite_cmulex -lflite_usenglish -lflite 
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1'
===========================================================================
=======================<phase: run-depends    >============================
===>   eflite-0.4.1 depends on executable: flite - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for eflite-0.4.1
===>   Generating temporary packing list
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1'
mkdir -p /usr/local/bin && install -c -m 0755 eflite /usr/local/bin
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1'
cd /wrkdirs/usr/ports/accessibility/eflite/work/eflite-0.4.1; install  -o root 
-g wheel -m 444 AUTHORS CREDITS ChangeLog INSTALL README 
/wrkdirs/usr/ports/accessibility/eflite/work/stage/usr/local/share/doc/eflite
install  -o root -g wheel -m 444 
/usr/ports/accessibility/eflite/files/es.conf.sample 
/wrkdirs/usr/ports/accessibility/eflite/work/stage/usr/local/etc
====> Compressing man pages (compress-man)
===========================================================================
=======================<phase: package        >============================
===>  Building package for eflite-0.4.1
pkg-static: 
lstat(/wrkdirs/usr/ports/accessibility/eflite/work/stage/usr/local/bin/eflite): 
No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/accessibility/eflite
===>  Cleaning for eflite-0.4.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to