You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     l...@freebsd.org
Last committer: lini...@freebsd.org
Ident:          $FreeBSD: branches/2018Q1/databases/rocksdb-lite/Makefile 
457353 2017-12-27 08:02:58Z linimon $
Log URL:        
http://beefy2.nyi.freebsd.org/data/103amd64-quarterly/461680/logs/rocksdb-lite-5.9.2.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=103amd64-quarterly&build=461680
Log:

=>> Building databases/rocksdb-lite
build started at Tue Feb 13 01:08:10 UTC 2018
port directory: /usr/ports/databases/rocksdb-lite
package name: rocksdb-lite-5.9.2
building for: FreeBSD 103amd64-quarterly-job-13 10.3-RELEASE-p26 FreeBSD 
10.3-RELEASE-p26 amd64
maintained by: l...@freebsd.org
Makefile ident:      $FreeBSD: branches/2018Q1/databases/rocksdb-lite/Makefile 
457353 2017-12-27 08:02:58Z linimon $
Poudriere version: 3.2.4-53-g8afae7cc
Host OSVERSION: 1200054
Jail OSVERSION: 1003000
Job Id: 13

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1003000
UNAME_v=FreeBSD 10.3-RELEASE-p26
UNAME_r=10.3-RELEASE-p26
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.4-53-g8afae7cc
MASTERMNT=/usr/local/poudriere/data/.m/103amd64-quarterly/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/103amd64-quarterly/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=103amd64-quarterly
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/103amd64-quarterly/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for rocksdb-lite-5.9.2:
     DEBUG=off: Build with debugging support
     LZ4=on: LZ4 compression support
     ZSTD=off: Zstandard compression support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
l...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
make_config.mk
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PORTABLE=0 
ROCKSDB_ROOT=/wrkdirs/usr/ports/databases/rocksdb-lite/work/rocksdb-rocksdb-5.9.2
 MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work  
HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/databases/rocksdb-lite/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh CMAKE_PREFIX_PATH="/usr/local"
--End CONFIGURE_ENV--

--MAKE_ENV--
CXX=c++ 
INSTALL_PATH=/wrkdirs/usr/ports/databases/rocksdb-lite/work/stage/usr/local 
LIBNAME=librocksdb-lite DEBUG_LEVEL=0 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work  
HOME=/wrkdirs/usr/ports/databases/rocksdb-lite/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/databases/rocksdb-lite/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe  -DOS_FREEBSD -DROCKSDB_LITE=1 -fstack-protector -isystem 
/usr/local/include -fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-isystem 
/usr/local/include"  LDFLAGS=" -fstack-protector -L/usr/local/lib" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe  -DOS_FREEBSD -DROCKSDB_LITE=1 -fstack-protector 
-isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include 
-std=c++1
 1"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PORTVERSION=5.9.2 SHLIB_MAJOR=5 SHLIB_MINOR=9 LITE=-lite OSREL=10.3 PREFIX=%D 
LOCALBASE=/usr/local  RESETPREFIX=/usr/local PORTDOCS="" PORTEXAMPLES="" 
LIB32DIR=lib DOCSDIR="share/doc/rocksdb"  EXAMPLESDIR="share/examples/rocksdb"  
DATADIR="share/rocksdb"  WWWDIR="www/rocksdb"  ETCDIR="etc/rocksdb"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/rocksdb 
DOCSDIR=/usr/local/share/doc/rocksdb 
EXAMPLESDIR=/usr/local/share/examples/rocksdb  WWWDIR=/usr/local/www/rocksdb 
ETCDIR=/usr/local/etc/rocksdb
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
ARCH=amd64
CONFIGURE_MAX_CMD_LEN=262144
HAVE_COMPAT_IA32_KERN=YES
OPSYS=FreeBSD
OSREL=10.3
OSVERSION=1003000
PYTHONBASE=/usr/local
UID=0
_OSRELEASE=10.3-RELEASE-p26
#### Misc Poudriere ####
GID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
sbsize                   (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License APACHE20 GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rocksdb-lite-5.9.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.10.3_1.txz
[103amd64-quarterly-job-13] Installing pkg-1.10.3_1...
[103amd64-quarterly-job-13] Extracting pkg-1.10.3_1: .......... done
===>   rocksdb-lite-5.9.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rocksdb-lite-5.9.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License APACHE20 GPLv2 accepted by the user
===> Fetching all distfiles required by rocksdb-lite-5.9.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License APACHE20 GPLv2 accepted by the user
===> Fetching all distfiles required by rocksdb-lite-5.9.2 for building
=> SHA256 Checksum OK for facebook-rocksdb-rocksdb-5.9.2_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License APACHE20 GPLv2 accepted by the user
===> Fetching all distfiles required by rocksdb-lite-5.9.2 for building
===>  Extracting for rocksdb-lite-5.9.2
=> SHA256 Checksum OK for facebook-rocksdb-rocksdb-5.9.2_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rocksdb-lite-5.9.2
===>  Applying FreeBSD patches for rocksdb-lite-5.9.2
===========================================================================
=======================<phase: build-depends  >============================
===>   rocksdb-lite-5.9.2 depends on executable: bash - not found
===>   Installing existing package /packages/All/bash-4.4.12_3.txz
[103amd64-quarterly-job-13] Installing bash-4.4.12_3...
[103amd64-quarterly-job-13] `-- Installing gettext-runtime-0.19.8.1_1...
[103amd64-quarterly-job-13] |   `-- Installing indexinfo-0.3.1...
[103amd64-quarterly-job-13] |   `-- Extracting indexinfo-0.3.1: .... done
[103amd64-quarterly-job-13] `-- Extracting gettext-runtime-0.19.8.1_1: 
.......... done
[103amd64-quarterly-job-13] Extracting bash-4.4.12_3: .......... done
===>   rocksdb-lite-5.9.2 depends on executable: bash - found
===>   Returning to build of rocksdb-lite-5.9.2
===>   rocksdb-lite-5.9.2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_1.txz
[103amd64-quarterly-job-13] Installing gmake-4.2.1_1...
[103amd64-quarterly-job-13] Extracting gmake-4.2.1_1: .......... done
===>   rocksdb-lite-5.9.2 depends on executable: gmake - found
===>   Returning to build of rocksdb-lite-5.9.2
===========================================================================
=======================<phase: lib-depends    >============================
===>   rocksdb-lite-5.9.2 depends on shared library: libgflags.so - not found
===>   Installing existing package /packages/All/gflags-2.2.1.txz
[103amd64-quarterly-job-13] Installing gflags-2.2.1...
[103amd64-quarterly-job-13] Extracting gflags-2.2.1: .......... done
===>   rocksdb-lite-5.9.2 depends on shared library: libgflags.so - found 
(/usr/local/lib/libgflags.so)
===>   Returning to build of rocksdb-lite-5.9.2
===>   rocksdb-lite-5.9.2 depends on shared library: libsnappy.so - not found
===>   Installing existing package /packages/All/snappy-1.1.6.txz
[103amd64-quarterly-job-13] Installing snappy-1.1.6...
[103amd64-quarterly-job-13] Extracting snappy-1.1.6: .......... done
===>   rocksdb-lite-5.9.2 depends on shared library: libsnappy.so - found 
(/usr/local/lib/libsnappy.so)
===>   Returning to build of rocksdb-lite-5.9.2
===>   rocksdb-lite-5.9.2 depends on shared library: liblz4.so - not found
===>   Installing existing package /packages/All/liblz4-1.8.0,1.txz
[103amd64-quarterly-job-13] Installing liblz4-1.8.0,1...
[103amd64-quarterly-job-13] Extracting liblz4-1.8.0,1: .......... done
===>   rocksdb-lite-5.9.2 depends on shared library: liblz4.so - found 
(/usr/local/lib/liblz4.so)
===>   Returning to build of rocksdb-lite-5.9.2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rocksdb-lite-5.9.2
===========================================================================
=======================<phase: build          >============================
===>  Building for rocksdb-lite-5.9.2
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/databases/rocksdb-lite/work/rocksdb-rocksdb-5.9.2'
/usr/local/bin/bash: perl: command not found
  GEN      util/build_version.cc
/usr/local/bin/bash: perl: command not found
  GEN      util/build_version.cc
  CC       shared-objects/cache/clock_cache.o
  CC       shared-objects/cache/lru_cache.o
  CC       shared-objects/cache/sharded_cache.o
  CC       shared-objects/db/builder.o
In file included from db/builder.cc:10:
In file included from ./db/builder.h:22:
In file included from ./util/event_logger.h:14:
In file included from ./util/log_buffer.h:9:
./util/arena.h:85:70: error: unknown type name 'max_align_t'; did you mean 
'std::max_align_t'?
  char inline_block_[kInlineSize] 
__attribute__((__aligned__(alignof(max_align_t))));
                                                                     ^~~~~~~~~~~
                                                                     
std::max_align_t
/usr/include/c++/v1/cstddef:53:21: note: 'std::max_align_t' declared here
typedef long double max_align_t;
                    ^
1 error generated.
gmake[1]: *** [Makefile:615: shared-objects/db/builder.o] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/databases/rocksdb-lite/work/rocksdb-rocksdb-5.9.2'
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/rocksdb-lite
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to